Universal MIDI Librarian Management
and Editor Systems

User Manual Version 3.0
English
PACKAGE LICENSE AGREEMENT

BEFORE YOU OPEN THIS SEALED PACKAGE CAREFULLY READ THE FOLLOWING. OPENING THIS PACKAGE INDICATES THAT YOU AGREE TO BE BOUND TO THE TERMS AND CONDITIONS OF THE LICENSE AGREEMENT CONTAINED INSIDE, WHICH IMPOSES LEGAL OBLIGATIONS ON YOU WITH RESPECT TO THE USE OF THIS SOFTWARE AND DOCUMENTATION. IF YOU DO NOT AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT, DO NOT OPEN THIS PACKAGE. INSTEAD, PROMPTLY RETURN THIS UNOPENED PACKAGE AND ANY OTHER ITEMS (INCLUDING WRITTEN MATERIALS, BINDERS OR DOCUMENTATION) THAT YOU MAY HAVE CONCERNING THIS PACKAGE TO THE PLACE WHERE YOU OBTAINED THEM FOR A FULL REFUND. IF YOU WOULD LIKE A COPY OF THE TERMS OF THIS LICENSE PRIOR TO OPENING THE PACKAGE, PLEASE CALL +1 530-477-1051.
Emagic Incorporated End User License Agreement

NOTICE TO END USER: CAREFULLY READ THE FOLLOWING LEGAL AGREEMENT. USE OF THE SOFTWARE PROVIDED WITH THIS AGREEMENT (THE “SOFTWARE”) CONSTITUTES YOUR ACCEPTANCE OF THESE TERMS. IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, PROMPTLY RETURN THE SOFTWARE AND THE ACCOMPANYING ITEMS (INCLUDING WRITTEN MATERIALS AND CONTAINERS) TO THE LOCATION WHERE YOU OBTAINED THEM FOR A FULL REFUND.

1. License Grant. EMAGIC Incorporated (“EMAGIC”) grants to you (either as an individual or entity) a personal, non-transferable, and non-exclusive license to use the copy of the object code version of the SOFTWARE recorded on the media provided in this package. The term of this agreement and the above license will be for the duration of EMAGIC’s copyright in the SOFTWARE; provided, that such term shall automatically expire if you breach any provision herein. Upon termination of this license, you shall return the original and all copies of the SOFTWARE and documentation to EMAGIC or the place where you obtained the PACKAGE, or certify to EMAGIC that you have destroyed the original and all copies of the SOFTWARE and documentation in your possession and within your control. You agree you will not copy the SOFTWARE except as necessary to use it on a single computer system. You agree that you may not copy the written materials accompanying the SOFTWARE. You may assign your rights under this Agreement to a third party who agrees in writing to be bound by this Agreement prior to the assignment and provided that you transfer all copies of the SOFTWARE and related documentation to the third party or destroy any copies not transferred. Except as set forth above, you may not assign your rights under this Agreement.
2. **Copyright.** You acknowledge that no title to the intellectual property in the SOFTWARE is transferred to you. You further acknowledge that title and full ownership rights to the SOFTWARE will remain the exclusive property of EMAGIC or its suppliers, and you will not acquire any rights to the SOFTWARE except as expressly set forth above. You agree that any copies of the SOFTWARE will contain the same proprietary notices which appear on and in the SOFTWARE.

3. **Reverse Engineering.** You agree that you will not attempt, and if you are a corporation, you will use your best efforts to prevent your employees and contractors from attempting, to reverse compile, modify, translate, or disassemble the SOFTWARE in whole or in part.

4. **Limited Warranty.** EMAGIC warrants that the media contained in this package is free from any physical defects for a period of ninety (90) days from the date of purchase (“Limited Warranty”). EMAGIC DOES NOT WARRANT THAT THE SOFTWARE IS ERROR FREE. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, EMAGIC MAKES NO OTHER EXPRESS, IMPLIED OR STATUTORY WARRANTIES AND SPECIFICALLY DISCLAIMS ANY WARRANTIES AS TO THE PERFORMANCE OF THE SOFTWARE, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES OR LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY MAY LAST, OR THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO SUCH LIMITATIONS OR EXCLUSIONS MAY NOT APPLY TO YOU. AS TO ANY IMPLIED WARRANTY WHICH MAY NOT BE DISCLAIMED UNDER APPLICABLE LAW, THE DURATION OF SUCH WARRANTY IS 90 DAYS FROM THE DATE OF DELIVERY. THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS AND YOU MAY ALSO HAVE
OTHER RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION.

5. Customer Remedies. EMAGIC’s entire liability and your sole and exclusive remedy shall be, at EMAGIC’s option, to (a) replace defective media or (b) authorize a refund, so long as the SOFTWARE, documentation and media are returned to EMAGIC with a copy of your receipt. This Limited Warranty is void if a defect has resulted from accident, abuse, or misapplication. Any replacement media will be warranted for the remainder of the original warranty period.

6. Severability. In the event of invalidity of any provision of this Agreement, the parties agree that such invalidity shall not affect the validity of the remaining portions of this Agreement.

7. No Liability for Consequential Damages. IN NO EVENT SHALL EMAGIC BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, SPECIAL, INCIDENTAL OR INDIRECT DAMAGES OF ANY KIND ARISING OUT OF THE USE OF THE EMAGIC SOFTWARE, EVEN IF EMAGIC HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL EMAGIC’S LIABILITY FOR ANY CLAIM, WHETHER IN CONTRACT, TORT OR ANY OTHER THEORY OF LIABILITY, EXCEED THE LICENSE FEE PAID BY YOU.

8. Export. You agree that you will not export or re-export the SOFTWARE without the appropriate United States or foreign government licenses and the express written permission of EMAGIC.

9. U.S. Government Restricted Rights. If this SOFTWARE is acquired under the terms of: (i) a DoD contract: Pursuant to 48 CFR 227.7202 and its successors, use, duplication, or disclosure by the Government is subject to restrictions as set forth in this Agreement; or (ii) a Civilian agency contract: Pursuant to 48 CFR 12.212 and its successors, use reproduction, or disclosure is subject to the restrictions set forth in this Agreement.

Unpublished—rights reserved under the copyright laws of the
10. Governing Law. This Agreement will be governed by the laws of the State of California as they are applied to agreements between California residents entered into and to be performed entirely within California. The United Nations Convention on Contracts for the International Sale of Goods is specifically disclaimed.

11. Entire Agreement. This is the entire agreement between you and EMAGIC which supersedes any prior agreement, whether written or oral, relating to the subject matter of this Agreement.

EMAGIC Product Warranty

1. Product Warranty. Product hardware and media are warranted to be free from defects in material and workmanship during the warranty period (as defined below). Product hardware is warranted to conform substantially to EMAGIC’s then current (as of the date of EMAGIC’s product shipment) published user documentation during the warranty period. The warranty period is twelve (12) months for product hardware and thirty (30) days for media. Product support beyond these periods may be available at additional cost—consult EMAGIC for details.

2. Warranty Claims. EMAGIC shall incur no liability under this warranty if the end user fails to provide EMAGIC with notice of the alleged defect during the applicable warranty period and within thirty (30) days of its discovery. After receiving such notice, EMAGIC’s technical assistance center (“tac”) will notify the purchaser of its designation of one of the following problem resolution methods:

Return to Factory: The allegedly defective goods must be returned to EMAGIC within thirty (30) days of TAC’s notice
and in accordance with EMAGIC’s Return to Factory repair procedures.

Other: TAC will use commercially reasonable efforts to repair, correct or workaround the problem by means of telephone support, including patches, corrective software releases or other means reasonably determined by EMAGIC.

EMAGIC shall incur no liability under this warranty if EMAGIC’s tests disclose that the alleged defect is due to causes not within EMAGIC’s reasonable control, including alteration or abuse of the goods. Under the Return to Factory alternative, if a Product is determined not to be defective or to have a defect due to causes not within EMAGIC’s reasonable control, EMAGIC’s then current processing charge will apply.

3. EMAGIC’S Liability. EMAGIC’S liability, and end user’s sole and exclusive remedy, shall be limited to the express remedies set forth in this EMAGIC product warranty. This warranty is void if the product serial numbers have been removed from the product or if the product has been damaged by misuse, modification or unauthorized repair. EMAGIC hardware does not contain any user-serviceable parts.

4. Disclaimer of Warranties. EMAGIC MAKES NO OTHER WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, REGARDING PRODUCTS. ALL OTHER WARRANTIES AS TO THE QUALITY, CONDITION, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT ARE EXPRESSLY DISCLAIMED.

5. Limitation of Liability. EMAGIC SHALL NOT BE RESPONSIBLE FOR DIRECT DAMAGES IN EXCESS OF THE PURCHASE PRICE PAID BY THE END USER OR FOR ANY SPECIAL, CONSEQUENTIAL, INCIDENTAL, OR PUNITIVE DAMAGE, INCLUDING, BUT NOT LIMITED TO, LOSS OF PROFITS OR DAMAGES TO BUSINESS OR BUSINESS RELATIONS OR, TO THE EXTENT PERMITTED BY LAW, DAMAGES FOR
PERSONAL INJURY, WHETHER OR NOT ADVISED IN ADVANCE OF THE POSSIBILITY OF SUCH DAMAGES THE FOREGOING LIMITATIONS SHALL APPLY NOTWITHSTANDING THE FAILURE OF ANY EXCLUSIVE REMEDIES.

6. Warranty Repair (Return To Factory). If TAC designates Return to Factory as the appropriate problem resolution method, the following provisions apply.

(a) During the first three (3) months of ownership, EMAGIC will ship a replacement for defective Product hardware covered under warranty within twenty-four (24) hours. During the fourth (4th) through twelfth (12th) months of ownership, EMAGIC will repair or replace defective Product hardware covered under warranty within ten (10) business days of receipt of the Product. The warranty period for the replaced product shall be ninety (90) days or the remainder of the warranty period of the original unit, whichever is greater. EMAGIC will ship surface freight. Expedited freight is at end user’s expense.

(b) The end user must return the defective Product to EMAGIC within fourteen (14) days after the request for replacement. If the defective Product is not returned within this time period, EMAGIC will bill the end user for the Product at list price.

7. Out-Of-Warranty Repair (Hardware). EMAGIC will either repair or, at its option, replace defective product hardware not covered under warranty within ten (10) working days of its receipt. Repair charges are available from the repair facility upon request. The warranty on a serviced product is thirty (30) days from date of shipment of the serviced unit. Out-of-warranty repair charges are based upon the prices in effect at the time of return.
## Credits

The contributors to this program and its operating manual are:

<table>
<thead>
<tr>
<th>Role</th>
<th>Contributors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concept, programming, project leader</td>
<td>Michael Haydn</td>
</tr>
<tr>
<td>Program libraries</td>
<td>Jan Cordes, Felix Bertram, Markus Fritze, Clemens Homburg, Gerhard Lengeling, Troy Gaul, Infinity Systems, Ramon M. Felciano</td>
</tr>
<tr>
<td>Module programming</td>
<td>Jens Altfelder, Ingo Debus, Michael Haydn, Udo Hilwerling, Jochen Koeckler, Shehryar Lasi, Robert Rampley, Malte Rogacki, Christian Roth, Oliver Scheel, Marc Teichmann, Robert Vetter, Petra Wolf</td>
</tr>
<tr>
<td>Project management</td>
<td>Jan-Hinnerk Helms, Thomas Sauer</td>
</tr>
<tr>
<td>Manual</td>
<td>Michael Haydn, Thomas Kerschbaum, Jan-Friedrich Conrad, Peter Gorges</td>
</tr>
<tr>
<td>Manual layout and editing</td>
<td>Uwe Senkler, Michael Haydn, Thorsten Adam, Ole Lagemann</td>
</tr>
</tbody>
</table>
This documentation is printed on chlorine-free bleached paper.
Preface

Congratulations!

With SoundDiver, you have chosen one of the most powerful editor/librarian systems available today. SoundDiver makes the daily work of many top producers, musicians and keyboard technicians easier and faster.

We are confident that you will appreciate the sheer number of supported devices, the ease of operation, universal libraries and flexible editors that have won SoundDiver acclaim from users around the globe.

Version 3.0 introduces a stunning new user interface, simplified operation and the unparalleled flexibility afforded by Controller Assignments, which will further accelerate your use of SoundDiver.

If you are new to SoundDiver, you will quickly discover the previously hidden depths of your sound modules.

We are confident that once you have spent a little time with SoundDiver, you will never want to go back to the arcane menus and parameters found on the tiny LCD screens of most MIDI devices.

SoundDiver would not have been possible without the assistance of numerous external developers, adaptation authors and beta testers.

In addition, many “regular” SoundDiver users have sent us extensive feedback which motivated us to add new functions and contributed to many of the improvements found in Version 3.0.

To all of these people, we’d like to say…

Many thanks!

Wishing you all the best with SoundDiver!

Michael Haydn & the Emagic team, September 2000
New Features in Version 3.0

For users who have upgraded from version 2.0 or 2.1 to SoundDiver 3.0, here are the most important new features. For further reference, please look up a suitable key word in the index.

Overall
- New design similar to Logic Audio 4.x; photorealistic device icons
- Some terms have been replaced by easier ones:
  - Memory Manager → Device window; Surf! → Audition;
  - Dive! → Edit; AutoSurf → AutoAudition
- Menu menu structure similar to Logic Audio 4.x
- Key commands window; including some new features
- ToolTips
- Controller Assignments
- Numerous new modules and adaptations

MIDI handling
- Processing of incoming MIDI has priority to screen redraws
- Full MIDI In handling: MIDI inputs can (but don’t have to) be separated
- MIDI loopback test

Setup window
- Device icon is displayed in the parameter column
- Improved icon positioning
- Switching between icon and list view independent from font size

Preferences
- New page “Display”
- Default preferences file has a different name; helps for migration
Install window
- Icon of the selected device is displayed in the left column
- Width of the left column can be modified

Device window
- Hiding of banks of a data type in the Device window
- Names of deleted entries are still displayed

Editor window
- When opening a second editor window, “Link window” is disabled in all editor windows
- Modules can open separate editor windows in a different view. Example: VM-7100 EQs.
- Text input now works with all parameter types. The value which matches best the entered string is chosen.
- 🍊: multi-column flip menus
- 🍊: short click on a flip menu leaves it open, second click closes it

Universal Module
- icons may be imported
- AutoPlay can be suppressed
- Switch “Has keyboard”
# Table of Contents

## Chapter 1  Introduction

1.1 The Challenge ........................................ 39
    ...the Solution ........................................ 40
    Universal, but Specially Tailored to Every Device ................. 40
    The Control Center ....................................... 41
    Mixed Libraries Manage Thousands of Entries ..................... 42
    Automatic Recognition of Connected Devices .................... 42
    Convenient Editors in SoundDiver ................................ 42
    Ease of Use ............................................... 43

1.2 SoundDiver Variants ....................................... 44
    Macintosh vs. Windows versions ............................ 45
    SoundDiver OEM Versions ................................... 45

1.3 About this Manual ........................................ 46
    Concepts .................................................. 46
    Menu Functions ........................................... 47
    Key Commands .............................................. 47
    Explanations ............................................... 47

## Chapter 2  Installation

2.1 What the Package Includes ................................ 49

2.2 System Requirements ...................................... 50
    System Requirements for Windows Computers ....................... 50
    System Requirements for Macintosh Computers .................... 50

2.3 Connecting a MIDI Interface ................................ 51
    Windows .................................................... 51
    Macintosh ................................................. 52

2.4 Connecting the System ..................................... 52
    A Few Rules Governing the MIDI Configuration .................... 53
    Emagic's Unitor Family and Other Patchbays ..................... 54
    MIDI Patchbays ............................................ 54
    J.L. Cooper Synapse ....................................... 55
    J.L. Cooper MSB-16/20 ..................................... 55
    J.L. Cooper MSB Plus and MSB Plus Rev2 ........................ 56
    Digital Music MX-8 ........................................ 56
    Ensoniq KMX-8 and KMX-16 .................................. 56
    MIDITEMP PMM-44/PMM-88 .................................. 57
    Roland A-880 ............................................... 58
    Waldorf Midibay ............................................ 58
    Other Patchbays ............................................ 59
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macintosh Peculiarities</td>
<td>59</td>
</tr>
<tr>
<td>Changed MIDI Ports with Windows</td>
<td>60</td>
</tr>
<tr>
<td>2.5 Installation of SoundDiver</td>
<td>60</td>
</tr>
<tr>
<td>Copy-protection</td>
<td>60</td>
</tr>
<tr>
<td>Installing a New Program on a Hard Disk</td>
<td>61</td>
</tr>
<tr>
<td>Updating an Existing Program</td>
<td>61</td>
</tr>
<tr>
<td>Authorizing the Hard Disk</td>
<td>61</td>
</tr>
<tr>
<td>Renewing the Authorization</td>
<td>62</td>
</tr>
<tr>
<td>Removing an Authorization (Deauthorizing)</td>
<td>62</td>
</tr>
<tr>
<td>Starting SoundDiver without Authorization</td>
<td>63</td>
</tr>
<tr>
<td>Optimization Programs</td>
<td>63</td>
</tr>
<tr>
<td>Formatting the Hard Disk</td>
<td>63</td>
</tr>
<tr>
<td>Completely Removing SoundDiver from the Hard Disk</td>
<td>64</td>
</tr>
<tr>
<td>2.6 Starting the Program for the First Time</td>
<td>64</td>
</tr>
<tr>
<td>Language Used in SoundDiver</td>
<td>65</td>
</tr>
<tr>
<td>2.7 Installing Devices</td>
<td>65</td>
</tr>
<tr>
<td>The Install Window</td>
<td>66</td>
</tr>
<tr>
<td>Selecting the Models</td>
<td>66</td>
</tr>
<tr>
<td>Scanning Using the Keys</td>
<td>67</td>
</tr>
<tr>
<td>Scanning</td>
<td>67</td>
</tr>
<tr>
<td>Models which Cannot Be Scanned</td>
<td>68</td>
</tr>
<tr>
<td>Scan All</td>
<td>69</td>
</tr>
<tr>
<td>Manually Adding Devices to the Setup</td>
<td>69</td>
</tr>
<tr>
<td>Done</td>
<td>70</td>
</tr>
<tr>
<td>Help</td>
<td>70</td>
</tr>
<tr>
<td>Creating the List of Models</td>
<td>70</td>
</tr>
<tr>
<td>Check the MIDI Connection</td>
<td>70</td>
</tr>
<tr>
<td>2.8 Shortcut/Alias of the Program File</td>
<td>71</td>
</tr>
<tr>
<td>2.9 The Diver Folder</td>
<td>71</td>
</tr>
<tr>
<td>2.10 Windows File Types</td>
<td>72</td>
</tr>
<tr>
<td>Installing Modules and Adaptations</td>
<td>72</td>
</tr>
<tr>
<td>Removing Unwanted Modules</td>
<td>72</td>
</tr>
<tr>
<td>Removing Unwanted Adaptations</td>
<td>73</td>
</tr>
<tr>
<td>2.12 SoundDiver and MIDI-Tasking</td>
<td>73</td>
</tr>
<tr>
<td>AutoLink</td>
<td>73</td>
</tr>
<tr>
<td>MIDI-Tasking on Macintosh</td>
<td>74</td>
</tr>
<tr>
<td>OMS</td>
<td>74</td>
</tr>
<tr>
<td>MIDI Manager</td>
<td>78</td>
</tr>
<tr>
<td>Any Other MIDI-tasking System</td>
<td>79</td>
</tr>
<tr>
<td>MIDI-Tasking on Windows</td>
<td>79</td>
</tr>
<tr>
<td>Multi-client MIDI drivers</td>
<td>79</td>
</tr>
</tbody>
</table>
# Table of Contents

**SoundDiver**

- How to Block MIDI Ports (Windows:) ........................................... 82
- SoundDiver as a Background Program ........................................ 83
  - 2.13 Compatibility of the Windows, Macintosh, and Atari Versions ................. 83
  - Converting Files between the three Platforms .................................. 83
  - Converting Files from and to the Macintosh .................................... 85
  - 2.14 Key Commands and Remote Control via MIDI .................................. 85
  - Modifier Keys on Macintosh vs. Windows ........................................ 86
  - Save Your Personal Settings .......................................................... 86
  - Menus and Dialogs ............................................................................. 87
  - Special Keys ...................................................................................... 87
  - Key Commands Window ....................................................................... 88
  - Assigning a Function to a Key .......................................................... 89
  - Learn Separate Key ............................................................................ 89
  - Assigning a Function to a MIDI Message ............................................ 90
  - Deleting Assignments ........................................................................ 90
  - Switching MIDI Remote on/off .......................................................... 91
  - Checking the Function of a Key ......................................................... 91
  - Making the Display Clearer ............................................................... 91
  - Finding Key Commands ..................................................................... 92
  - Scroll to Selection ............................................................................... 92
  - Printing a Key Command List ............................................................ 92
  - Storing Key Command Assignments ................................................... 93
  - Importing Key Commands ................................................................... 93
  - Initializing Key or MIDI Event Assignments ....................................... 93
  - Entering Numerals .............................................................................. 94

**Chapter 3 Introductory Tour of SoundDiver**

- 3.1 Start .............................................................................................. 95
- 3.2 Station 1: Setup and Install Windows .......................................... 97
  - Scanning ............................................................................................ 98
  - Installing Devices Manually .............................................................. 99
  - Window Operation .............................................................................. 99
    - Window Layout ................................................................................ 99
    - Local Menus .................................................................................. 100
    - Scrolling the Contents of the Window .............................................. 100
  - Parameter Box .................................................................................. 101
- 3.3 Station 2: The Device Window .................................................... 102
  - Contents of the Device Window ......................................................... 102
  - Requesting the Memory Contents of the Devices .............................. 104
  - Saving the Memory Contents of the Devices ..................................... 104

**User Manual**

*Version 3.0*
# Table of Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selecting Entries</td>
<td>105</td>
</tr>
<tr>
<td>Auditioning the Selected Entries</td>
<td>106</td>
</tr>
<tr>
<td>Moving and Copying Entries</td>
<td>106</td>
</tr>
<tr>
<td><strong>3.4 Station 3: The Library</strong></td>
<td>107</td>
</tr>
<tr>
<td>User-definable Configuration of the Library Window</td>
<td>108</td>
</tr>
<tr>
<td>Sorting</td>
<td>109</td>
</tr>
<tr>
<td>Moving Columns and Altering Their Widths</td>
<td>110</td>
</tr>
<tr>
<td>Mixed Libraries</td>
<td>110</td>
</tr>
<tr>
<td>Dividing a Library into Zones</td>
<td>110</td>
</tr>
<tr>
<td>Find Functions</td>
<td>111</td>
</tr>
<tr>
<td><strong>3.5 Station 4: The Editors</strong></td>
<td>112</td>
</tr>
<tr>
<td>Let's Start...</td>
<td>114</td>
</tr>
<tr>
<td>... in the Library</td>
<td>114</td>
</tr>
<tr>
<td>Welcome to Pleasure-programming...</td>
<td>115</td>
</tr>
<tr>
<td>A Handful of Editing Functions...</td>
<td>115</td>
</tr>
<tr>
<td>Randomize</td>
<td>120</td>
</tr>
<tr>
<td><strong>3.6 Station 5: The On-line Help</strong></td>
<td>120</td>
</tr>
<tr>
<td><strong>3.7 Other Functions</strong></td>
<td>121</td>
</tr>
<tr>
<td>The Mini-sequencer</td>
<td>121</td>
</tr>
<tr>
<td>Screensets</td>
<td>122</td>
</tr>
<tr>
<td><strong>3.8 Short Introduction to SysEx</strong></td>
<td>122</td>
</tr>
<tr>
<td>What is System Exclusive Data?</td>
<td>123</td>
</tr>
<tr>
<td>Device IDs</td>
<td>124</td>
</tr>
<tr>
<td>Dump Request</td>
<td>124</td>
</tr>
<tr>
<td>Dumps</td>
<td>125</td>
</tr>
<tr>
<td>Parameter Changes</td>
<td>125</td>
</tr>
</tbody>
</table>

## Chapter 4  
**SoundDiver's User Interface**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1 The Look of SoundDiver</td>
<td>127</td>
</tr>
<tr>
<td>3-D Appearance</td>
<td>127</td>
</tr>
<tr>
<td>SoundDiver 2.0 Appearance</td>
<td>128</td>
</tr>
<tr>
<td><strong>4.2 General Operation</strong></td>
<td>128</td>
</tr>
<tr>
<td>Mouse</td>
<td>128</td>
</tr>
<tr>
<td>Microsoft IntelliMouse™ (Windows Only).</td>
<td>130</td>
</tr>
<tr>
<td>Contextual Menus (Windows Only).</td>
<td>131</td>
</tr>
<tr>
<td>The Computer Keyboard</td>
<td>131</td>
</tr>
<tr>
<td>Moving the Cursor</td>
<td>131</td>
</tr>
<tr>
<td>Entering Text</td>
<td>132</td>
</tr>
<tr>
<td>Defining the Font Used (Windows Only)</td>
<td>133</td>
</tr>
<tr>
<td>Menus</td>
<td>133</td>
</tr>
</tbody>
</table>
## Table of Contents

- Undo.......................... 148
- Redo.......................... 149
- The Text Clipboard........... 150
- Cut............................ 150
- Library/Device Window........ 150
- Copy.......................... 151
- Paste.......................... 151
- Library........................ 151
- Device Window................ 152
- Strategies Used in Paste.... 152
- Clear.......................... 154
- Library........................ 154
- Setup Window.................. 155
- Select all..................... 155
- Toggle Selection.............. 155
- Request....................... 155
- Setup Window.................. 156
- Library Window.............. 156
- Device Window.............. 156
- Editor Window................ 156
- Transmit...................... 157
- Setup Window.................. 157
- Library Window.............. 158
- Device Window.............. 158
- Editor Window................ 158
- Find.../Find again........... 158

4.8 The Options Menu........... 159
  - Settings..................... 159
  - AutoAudition............... 159
  - AutoPlay................... 159
  - MIDI Thru.................. 160
  - Hold Transmission.......... 160
  - Send MIDI.................. 161
    - All Notes Off............ 161
    - Reset Controllers........ 161
    - Maximum Volume.......... 161
  - Loopback Test............... 162

4.9 The Windows Menu............ 163
  - Screensets.................. 163
  - Storing Screensets.......... 164
  - Switching Screensets........ 164
Table of Contents

Protecting Screensets ........................................... 164
Copying Screensets ........................................... 164
Reverting to a Stored Screenset ............................... 165
Sequencer-controlled Switching ............................ 165
Open Library ...................................................... 165
Open Setup ....................................................... 166
Open Device ...................................................... 166
Open Editor ....................................................... 167
Open Controller Assignments ............................... 168
Open Install Window ....................................... 168
Open Sequencer ............................................... 168
Open MIDI Monitor ........................................... 169
Open Help .......................................................... 169
Larger View ......................................................... 169
Smaller View ......................................................... 169
Next Window ....................................................... 169
Zoom Window ....................................................... 170
Close Window ....................................................... 170
Tile Windows ....................................................... 170
Tile Windows Horizontally ............................... 170
Stack Windows ...................................................... 171
Window List ......................................................... 171
Library List ......................................................... 171
4.10 On-line Help .................................................... 171
Help Menu for Windows ....................................... 172
Help ................................................................. 172
Search Help ......................................................... 173
How to Use Help .................................................. 173
Common Menus ...................................................... 173
About SoundDiver ............................................... 173
License Agreement ............................................... 173
SoundDiver Features .......................................... 173
Emagic Distributors ............................................. 173
Layout of the Help Window .................................. 174
The Help Window ............................................... 174
The Control Bar on Windows ............................... 174
Index ................................................................. 175
Operating the On-line Help .................................. 175
Zoom ................................................................. 175
Cross-references .................................................. 175
Icons ................................................................. 175

User Manual
Version 3.0

23
Table of Contents

Standard Pages ............................................. 176
"Module" Module (e.g. JV1080 Module) .................. 176
"Model" (e.g. XP-80) ..................................... 176
Installation ................................................. 176
Scan ............................................................. 177
MIDI .............................................................. 177
AutoLink ....................................................... 177
SysEx Communication Error ............................... 177
Memory Manager ............................................ 177
"Data type" (e.g. Patch) .................................. 178
"Bank" (e.g. Performance Mode Temporary Patches) .... 178
Device Parameter box .................................... 178
Conversion ................................................... 178
Import ......................................................... 178
Credits ......................................................... 178
"Data type" Editor (e.g. Patch Editor) .................... 179
"Parameter group" (e.g. TVA Envelope) ................... 179
"Parameter" (e.g. Cutoff Frequency) ...................... 179

4.11 The ToolTips ............................................. 179
ToolTips in the Editor Window ......................... 180
ToolTips in the Device Window ....................... 180
Adjust ToolTips ............................................ 180
Particularities .............................................. 181

4.12 The Mini Sequencer .................................... 182
Record ......................................................... 183
Output Parameters ....................................... 183
Play ............................................................ 183
Drum Autoplay ............................................ 183
Free Memory ............................................... 184
Store Sequence ............................................. 184

4.13 MIDI Monitor ............................................ 185
Edit Menu ..................................................... 186
Copy ........................................................... 186
Clear ......................................................... 186
Show Menu .................................................. 186
MIDI In ...................................................... 187
MIDI Out ..................................................... 187
View Menu .................................................... 187
Time Stamps ................................................. 187
... of Status Bytes Only .................................. 188
Note Off, ..., System messages ......................... 188
Chapter 5  The Setup Window

5.1 Installing Your Devices ................................. 191
5.2 Installing New Devices Manually ...................... 191
5.3 Interactive On-line Help ............................... 192
5.4 Graphic Display of the Setup.
   Icons and Lists ........................................ 193
   Activating a Device .................................. 194
   Moving Icons with the Mouse ....................... 194
   Import New Icons ..................................... 195
   Opening a Device Window ............................. 195
   Deinstalling a Device ................................ 196
   Buttons for Requesting/Transmitting ................. 196
5.5 Contextual Menu on Windows ......................... 196
5.6 The Device Parameter Box ............................. 197
   Hiding and Displaying the Parameter Box ............ 198
   Name .................................................. 198
   Out Port and Input .................................. 198
   Issues Particular to Windows ....................... 199
   Issues Particular to the Macintosh ................. 199
   Inputs and Outputs Using Patchbays ................. 199
   Connected to ........................................ 199
   Out Port (of the Patchbay) .......................... 200
   Return to ............................................ 200
   Input (of the Patchbay) ............................. 200
   Device ID ............................................ 201
   Thru Channel ......................................... 202
   Preserve Thru-Port/Channel. ......................... 202
   Velocity .............................................. 203
   Timeout .............................................. 203
   Send Pause ........................................... 203
   Play Delay ............................................ 204
   Patchbay Program ..................................... 204
   Master Keyboard ..................................... 205
   Auto Request ......................................... 206
   Module ............................................... 207
   Model ............................................... 207
   Version .............................................. 207
5.7 Special Device Parameters ............................ 208
Table of Contents

Help on Special Parameters .......................... 208
Special Parameters for Patchbays ................. 208
Patchbay Program and Standard Program .......... 209
5.8 Interactive On-line Help ......................... 210
5.9 Local Menus in the Setup Window ............. 211
New .................................................. 211
Install ............................................... 211
Scan All Models .................................. 211
Load and Transmit File ............................. 211
Build Library ...................................... 211
Save as ............................................. 211
Export .............................................. 212
Save Library for Logic Song ....................... 212
Store All Edits .................................... 212
View ............................................... 212
Parameters ........................................ 212
As Icons/As List .................................. 213
5.10 Automatically Creating a Library ............. 213
5.11 Device Selection Strategy when Sending from a Library .... 214

Chapter 6  The Device Window

6.1 Data Consistency between the Device and Device Window ... 218
6.2 Entry Dependency Management .................. 218
Devices with Individual Edit Buffers .............. 219
6.3 The Device Window ................................ 220
The Link Function .................................. 220
Buttons for Requesting/Transmitting .............. 221
Zoom Functions .................................... 221
Layout of the Device Window ...................... 222
The Contents of the Device Window ............... 223
Banks ................................................ 223
Entries with Dependencies ......................... 224
Entries Shown in Gray ............................. 224
Names of ROM Entries ............................ 224
6.4 Functions in the Device Window ............... 225
Selecting Entries in the Device Window .......... 226
Selecting Entries Using Names .................... 227
Exchanging, Moving and Copying Entries with the Mouse .... 228
Exchanging ........................................ 228
Copying ............................................ 228

Emagic
SoundDiver
Table of Contents

Using the Edit Menu to Cut, Copy, Paste and Delete Entries . 229
Editing Entries ................................................. 229
6.5 Contextual Menu ........................................... 229
6.6 The Device Parameter Box ............................... 230
6.7 Special Functions ........................................... 230
6.8 Interactive On-line Help ................................. 231
6.9 Dependency List .......................................... 231
6.10 Local Menus in the Device Window ................. 232
   Entry .................................................................. 232
   Load and transmit File ...................................... 232
   Initialize .......................................................... 233
   Rename ............................................................ 233
   Audition ......................................................... 233
   Edit ................................................................. 234
   Build Library .................................................. 234
   Save as .......................................................... 234
   Export ............................................................... 234
   Append to Library ............................................. 234
   View ................................................................ 235
   Parameters ....................................................... 235
   Link Windows .................................................. 235
   Next Device/Previous Device ............................. 235
   Data Types ...................................................... 236
   Select Data Type via Buttons ............................ 236
   Special ............................................................. 237
   Adaptation ........................................................ 237
6.11 MIDI Functions of the Device Window .............. 237
   Requesting Entries .......................................... 237
   Transmitting Entries ....................................... 238
   Requesting the Device Window Contents at Power-up 239
6.12 Saving the Device Window to Disk ................. 240
   Saving the Device Window as a Library ................. 240
   Reloading the Device Window .......................... 241
   Reloading Part of the Device Window .................. 241
   Saving the Device Window Contents Automatically .. 242
6.13 Remote Control Adaptations .......................... 242

Chapter 7   The Library

7.1 What Is a SoundDiver Library? ....................... 245
7.2 The Library Window ...................................... 246

User Manual
Version 3.0
# Table of Contents

- Opening and Closing a Library File ................................................. 247
- Opening a Library Window ............................................................... 247
- Selecting Entries in the Library ......................................................... 248
- Selecting Child Entries as Well ......................................................... 249

## 7.3 Mouse Operations in the Library .................................................... 249

## 7.4 Contextual Menu on Windows ......................................................... 250

## 7.5 Managing Libraries on Disk .......................................................... 251

## 7.6 Creating a Library ................................................................. 251

## 7.7 Automatically Loading a Library on Start-up .................................. 252

## 7.8 The Layout of the Library Table .................................................. 252
- Number .......................................................................................... 253
- Altering the Order of the Columns ...................................................... 253
- Altering the Widths of the Columns .................................................... 253
- The View Menu ................................................................................. 254
- Size of Text ......................................................................................... 254

## 7.9 Sort Functions ................................................................................. 255
- Sorting within the Title Bar ................................................................. 255

### The Sort Menu .................................................................................. 255
- Sort by Name ....................................................................................... 256
- Sort by Module .................................................................................... 256
- Sort by Model ...................................................................................... 256
- Sort by Device ID ................................................................................. 256
- Sort by Data Type .................................................................................. 256
- Sort by Location .................................................................................... 256
- Sort by Size .......................................................................................... 257
- Sort by Date .......................................................................................... 257
- Sort by Comment ................................................................................... 257
- Auto (AutoSort) .................................................................................... 257

- Undoing Sorts ....................................................................................... 257
- Sorting a Zoned Library ................................................................. 258

## 7.10 The Parameter Box for Entries ......................................................... 259

### Adding Text to Multiple Entries ......................................................... 259
- Name ................................................................................................. 260
- Module ................................................................................................. 260
- Model ................................................................................................. 260
- Device ID .............................................................................................. 261
- Data Type ............................................................................................. 261
- Location ............................................................................................... 262
- Date ....................................................................................................... 262
Table of Contents

Time . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 262
Size . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 262
Comment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 263
The Dependency List . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 263

7.11 Local Library Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 263
Audition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 263
Devices with Individual Edit Buffers . . . . . . . . . . . . . . . . . . . . 264
Edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 264
Store Sequence . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265
Delete Sequence . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265
Insert Title . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265
Insert File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 266

7.12 Requesting Library Entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267
7.13 Sending Library Entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267
Default Destination Location . . . . . . . . . . . . . . . . . . . . . . . . . . . 267

7.14 The Find Function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268
Opening the Find Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 269
A Simple Find Operation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 270
Starting the Find Operation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 270
Repeating the Find . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 270
More Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 271
What . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 271
Special Issues with the Criterion “Data” . . . . . . . . . . . . . . . . . . . 272
How . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 272
Comparison Criteria . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 273
The Find Value . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 273
Selection of the Entries Found . . . . . . . . . . . . . . . . . . . . . . . . . . 273
Select One . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274
Select All . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274
Add to Selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274
Select in Selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274
Keep First, Delete Rest . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274
Search in All Documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 275
Less Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 275
Find . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 275

7.15 Importing from Other Programs . . . . . . . . . . . . . . . . . . . . . . . . 275
Importing Polyframe Libraries . . . . . . . . . . . . . . . . . . . . . . . . . . 275
Importing Standard MIDI Files . . . . . . . . . . . . . . . . . . . . . . . . . . 276
Conditions for the File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 276
How the Import Function Works . . . . . . . . . . . . . . . . . . . . . . . . . 277
Import of Files with Several Dumps for the Same Entries . . . . . . . 278
## Table of Contents

- Import from a Song File .............................................. 279
- Unrecognized Dumps .................................................. 280
- Importing SYX Files .................................................. 281
- Conditions for the File .............................................. 281
- How the Import Function Works ................................... 281
- Import Functions for Specific Modules ........................... 281
- Format Recognition .................................................... 281
- Data Format for the Import ......................................... 282
- Additional Information .............................................. 282

7.16 Exporting Files ................................................... 282
- Exporting Standard MIDI Files (SMF) .............................. 283
- Exporting SYX Files .................................................. 284
- Limitations with File Export ........................................ 285
- Questions and Answers on File Export ............................ 285

7.17 Converting the Sounds of Related Devices ...................... 286

7.18 Saving a Sound Bank as a Library ............................... 286
- Sub Menu ............................................................. 287
  - Editable Entries .................................................. 287
  - Memory Locations ............................................... 288
  - All Entries ...................................................... 288
  - Selected Entries ............................................... 288
  - Known Entries ................................................. 288
  - “Save as…” .......................................................... 288
- Load and Transmit File ............................................. 288
  - Loading for a Single Device ..................................... 290
  - Importing Different Formats ................................... 290
- Sending Entries from the Library .................................. 290
- Changing the Location .............................................. 290
- Deleting the Memory Location Assignment ...................... 291
- The Edit Buffers ..................................................... 291

7.19 Practical Examples for Libraries ................................. 292
- Instantly Saving Sounds for a Production ......................... 292
- Archiving Layered Sounds ......................................... 293

### Chapter 8 Editing with SoundDiver

8.1 General ............................................................. 295
8.2 Opening the Editor ................................................ 296
  - The Overview ..................................................... 297
8.3 The Easy Page ...................................................... 298
8.4 Navigating the Editor Window .................................... 299

**Emagic**

- SoundDiver
8.5 Selecting the Parameter to Edit ........................................... 301
   Parameter Help ......................................................... 301
   Cursor Position ....................................................... 302
   MIDI Thru Channel .................................................... 302
8.6 Editing Parameters with the Mouse ..................................... 302
   Using the Mouse as a Slider ........................................... 303
   Using the Mouse to Decrement/Increment ............................. 303
   Flip-menus .................................................................. 303
   Mouse Operation ....................................................... 304
   Display ................................................................ 304
   Windows: Keyboard Operation ........................................ 304
   Editing a Flip-menu Object without a Flip-menu ..................... 305
   Editing with Graphic Objects .......................................... 305
   Envelopes .................................................................. 306
   Keyboard Window ....................................................... 306
   Keyboard Velocity Windows ............................................ 307
8.7 Inputting Values via the Keyboard ....................................... 308
   Number-input Mode ..................................................... 308
   Text Input Box ............................................................ 308
   Increasing or Decreasing Values ....................................... 309
   Names .................................................................... 310
8.8 Inputting Values via MIDI ................................................... 310
8.9 AutoPlay ................................................................. 311
8.10 Edit Button .............................................................. 311
8.11 Contextual Menu in Windows ........................................... 311
8.12 More than One Editor Window .......................................... 312
8.13 The Edit Buffer ........................................................ 313
   Multiple Edit Buffers ................................................... 314
   MIDI Thru ............................................................... 314
8.14 Remote-control and Monitors ........................................... 314
8.15 Undo Edit ............................................................. 315
8.16 Clipboard Functions in the Editor ...................................... 316
   Selecting a Parameter Group .......................................... 316
   Clipboard Functions for Selected Groups .............................. 317
   Cutting a Parameter Group ......................................... 317
   Copying a Parameter Group ......................................... 317
   Pasting a Parameter Group ......................................... 318
   Drag-and-Drop .......................................................... 318
   Deleting a Parameter Group ......................................... 318
8.17 Local Windows in the Editor Menu ..................................... 318
   The Edit Menu ........................................................... 318
Table of Contents

Chapter 9  Controller Assignments

9.1 What’s a Controller Assignment? .......................... 329
First Example of a Controller Assignment .................. 330
Controller Assignment Features ............................... 332
Fader Box Modules ............................................ 332
Example for Creating a Controller Assignment ........... 333
9.2 Terminology .................................................. 335
9.3 The Controller Assignments Window ..................... 336
The Data Inside the Controller Assignments Window .... 337
Handling of Controller Assignments .......................... 337

Emagic
SoundDiver
Table of Contents

Predefined Controller Assignments .......................... 353
Defining Manually ............................................. 354

Chapter 10 AutoLink

10.1 What Is Autolink? .......................................... 357
10.2 How Do You Start Autolink? ......................... 358
10.3 MIDI Communication with Autolink .............. 359
10.4 The Sound Names in Logic Instruments ........... 362
10.5 Remote-controlling Logic by SoundDiver ........ 368
10.6 Changing Logic’s Track Instruments ............... 368
10.7 Saving Song Data in a Library ....................... 369
10.8 Recording Parameter Changes in Logic ............ 371
10.9 Displaying Recorded Parameter Changes in SoundDiver 374
10.10 Recording Dumps in Logic ......................... 376
10.11 Synchronizing Screensets ......................... 376
10.12 Open SoundDiver for Instrument ................. 377

Chapter 11 The Universal Module

11.1 The Differences between Modules and Adaptations . 380
11.2 Editing Adaptations ....................................... 382

Emagic
SoundDiver
Chapter 12  The Preferences

12.1 Communication ........................................... 385
  Particular Issues on Windows ................................. 386
    MIDI Input Buffers per Port ............................... 386
    KB per MIDI Input Buffer ................................. 386
    Ignore MIDI In Errors .................................... 387
    USB Plug-and-play ........................................ 387
  Particular Issues on the Macintosh ......................... 388
    Modem Port/Printer Port ................................. 388
    USB ......................................................... 389
    Display of Recognized Interfaces ....................... 389
    Options for Modem and Printer Port ....................... 390
    Use MIDI Manager if Available ............................ 392
    Use OMS if Available .................................... 393
    OMS Settings ............................................... 394
  Particular Issues in AutoLink Mode ......................... 394
    Synchronize Screensets ..................................... 394
    Process Incoming MIDI only for Active Device .......... 394
    Check Device Connections at Startup ....................... 395
    Additional Timeout ....................................... 396
    Request Retries .......................................... 396

12.2 Global Settings .......................................... 397
  Save Device Entries in Preferences File .................. 397
  Auto Snapshot Every x s .................................. 398
  Dependency Management .................................... 399
  Mouse as Slider .............................................. 399
  Fader Tracking .............................................. 399
  Num Lock ...................................................... 400
  Deauthorize .................................................. 400

12.3 Display Settings .......................................... 401
  Different Appearance ....................................... 401
  Hide Value in Linear Parameters ............................ 401
  3D Look ....................................................... 402
Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sound Effects</td>
<td>402</td>
</tr>
<tr>
<td>Show Progress</td>
<td>402</td>
</tr>
<tr>
<td>Flicker-free Display</td>
<td>402</td>
</tr>
<tr>
<td>ToolTips</td>
<td>403</td>
</tr>
<tr>
<td>When Pointing on Objects</td>
<td>403</td>
</tr>
<tr>
<td>While Editing</td>
<td>403</td>
</tr>
<tr>
<td>Language</td>
<td>403</td>
</tr>
<tr>
<td>12.4 Safety Messages</td>
<td>404</td>
</tr>
<tr>
<td>Loading Device Entries from Preferences</td>
<td>404</td>
</tr>
<tr>
<td>Saving Preferences</td>
<td>405</td>
</tr>
<tr>
<td>Overwriting Memory Entries</td>
<td>405</td>
</tr>
<tr>
<td>Deleting Doubles</td>
<td>405</td>
</tr>
<tr>
<td>Editing Unknown Entries</td>
<td>406</td>
</tr>
<tr>
<td>Closing Altered Editor Windows</td>
<td>406</td>
</tr>
<tr>
<td>Overwriting Edited Entries</td>
<td>406</td>
</tr>
<tr>
<td>Create Logic Instruments</td>
<td>407</td>
</tr>
<tr>
<td>12.5 Library</td>
<td>407</td>
</tr>
<tr>
<td>Auto-save Libraries Every x min.</td>
<td>407</td>
</tr>
<tr>
<td>Reopen Libraries</td>
<td>408</td>
</tr>
<tr>
<td>Check Doubles</td>
<td>408</td>
</tr>
<tr>
<td>Prefer Selected Devices as Target.</td>
<td>408</td>
</tr>
<tr>
<td>12.6 Preferences File</td>
<td>408</td>
</tr>
<tr>
<td>Contents of the Preferences File</td>
<td>409</td>
</tr>
<tr>
<td>Creating the Preferences File</td>
<td>410</td>
</tr>
<tr>
<td>Saving Preferences Automatically</td>
<td>411</td>
</tr>
<tr>
<td>Saving Preferences Manually</td>
<td>411</td>
</tr>
<tr>
<td>Saving Preferences in the Current File</td>
<td>411</td>
</tr>
<tr>
<td>Save Preferences under a Different File Name</td>
<td>411</td>
</tr>
<tr>
<td>Loading Preferences</td>
<td>411</td>
</tr>
<tr>
<td>Rebuild the Content of the Install Window</td>
<td>412</td>
</tr>
<tr>
<td>Reload Icons</td>
<td>412</td>
</tr>
<tr>
<td>Reset Preferences</td>
<td>412</td>
</tr>
<tr>
<td>Language</td>
<td>412</td>
</tr>
</tbody>
</table>

Appendix A  Key Commands ........................................ 415

A.1 Differences of Key Commands .................................. 415
A.2 Key Commands .................................................. 416

Emagic

SoundDiver
## Appendix B

**Using the Mouse** ........................................ 419

## Appendix C

**Troubleshooting** ........................................ 421
- C.1 General ............................................. 421
- C.2 Installation ......................................... 424
- C.3 Startup ............................................. 425
- C.4 Scanning ............................................ 426
- C.5 MIDI Communication .............................. 427
- C.6 Library .............................................. 435
- C.7 Device Window ..................................... 436
- C.8 Editor ............................................... 437
- C.9 AutoLink ............................................ 440

## Appendix D

**Glossary** .................................................. 443

**Index** .................................................... 453
Chapter 1

Introduction

1.1 The Challenge…

Anyone who uses synthesizers these days potentially has access to thousands of sounds. In addition, there are effects devices, MIDI patchbays and other peripheral devices from which data can be accessed and then managed or archived.

Synthesizers and other MIDI devices offer limited options for effectively archiving this data and having it available at the right moment. A synthesizer’s user interface simply cannot compete with the convenience of a monitor and a mouse. They also often lack sufficient memory or storage options like a hard disk, or even a floppy disk drive. Finally, they rarely provide
suitable software for finding and sorting your growing library of patch data.

**...the Solution**

All of the above shortcomings can be solved using your computer. A Mac OS machine or a Windows 98 PC has the necessary hardware and computing capacity to hold dozens of sound banks and libraries in its working memory.

SoundDiver provides an intelligent link between the computer and your MIDI devices. First and foremost, SoundDiver is a sound management program. You will probably have already come across programs described as “dump utilities”, “sound managers” or “librarians”. All these programs deal with the saveable data of synthesizers, drum machines, effects devices, MIDI patchbays and so on. Of course SoundDiver can do all of these things, but it also does much more.

**Universal, but Specially Tailored to Every Device**

SoundDiver is a modular system designed to work with almost any MIDI device. Modules are already supplied for many devices. The program code for each specific device is stored in a separate module file. The advantage is, that only modules you need at a time will occupy space in the working memory and on your hard disk.

In addition to modules, SoundDiver allows you to create and save your own adaptations for any MIDI device. This means you can add devices to your SoundDiver system without waiting for them to be programmed by Emagic or a third party developer. This is made possible by the *Universal Module*. This module can simultaneously manage multiple adaptations. Your SoundDiver program comes with a large number of adaptations ready for use. If you are interested in creating your own adaptations, there is a text file version of the programming manual.
Unlike many other universal programs, SoundDiver knows every detail of those devices for which it has a module, and can therefore make full use of its particular capabilities. For example, SoundDiver’s SY99 module can convert DX7 sounds, and the Microwave module can manage wave tables.

SoundDiver supports remote control. With this feature any parameter can be controlled by any MIDI message—which makes using fader boxes especially convenient.

The Control Center

SoundDiver can be the control center of your MIDI system. It knows all of the connected devices and their memory contents. If you alter anything, SoundDiver automatically considers all the repercussions of the alteration. This makes it virtually impossible for you to unintentionally alter or delete any of your files.

SoundDiver uses a Device window with contents that are always a mirror image of the memory contents of the corresponding device. If a discrepancy arises—e.g. because you have copied a sound within the device itself—you can restore the data using simple commands.

SoundDiver’s Entry Dependency Management also ensures that the connections between child patches and parent patches remain intact. Let’s say you create a voice for a Yamaha EX5 and save it to a new memory location. The reference of all the performances that refer to this program is automatically updated—you don’t have to worry about doing it yourself.

Best of all, with SoundDiver, you can manage all your sounds directly on the screen—you never need to touch the device itself.
Chapter 1
Introduction

Mixed Libraries Manage Thousands of Entries

You also will not have to search through the individual library of each synthesizer for certain sounds. That’s because SoundDiver lets you collect sounds from different synthesizers into one library.

Open your “Bass Sound” library, and up comes every bass sound in your MIDI rig, regardless of the device it belongs to! All you have to do is click the entries and SoundDiver automatically sends the sound to the right synthesizer and ensures that the master keyboard will play that specific synthesizer.

This feature relieves you of tiresome management work, leaving your mind free for what is most important: concentrating on the music and having the right sounds available at the right time.

Automatic Recognition of Connected Devices

SoundDiver can independently recognize your MIDI setup. From the Install window, you can ask SoundDiver to automatically scan your MIDI system and install the located devices. Their memory contents can be automatically transferred to the computer.

Convenient Editors in SoundDiver

There are Editors for nearly all devices recognized by SoundDiver. Even with so many Editors, each Editor has the same number and type of features that you might only expect in a program dedicated to a specific device. Features like:

- graphic display and editing of all parameters including envelopes, sound structures and effects;
• an Easy Page, where you can effect global changes with just a few parameters;
• copying, cutting and pasting of parameter groups between voices and elements;
• randomize functions.

Although each individual Editor is specifically tailored to a particular device, all the Editors follow the same general layout and conventions. This makes it easy to use all of the Editors once you have learned to use just one.

Ease of Use

Despite all of these different options, SoundDiver is easy to use.

Functions are logically and conveniently grouped into local menus contained in the individual windows or inserted in the menu bar.

We have tried to standardize the menus and key commands whenever possible. For example, the standard menus and key commands which are found in other Emagic programs are exactly the same. Of course key commands can be changed to fit your personal needs.

SoundDiver’s window technology allows you to open several windows of a sound bank or library and configure the display of your sounds according to your own wishes. You can save up to 90 of these so-called screensets and recall them instantly with a key command.

Once again here is a quick summary of the main features:

• SoundDiver is universal: it is designed to work with any MIDI device. Powerful modules or adaptations are supplied for most devices. You can create your own adaptations for all other devices.
Chapter 1
Introduction

• SoundDiver is user-friendly—you don’t need to know anything about System Exclusive data to operate the main program. You don’t have to know what a dump request or a manufacturer’s ID is, so you can concentrate fully on your sounds. However, if you are a MIDI pro, SoundDiver offers you all sorts of options for editing the pre-supplied adaptations to suit your own taste, or for creating your own patches from scratch.

• SoundDiver gives you instant access to the right sounds. You can also create as many libraries with as many entries as you want, all of which can be searched and sorted. SoundDiver libraries can also mix the data from different devices within one library.

• SoundDiver keeps an overview of your entire setup. It knows the data structure of all the devices and automatically adjusts any inter-related data to take account of any changes that are made.

• SoundDiver offers all of this plus convenient Editors for your devices. Despite the fact that each Editor is specifically tailored to one device their operation is uniform.

The section Installation from page 49 onwards will explain how to install SoundDiver and arrange your MIDI setup. In page 95 you can try out what you have just learned on the real thing, as we take a tour through SoundDiver’s different levels.

Enjoy!

1.2 SoundDiver Variants

SoundDiver is a very powerful program, that allows you to manage your sounds and other SysEx data in a homogenous way with direct access to all your data at all times.

It is available in several flavors:
Macintosh vs. Windows versions

SoundDiver is available in more-or-less identical versions for Windows 98/2000 and Mac OS. The variations in the program versions relate solely to:

- the details of the file and window management used by the respective operating system;
- support of color and fonts;
- the contents of the preferences window
- the search window (section The Find Function from page 268 onwards)
- the different hardware accessories—in particular the available MIDI ports and MIDI interfaces;
- support of MIDI system extensions such as MIDI Manager or OMS.

SoundDiver OEM Versions

Special versions of SoundDiver come bundled with some devices, e.g. “SoundDiver EOS”or “SoundDiver K5000”. The differences from the retail version are:

- SoundDiver OEM is not modular, but has only one Module integrated into the program code. The Module cannot be exchanged.
- SoundDiver OEM is not copy protected. Installation consists of simply starting the program.
- When the program is initially started, the Scan function is initiated automatically. If the device is not found, you can install the device manually.
- Only one device can be managed.
- SoundDiver OEM can only open a single library at a time. Opening a second library first closes the previously opened one.
Chapter 1
Introduction

• As there is no Universal Module available. Adaptations cannot be used or created.

If you have received this manual for SoundDiver OEM, you should take the above limitations into account. If you are interested in the retail version of SoundDiver, please note:

• all files created by SoundDiver OEM (Libraries, preferences) are fully compatible with SoundDiver.

• SoundDiver contains all Modules of the OEM versions.

As a user of SoundDiver OEM, you can purchase the SoundDiver retail version for a special price by contacting your national Emagic Distributor.

1.3 About this Manual

This SoundDiver manual covers both, the Macintosh and Windows versions of SoundDiver. Differences between the two operating systems are explained, and the affected paragraphs are marked with an icon (see right).

Paragraphs which apply only to the Macintosh version are marked with “ː.”

Please contact your national Emagic Distributor for the availability of SoundDiver documentation for other languages.

Emagic manuals are always as up-to-date as possible. However, improvements and additions are sometimes made after an instructional manual has been printed. These are covered in a Readme file contained on the program disk. We recommend that you print this file and keep it with your SoundDiver manual. This way you always have the information handy for when you’re working with the program.

This manual covers SoundDiver Version 3.0. If your program version is newer, any changes will be listed in the above-mentioned Readme file.

Concepts

SoundDiver (the program) is available in various languages.
If a concept isn’t clear, you can look it up in the glossary contained in the appendix section of this manual. All of SoundDiver’s concepts (e.g., entry, module) are explained there.

**Menu Functions**

Menu functions are shown in this type face: *Function*.

If a function can be reached via a hierarchical menu, the levels are separated this way: **Menu > Menu entry > Function**.

**Key Commands**

Most key commands in SoundDiver are user-definable. Therefore, this manual only shows the fixed assignments and modifier keys in clear text.

For user-definable key commands, you see only this symbol to the side. The currently assigned key command is displayed by SoundDiver at the right of the menu item or in the Key Commands window.

As some key commands and modifier key assignments differ between the Macintosh and Windows versions, they are shown abbreviated as the following example depicts: ⌘(⌘: ⌘). This means: on Windows, hold down the ⌘ key, and on Macintosh the ⌘ key.

**Explanations**

ℹ️ Additional hints and tips which are not necessarily required to operate SoundDiver are displayed like this.
Chapter 1
Introduction
Chapter 2

Installation

2.1 What the Package Includes

Your SoundDiver package contains the following components:

- the SoundDiver CD
- this manual
- a registration card.

Please complete the registration card as soon as possible and send it to your country’s distributor.

It is only after you have registered that you will have access to…

- a regular update and support service via the Internet:
  http://www.emagic.de
- support via our Hotline:
  in the USA phone 1-530-477 1050, fax 1-530-477 1052
  in Germany phone +49-4101-495-110
  in other countries: please ask your country’s Emagic distributor.

Users of SoundDiver OEM (i.e. special versions included free of charge with some MIDI equipment) are not entitled to use the phone hotline. Please use the above mentioned Internet facilities.
2.2 System Requirements

System Requirements for Windows Computers

- Pentium computer
- MIDI interface with 32-Bit compliant Windows driver. For details see section Connecting a MIDI Interface on page 51;
- Large high resolution display recommended
- Autolink with Logic Audio Version 4.0 upwards.
- Supported: Microsoft IntelliMouse™, 3-button mouse and multiple monitors on Windows 98 and Windows 2000.

System Requirements for Macintosh Computers

- Power Macintosh (68k Macs are no longer supported as of version 3.0).
- System 7.1 or higher. Mac OS 9.0 or higher is recommended.
- MIDI interface. SoundDiver supports the following interfaces:
  - all Emagic interfaces (Unitor8, Unitor8 MkII, AMT8, MT4), either via serial or USB connection
  - all MTP compatible interfaces (e.g. MIDI Express, MIDI Time Piece I/II/AV, Studio 4/5).
  - all interfaces with an OMS driver
  - all interfaces with a MIDI Manager driver
- Large high resolution display recommended
2.3 Connecting a MIDI Interface

Windows

To use SoundDiver for Windows 95/98 or Windows NT 4.0/2000, you will need a MIDI interface. A MIDI interface is an optional accessory, and is not supplied with your PC. They are available in a variety of configurations, such as ISA cards or external devices which connect to the printer, serial or USB port.

You can use any MIDI interface which comes with a 32-bit compliant Windows driver. Please note that drivers for Windows 3.1x may work with Windows 95/98, but not with Windows NT4.0/2000. For this operating system, you need dedicated drivers.

MIDI interfaces essentially differ in the number of connections and additional features, like SMPTE synchronization. For smaller setups, we recommend the Emagic MT4, for larger setups the AMT 8 and Unitor 8 MkII. These interfaces are fully compatible with Logic Audio and SoundDiver.

- If you want to use an Opcode 8Port/SE, use driver version 1.62 and enable “Backwards compatibility” in the driver properties. Driver versions 1.50 and 1.60 don’t work.
- If you want to use a MotU interface (e.g. MIDI Express XT), use driver version 1.01. Driver version 1.04 does not work reliably with SysEx data.
- Many sound cards have a built-in MIDI interface. Most of those sound cards have an important restriction: they do not allow the simultaneous transmission and reception of MIDI data (referred to as full duplex mode—not to be confused with full duplex mode for audio input and output). This ability is extremely important for reliable operation with SoundDiver. Just as important is that the MIDI driver reliably transmit system exclusive data. This unfortunately is not the case with many sound cards. If you experience problems, you should consider purchasing a dedicated MIDI interface.
Macintosh

To operate SoundDiver you need to have a MIDI interface connected to the modem, printer and/or USB port. A MIDI interface is an optional accessory, and is not supplied with your Macintosh. If you don’t have a MIDI interface, ask your music dealer for advice regarding a suitable model.

You can use any MIDI interface. The special features of the Emagic Unitor8 are directly supported by SoundDiver. This also applies to Emagic’s Unitor8 MKII, AMT8, MT4. The MIDI Time Piece (from Mark of the Unicorn) MIDI Express, MTP II and MTP AV, as well as Opcode Studio 4 and Studio 5 are also supported.

MIDI interfaces basically differ according to the number of ports they have, and whether they come with or without a (SMPTE) synchronizer. For smaller setups, we recommend the Emagic MT4, for larger setups the AMT 8 and/or Unitor 8 MkII. These interfaces are fully compatible with Logic Audio and SoundDiver.

2.4 Connecting the System

SoundDiver works best if you connect your MIDI setup in accordance with the following guidelines:

1. every MIDI device that SoundDiver is going to work with should be connected with the computer in both directions. If you are using one or more patchbays please refer to the section MIDI Patchbays on page 54 below.

2. connect the MIDI Out of the device with the MIDI In of the MIDI interface and vice versa.

In theory you can connect several devices to a simple MIDI interface, by chaining them via their MIDI Thru ports. The drawback is that because the MIDI Outs of the devices are not connected to the Computer, SoundDiver can only communicate with the devices in one direction. This means that you lose some of SoundDiver's options (automatic recognition, auto request, for example.).
Connecting the System

We strongly recommend selecting a MIDI interface system that allows the direct connection of all MIDI devices with the computer in both directions. Plan to use one MIDI input and output per unit and avoid MIDI thru chaining. The expandable Unitor8 MkII/AMT8 system is ideal for this purpose.

- you will find more detailed information on setting up your device in the on-line Help for the relevant device. To call this up, click the device in the Setup window and select Windows > Help. There will usually be a reference for "Installation".

A Few Rules Governing the MIDI Configuration

If you have the correct MIDI configuration, SoundDiver can save you the effort of reprogramming patchbays or swapping cables around by automatically establishing all the connections. To guarantee faultless operation and the greatest data safety, we recommend you adhere to the following simple rules:

- a device should not be simultaneously connected to two different patchbays, although you can connect the MIDI Out of a device to a patchbay and the MIDI In to the computer, or vice versa.

- a device’s input must not be connected directly to the computer while its output is connected to a patchbay’s input, as this combination cannot be recognized by SoundDiver’s Scan function.

- although you can use two identical devices (e.g. two Yamaha EX5R) with the same device ID, these must be connected to different MIDI ports of the computer (this also applies to devices which don’t have a device ID at all, e.g. Oberheim Matrix-6/6R/1000 and all Alesis devices). However, it is always better to use different device IDs.
Emagic’s Unitor Family and Other Patchbays

All of Emagic’s MIDI hardware products (Unitor8, Unitor MkII, AMT8, MT4) provide more functions than simple patchbays, they include multiport MIDI Interface facilities. In general, patchbays can be edited at their front panel. The possibility of editing via SoundDiver or via Unitor8 Control eliminates the need to have editing facilities at their front panel.

SoundDiver’s patchbay modules are able to generate assignments within the patchbay to connect a device in both directions to your computer.

MIDI Patchbays

If you have a MIDI patchbay, this will be fully supported by SoundDiver. Ideally the patchbay will also be completely remote-controlled by SoundDiver. All the common patchbays are directly supported, so that SoundDiver can reprogram the data paths within the patchbay via SysEx. For patchbays which are not addressable via SysEx, SoundDiver uses Program Change commands. In this case, you will have to configure the required patches manually.

This flexible patchbay support offers you the following options:

• you can connect several patchbays simultaneously

• each patchbay can be connected to a different computer output

• any number of patchbay inputs can be connected to computer outputs, as well as any number of patchbay outputs can be connected to computer inputs. This is important if you want to use your sequencer with more than 16 MIDI channels, or the bandwidth of a MIDI cable is not sufficient.

The cabling is detected by SoundDiver automatically, however, SoundDiver always uses the first detected input and output when a device is accessed for SysEx data.
Connecting the System

transfer. Therefore, if you have changed the cabling after the initial setup, perform the Scan function again, or enter the changes in the Special parameters section in SoundDiver.

- you can connect the patchbays in any sequence you want—the exact order doesn’t matter.

SoundDiver supports the following MIDI patchbay models with dedicated modules:

- J.L. Cooper Synapse, MSB 16/20, MSB Plus and MSB Plus Rev2
- Digital Music MX-8
- Ensoniq KMX-8 and KMX-16
- MIDITEMP PMM-44/PMM-88
- Roland A-880
- Waldorf Midibay

J.L. Cooper Synapse

- Define the MIDI In which is connected to the computer as “Remote In”. To do this hold down the [MODE] key, press key [18] and set the parameter with keys [12] and [13].
- define the MIDI Out of the Synapse which leads to the computer as “Remote Out”. The procedure is the same as described in the above section but use keys [14] and [15] instead. If you later connect another MIDI Out to the computer, you will have to scan the patchbay again.
- set the remote channel to 16. In PC mode, set the Remote Channel using buttons [16] and [17].
- don’t store any data in memory location 64 of the patchbay because this will be overwritten by SoundDiver during the scan operation, and also when the patchbay is switched over.

J.L. Cooper MSB-16/20

- Keep in mind that all commands sent to the MSB 16/20 must come in on the INPUT PORT assigned to OUTPUT
PORT #20 and that the output data will go out of the OUTPUT PORT(s) that are assigned to INPUT PORT #16.

- Please check the MSB manual for information on which input accepts SysEx-Data.
- The help file contains additional information.

**J.L. Cooper MSB Plus and MSB Plus Rev2**

- Byte 16 dictates the SysEx Output Port assignment (0=port 1, 1=port 2, etc.)
- SysEx info is dumped to this output port.
- The help file contains additional information.

**Digital Music MX-8**

- Route the MIDI In which is connected to the computer to processor A. Select the In/Out screen with the “Function” key, move the cursor to the digit to the left of “→ A” and enter the appropriate input with the data keys.
- If you experience problems, make sure that the MX-8 has firmware version 1.51 or newer. The version number is shown at power-up.

**Ensoniq KMX-8 and KMX-16**

Please bear the following in mind when installing either of these patchbays:

- Connect the computer with MIDI Inputs 1 (and possibly 2) of the patchbay, not Inputs 3 to 8 or 16.
- With the KMX-16, also be sure that the computer MIDI Input and Output are connected with the same port of the patchbay. Thus, if the computer’s MIDI Out goes to MIDI In 1 of the KMX-16, the computer’s MIDI In must go to MIDI Out 1 of the KMX-16.
Set the KMX-16’s MIDI channel and Device ID to identical values in SoundDiver.

**MIDITEMP PMM-44/PMM-88**

Configure the output of the computer as the master input of the patchbay:

- double-click mode
- edit
- key 6
- now press the number of the input. In the display you can set the MIDI channel for incoming Program Change commands (U stands for unchanged, i.e. all channels). Make sure that this does not conflict with the MIDI channels of the other devices

Don’t store any data in memory location 128 of the patchbay, because this location will be overwritten by SoundDiver during the scan operation, and also when the patchbay is switched over.

Only the values 11 to 20 are recognized as possible Device IDs for reasons of speed, even though the device will recognize 0 to 127.

The PMM-44/PMM-88 will only work with SysEx data if the data arrives on its master input. If the device isn’t responding, check this.

The PMM-44/PMM-88 will only work with SysEx data and Program Changes if the data arrives on this input.

So that the device will react to SysEx, define the master input:

- Double-click on MODE, 1x EDIT and finally button 6 “U”
  - Now press the button of the input number that’s connected to the computer.
Be sure your PMM has a software version of 2-4 or newer. The version is shown at power-up. If you have an older version, please contact MIDITEMP.

**Roland A-880**
- Make sure that the A-880 has firmware version 1.03 or higher. If you experience problems, please contact Roland. You can determine the version of the A-880 by switching on the patchbay while pushing Output buttons 1 + 2 + 4 + 8 (all together). The LED’s give you the version number: LED 1 = 0.01, 2 = 0.02, 3 = 0.04, 4 = 0.08, 5 = 0.16, 6 = 0.32, 7 = 0.64, 8 = 1.28. Add the LEDs to get the version number.
- Configure the MIDI In which is connected to the computer as “Control In”: hold down the input key when you switch on the A-880. SysEx and Program Change messages are processed on this input only.
- The Device ID is the same as the Program Change channel. It can be set at the device by pressing the “MEMORY” and “WRITE” buttons together while pressing the corresponding number button.
- Define the MIDI Out of the A-880 which is connected to the computer as the mix output.

**Waldorf Midibay**
- Connect the computer to Source 1 and Destination 1
- Don’t set the unit number to “off” or “omni”: press [Mode] five times. The display shows “un” followed by the unit number. Use the Up and Down keys to set a value from 1 to 16

Don’t store any data in memory location 99 of the patchbay, because this will be overwritten by SoundDiver during the scan operation, and also when the patchbay is switched over.
Other Patchbays

In the next section you will learn how to start SoundDiver for the first time. It is therefore recommended that you set up your patchbay so that SoundDiver can address all the connected devices through it. Before you start SoundDiver you should set your patchbay so that:

- the MIDI Out of the computer can address all the MIDI Ins of the connected devices
- the MIDI Outs of the connected devices are connected to a MIDI In of the computer.

If your patchbay doesn’t allow you to simultaneously connect the MIDI Outs of the connected devices with the MIDI In(s) of the computer please refer to the section The Setup Window on page 191 in Chapter 5 The Setup Window.

If at the beginning of the scan operation, a MIDI Thru loop is revealed you should set the patchbay to an empty program and reprogram the connections.

Macintosh Peculiarities

Emagic Interfaces Connected via a Macintosh’s USB-Port

SoundDiver supports Emagic’s Unitor8 Mk II, AMT8 and MT4 connected via USB-Port. OMS is not needed. Hot swapping is possible.

Macintosh Computers with No Modem/Printer Port

If a Macintosh Computer does not have a modem and/or printer port, this is recognized and shown accordingly in the preferences: the ports are not available.

If a GeeThree Stealth or a Griffin gPort in a G4 or a blue/white G3 is used, you have to install the appropriate system extension (“Stealth Serial Port Software 1.0.3” from <http://www.geethree.com/download.html>, or “gPort Driver 1.1” from <http://www.griffintechnology.com/g3/>). If it’s not installed, SoundDiver will not recognize these modem port extensions.
Chapter 2
Installation

Changed MIDI Ports with Windows
When MME MIDI drivers are added or deleted (or if their settings are changed), the enumeration of MIDI ports may change. SoundDiver takes this into account. If a port is not found an appropriate alert is shown (“MIDI Port xxxx not found”). This makes it much easier to look for the missing port.

In certain cases it’s a good idea to check the functionality of the MIDI connection, using **Options > Loopback test**... A detailed description can be found at section **Loopback Test** from page 162 onwards.

2.5 Installation of SoundDiver

Copy-protection
SoundDiver is protected against illegal copying by special software protection. This protection is transparent and is contained on the SoundDiver CD. You can make as many copies of SoundDiver as you like onto a hard disk, but these will only work if the SoundDiver CD is temporarily inserted.

To prevent the need to insert the SoundDiver CD every time you start SoundDiver, you should **authorize** the hard disk. This authorization can be undone if you want to sell your SoundDiver licence. Installation is covered in the next section.

- The authorization is saved in the boot partition (Windows) or Start Volume (Mac). If you are booting from a different partition or Volume, please authorize this partition or Volume as well.

- Multiple copies of SoundDiver can be used at different locations on your machine—only one authorization is needed. The program file itself does not contain any authorization information, so that this file can be deleted, copied or moved as you like.
Installation of SoundDiver

You will be asked for the CD every now and then to ensure that you still have it.

Starting one week before the authorization is due to expire, a warning will appear when you launch SoundDiver. Insert the SoundDiver CD as soon as possible, to renew the authorization.

Installing a New Program on a Hard Disk

On the SoundDiver CD you will find an installation program. Start this program and read the explanations carefully.

You can make any number of copies of the SoundDiver program file on several hard disks. However, to make a copy that will run without the need to insert the SoundDiver CD, you need to authorize the hard disk (see the section Authorizing the Hard Disk on page 61).

Updating an Existing Program

If you want to update SoundDiver with an update CD, or install new modules, install the file as usual—either in a new folder or by overwriting the existing files. The hard disk authorization is not affected, and you can start the new version immediately.

If you are merely updating modules or adaptations—for example, from http://www.emagic.de—just copy the new files into the Diver folder. If a warning appears telling you that the file already exists, click Replace or Replace All. The next time you run it, SoundDiver will automatically use the new Module or Adaptation version.

Authorizing the Hard Disk

If you are asked to authorize, or if you want to authorize for the first time, please follow these steps:

- Start SoundDiver by double-clicking the SoundDiver icon (Windows: also by selecting the menu item Programs > Emagic > SoundDiver > SoundDiver in the Start menu).
- If the original CD is not inserted you will be asked to do so.
Chapter 2
Installation

- The authorization window will appear
- Select Authorize in order to allow SoundDiver to be started from your hard disk. From now on you will be able to run SoundDiver without using the original SoundDiver CD. A message will appear confirming this:
  
  *SoundDiver has been successfully authorized. You can authorize at any time from CD.*

- Select Quit and the installation will be aborted.

Renewing the Authorization

From time to time you will be asked to renew the authorization. The following message will appear:

*Hard disk authorization will expire in 7 days. Do you want to reauthorize now or later?*

The authorization will expire 7 days after the warning has been displayed for the first time. It doesn’t matter if SoundDiver is used in this period or not.

After expiration this message will appear:

*Hard disk authorization has expired. You have to re-authorize from CD.*

To avoid this, please renew the authorization as soon as you are asked for it.

Removing an Authorization (Deauthorizing)

Removing the authorization has no effect on the program files or any libraries you have created. Only the authorization file is removed (If you want to delete files, see the section Completely Removing SoundDiver from the Hard disk on page 64).

- Start SoundDiver.
Installation of SoundDiver

Open the global settings from **Options > Settings > Global Settings**. Click the **Deauthorize** button. You will get a safety alert:

![Deauthorize Alert]

Deauthorizing does not require that the CD be inserted.

**Starting SoundDiver without Authorization**

You may also start SoundDiver without an authorization. This can make sense where you want to temporarily use the program on someone else’s computer. To do this you always need the original SoundDiver CD:

- insert the original SoundDiver CD
- copy SoundDiver to the desired hard disk, and start the copy by double-clicking its SoundDiver icon. The authorization dialog box will appear
- select **Continue**, and SoundDiver will start.

**Optimization Programs**

SoundDiver’s copy protection is not affected by disk optimization and defragmenting programs. You may use programs such as Speed Disk or DiskExpressII as often as you like.

**Formatting the Hard Disk**

If you format or partition a hard disk which is authorized for SoundDiver, you need to authorize SoundDiver afterwards.

It is not sufficient to make a file backup of the hard disk and restore it after formatting the hard disk.
Chapter 2
Installation

Completely Removing SoundDiver from the Hard disk

To remove SoundDiver completely from the hard disk:

- remove the authorization as described above, then
- delete the SoundDiver file, the Diver folder, the libraries and preferences (Mac: don’t forget the SoundDiver 3.0 Preferences file in the Preferences folder of the System folder) from the hard disk.

2.6 Starting the Program for the First Time

When you start the program for the first time SoundDiver carries out a few automatic routines that allow as rapid and correct an installation of your MIDI system as possible. To ensure that everything functions as well as it should, before you start the program for the first time, please check that:

- all devices and any patchbays being used are correctly connected in both directions with the computer
- all devices are switched on and their MIDI parameters correctly set. Make especially sure that their System Exclusive capabilities are enabled, and that similar or identical devices are set to different Device IDs or MIDI channels
- AppleTalk is disabled if it uses LocalTalk. LocalTalk interferes with MIDI communication and can cause transmission failures.

When SoundDiver is started for the first time, a variety of dialog boxes appear that present you with the first steps before scanning.

Mac: SoundDiver starts by opening the Preferences window in which you define the MIDI port(s) via which the devices and the computer communicate. You only need to activate the
Printer port here if you have a MIDI interface connected to the Printer port.

**Language Used in SoundDiver**

Depending on the currently selected keyboard layout, all menus and dialogs are displayed in English or German. This is done automatically—no configuration is necessary; Each program and Module file contains all text in both languages.

If you want to use SoundDiver in a language different from the keyboard layout, please refer to the section Language on page 412 and the section Language on page 403.

Support of additional languages is possible. If you are interested, please contact your country's Emagic distributor. If desired, you can order a SoundDiver manual in German, or other languages as well.

### 2.7 Installing Devices

SoundDiver automatically opens the Setup and Install windows when started for the first time. Later, you can open them manually by selecting the menu item **Window > Install** in order to install devices. The installation is required for all subsequent communication.

Installation is very easy: all you need do is select the devices that SoundDiver is to install, and press \( R \). SoundDiver does all the rest on its own.

Optionally, you can also click **Scan all**, in which case all devices supported by SoundDiver are scanned. Please be aware that this may take a while.

The following sections cover the installation of devices in detail.
Chapter 2
Installation

The Install Window

The Install window is where you can ask SoundDiver to scan the devices, or where you can install them manually.

Selecting the Models

First select the desired devices in the Install window before you scan or manually add them. You may select one or more models. If you select more than one model, SoundDiver carries out the desired operation for each model in turn. SoundDiver shows the icon of the selected device beneath the buttons.

What you can select:

- To select just one model, click its line.
- To select more than one model click each respective line while pressing `⌘`.
- A second `⌘` click on a line deselects it.
- To select all the models, select Edit > Select All. In this case you can use Toggle selection to undo what you’ve done. Please bear in mind, though, that scanning all the devices supported by SoundDiver takes a long time, as there are a lot of them.
Scanning Using the Keys
The Install window allows you to target the names of specific devices by using the computer keyboard. Considering the growing number of modules and adaptations, this method of finding things is much quicker than scrolling the list.

To find a specific device, activate Caps Lock with  Y (the key above  S —the Caps Lock LED must be lit, this is the one built into the  Y key on Mac keyboards. On PC keyboards, it is the middle of the three LEDs on the keyboard) and type in the first few letters of the model name while the Add New Devices window is open. The selection beam will jump to the nearest match it finds.

If you type something like “DX4” SoundDiver finds the DX7, because it sees the letters DX in several model names, though not “4”. In this case the next number up that it finds is “7”.

This function relates solely to model names, not those of the manufacturers.

Pressing  T allows you to jump around the list alphabetically in ascending order.  ST does the same in reverse.

Scanning
Click the Scan button to start the process. You can also press  R or double-click the name. SoundDiver now analyzes your MIDI system, and automatically installs the devices it finds, together with the correct connection settings.

This option is preferable to manual installation, as SoundDiver is then able to gather the maximum information about the devices, and human-error (incorrectly set MIDI parameters or connections) is avoided.

After scanning, a dialog box will appear in which you can tell SoundDiver to directly request the memory contents of any device that’s been found.

If the scan does not work, please refer to Appendix C Troubleshooting on page 421. Here you will find detailed solutions to various problems.
Bear the following in mind: as most of the SoundDiver modules apply to a whole family of models, a scan for a specific device often finds related devices as well, such as finding a TG77 when you wanted an SY99.

SoundDiver supports MIDI patchbays in general, and is capable of automatically controlling the overall communication with the patchbay where this is possible. Patchbays, for instance, can be reprogrammed via SysEx to allow devices to be scanned that are not patched with the computer in the current patchbay program.

Important advice when using patchbays:

- The special support for MIDI patchbays is only possible with patchbays for which there is a dedicated module. You can find a list in the section MIDI Patchbays on page 54.

- If you scan devices individually, you should always first scan the patchbays, or the devices connected to it won’t be found. You can abort this procedure pressing ⌘ (Mac) or Ctrl+C (Windows).

- Before you start scanning, you should set the patchbay in such a way that there are no MIDI loops with the computer. If there are, scanning takes much longer, besides which incorrect connections may prevent devices from being found.

Models which Cannot Be Scanned

Some devices cannot be detected by the scan option because either:

- they don’t have a MIDI output
- they don’t process request messages, and thus cannot identify themselves
- the Adaptation is not dedicated to a specific device (e.g. Generic) and thus scanning is not possible
- the Adaptation for the device does not yet support the Scan function.
In this case, the affected devices are not scanned, and their names are shown in italic typeface.

You will get an appropriate message at the end of the scan process.

**Scan All**

If you are not sure which devices are connected to the computer, or you don’t want to select the models to be scanned manually, simply click this button. Then SoundDiver will scan for all supported models. This can take some time, depending on the MIDI interfaces and patchbays.

**Manually Adding Devices to the Setup**

You can also manually add the selected devices to the Setup. In this case you have to manually set parameters such as their Device IDs and connections.

You should only add a device manually when it cannot be scanned (e.g. if it has no MIDI Out port or doesn’t support scanning), or for test purposes.

To manually add the selected devices to the Setup,

- click the *Add* button,
- or press **⌘** (or **¶**),
- or **⌘**-double click one of them.

If there’s already a compatible device in the Setup, you will be asked whether you really want to add the new device. The newly-added device will be given a new Device ID by SoundDiver: you will need to manually alter the ID in the device itself to match SoundDiver.

The message “No more Device IDs” signifies that all the available IDs are being used on the current output (or the device doesn’t have a Device ID). In this case you should connect one of the existing devices to a different output of the computer.

You can double-click module or adaptation files in the Finder, or drag them onto the SoundDiver icon. The Installation window will then open, and the relevant models will be selected. A dialog box allows you to select between scanning and manual installation.
Once you have completed the scanning or installation of the devices, click Done. The window will close. You may also press ﬂapp or ﬀapp (↵ or ⇧). 

Help

In the Install window, SoundDiver’s on-line Help shows you the Help message for whichever model is first selected. To open the Help, select Windows > Help or click the Help button.

If you open the Help using ﬂapp, it becomes a “floating window”. (Use the “Help” menu with Windows). More on this can be found in the section On-line Help on page 171 in Chapter 4 SoundDiver’s User Interface.

Creating the List of Models

You may copy all or part of the list of the available models into the clipboard for further work in a word processor, or for printing out.

Select the devices you want and select Edit > Copy.

There is a complete list of all the models on the SoundDiver CD. Double-click the SoundDiver 3.0 Model List file.

Check the MIDI Connection

If the scanning fails, it’s wise to check the MIDI connection using the Options > Loopback test... A detailed description can be found at section Loopback Test from page 162 onwards.
2.8 Shortcut/Alias of the Program File

In Windows 95/98, you can create a shortcut for SoundDiver on the Desktop. By double-clicking this icon, you can start SoundDiver extremely quickly.

Under System 7 or later, you can create an alias of SoundDiver and keep the alias on the Desktop or in the Apple Menu Items folder within the System folder. This allows you to always have the program handy without having to search for it. Of course, you can also create an alias of a library, and start SoundDiver directly from this library.

2.9 The Diver Folder

All module and adaptation files used by SoundDiver are placed in a specific folder, named Diver, so that SoundDiver can find them. This folder is created automatically the first time you start the SoundDiver program (if it does not exist already).

If there is not enough space on the volume where SoundDiver is installed you can move the Diver folder to a different volume. This is how you do it:

- Move the folder to the desired position.
- Delete the old folder.
- Create an alias of the new folder (select Make Alias from the File menu in the Finder).
- Move this alias to the position of the old folder (in the same folder as the SoundDiver application).
- Delete the suffix “Alias” so that the alias is called “Diver”.

This also works with the Libraries folder.
2.10 **Windows File Types**

SoundDiver uses different file types for saving sound libraries, help files or modules. The following file name extensions are used, which help you to recognize the type of file you are dealing with:

<table>
<thead>
<tr>
<th>File Type</th>
<th>Ending</th>
<th>Description</th>
<th>Created by</th>
</tr>
</thead>
<tbody>
<tr>
<td>library</td>
<td>*.LIB</td>
<td>Library file with sounds or other effects programs from various MIDI devices</td>
<td>SoundDiver by selecting “Save” from the File menu</td>
</tr>
<tr>
<td>module</td>
<td>*.DLL (Windows)</td>
<td>module for a specific MIDI device</td>
<td>the installation program when installing a module</td>
</tr>
<tr>
<td>adaptation</td>
<td>*.ADA</td>
<td>file for the universal module containing the adaptation for a MIDI device</td>
<td>the installation program when installing an adaptation</td>
</tr>
<tr>
<td>help file</td>
<td>*.HLP</td>
<td>text file for On-line Help in a Module or Adaptation</td>
<td>the installation program when installing a Module or Adaptation</td>
</tr>
<tr>
<td>preferences</td>
<td>*.PRF</td>
<td>saveable default settings</td>
<td>SoundDiver when you quit or select “Save Preferences as…”</td>
</tr>
</tbody>
</table>

2.11 **Installing Modules and Adaptations**

SoundDiver’s Install window shows only the modules and adaptations which are currently located in the *Diver* folder.

**Removing Unwanted Modules**

To save space on your hard disk, you can delete module and adaptation files from the *Diver* folder or move them somewhere else. This automatically results in a shorter list in the Install window.

Also see the section *Rebuild the Content of the Install Window* from page 412 onwards.
Removing Unwanted Adaptations

If you change the contents of the Diver folder (where adaptations and modules reside), the change will not be reflected within SoundDiver’s Install Device list until you delete the file Universal Module Cache from the Diver folder. This forces the Universal module to rebuild its list of adaptations at the next start-up of SoundDiver. This operation may take a little time.

Also see the section Rebuild the Content of the Install Window from page 412 onwards.

2.12 SoundDiver and MIDI-Tasking

You can run SoundDiver either alone or simultaneously with other programs on your computer.

SoundDiver is compatible with AutoLink.

SoundDiver also is compatible with the OMS and MIDI Manager multitasking MIDI systems

SoundDiver will behave slightly differently, depending on the MIDI-Tasking environment.

AutoLink

Logic Audio’s AutoLink mode gives you many options. For details see page 357.
Chapter 2
Installation

**MIDI-Tasking on Macintosh**

**OMS**

**What is OMS?**
OMS or “Open Music System” (formerly “Opcode MIDI System”) is a system extension that functions between application programs and the physical MIDI ports. OMS allows you to define so-called “nodes” which represent single devices of your external MIDI setup. These nodes (generally referred to as “Devices”), consist of a name, information about where the device is connected, on which MIDI channels it receives, and so forth. You can create, modify or delete OMS Devices with the OMS Setup application. For further information see the OMS manual.

When you use OMS as a MIDI system driver, SoundDiver does not know anything about the MIDI interfaces or the real physical ports. All information about this is hidden in the OMS system, and is inaccessible to application programs like SoundDiver. Instead, OMS provides the above mentioned Devices for communication, and makes sure that the data flow from and to the Devices is managed correctly, in case data streams have to be merged.

The main value of OMS, as compared to Autolink for example, is that it allows you to use several MIDI programs from different companies at the same time.

**When You Should Use OMS**
SoundDiver supports all MIDI functions of OMS and is compatible with versions 1.2.3 and 2.x (the Name Manager and Time Manager are currently not supported).

However, you should install OMS only if you want to simultaneously use other MIDI programs which don’t support Autolink with SoundDiver, like Steinberg Cubase or Opcode Vision.
You don’t need OMS to use a MIDI interface from Opcode. The Studio 4 as well as the Studio 5 can be used in MTP emulation mode without limitations, unless you want to use more than one Studio 5 connected to a serial port.

Use SoundDiver in OMS mode with OMS 2.2 or newer on PowerBook 1xx models. These have a problem with the Power Manager, a part of the System software which may lead to incoming MIDI bytes being “eaten up” if you don’t use OMS.

**When OMS Becomes Active**

OMS is active (i.e. accesses the serial ports) only as long as at least one program has signed in to OMS. Thus, it is not necessary to move OMS out of the System folder to deactivate it. Simply quit all OMS applications.

This is very useful when you have an Opcode interface, but don’t want to use SoundDiver with OMS. These interfaces need the OMS Setup program to configure the MTP emulation and to stripe SMPTE code.

Before you run SoundDiver (without OMS), please quit the OMS Setup program to deactivate OMS again. Otherwise SoundDiver would complain that it cannot access the serial ports.

**SoundDiver in OMS Mode**

To run SoundDiver with OMS, select **Options > Settings > MIDI Interface Communication**... and set **Use OMS if available** to **always**.

When OMS is installed, SoundDiver will instantly switch to OMS mode.

For each device installed in SoundDiver, the output assignment is stored separately for OMS and non-OMS operation. This allows you to easily switch SoundDiver between using OMS or not, without requiring that you reassign the outputs every time you change the mode.
Chapter 2
Installation

Scanning in OMS Mode
SoundDiver can scan your MIDI studio in OMS mode. However, it is necessary that for every output of your MIDI interfaces, an OMS Device be defined. This usually happens automatically when you install OMS 2.x.

For MTP compatible MIDI interfaces (including the Emagic Unitor8 and MIDI Express), the OMS installation process usually adds a “top level” node which sends on all outputs. Such nodes are skipped by SoundDiver in the scanning process, as they are not helpful for finding out the exact cabling.

The MIDI patchbay support described in the section MIDI Patchbays on page 54 is also available in OMS mode, however this does not have to do anything with the definition of MIDI patchbays in OMS.

Synchronization of Port Assignments with/without OMS
SoundDiver automatically synchronizes port assignments with and without OMS:

• when a device has been scanned without OMS, it will automatically get the correct OMS port assignment when switching to OMS mode.

• and vice versa

This allows you to alternatively scan with and without OMS mode, and prevents the creation of duplicate devices in the Setup window.

Of course this feature works only with MIDI interfaces that work with OMS (usually via a driver for OMS provided by the manufacturer) as well as without OMS.

MIDI Thru and Mini Sequencer in OMS Mode
MIDI thru and SoundDiver’s mini sequencer are also available in OMS, however only while SoundDiver is in the foreground. If you have configured your OMS sequencer to generates MIDI Thru even in background, you should switch off MIDI Thru and AutoPlay in SoundDiver.
Communication with Logic in OMS Mode
It is possible to use OMS and AutoLink simultaneously in Logic and SoundDiver. This gives you the convenience of AutoLink without needing to do without simultaneous operation of OMS programs.

In this mode, Logic and SoundDiver exchange MIDI output information in the OMS format (rather than MTP cable numbers).

To enable OMS and AutoLink, simply activate the options *Use AutoLink if available* and *Use OMS if available* in Logic, as well the option *Use OMS if available* in SoundDiver.

Now you have all options of AutoLink available. For further details, please refer to the section *AutoLink* on page 357.

ℹ️ If you are using Logic and SoundDiver simultaneously, it is not possible to use one of them without OMS if the other is using OMS.

Communication with Other Programs in OMS Mode
In OMS, the so-called IAC Bus is available (IAC stands for “Inter-Application Communication”). This allows you to send MIDI data from one application to another within the computer. Thus, you can record parameter changes or dumps in a sequencer program.

Recording SoundDiver data in the sequencer
- Make sure that the sequencer program has the IAC Bus activated as an input
- start recording
- switch over to SoundDiver
- change the device’s output whose data you want to record, to the IAC Bus (in the Device Parameter box)
- generate the desired MIDI messages, e.g. by moving a slider in an editor
- reset the device’s output to the original setting.
If you want to use this function often, you should instead

- define an OMS Patch with a “Virtual Instrument” which sends to the OMS node as well as to the IAC Bus, using a “Splitter Object”. For further details, refer to the OMS manual or your Opcode interface’s manual.

- select this “Virtual Instrument” as the output for the device in SoundDiver.

If this is too complicated for you, you should use Logic and AutoLink instead. In this case, you don’t have to configure anything, and you can even start recording from within SoundDiver. Also see the section Recording Parameter Changes in Logic on page 371.

Displaying recorded data in SoundDiver during playback

- Create a “Virtual Instrument” that sends to the device as well as to the IAC Bus, as described above

- select this “Virtual Instrument” in the track which contains the recorded data

- start playing back.

A similar feature is available in AutoLink as well. See the section Displaying Recorded Parameter Changes in SoundDiver on page 374.

MIDI Manager

SoundDiver is compatible with the Apple MIDI Manager, which was the standard driver for nearly all MIDI software applications before OMS became popular. We recommend that you only use the MIDI Manager if you want to run SoundDiver in parallel with other MIDI applications which don’t support AutoLink or OMS.

To install the MIDI Manager, drag the “MIDI Manager” and “Apple MIDI Driver” files into the System folder. They will be automatically stored in the correct locations. You should also install “Patchbay™”.

You should use MIDI Manager 2.0 or newer. Older versions can cause communication problems.
After installing the MIDI Manager, please restart the computer.

There are seven separate software inputs and outputs available which you can configure in “Patchbay™”. The settings made there are memorized by SoundDiver and automatically recalled at the next session. You don’t have to do this in “PatchBay™” yourself.

For further information on the functions of the MIDI Manager and Patchbay, please refer to the help function in “Patchbay™”.

Any Other MIDI-tasking System

Make sure you don’t run any programs in parallel with SoundDiver that also use the printer or modem port, as these ports can only be assigned once. These include, for example, printing or communications programs. You should deactivate AppleTalk while running SoundDiver (with the desk accessory “Selectr” which is usually installed in the Apple menu) if you use LocalTalk. However, if you want to print using an AppleTalk printer, please re-activate AppleTalk.

If you run programs in parallel to SoundDiver that perform a lot of background activity, this can disrupt the program. You should therefore deactivate file sharing if possible, using the “File Sharing” Control Panel.

MIDI-Tasking on Windows

Multi-client MIDI drivers

When you want to run several MIDI programs on a Windows PC simultaneously, they must be able to access the MIDI ports concurrently. This implies that the MIDI driver can be opened by several programs (clients). Such drivers are called “multi-client” MIDI drivers. Unfortunately not all MIDI drivers have this ability, as it is not necessary for “normal” applications like games.
Chapter 2
Installation

Conventional MIDI drivers can only be used by one application at the same time:

If another application tries to open the MIDI driver, it fails with an appropriate error message. The reason for this user-unfriendly behavior is that a driver with only one input and output is much easier to program.

A multi-client driver however delivers incoming MIDI data to all applications and merges outgoing data correctly:

**MIDI Interfaces with Multi-client Drivers**

Fortunately, multi-client MIDI drivers are available for most MIDI interfaces and sound cards on the market. Please contact the manufacturer of your interface or sound card to get the latest driver version.

**Virtual MIDI drivers**

There are solutions for MIDI interfaces that don’t provide multi-client drivers. As there are dozens if not hundreds of different MIDI cards and interfaces available, it would be impossible to write new MIDI drivers for all these devices. Instead, there are multi-client drivers which open the conventional drivers as a client, and simply pass on the MIDI data:
There are several different “virtual drivers” some of which are described below.

**MultiMID**

Multimid is probably the best-known virtual driver. It is commercial software ($39.95), however there is a “crippled” demo version available which can be freely copied.

The connections to the “conventional” drivers are defined in the configuration dialog of MultiMID. For every opened driver (e.g. “Soundblaster In”), a multi-client capable counterpart (e.g. “Multi-Soundblaster In”) is created, which can then be opened by several applications.

A “pipeline” output allows MIDI data to be forwarded from one application to another. The full version also allows inputs and outputs to be renamed, as well as the use of plug-ins which can manipulate MIDI data in real time—similar to Logic’s environment.

Contact address:

Hermann Seib  
Am Tabor 12/1/24  
A-1020 Wien  
Österreich

Email: seib@t0.or.at

**Hubi’s MIDI Loopback Device**

This package is freeware (i.e. can be used and copied for free) and consists of a driver (“**Midlpbk.dru**”) which installs up to four “loopback nodes” (LB1 to LB4), as well as an application which simply connects a MIDI In with a MIDI out. Therefore
Chapter 2
Installation

the name “Hwmdcabl.exe”—the task of this program is comparable to a MIDI cable; however you can define additional filters.

The user can now open several instances of “Hwmdcabl.exe” and connect one input with one output each. This is very flexible, and can also connect a program’s input with another program’s output.

“Hubi’s MIDI Loopback Device” needs very little memory, has excellent timing, and is very reliable.

By courtesy of the author, we have included this tool on the CD. The file name is “MDLBK251.ZIP”. You need PKZIP, WinZip, StuffIt Expander or a similar tool to unpack this file. The contact address can be found in the file “MIDLBPK.TXT”.

How to Block MIDI Ports (Windows:)

It is possible to prevent SoundDiver from opening certain MIDI inputs and outputs:

☐ Open the file “WIN.INI” in your Windows folder

☐ If you have launched SoundDiver at least once, you will find a section [SoundDiver]. Otherwise, add this section name to the file (don’t forget the brackets).

☐ If you have launched SoundDiver at least once, you will find a line “portname=1” for each port. For each unwanted port, change the line to “portname=0”.

For example, if you don’t need input and output 2 of a Unitor8, WIN.INI should contain

[SoundDiver]
MidiIn_Unitor_In_02=0
MidiOut_Unitor_Out_02=0

This feature is important for using sound cards whose driver crashes or hangs when sending SysEx to the internal Wavetable generator. Some drivers show this behavior even when they are
opened while SoundDiver is launching. In this case, they don’t support SysEx, and can’t be used with SoundDiver anyway.

To prevent MIDI loops using Hubi’s MIDI Loopback Device use the following:

... ...

[Logic]
MidiIn_LB1=0
MidiOut_LB2=0

... ...

[SOUNDdiver]
MidiOut_LB1=0
MidiIn_LB2=0

**SoundDiver as a Background Program**

If you are running several applications and you have sufficient space on the screen, you can keep any number of the windows permanently open while you are working in the other MIDI applications. In this case it’s convenient to use two monitors.

Certain activities (e.g. displaying error messages) are stopped while SoundDiver is in the background. As soon as you activate it again, any error messages will be shown.

---

2.13 Compatibility of the Windows, Macintosh, and Atari Versions

**Converting Files between the three Platforms**

SoundDiver’s Windows and Macintosh versions are file format compatible. This also applies to the older Atari Versions. This is very useful if you happen to be using SoundDiver on more than one of these platforms, or are collaborating with other SoundDiver users. Files created by (discontinued) SoundSurfer,
Chapter 2
Installation

SoundDiver and SoundDiver OEM versions are compatible as well.

Libraries, Adaptations, and Help source files are compatible, and need only be copied from one computer to the other. If necessary, you have to adjust the file name:

Table 1 File name extensions of Windows/Atari files and Macintosh Type/Creator

<table>
<thead>
<tr>
<th>File type</th>
<th>Extension</th>
<th>Macintosh File Type</th>
<th>Macintosh Creator (SoundDiver)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library</td>
<td>.LIB</td>
<td>EM9F</td>
<td>EMA6</td>
</tr>
<tr>
<td>Adaptation</td>
<td>.ADA</td>
<td>EM7F</td>
<td>EMA6</td>
</tr>
<tr>
<td>Help source file</td>
<td>.ADT</td>
<td>TEXT</td>
<td>any</td>
</tr>
<tr>
<td>Standard MIDI file</td>
<td>.MID</td>
<td>Midi</td>
<td>any</td>
</tr>
<tr>
<td>SYX / MidiEx</td>
<td>.SYX</td>
<td>TEXT</td>
<td>any</td>
</tr>
</tbody>
</table>

Module files however work only on one platform. To use a Module on a different platform, you need the appropriate file version, which you can download from the Emagic web site (see the section What the Package Includes on page 49).

Since version 2.0.7 the naming convention for files has been unified:

- • Apple: Adaptation files have to have the suffix .ADA even on the Macintosh. This improves compatibility with adaptations created in Windows.

- • The file name of an adaptation results from the name of the device the adaptation supports. This name may contain characters which are not allowed in file names of a certain platform. These characters are now replaced by “_” on all platforms.

Example: the Adaptation file “DX21/27/100” is now named “DX21_27_100.ADA”, on the Macintosh as well as in Windows.
Converting Files from and to the Macintosh

You need a Macintosh program such as File Exchange, PC Exchange, DOS Mounter, Access PC, or Smart Link to enable the Macintosh to read DOS floppy disks. PC Exchange is included in System 7.5. File Exchange is included in Mac OS 8 and 9.

So that the Macintosh can recognize Windows or Atari files without restrictions, you have to alter the Type and Creator of a file coming from an PC or Atari.

Many newer versions of PC disk mounters and File Exchange automatically allow this after you have entered the file name extension and the Macintosh Creator and Type. Please read these program’s manuals for more details.

If you don’t have such a program, but have ResEdit, File Buddy, FastFind or similar, that allows you to manually alter the Creator, this works as well (although it is less convenient).

When converting Windows or Atari files to the Macintosh, the file name extension of Library files can remain. With Standard MIDI files and SYX files however, it is not required, as long as the file type is correct (also see the section Importing Standard MIDI Files on page 276).

Adaptation files have to have the extension .ADA even on the Macintosh. In help source files, the extension .ADT must remain (for further details, please see the Universal Module Programming Manual).

2.14 Key Commands and Remote Control via MIDI

You can initiate almost all of SoundDiver’s functions with a key command or a MIDI message. The Key Commands window is where you assign key commands to the keys, or to MIDI messages.
Chapter 2
Installation

Whenever this manual mentions a key command, this refers to a command which can be called up by either a keystroke or a MIDI message. This allows you to completely customize SoundDiver to suit your own working style.

The key commands described in this instruction manual are based on the default Windows and Macintosh key command assignments. So if you make changes in the Key Commands window, the key commands mentioned in this manual may not apply to your SoundDiver installation.

**Modifier Keys on Macintosh vs. Windows**

The Macintosh has one modifier key (⌘) that the Windows platform does not have, and the modifier keys are also named slightly differently.

Basically, on Windows you often use the `Ctrl` key whenever the Macintosh `⌘` modifier key is indicated.

A “variation” of a key command is often carried out using the `⌘` modifier keys on the Macintosh and `Ctrl` on Windows. For example, the command “Quit without saving”, `⌘q`, would be executed by pressing `Ctrl+Q` on Windows.

Please note that the above applies only to the default key command assignments. If you want, you can change this.

On Windows, the meaning of `Ctrl` and `⌘` is the opposite of the Macintosh concerning multiple selection.

The remaining modifier keys used within SoundDiver apply to Windows and Macintosh without distinction.

**Save Your Personal Settings**

Your personal key assignments are stored (together with the settings of the Preferences pages) in a file called “SoundDiver 3.0 Preferences” on the Macintosh and “SoundDiver 3.0 Preferences.PRF” on the Windows PC. These settings can be stored in any file at any place on the hard disk by using File > Save Prefs as... You should:
• make a backup of this file at another location on your hard disk;
• make a floppy disk backup of it, in case you need to use a SoundDiver system on another computer.
• When you install updates to your version of SoundDiver, your personal key commands will remain unaltered.

Menus and Dialogs
You can respond to all prompts and dialogs via your computer keyboard in keeping with operating system conventions. Use Return or Enter to activate the OK button, Esc to activate the Cancel button.

On Windows, you can also handle all menus with the keyboard.
• Even the fixed global Key Commands of older versions are now user definable. Please keep in mind that some of these commands like Undo, Save, Quit, New, Open, Cut, Copy, Paste... follow “common conventions” and probably shouldn’t be altered.
• The defined Key Commands are displayed in the corresponding menu entries.

Special Keys
Some keys have special functions:
• The modifier keys Ctrl, Shift, and Alt (⌘, ⌘, ⌘, ⌘, and ⌘) can only be used in conjunction with other keys.
• The backspace key (⌫) has the fixed function “delete selected objects”. It can only be assigned to a function in conjunction with the modifier keys Ctrl, Shift, and Alt (⌘, Shift, Ctrl, ⌘, ⌘, and ⌘).

• On Windows only: The Ctrl+Esc key (close window) and Alt+Esc key combination (close application) cannot be reassigned.
The + and _ keys increase or decrease any selected parameter value in single units. However, they can be assigned different functions, which then override this function.

**Key Commands Window**

The Key Commands window can be opened by selecting Options > Settings > Key Commands...

All the available key commands are listed on the right side. They are grouped according to the following categories:

- Global commands
- Functions affecting all windows (various windows)
- Functions affecting Libraries
• Functions affecting the Setup window
• Functions affecting the Device window
• Functions affecting the Editor window
• Functions affecting the Install window
• Functions affecting the MIDI Monitor window
• Functions affecting the Controller Assignments window

A “•” (Macintosh) or “*” (Windows) in front of the description of the function indicates that the function is only available as a key command, or MIDI command. To the left you can see the currently-assigned key, and even further to the left, the assigned MIDI message. A dash here indicates that no assignment has been made.

Assigning a Function to a Key

- Click the **Learn Key** button.
- Select the desired function with the mouse.
- Press the desired key, if necessary together with the desired modifier key(s) (⌥, ⌘, ⌘, and ⌘ on the Macintosh and ⌘, ⌘, and ⌘ on Windows).
- If you want to make another assignment, repeat steps 2 and 3.
- Deactivate **Learn Key**.

You can also set the key and the modifier via pull-down menus in the parameter box (top left).

Learn Separate Key

Learn Separate Key works in the same way, but differs in that it’s not just a reference to an ASCII code that is stored, but the actual code of the key that is pressed.
In practice, this means that you can, for example, assign different commands to the number keys on the numeric keypad than to the ones on the number keys on the main part of the keyboard—and the same goes for the different and—keys on the numeric keypad and main keyboard. The only disadvantage is that the key code (a number) is displayed in the Key Commands window instead of the ASCII symbol, which is more useful for reference purposes.

- If there is only one key command defined for the key, it will be used, no matter which of the two keys is pressed.
- If there are two key commands defined (one for the alphanumeric keyboard, one for the numeric keypad), then the appropriate key command will be used.

### Assigning a Function to a MIDI Message

- Click the Learn MIDI button.
- Select the desired function with the mouse.
- Send the desired MIDI message from your controller.
- If you want to make another assignment repeat steps 2 and 3.
- Deactivate Learn MIDI.

- If you want to assign a Note On message, remember to switch off Learn MIDI before you release the key in question (and thereby transmit a Note Off message). The last message received is always the assignment used.

You can set the type of message, the channel and the first and second data bytes in the Parameter box, using pull-down menus, or using the mouse.

### Deleting Assignments

- Click on Learn Key, to erase the key assignment, and/or Learn MIDI, to erase the MIDI assignment.
- Use the mouse to select the function whose key or MIDI assignment you want to delete.
Press [B].

To erase more assignments, repeat the second and third steps.

Deactivate the Learn Key and/or Learn MIDI button.

Switching MIDI Remote on/off

You can use the MIDI Remote button to globally switch on/off response to all defined MIDI messages. The MIDI command for this (Toggle MIDI remote) is always active, even when MIDI Remote is disabled, and is therefore always available.

If you have assigned MIDI Remote commands to all the keys on your master keyboard, you are advised to use a second foot pedal or a programmable button on your keyboard for Toggle MIDI Remote, which you cannot accidentally press while you are recording. If nothing like this is available, use a key you are unlikely to press by accident (for example the lowest or highest key)—but be aware that you will no longer be able to use that key to record any notes.

Disable MIDI Remote switches off MIDI remote control.

Checking the Function of a Key

Deactivate Learn Key and Learn sep. Key, and press the key whose function you want to check. The function will be automatically selected, and displayed in the middle of the window.

Making the Display Clearer

You can use the Hide Used and Hide Unused buttons to remove all the used, or unused key commands from the window display.

All the other Key Commands window functions remain available for you to use.
Finding Key Commands

Due to the large number of possible key commands, it can sometimes be difficult to find one in particular. For this reason, SoundDiver offers a *Find* function, which lets you search for a key command by typing in its name (or a part thereof).

Simply click in the white space to the right of the *Find:* button and enter the string of characters you’re searching for. The window will then display only those key commands that contain that character string (plus the currently selected command, even if it doesn’t contain that string).

The Key Commands window remains active, even in Find mode; you don’t have to leave this mode to continue making assignments.

The *Find:* button switches Find mode off and on. The button is automatically activated if a string of characters is entered.

Scroll to Selection

If you select the *Options > Scroll To Selection* menu, the key commands window will scroll to the currently selected key command. The same function will automatically be performed when the *Find:* button is disabled.

Printing a Key Command List

The *Options > Copy Key Commands to Clipboard* function copies the key commands into the clipboard as text. From here, it’s a simple matter to paste the results into any word processor document, format them any way you want, and print them out.
The **Copy Key Commands to Clipboard** function also takes into account the *Hide* and *Find:* function settings. You could, therefore, export only a certain group of key commands (e.g. all those containing a particular character string). What you see in the window display is exactly what’s exported.

**Storing Key Command Assignments**

The assignments you make are stored in the Preferences file automatically when you quit the program. However, you can also store your key commands manually, using **File > Save Preferences.** This also stores all the other Preferences settings as well.

**Importing Key Commands**

This function is particularly useful if you need to work temporarily on someone else’s system; you might wish you could use your personal key assignments on it, but without altering the system settings.

The **Options > Import Key Commands…** function in the Key Commands window allows you to import the key assignments from any "**SoundDiver 3.0 Preferences.PRF**" file, with a typical file selection box, which you could set to look at a floppy disk containing your personal SoundDiver 3.0 Preferences file).

The Preferences file in the Diver folder that has been in use up until now will be renamed to “SoundDiver 3.0 Preferences.bak”. This file contains the old key commands.

You don’t have to restart SoundDiver to continue.

**Initializing Key or MIDI Event Assignments**

The **Options > Initialize > …** command either initializes all Preference options (… *All Preferences except Commands*), all key assignments (… *All Key Commands*) or all MIDI
commands (... All MIDI Commands). The default assignments are then in effect.

Please be aware that you will lose your own key command assignments, if you haven’t created your own copy of the “SoundDiver 3.0 Preferences.PRF” file.

Apple: All “OMS” assignments are deleted if you use ... All Preferences except Commands.

**Entering Numerals**

We recommend that you use the number keys on the numeric keypad if the number is part of a key command (example: 5(0)). Of course, the number keys on the typewriter keypad work as well. So if you don’t have a numerical keypad (e.g. you have a PowerBook), you can press the 5 key instead of the 5 on the numerical keypad.
Chapter 3

Introductory Tour of SoundDiver

We have prepared a brief tour of SoundDiver so that you can get to know the program as quickly and easily as possible. During the tour, you can make a short stop at each station and carry out a few practical experiments with SoundDiver.

We recommend that you spend half-an-hour doing this, as it will save you a lot more time later. In the meantime, you’ll get an overview of the program before getting immersed in the details.

Before starting the tour you should:

- install SoundDiver
- connect at least one device—better still, two or more
- have available storage space either on a floppy or hard disk, because we are going to create a library.

The device used in most of the examples is the Yamaha EX5. The Yamaha SY99 and the access Virus are also used. Of course, you don’t have to use any of these particular devices. You can use any device you want because, SoundDiver’s functions are relatively uniform for all devices.

Off we go…

3.1 Start

We begin the tour by double-clicking SoundDiver’s program icon. SoundDiver starts up.
You have to configure your ports first. Please look at the section OMS on page 74. After a short time, the “Install” window pops up, and a dialog box appears containing a welcome message. You are asked to select the devices you have and hit enter.
3.2 Station 1: Setup and Install Windows

The Setup window displays the connected MIDI system in the form of icons (symbols). Here you can also select the devices that you wish to edit. If you have not yet installed any devices, all you will see is the icon which represents your computer. This view will change once SoundDiver automatically locates and installs the connected devices with the help of the Scan function. (If you’ve already read page 49 and installed your system successfully, you may wish to skip the next two installation steps).
Scanning

During the scanning operation, SoundDiver examines all the MIDI ports to see if a certain device is present. It does this by first loading the module or adaptation and then sending MIDI “Requests”. If a device answers, it is installed by SoundDiver and is then available for use.

Make sure that your devices are connected in both directions. To the right of the Setup window, you will see the Install window. If not (maybe because you already have installed a device, and therefore the Install window is not opened automatically), select **New > Install...** in the Setup window. The Setup window has to be the active window to see this menu.

Click the **Scan All** button. The scan procedure will begin. If SoundDiver finds a device, an icon will appear in the Setup window.

The Setup window might end up looking like this:

![Setup Window](image)

This means that your devices have been installed.

If there is a problem, please refer to the section *Scanning* on page 426 in Appendix C *Troubleshooting.*
If the scan function did not successfully install some or all of the devices in your system, the next step is to try adding these devices manually.

**Installing Devices Manually**

If the Install window is not yet open, select **New > Install…** in the Setup window.

We are now going to install a device manually. The list is sorted alphabetically, according to the manufacturer’s name and model name. Find the entry for “Waldorf microWAVE XT”, click it, then click the **Add** button.

If you already have a Microwave in your system, install this second one anyway because we are not going to alter the settings for your original Microwave.

The relevant icon (displayed inverted) will appear in the Setup window. Now close the Install window by clicking the **Done** button. We will come back to this newly installed Microwave later.

**Window Operation**

Before we cover the actual Setup functions, you should get to know the main functions relating to window configuration. These functions are available in SoundDiver’s Setup, Library, and Device windows.

**Window Layout**

On the left side of the Setup window is the parameter box. It displays the parameters of the currently-active device and allows you to adjust these to suit your taste and system’s idiosyncrasies.

In the upper left corner of the parameter box is a small triangle. Clicking this will enlarge or shrink the parameter box. This function is also available in other SoundDiver windows.
Now move the mouse pointer over the vertical dividing line down the left-hand border of the icon region. The pointer will turn into a double-arrow symbol. Hold down the mouse button and move the mouse left and right. Using this method you can quickly adjust any SoundDiver window to suit the situation. Use this function especially if the names of the MIDI-Ports are only partially visible. Return the dividing line to its original position.

**Local Menus**

You have already used the “New” local menu to install your MIDI devices.

Windows: For most windows in SoundDiver, additional specific (“local”) menus appear in the menu bar—inserted between the Options and Windows menu—with functions relating solely to that window.

Mac: Most windows in SoundDiver also contain a local menu bar with functions relating solely to that window. The main menu bar remains visible.

Now select View > Parameters from the Setup window’s local menu. The parameter box disappears, leaving the whole window free for the MIDI setup. If you select the same menu item again, the parameter box reappears.

**Scrolling the Contents of the Window**

In other programs you have no doubt seen the scroll bars which are situated along the lower and right-hand edges of the window. In SoundDiver they are easier to use, since the contents of the window move at the same time as you drag the scroll boxes so you always know where you are.

Click anywhere in the empty area of the scroll bar opposite the box. The contents of the window are moved exactly one page in the appropriate direction.
Click-holding the x/y scroll gadget (a small box at the lower left corner of any window) allows the simultaneous movement of the window’s visible section in both the horizontal and vertical direction. This is also achievable by pressing the wheel of a wheel-mouse.

**Parameter Box**

The parameter box in the Setup window is where you set the parameters for each device: SoundDiver will use these settings when it communicates with the device.

Clicking a device icon will select it (displayed inverted), and the contents of the parameter box will change to display the parameters of that device. If you now click the icon for the Microwave XT that you just installed, the screen should look like this:

First, we will give the Microwave XT a new name so it can be clearly identified. Click the name line in the parameter box and a text field will appear. Type in “Waldorf 1” (note that entering W replaces the previous contents by a W). If you then press Enter, the name will be entered. We will cover all the other parameters of the parameter box when we get to page 191.

Now we are going to remove this Microwave since we don’t actually need it.
To do this just click the Microwave symbol and select **Edit > Clear**. A dialog box appears with a safety question, and you confirm with OK.

To sum up briefly, the Setup window is an exact depiction of your MIDI setup. This is where you can scan devices or manually install and remove them, as well as adjust their parameters.

On we go to the next station…

### 3.3 Station 2: The Device Window

In the same way as the Setup window is an exact depiction of your MIDI setup, the Device window is an exact depiction of the memory contents of an individual device.

**Contents of the Device Window**

The Device window displays all the memory locations for sounds, multis, edit buffers, drum kits and any other data controlled by the device, either internally or on a card. SoundDiver can thereby fully exploit all the MIDI options of the device.

By virtue of “Entry Link Management” SoundDiver can recognize whether the entry that is currently being edited (e.g. copied or moved) is being used by another entry, and ensures that these cross-references remain intact.

**Example:** if you are moving an entry (“child entry”) which is being used in another entry (“parent entry”), SoundDiver will automatically update the corresponding parameters in the parent entry so that these will continue to use the right sound. This means that you can move your sounds wherever you want, and SoundDiver will take care of the rest.

SoundDiver makes it easy to recognize these entries by displaying them in bold type.
Let’s have a closer look at the Device window. For the following experiments you need a MIDI keyboard with a synthesizer. We will use the Yamaha SY99, but the experiments can be carried out on any MIDI keyboard or expander. Open the Device window by double-clicking the symbol for your device in the Setup window. The Device window will initially be empty, with the possible exception of ROM entries.

![Device Window](image URL)

Of course, SoundDiver first needs to receive the memory contents of the keyboard which will then be used as the basis for further experiments. If you are missing a certain group of parameters, or this window is completely empty, select **View > Data types > Show all**.
Chapter 3
Introductory Tour of SoundDiver

Requesting the Memory Contents of the Devices

Select Edit > Select all. All the locations in the Device window will be displayed black which means they have been selected. Now select Edit > Request. A dialog box will appear saying “Receiving data from…” and a small bar indicates the progress of the transfer. You will see the Device window filling up with entries.

Even though the Device window usually contains the sounds of a synthesizer this instruction manual always talks in terms of “entries” rather than “sounds”, since entries can also be effects programs from reverbs, etc. An entry in the Device window could also be a system setup, a drum-setup or an edit buffer, and in this case “sound” would not be the correct description.

Take a close look at the Device window: on the left is the device parameter box which you will recognize from the Setup window. The Device window displays all the memory locations for the device. Use the scroll bars or x/y scroll gadget mentioned previously to access items that are currently out of view.

Saving the Memory Contents of the Devices

As mentioned earlier, the Device window is an exact depiction of the device’s internal memory (also the card memory if available). This means that when you are working in the Device window, you are directly accessing the memory contents of your device, and you could accidentally erase data. We therefore want to play it safe and let SoundDiver receive the entire memory contents of your devices and save them to disk. We will cover the individual steps in detail in a moment, but for the time being just follow the instructions below:

- select all the devices installed in the Setup window
- select New > Build library > All entries in the local menu of the Setup window. SoundDiver will now request the data of
the devices— if this was not done in the previous section—
and creates a mixed library named “UNTITLED”

Now select **File > Save**. You can now save this new library
onto your hard disk.

Even if you accidentally alter the memory contents of your
devices during the following exercises— although SoundDiver
warns you of this wherever possible— you now have a safety
copy with which you can restore everything to its original state.

**Selecting Entries**

There are several different ways of selecting entries or groups
of entries.

The Device window is clearly divided into the individual data
types (in this case setup, performances and patches). Every area
has its own small gray title bar.

Click one of these title bars and the relevant area will be
selected. Click a column title bar in the patch bank and just this
column will be selected.

Select **Edit > Toggle** and all entries will be selected except those
that were previously selected. Now click anywhere in the gray
area and the selection will be cancelled.

Select a single entry by clicking it. Hold downOption (: S)
and you can select other entries as well.

At this point we will try out another function: enable Caps Lock
(this is the key above S), press the letter E and watch what
happens. SoundDiver selects the first entry whose name begins
with an “E”. If there are no entries beginning with “E” the
following entry in the alphabet is selected. Now press T
and the next entry in alphabetical order will be selected. Pressing
ST will take you in the opposite direction.
Auditioning the Selected Entries

To transfer an entry from the Device window to the appropriate edit buffer in the relevant synthesizer, enable **Options > AutoAudition** (so that a checkmark is displayed in this menu item) and click the entry.

After a short while you can audition the patch on your keyboard.

Every selected entry you click now is sent automatically to the device, providing a very quick and convenient way to audition selected sounds. To disable this feature, select **Options > AutoAudition** again.

If you enable **Options > AutoPlay** as well, SoundDiver will also transmit a test note, which is useful if your synthesizer doesn’t have a keyboard or you can’t reach it from the computer.

Moving and Copying Entries

In the Device window you can copy, move, initialize or delete the entries if you want to sort your sound bank or compile a new bank from several other banks. You can also copy entries between Device windows, as long as they originate from identical or compatible devices.

In this case SoundDiver can automatically recognize whether the data is convertible if you are dealing with related devices. So, for example, you could copy entries between a D-50 and a D-550 or even between an M1 and a T1 or a DX7 and an SY77. You can also copy entries within a library using the mouse (we will cover this later).

**Warning:** the following exercise will alter the memory contents of your device.

Grab an entry with the mouse and move it to another location. Make sure that you stay within the same bank, i.e., don’t move a sound program to a system setup or a performance to a drum kit. If you just move an entry onto another entry their locations will be swapped.

You can reverse this operation by selecting **Edit > Undo**.
If you want to duplicate an entry, hold down `⌘` (: ⌃) while you drag the entry to its destination position. You can also reverse this operation.

What if you want to initialize a sound or a performance? No problem. Simply select the relevant entry or entries and select Entry > Initialize in the local Device window menu. SoundDiver will then set all the parameters of the entry to neutral values. This is equivalent to the initialize function that is found in many synthesizers and other devices.

Let’s now go to the next station: the library.

3.4 Station 3: The Library

A library in SoundDiver is a sort of database for sounds and other storable data from your MIDI devices. As in a database, you can find, sort, delete and copy entries according to certain criteria.
A SoundDiver library is unique in that it allows you to gather together programs from different devices: patches from a Roland JV-80, voices from a Yamaha SY99, effects programs from an Alesis Quadraverb—all these can be simultaneously stored in a single library. There are different ways of compiling libraries.

In the section Saving the Memory Contents of the Devices on page 104 you created a library and saved it onto disk. We now want to turn our attention to this library.

Please select Windows > Untitled.

Click the “maximize window” gadget in the upper right corner of the Library window so that it fills the screen.

User-definable Configuration of the Library Window

As you can see, the Library window displays not only the names of the entries, but also a range of important data for each entry which you can use to search, sort or simply distinguish the entries from one another.

Take a closer look at the details of the Library window. Notice that there is a parameter box here as well, which displays the parameters of every entry in one view. If you can’t see the parameter box, select View > Parameters.
Now let’s alter its display a bit. For example, at the moment we don’t need to view the comments column, so let’s get rid of it. Select View > Comment which previously had a tick beside it. The comment column disappears and the columns to the right of it move leftward. Now do the same with the date, since, at the moment, the date of all the entries in the library is identical.

**Sorting**

We are now going to alphabetically sort the library display according to the names of the entries. There are two ways to do this. You may either double-click the “Name” field in the title bar or select Sort > Sort by Name in the local menu.

Next, try sorting the library display according to Sort by Data type and Sort by Size.

For more details, see the section *The Library* from page 245 onwards

**Moving Columns and Altering Their Widths**

Would you rather have the model column on the left? No problem. Grab the caption “Model” in the title bar and move it over the caption “Name”. The columns will then be swapped.

Is the “Used by …” column too wide for you? Just click-hold the right edge of the field in the title bar and drag left when the mouse pointer turns into a double arrow.

If you have followed these steps the library might look like this:
Chapter 3
Introductory Tour of SoundDiver

Mixed Libraries

One of the greatest advantages of SoundDiver libraries is that you can manage entries from different devices within one library. If you have more than one MIDI device and you have installed them in the Setup window, your library will already be mixed because it will contain data from the different devices. If you want to gather together all the entries belonging to a certain device, just sort them according to Sort > Sort by Model.

Dividing a Library into Zones

You can also divide any library into zones which can each be given an appropriate title. The sort functions will then automatically work within a zone. To demonstrate, try sorting your mixed library by model. Now locate the point where the entries for the next device begin, and select the first entry for this device.
Select **Library > Insert title** from the local menu. A text field will then open in which you should enter the following: “Memory contents of <device name>”. Now sort the names alphabetically. You will see that SoundDiver alphabetically sorts the zones separately above and below the title.

Delete the title again by selecting it and pressing **Esc**.

### Find Functions

Even the best library is of no use unless you can quickly locate specific sounds or other entries. SoundDiver therefore offers a range of Find functions which will help you find what you are looking for straight away, whether it is the right piano sound or all EXS performances—even in the largest libraries.

Let’s imagine that you want to see if there are any bass sounds in your library. Initially we have to use the name for the Find, i.e. we ask SoundDiver to find entries whose names contains the syllable “bas”.

Select **Edit > Find**. A window appears in which you enter the characters. Type in “bas” and click **Find**. SoundDiver will find the first entry in the library that matches the criterion, and select it. Now close the Find window.

Activate **Options > AutoPlay** and **AutoAudition**.
Chapter 3
Introductory Tour of SoundDiver

Now select Edit > Find Again.

If there is another bass sound, SoundDiver will find it, send it to the device and play it. You can keep repeating Find again until you have found all the bass sounds in the library.

What if you want to search according to completely different criteria? Say you want to transfer all the data that comes from the EX5 from a mixed library to a new separate library.

To do this open the Find window via Edit > Find… and click More Options. Here you should enter the following:

SoundDiver now searches for entries that originate from the model “EX 5” and simultaneously selects all the entries it finds. You can use standard cut and paste functions to transfer these to another library, or copy them by dragging them with the mouse.

It’s time to dive deeper with SoundDiver, and explore some of the unique editing capabilities it offers.

3.5 Station 4: The Editors

The principle is easy to explain: every module and most of the adaptations in SoundDiver which already use the Device window, Setup and Library also have a complete editor for the relevant device.
In the past, a program like this was often specially-written for a specific device. There was a DX7 editor, a Korg M1 editor and so on. If you used several devices, you had to load a different program for each device. A few years ago this may have not been such a problem since the average setup did not usually contain many devices.

In a larger MIDI setup consisting of many smaller synthesizers plus effects and MIDI patchbays, this process is too cumbersome. Say you have just finished a session and you want to store the sounds of all your devices in the computer. You would have to load a device’s relevant program, save its sounds, load the program for the next device and so on...

SoundDiver allows you to organize your sounds universally for all devices. During a production session, however, you often need to change or edit the sounds in an arrangement, with the sequencer running if possible, and without having to continually start and quit programs.
Chapter 3
Introductory Tour of SoundDiver

SoundDiver allows you to do just that. You can simultaneously open several editors, each of which contains several windows offering different views of the sound parameters. This enables you to zoom in on the envelope of an EX5 on the screen, while another window will show you the complete effects section.

The screensets let you make optimum use of these options, even on small screens.

Let's Start…

Let’s edit a few things in the EX 5. To be on the safe side, make sure that you’ve created a Backup Library of everything in the EX 5’s memory, so you don’t change anything permanently by accident. The procedure is similar to the one described in section Saving the Memory Contents of the Devices on page 104. First, open the EX 5’s Device window (or the one of your favorite device).

… in the Library

Select Entry > Build Library from the local menu of the Device window. This one has a sub-menu where you can select specific groups of entries:

We want to select all entries, so (not surprisingly) select All Entries.
SoundDiver automatically carries out a number of operations: it receives the sounds, creates and opens a new library and then copies the received entries into it.

**Welcome to Pleasure-programming…**

If you click an entry in SoundDiver it opens the editor (see above diagram) where you can immediately begin modifying the sound.

- first activate **Options > AutoAudition** and **AutoPlay**
- double-click a sound to open the editor. Experiment at random with the various operating elements—move the sliders, redraw the envelopes and switch the functions on and off. You will be able to simultaneously audition your editing
- quit the editor by clicking the close box of the window.

If you like the result of your random programming, click **Store** in the dialog box that appears. You can also select a different location for the edited sound in the flip-menu of the dialog box. On this occasion, it is probably safer to click **Don’t Store**.

**A Handful of Editing Functions…**

We are now going to experiment with the editor in more detail. Have you connected a device and opened the editor? If so, you should be able to see an editor window.

The diagram shows a typical editor window, in this case for an EX 5:
Here you can see the Overview that initially appears with more complex devices. This shows you all the elements of a sound or program at a single glance.

There are several macro parameters (volume, pan, detune...) that can be used to edit the sound quickly and easily. This is the “Easy Page”.

Use these to edit a sound without having to go into too much detail. In the example given in the diagram, the cutoff frequency was raised, the resonance lowered slightly and the attack lengthened.

Say we wanted to edit the filter envelope for tone 1. Click this button in the Overview display, and SoundDiver switches to the “detailed display”.

Basically you can view a SoundDiver editor like a street map. The Editor window is a view of a certain section of this map. The Overview, on the other hand, is the entire map at a larger scale.

In the detailed display, you can see every parameter of the device, although compared to the device itself, these are presented in a far more convenient and manageable form. Envelopes may be edited graphically, and there are knobs, beam displays and flip-menus.
The diagram shows a section of the detailed display of the EX5 editor, where you can see all the major controls at once.

In every editor you can open several windows showing whatever section you want. This can be very useful, for example, when you want to see just the left and right edges of the detailed editor at the same time. Instead of continually scrolling back and forth between the two sections, just open a second window by selecting **Windows > Open Editor**. Position this next to the first and scroll to the desired section. Another example might be if you want to simultaneously see the overview and the detailed display of a sound, as shown in the diagram. No problem, open two windows and set each view accordingly.
Chapter 3
Introductory Tour of SoundDiver

The screensets allow you to instantly call up the different editor displays.

If you don’t know what a parameter means, just click it and press \( \text{F1} \) (\( \text{F1} \)). SoundDiver’s On-line Help will immediately display the relevant information.
If the mouse pointer remains located above a parameter object, a short explanation and the current value is shown in a small window until you move the mouse pointer somewhere else.

But that’s not all. The functions of the Edit menu are also available in the editor. This means that the sound components and parameter groups may be copied at will, even between different entries. Just click a parameter group with **S** held down to select it. This feature is available only within modules.

The above diagram shows a group of selected parameters (DFCs). You can use **Edit > Cut**, **Copy** and **Paste** to copy it via the edit buffer into other components of the sound (tones, elements, voices) and of course into other sounds.
Chapter 3
Introductory Tour of SoundDiver

Randomize

If you don’t have the urge to program yourself, or you need some creative impetus, try SoundDiver’s randomizing function. Not only can it create entire sounds by chance, but also individual parameter groups. A random envelope in an effect sound, a random new waveform in a pad sound—and the sound becomes completely new.

The diagram shows the menu item “Random value” in the Editor menu, and next to it a randomly generated envelope—it doesn’t look too bad really…

3.6 Station 5: The On-line Help

SoundDiver has a comprehensive, built-in on-line Help function. This amounts to an individual instruction manual for the modules and adaptations, and describes the characteristics of each one. The on-line Help is interactive and context-sensitive. That sounds a bit complicated but means in practice that
SoundDiver will always supply you with the appropriate help text for the situation at hand. Let’s try it out now.

Call up the Setup window and position it so that it occupies the left half of the screen. Now select **Windows > Help**.

You should get into the habit of using the on-line Help function when you encounter a problem. Select one of your devices in the Setup window and have a look at all its help messages. Familiarize yourself with the different topics. Now, when you get into trouble, you will immediately know where to find the information which may solve your problem.

### 3.7 Other Functions

#### The Mini-sequencer

An important component of SoundDiver is its mini-sequencer. It is not intended for recording complete MIDI songs, but it gives you the possibility of recording a melody or phrase which you can use to test out sounds.

You open the sequencer by selecting **Windows > Sequencer**. The sequencer window is by default a “floating” window which always remains in the foreground and cannot be moved to the background even when you activate another window.

Check that your MIDI keyboard is connected properly by playing a few notes on it. If the sequencer is receiving notes a bar will appear in the field previously labelled “NO IN” in the sequencer window, and note information will be displayed.

In the lower part of the sequencer you will see the transport buttons which look similar to those on a cassette recorder. Click the record button (upper right). You will now hear a metronome signal coming from the loudspeaker of your computer; the counter of the sequencer keeps repeating the first beat—the sequencer is in waiting mode.
Now play a short phrase of about four bars. Click the stop button (lower right) when you are done. The phrase will have been recorded. You can listen to it by clicking the play button (below in the middle).

Call up the Library or Device windows. If you have activated Options > AutoPlay and AutoAudition, as described above, an entry will be sent to the MIDI device as soon as you click it and the sequencer will automatically play the test phrase.

**Screensets**

SoundDiver stores the layouts of the windows and various other settings as so-called "screensets". You can assemble up to 90 different screensets and call them up via key commands. Your current screenset is “1”, which is displayed in the main menu bar. If you now press 2 you will see an empty screen and “2” will be displayed in the main menu bar.

Now open a few windows and the sequencer as well.

By alternately pressing 1 and 2 you can toggle between these predefined screensets. You can arrange the windows precisely and then lock the screenset by selecting Windows > Screenset > Locked. You can change the locked screenset, but when you recall it later, it will have the original window layout. Selecting the same menu item again unlocks the screenset.

With the help of these recallable screensets, you will always have an optimum overview, even on a small monitor.

### 3.8 Short Introduction to SysEx

Don’t worry, you won’t have to deal with SysEx data—that’s what SoundDiver’s for. However, we thought that a brief introduction wouldn’t hurt. So if you’re interested, read on.
What is System Exclusive Data?

SoundDiver controls sounds, combinations, programs—in short all the saveable data of your MIDI device. This data differs from the standardized MIDI commands like Note On, Aftertouch or Program Change because they are different for every device. A special data format was created within the MIDI specification to deal with the transfer of device-specific parameters: System Exclusive data.

There are two plausible explanations for the term “System Exclusive”: it’s not certain which is “officially” correct. You can decide for yourself:

- System Exclusive data is the exception among MIDI data formats because it is the only one that is not uniform for all devices
- System Exclusive data is intended to be exclusively for a specific system (device, model) and is ignored by all other systems

SoundDiver communicates with its MIDI devices almost entirely on a System Exclusive level. You will hardly be aware of this, since SoundDiver’s orientation to the different devices is contained in the modules and adaptations. To you, it may appear almost as if SoundDiver is addressing all the devices in the same way. This is exactly how it should look, so that the operation of the devices is as uniform as possible, and works quickly and efficiently in practice. However, SoundDiver sometimes takes longer to receive the memory contents of device A than device B.

The System Exclusive data format of a device is laid down by the manufacturer, with hardly any restrictions. This means that whereas one device may be able to send each sound individually, another one may not. Even the amount of data used for a single sound varies greatly from device to device.
Chapter 3
Introductory Tour of SoundDiver

There are a few special features of System Exclusive data which you will come across in your work with SoundDiver, as follows.

**Device IDs**

Normally you distinguish between different devices within the MIDI system by allocating them different MIDI channels. When dealing with System Exclusive data, that is not always practical. For example, say you want to put four synthesizers of the same model all on one channel but with each one generating a different sound. In this case you need to be able to distinguish between them on the basis of the devices themselves—not MIDI channels.

For this reason, nearly all new devices and many older ones have their own identifiable number for System Exclusive data—the “Device ID”. SysEx-compatible devices within the system should have different IDs so that they can be addressed individually. This means that you can individually address considerably more than just sixteen devices at once and you can even distinguish between identical devices—say several DX7 modules in one TX816 rack. The device ID is usually totally independent of the MIDI channel of the device. If a device treats the MIDI channel and device ID separately, you only need to let SoundDiver know this ID and from then on you don’t even have to keep the device on the same MIDI channel.

**Dump Request**

Nearly all MIDI devices can transmit their data on request. This is vital if the computer is to be able to communicate with a device. For example, when you select *Edit > Request*, SoundDiver transmits a dump request to the device asking it to send this data to the computer. Depending on the device, there are different dump requests for sound banks, individual sounds, performances, system setups, drum kits etc. SoundDiver...
supports all types of dump requests used by the different devices.

**Dumps**

A dump is a device’s response to a dump request—it contains the requested sound data. Dumps are also used by SoundDiver itself, for example, with the **AutoAudition** function. Many devices can initiate “active dumps”. These are dumps from device to computer initiated by the device itself, i.e. without any dump request having been sent. SoundDiver can process active dumps at any time.

**Parameter Changes**

If you change a parameter in a SoundDiver Editor, SoundDiver uses a “Parameter Change” message to inform the device. Of course, it could just transmit a dump of the contents of the Edit Buffer. However, that would take too long and would make real-time editing impossible. If you are using SoundDiver together with a sequencer in a MIDI-tasking system you can record parameter changes in the same way as controller or pitch bend information.

Unfortunately, not all devices support parameter changes. In this case, SoundDiver has to transmit a dump. To avoid this happening after every small alteration (which would make the Editor unusable), the dump is delayed until about a second after the last alteration in the Editor.

We hope that this chapter has not only shed some light on the subject but also wet your appetite for more. So far, we have only skimmed the surface of SoundDiver’s functions. In the following chapters you will learn the details of all SoundDiver’s functions and capabilities.

We advise you to take the time to carefully read the remaining chapters. It will only take a few hours, but it will pay off in a
very short time. Of course, you won’t be able to remember everything at first. If you come across an unfamiliar term, look it up in the index. We have endeavored to make this as extensive as possible so that you have some support when you really need it. Initially, you should also make full use of the on-line Help which we covered earlier.

In the next chapter you will learn how SoundDiver operates, and also touch on the main menu bar.
Chapter 4

SoundDiver’s User Interface

In this chapter you will learn how SoundDiver operates by way of many practical examples. Among other things, you will learn how to operate the mouse, menus, key commands and windows, how to optimize the display of your MIDI setup, sort your sounds in the Device window and create a new library. After reading this chapter, you will be well on your way to mastering SoundDiver.

4.1 The Look of SoundDiver

3-D Appearance

As you can see from the illustrations in this manual, SoundDiver has acquired the same Emagic family “look” as programs like Logic or MicroLogic.

Boxes and buttons are in 3-D, and the background has a new gray 3-D appearance. While these features may improve SoundDiver’s appearance, they do require some of your computer’s “thinking time”, something which can be noticeable with slower computers.

You can accelerate SoundDiver if you disable 3-D Background in the dialog which appears when you select Options > Settings > Display Preferences.
SoundDiver 2.0 Appearance

If you prefer to work with the familiar look of SoundDiver 2.0, you can switch back. Change the settings in the above mentioned dialog.

You can also completely switch off the 3-D appearance.

4.2 General Operation

Mouse

The mouse operations are covered in more detail in the respective chapters because, for example, there are different functions for the Device and Library windows. This section deals with general mouse operations. We recommend that you try them out immediately in SoundDiver to help you remember them:

- clicking a non-selected object will select it and deselect all others. If the object was already selected, nothing happens,
- if you hold down \( \text{Alt} \) while you click an object, the selection of the object will be toggled.

**Example:** if you click a selected library entry it will be dese-
lected. The selection of the other devices will remain unchanged,

- to define a block, click the first entry, hold down **S** (**:**) and click the last entry in the block. To select several blocks, hold down **S** (**:**) as well after you have selected the first block.

Example: in a library, you want to select two blocks. First click the first entry of the first block. Select the last entry with **S** (**:**) held down. Now click the first entry of the second block with **S** (**:**) held down. Click the last entry of the second block with **S** (**:**) held down.

- On Windows, the mouse functions as a data “slider”. Click a value and hold down the mouse button. You can now change the value by moving the mouse forwards/backwards.

- **S**: The way you change values with the mouse depends on the *Mouse as slider* setting in the *Options > Settings > Global Preferences...* window.

If *Mouse as slider* is deactivated (refer to the section *Global Settings* on page 397), the mouse works as follows: to increase a value, click it. To decrease a value, hold down **C** at the same time. However if you hold down **C** the mouse turns into a slider and you can alter the value by moving the mouse forwards/backwards.

- A single click in the background (i.e. not on any object) will deselect all objects.

- A click in the background with subsequent dragging (while holding the mouse button) shows a “rubber band”. All objects inside this rectangle are selected. You can use **C** (**:**) here as well to toggle the selection or select the objects inside several rectangles.

- “Drag-and-Drop”: click and hold an object, then move the mouse (without releasing the mouse button). The object will be moved or copied to the location pointed to by the arrow when the mouse button is released. If this action is performed within the same organizational unit, the object is
moved. (If done within the Device window, the locations of the two items are swapped.) It is however copied instead of moved if the destination is located in a different organizational unit, e.g. when dragging an object from a Device window in a Library, or from one Library to another. While dragging, the window scrolls automatically when the mouse points to a window edge. This scrolling will stop once the mouse travels outside of the window’s edge.

- ⚪: The “Sticky Menus” feature from Mac OS 8 is supported in SoundDiver: one short click on a menu title keeps the menu open without holding the mouse button down. A click on a menu item selects it.

### Microsoft IntelliMouse™ (Windows Only)

SoundDiver Windows supports the Microsoft IntelliMouse™ according to the guidelines from Microsoft. Please install the IntelliPoint 2.0 system software for this to work properly.

- Scrolling: turning the IntelliMouse wheel (without clicking a mouse button) scrolls the section currently visible in the window. Scrolling is done in the direction (horizontal or vertical) which has the smallest percentage visible. The number of lines which is scrolled with one nudge, as well as the direction, can be adjusted with the IntelliPoint 2.0 software (Menu “Start > Settings > Control Panel”, control panel “Mouse”, tab “Wheel”, button “Settings…”).

- Zooming: turning the IntelliMouse wheel while holding ⌘ changes the zoom factor, i.e. the font size (only in windows which have this option).

- Data zoom: in editor windows which offer an overview display, turning the IntelliMouse wheel while holding ⌘ toggles between the overview and detail display.

- Panning: click somewhere in a window with the wheel button, hold it and move the mouse. The visible section will scroll in the desired direction. This function is identical to a
- click on the x/y scroll gadget (see the section The x/y Scroll Gadget on page 136).

- Autoscroll: click and release the wheel button. Now you can scroll the window (just like with Panning) without the need to hold a mouse button. Click any mouse button or key on the keyboard to exit this mode.

**Contextual Menus (Windows Only)**

In most of the windows, clicking somewhere with the right mouse button opens a contextual menu, as is done in Windows 95/98 and Windows NT4.0/2000. This contextual menu contains a summary of the menu items which have an effect on the selected objects.

If nothing is already selected, the clicked object will be selected before the contextual menu appears. If the clicked object has already been selected, the selection will be unchanged.

A menu item selected in a contextual menu always applies to all selected objects.

There are more specific explanations in the subsequent chapters.

**The Computer Keyboard**

There are slight differences in the key commands between the Macintosh and Windows versions, due to different keyboard layouts and user interface standards in the operating systems. These differences are described in the section Differences of Key Commands on page 415.

**Moving the Cursor**

In every window there is a cursor indicating the object being edited. In the Setup window, the device icon on which the cursor is positioned is displayed emphasized.
Chapter 4

SoundDiver’s User Interface

Windows: selected objects shown as text are displayed with the colors for selected objects defined in the “Display” system control panel.

Mac: selected objects shown as text are displayed with the color defined in the “Appearance” control panel (formerly: “Color”).

You can move the cursor either with the mouse, by clicking the desired location (device icon, entry), or using the cursor keys on the computer keyboard.

Apart from being able to move it in all four directions, there are a few other options which make the cursor easier to use. All of these useful options are listed in the table below:

<table>
<thead>
<tr>
<th>Window</th>
<th>Operation</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>All windows</td>
<td>select device/entry</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
<tr>
<td></td>
<td>extend selection by one object</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
<tr>
<td></td>
<td>turn page down/up</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
<tr>
<td></td>
<td>turn page right/left</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
<tr>
<td></td>
<td>scroll towards top left corner</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
<tr>
<td></td>
<td>scroll towards bottom right corner</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
<tr>
<td>List windows</td>
<td>extend selection by one page</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
<tr>
<td></td>
<td>extend selection to top/bottom</td>
<td>⇥, ⇦, ⇧, ⇨</td>
<td>⇥, ⇦, ⇧, ⇨</td>
</tr>
</tbody>
</table>

Entering Text

The computer keyboard is not only used for key commands (see the section Key Commands on page 415) but also for entering text (names of entries, comments, etc.):
to enter text, click the relevant field. You can completely delete it by selecting Edit > Select All and then pressing C. Type in the text and confirm with R.

- use the cursor keys ↑ or ↓ to change the position of the cursor,

- you can select a block of text by clicking in front of the first letter, holding down the mouse button and dragging the mouse pointer over the desired characters,

- you can delete a selected object (e.g. a block of text) by pressing C or DEL (), though if nothing is selected pressing C will delete the character before the cursor,

- you can use the Edit menu (see the section The Edit Menu on page 148) to cut, copy and paste text.

Defining the Font Used (Windows Only)
In Windows you can select the font which SoundDiver uses throughout the program.

In the WIN.INI file in your Windows folder, add the following line to the [SoundDiver] section:

Font=Fontname

and replace Fontname with the name of your preferred font.

This function is not available in the Macintosh version.

Menus

Windows
SoundDiver for Windows 95/98 and Windows NT 4.0/2000 is an MDI (Multiple Document Interface) application. This means that all document windows are shown within a main window (the “MDI frame window”). The main window also contains the menu bar. The menu bar always contains the menus File, Edit, Options, Window and Help.
Chapter 4
SoundDiver's User Interface

Depending on the active document window, there are additional window-specific menus (so-called “local menus”). These are always shown inserted between the Options and the Window menu.

Macintosh

To ensure the best overview, SoundDiver’s menus are divided amongst the main menu bar and the local menu bars.

The main menu bar is situated along the top edge of the screen, and contains the functions which apply to all areas of SoundDiver. It includes the File, Edit and Windows menus which you will find in every Emagic program.

Most windows in SoundDiver also contain one or more “local” menus which are situated in their own menu bar below the window’s title bar. They contain functions which are especially tailored to that particular window. Thus you can use the Sort menu in the Library window to sort the library entries according to different criteria or the New menu in the Setup window to install new devices.

That way you only ever see the menus when you need them.

4.3 Managing the Windows

SoundDiver’s windows are operated in exactly the same way as you are used to from other applications. However, they have a
few extra functions which allow you to maintain an overview in SoundDiver, even in the most complex window configurations. This section explains how to get the most effective use from the windows in SoundDiver, so that you always have an optimum overview of your work.

The Standard Gadgets

**Macintosh**
You will already be familiar with the standard window gadgets from other programs or from the desktop of your computer:

- clicking the close gadget in the top left corner closes the window,
- clicking the zoom gadget in the top right corner toggles you between two window sizes,
- by grabbing and dragging the size gadget at the bottom right corner of the window allows you to control its vertical and horizontal size. This even works while the window is in the background. The window will not be activated. To activate a window, click it briefly.

**Windows**
You will already be familiar with the standard window gadgets from other programs or from the desktop of your computer:

- clicking the close gadget at the top right corner or double-clicking at the top left corner closes the window,
- clicking the zoom gadget to the left of the close gadget toggles you between two window sizes,
- grabbing and dragging the corners or edges of the window allows you to control its vertical and horizontal size
**Scroll Bars**

The scroll bars along the right-hand and lower edges of each window vary not only in their position, but also in their size, which is proportional to the visible window section. This means you can always see the relationship between the visible section and the entire contents of the window. By clicking the empty area of the scroll bars, you can scroll the window section one page in the relevant direction. If the contents all fit into the current window section, the boxes will occupy the whole of the scroll bars and the arrows will disappear.

**The x/y Scroll Gadget**

In addition to the standard window commands, you may also use the x/y scroll gadget at the bottom left-hand corner of the window. This will move the window section both horizontally and vertically at the same time.

Grab the small gray box and the mouse pointer turns into a cross-hair. The window view will now move directly in accordance with the mouse. If you click the x/y scroll gadget while holding `C` (`Ctrl`), moving the mouse will control the scrolling speed instead of the direction.

With a 3-button mouse or the Microsoft IntelliMouse™ on Windows, you can click on any part of the window with the middle button (or the wheel button), and move the mouse while the button is held down.
Zooming

In all windows (except the Install, Edit and Sequencer windows) there is a small zoom button. This zoom gadget lets you enlarge or shrink the contents of the window (letters and icons).

A click on the upper half of the gadget will shrink the contents, a click on the lower half will expand the contents.

Automatic Scrolling

If you enlarge a window, SoundDiver automatically corrects the section being shown to show as much of the window’s contents as possible. This also happens when the contents of a window change and now contains fewer objects, as well as to zooming.

Altering a Window’s Column Layout

In various SoundDiver windows you can alter the width of the left side of the window using the mouse. Click and hold the vertical column border and move it left or right. By moving it to the left you create more space for the contents of the window; by moving it to the right you enlarge the parameter box, enabling you to read long parameter descriptions.

A change in the width of the parameter column also changes the size of the icon above the parameter column.

Moving Windows in the Background

It’s possible to move a window that’s in the background, without making it come into the foreground: press [Esc] while you drag its title bar.
Chapter 4
SoundDiver’s User Interface

Closing Windows

To close a window in the Windows version, click the close gadget at the top right corner or double-click the icon in the top left corner.

Apple: To close a window, click the close gadget at the top left corner.

Use these features as well:

- (Mac): -clicking the Library window’s close box closes all the Library’s windows without closing the Library itself. This feature is similar to that in Logic.
- (Mac): -clicking the close box of a window that is not a Library’s closes all the windows that don’t belong to a Library.
- (Mac): -clicking the close box of any window closes all windows.

Enlarging the Window to Full Size

By clicking in the full size gadget in the Windows version, the window takes up the entire client area of the main window. With you can easily cycle through the single document windows.

Apple: You can adjust the window size to fit the window contents by clicking the zoom buttons. This is useful if you want to show or hide the parameter list, or select a different typeface.

Floating Windows

All windows in SoundDiver may be opened as floating windows. A floating window will remain in the foreground, even when you open other windows which overlap it.

If you want to open a window as a floating window, hold down (Mac) when you open the window. The same modifier can
also be held down when selecting the equivalent command from the Windows menu.

Key commands for opening windows are available as a floating and a non-floating version.

In Windows, floating windows can be moved outside the main window.

There is one limitation with floating windows: key commands always apply to the top-most non-floating window. On Macintosh, you have to use the local menus instead. On Windows, you have to use the contextual menu (right mouse click on the title bar), as the normal menu also applies to the top-most non-floating window.

### Screensets

You can get an optimum overview of the screen instantly in any situation by calling up one of SoundDiver’s 90 user-defined screensets with a key command.

You select the screenset you want by pressing one of the numbers on the typewriter keyboard. Open a window and set its size, and the position of the scroll bars. These settings will automatically be saved, and will be restored the next time you call up that screenset. The number of the current screenset will be displayed in the menu bar next to the Windows menu, e.g. “45”.

& You cannot use the 0 key, so there are no screensets for 10, 20 … 90.

### Setting and Recalling Screensets

To call up a screenset:

- press the number key that corresponds to the screenset number. For example the 7 key will call up screenset 7.

& You can also use keys 1 to 0 on the numeric keypad, providing the number lock is switched off (see section Num Lock on page 400).
To enter a two-figure number hold down ⌘ (⌘: 重要原因) and type in both the numbers. For example, the combination ⌘ 78 (⌘: 重要原因) will call up screenset 78.

**Example:** let’s assume you want to store a screenset for a MIDI Setup window that uses the entire screen and gives you an overview of your system.

We will use screenset 99. Hold down ⌘ (⌘: 重要原因) and press 9 twice. The number 99 will now be displayed next to the Windows menu but the screen will be empty.

Now open the MIDI Setup window and maximize it’s size.

Now every time you select screenset 99, this screen layout will be restored. Try it for yourself.

**Copying a Screenset**

You can easily copy one screenset to another screenset number to use as a starting point for alterations. First, recall the screenset you want to copy. Now hold down ⌘ and recall the destination screenset number. You can also use ⌘ (⌘: 重要原因) to copy to a two-digit screenset number.

You can also use the functions **Windows > Screenset > Copy Screenset** and **Paste Screenset**.

**Multi-monitor Support**

SoundDiver is multi-monitor aware. If your computer and your operating system support this, it is highly recommended, especially if SoundDiver is used with a sequencing program like Logic Audio.

ℹ️: Multi-monitor operation is possible in all computers with PCI slots, independent from the Mac OS version.

On Windows, this is only possible with Windows 98 and 2000, but not with Windows 95 or NT 4.0. The graphics cards’ drivers must also be multi-monitor savvy.
4.4 Selecting Entries

There are several different ways of selecting entries or groups of entries in a Device window or library. We have already described the general functions. The special selection options for the Device and Library windows are covered in their respective chapters.

Read the following sections carefully and try out the functions in a Device or Library window.

Selecting Individual Entries

You select individual entries simply by clicking them. To select several entries which are spread out, hold down \( \text{command} (\text{⌘}) \) and click the entries you want. Clicking an entry again will deselect it.

Selecting Blocks

![Image of sound selections]

To select a contiguous block of entries, click the first entry, hold down \( \text{command} (\text{⌘}) \) and then click the last entry.

You can select several blocks by holding down \( \text{command} (\text{⌘}) \) as well. When selecting the first entry of the second block, hold down \( \text{command} (\text{⌘}) \), for the last entry use both modifiers.
Chapter 4
SoundDiver’s User Interface

Rubber Band
So select all entries within a rectangle, click in an empty area (or a vertical numbering column), hold down the mouse button and drag a rubber band across the entries you want to select.

As soon as this rubber band touches an edge of the window, the visible window section scrolls, enabling you to select entries that were previously not in view.

Inverting the Selection in an Area
To invert the selection within an area click in an empty area and—as described in the previous section—drag a rubber band across the entries while holding down \( \text{Option} \). The selection will be inverted for all those entries lying within or touched by the rubber band.

A current selection can also be inverted with Edit > Toggle Sel.

4.5 The Clipboard
SoundDiver has a clipboard into which data is transferred with Edit > Cut and Copy and which is inserted somewhere else with Edit > Paste. This clipboard works between different programs.

For example you could select all the entries in a library and import their names into a word processing program.

You can also take a clipboard of text from another program and add it to a library. It will be added as one or more title entries, and paragraphs of 75 characters per line will be automatically split up.

Using the clipboard, entries can be copied from a Device window to a multi instrument in Logic Audio. In case AutoLink is not working this is a simple workaround.

Printing the key commands is also effortless using the clipboard. After copying the content of the Key Command window to the clipboard (local menu item Options > Copy Key)
4.6 The File Menu

The File menu is where you can create new library files, open or save existing ones, print the contents of a library (or the Help window on the Macintosh), import and export files, make default settings or quit SoundDiver.

**New**

Creates a new library with an empty Library window and automatically names it “Untitled”. Every subsequently created library is given a number as well.

**Open…**

Opens an existing library from a floppy or hard disk. A file selection box appears in which you select a SoundDiver library.

When a library opens, the windows of the library documents will be opened in accordance with the current screenset.

If no window was saved for the current screenset, a default window opens instead.

- The screenset information belonging to a library’s windows are saved in the library file (not in the SoundDiver preferences which is the case for all other window classes). This way, opening a library automatically opens all windows as they were opened the last time it was opened, even if you did not use the library at all in the previous session.

- “Open…” basically contains the same functions as “Import…”, which only exists in the menu for reasons of clarity.

Commands to Clipboard, just paste it to your favorite word processing program, where you can edit the text for your personal needs.
Chapter 4
SoundDiver’s User Interface

: With “Open…” you can only load or import SoundDiver libraries, SoundDiver preferences, Standard MIDI Files and SYX/MidiEx files. For all other file types, please use the menu item “Import…”.

Close Library
Closes the current library, including all its windows. If you have altered anything since opening the library, you will automatically be asked whether you want to save the changes. As opposed to all other windows, closing a Library window will not close the library.

If you want to close just one window of the current library, select Windows > Close window instead.

Save
Saves the current library (the one which is checked in the Windows menu) onto floppy or hard disk. If you just created the library using File > New, you will be asked to give the file a name.

Save as…
Saves the current library under a different name, or using a different file path. Use this function when you don’t want to overwrite the existing library.

For both functions the following applies: if a file (of any type) cannot be saved, e.g. because there is not sufficient space left, the old file will not be overwritten and stays untouched. An error message will inform you of this.

Revert to Saved
If you have—mistakenly or otherwise—made any changes to a library which you would like to undo, you can use this function to call up the last version that you saved. The contents of the library will be loaded back in, but the windows will remain the same.
This process will cause all changes made since the previous save to be irretrievably lost. If you are not sure whether you want to discard all the changes, you should first save the current library under a different name using “Save as…” and then load the last version using “Open….”.

Save Preferences
This saves the current settings to the appropriate file. Please refer to page 411.

Save Preferences as…
Please see the section Save Preferences under a Different File Name on page 411 for details.

Page Setup…
Opens the window for defining the page layout. The relevant window for the printer will open. The paper format and indents are saved in the library file, so they don’t have to be redefined for the next print job.

Print…
Prints the contents of the currently active window with a connected printer. You can print the following:

• the current Library window. The column layout is printed exactly the same as you can see it on the screen. If the print width is too narrow, the rest of the library columns will be cut off.

• the entire on-line Help document which is presently displayed in the active Help window. Because the layout of the text depends on the width of the window, this is also carried over to the printer. However if the window is wider than the print area of the paper format, the rest of each line will be cut off. This should not happen with the preset print area.
Chapter 4
SoundDiver’s User Interface

To print a Windows help file, please use the appropriate function in Windows Help.

The format of the printing depends on the settings made in the Page Setup window (see above).

You can abort the printing with [Esc] or [Del].

Each library has a different page format, so that individual libraries can be set to print optimally.

SoundDiver prints a library as “WYSIWYG” (What You See Is What You Get) and supports TrueType for the best results.

ℹ️: The Help text’s line-wrapping is determined by the width of the page that you set under File > Page Setup, not the width of the on-Line Help window.

Margins are expressed in 1/72 inches, not in characters or lines. The paper format is built into the Page Setup dialog box.

**Import…**

This function allows you to convert files (C-LAB programs such as Polyframe, X-alyzer, Explorer 32 and Explorer M1 as well as Atari editor programs and bank loaders from other manufacturers) into SoundDiver libraries. You can also import Standard MIDI Files (SMF) and SYX (MidiEx) files.

For more information please refer to the section Importing SYX Files from page 281 onwards.

**Export MIDI File…**

This menu item is identical to Edit > Transmit (see the section Transmit on page 157), except that the data is not transmitted via MIDI, but saved to a Standard MIDI File.

This means:

- if a Device window is active, the selected entries are saved
- if a Setup window is active, the memory contents of the selected devices are saved
The File Menu

- if a Library window is active, the selected entries are saved so that playing back the file (e.g. in a sequencer program) will transmit the saved entries to the memory locations which are stated in the library’s “Location” column. If desired, you can reassign every memory location manually in the resulting dialog, just as in “Transmit”.

For further details on export functions, please refer to the section Exporting Files on page 282.

Capture as MIDI-File…

Selecting this menu item puts a check mark next to it, and all subsequent MIDI output is saved in a temporary buffer. When the menu item is unchecked the buffer is saved as a Standard MIDI File. As usual, you are asked for a file name and a path.

- Only MIDI output (no incoming MIDI events) is saved, except the output of the built-in sequencer or from "MIDI Thru".
- Unlike the functions described in section Export MIDI File… on page 146 and in the section Export … on page 212, the MIDI data is still sent out on the MIDI ports. This is necessary for example to receive acknowledgement messages from devices which require handshake communication.
- If you select one of the above mentioned “Export” functions, “Capture MIDI File” is aborted—all recorded data will get lost.

Quit

To quit SoundDiver select this menu command.

If there are libraries still open, you will be given the chance to save them first.

When you quit the program the preferences (see below) are always saved as well, so that the next time you start SoundDiver it will be set up exactly as it was before you quit the last time. However, if you don’t want this to happen, you should quit SoundDiver by selecting the menu item while holding
Chapter 4
SoundDiver's User Interface

4.7 The Edit Menu

The Edit menu contains the Find and Select functions as well as the standard functions for cutting, copying and pasting data which are found in every Macintosh or Windows program. Because these functions vary within the different levels of SoundDiver, we will cover them in detail. You will also find Request and Transmit in this menu transmitting all kinds of entries from and to SoundDiver.

Undo…

This command allows you to undo the last operation, if you accidentally deleted or altered something important. The function is available for practically all SoundDiver operations including:

- cutting, pasting and deleting in all windows apart from the Setup window,
- moving and sorting the entries in the library and the Device window,
- altering parameters and names in all windows. Continuous changes of the same parameter can only be “undone” as a whole.

The menu item is always accompanied by a description of the last operation, so that you always know what you can undo.

Of course all undone operations have an effect on the memory of your MIDI devices as well.

Example: Delete an entry A in the Device window, then swap entry B with entry C. By selecting Undo the first time (it now reads “Undo Swap”), C will be swapped back with B. Selecting
Undo again (the menu now shows “Undo Clear”), entry A is reestablished.

If the menu item is shown in gray and is named “Can’t undo”,

- the last operation can not be undone (e.g. deleting a device in the Setup window),
- there is no operation that could be undone,
- or there is not enough memory to undo (all steps are deleted).

The Undo function is unlimited in the number of undo steps: you can undo all previous operations, as long as there was sufficient memory to hold the necessary data to do so.

This unlimited Undo feature can take up a lot of memory, depending on the last performed operations. Therefore, in case of an “out of memory” situation, SoundDiver subsequently deletes the first step in the “undo chain” until sufficient memory is available. Under those circumstances, you would only be able to undo the most recent operations.

Undo steps are only deleted when other means (e.g. unloading unnecessary module or adaptation files) did not help to free memory.

Redo…

This command reverses the most recent Undo, allowing you to restore the situation to what it was before the undo function. As with Undo, Redo can be used an unlimited number of times.

If the menu item is shown in gray and is named “Can’t redo”,

- you either haven’t yet performed Undo,
- all undo steps have been redone,
- or there is so little memory left that the “redo chain” had to be deleted entirely.

As with Undo, there is a “redo chain” which is shortened in “out of memory” situations step by step; to be precise, it is always the longer of the two chains (“undo chain” and “redo chain”) which is shortened.
Chapter 4
SoundDiver’s User Interface

The Text Clipboard
When entries are stored in the clipboard as text when you perform Cut or Copy in a Library window, every entry is stored on one line and only the currently displayed columns appear. These are written out in full, and are separated by Tab characters.

This format is ideal for laying out tables in word processing programs or for importing into databases.

Cut
Moves selected objects from a window or text from a text field to the clipboard. From here the clipboard contents can be added to other places as often as you like, using paste.

Library/Device Window
If you cut out a library or Device window entry that uses other entries (“parent entry”; say a performance from the EX 5), the linked “child entries” are automatically copied into the clipboard as well. This ensures that if you add the entry to another library it will still be complete. This function covers all levels (e.g. program change table → multis → voices → pans). If you want to delete the linked entries as well as the entry you are cutting out, you have to select them too. In the library there is a special function for this: (⌘)-click (-click).

The term “parent entry” is used here and elsewhere in this manual as a generic way of describing an entry that is made up of multiple other component entries. The actual term used by your synthesizer is likely to be something else, i.e., Combi, Performance, or Preset.

If a linked entry is unknown in the Device window, a dialog box appears with the following options:

Cancel
the copy operation is cancelled,
The Edit Menu

Ignore
the entry is copied without its associated entries, which naturally results in incomplete data,

Ignore all
As with “Ignore”, but subsequent unknown entries are skipped without further prompting,

Request
the unknown entries are requested from the device via MIDI and then copied as well,

Request all
As with “Request”, but subsequent unknown entries are requested without further prompting.

If you just want to delete a large amount of data (i.e. you don’t want to copy it from the clipboard to somewhere else), it is better to use “Clear” (see below), because “Cut” temporarily duplicates the entries you want to remove, which can sometimes overload the memory. It’s quicker to clear than to cut.

Copy
Copies the selected objects or text from a window onto the clipboard, leaving the originals in place. The explanation regarding Cut also applies here for the library and the Device window.

Paste
Inserts the contents of the clipboard somewhere else, as follows:

Library
If you have selected an entry, the contents of the clipboard are added before this entry. If no entry is selected the data is appended to the end of the library. SoundDiver automatically checks for duplicates and deletes these if found.

If you add an entry that already exists, the existing one continues to be used. The reference (to the memory location of the
Device window) is not changed, but a reference to the existing entry is created instead.

**Warning:** the identity of two entries is established on the basis of the data, not the name. This means that if an identical entry already exists in the library, but under a different name, the existing entry continues to be used instead of the added one.

This automatic function can be switched off in the **Options > Settings > Library Preferences** window with **Check doubles** (see the section **Check Doubles** on page 408).

**Device Window**

The contents of the clipboard will overwrite the memory locations from the first selected entry. If no entry is selected, a suitable location will be searched for. SoundDiver has a series of routines designed to prevent the accidental overwriting of data or unnecessary addition of entries that are already present. This operates as follows:

- if the target memory location already contains the data which is to be added, nothing happens,
- if the entry to be pasted already exists in another memory location, it will not be added again,
- if there are no entries already present, a new target location is searched for beginning from the selected entry. When doing this, SoundDiver first searches for empty memory locations to avoid unnecessarily overwriting any entries. If there are no empty locations a dialog box appears in which you can select the target memory locations for yourself. The program first suggests a location where there are no cross-references.

**Strategies Used in Paste**

If you want to know exactly how SoundDiver associates locations when pasting entries, you will find a detailed explanation in this section.
The linked data which is also copied into the clipboard is also pasted. This works as follows:

- if the entry to be added is already present in any memory location, this is “reused”. The reference in the parent entry is adjusted if the memory location found is different from that given in the parent entry;
- otherwise, as above, the program searches for the most suitable target location that has the least effect on existing data.

**Example:** you previously copied a multi into the library that uses the voices “Piano” in memory location I-05, “Slap Bass” in I-17 and “Choir” in I-23. In the meantime you have regrouped the voices in the Device window so that the “Slap Bass” is now in location I-03 and the “Choir” is no longer there. If you now copy the multi from the library back into the Device window, the following occurs:

- because the piano voice has remained in the same memory location, nothing happens,
- SoundDiver realizes that “Slap Bass” is no longer in I-17 and there is a different voice there instead. It therefore searches for “Slap Bass” and finds it in I-05. The reference in the multi is adjusted from I-17 to I-03,
- in addition the “Choir” is no longer in I-23. This is also searched for, but not found. SoundDiver then searches for an empty memory location. If it cannot find an empty one, it searches for a location with no reference from other multis (or program change table). The memory location found is suggested as a target location in a dialog box, but you can alter it if you want. After you confirm with **OK**, the Choir is added to the Device window and sent to the device. The reference in the multi is adjusted from I-23 to the new memory location,
- finally, the altered multi is pasted and sent.

Remember that if you want to copy a parent entry with its associated child entries from a library into a Device window, you
just have to copy this parent entry onto the clipboard and paste it to the Device window. The associated child entries will be automatically copied as well. In cases where there is any doubt, you will be presented with a dialog box containing different options. The same also applies when operating in the opposite direction. This makes it easy to manage devices which have several layers of data (e.g. Korg Wavestation, Roland D-70 or Waldorf Microwave).

When pasting to the Device window only the sound data is compared, not the name.

Clear

This function deletes the selected objects or text without copying anything to the clipboard. You can reverse the clear operation with the Edit > Undo function.

Library

The Entry Dependency Management checks to see if you are deleting an entry which is being used by another entry. In this case a dialog box appears where you can select whether to:

- **Cancel**
  - cancels the entire clear operation,

- **No**
  - keeps the entry,

- **OK**
  - deletes the entry,

- **All**
  - all selected entries are deleted without further request.

In the “OK” and “All” cases the “uses” information in the entries which use the deleted entry is also deleted. For example, this can result in a parent entry becoming incomplete because you have deleted a child entry that it was using. It is obviously therefore important to be careful with the clear function.

Emagic

SoundDiver
Setup Window
Here you will always get a warning message because once you clear (remove) a device, the operation cannot be undone.

The computer icon can’t be removed.

Select all
Selects all the selectable objects in an active window, or all the text in a text field. For example, these could be library entries in the library, or device icons in the Setup window.

Use this function prior to editing, copying or moving the entire contents of a window.

Toggle Selection
This function toggles the selection within an active window: all the currently-selected objects are deselected and instead all the previously non-selected objects are selected.

Example: this would be useful if you wanted to delete most of the entries in a library. You could select the few entries you wanted to keep, toggle the selection and delete the selected entries.

Request
When you select this command, SoundDiver asks the active MIDI device to transmit the data for the selected entries. Depending on the selection you can request individual sounds, a sound bank, all edit buffers or the entire memory contents of a device.

If you have selected a device icon in the Setup window SoundDiver will request the entire memory contents of the device—another way of doing this would be to activate Select all in the Device window and then select Request.
Here is a detailed explanation of the functions of the Request command as it affects the different windows:

**Setup Window**

In the Setup window all previously unknown memory locations of the selected device are requested,

- “previously unknown” means that if entries have already been requested, they will not be requested again. So Request merely completes the data in the Device windows,
- “memory locations” means that no edit buffers are requested (because these are temporary) nor are ROM entries (because as a rule you don’t need to save these in a library),
- if no device icon is selected a dialog box appears in which you can select whether the operation should be carried out for all devices.

**Library Window**

The same happens in the Library window as in the Setup window; the memory locations of the selected devices (or all devices if none are selected) are copied into the library.

**Device Window**

In the Device window the selected entries are requested. Here, this can also include edit buffers and ROM entries.

- Some devices will not allow some or all data-types to be externally requested. In this case a dialog box appears in which you can cancel the operation or skip that particular entry.
- If a device will not allow individual entries to be transmitted, the program automatically requests the next largest data block.
- Some devices will not allow the entire memory contents to be requested via MIDI because you cannot change the device mode via MIDI (e.g. Roland JD-800, JD-990). If this happens you will see either an appropriate warning or the message “SysEx...”
communication error”. In this case click the “Help” button to find out what you have to do.

**Editor Window**

In editor windows, the currently edited entry is re-requested. This is particularly necessary if you

- select a different sound from the device’s front panel
- or edit the sound from the device’s front panel and the device does not transmit parameter change messages, after you have opened the editor window for this device.

**Transmit**

This command is primarily for bringing the memory contents of your device into line with SoundDiver—which is however seldom necessary, because SoundDiver takes care of this synchronization itself. If you select this function, SoundDiver transmits the data for the selected entries to the relevant MIDI devices.

Unlike the Audition and AutoAudition functions, the transmit function writes the data directly into the memory, and not into the edit buffer of the device.

Here is a detailed explanation of how SoundDiver operates when you select the Transmit command:

**Setup Window**

In the Setup window, all the memory locations of the selected devices are transmitted,

- “memory locations” here also means that no edit buffers or ROM entries are transmitted. Of course, there would be no point in sending the latter anyway,
- if no device icon is selected, a dialog box appears in which you can select whether the operation should be carried out for all devices.
Chapter 4
SoundDiver’s User Interface

Library Window
In the Library window, the selected entries are transmitted to the memory locations of the appropriate devices.

• If no entry is selected, SoundDiver asks if the entire library should be transmitted.

• The selection of the “appropriate device” is very sophisticated as there are many methods. For more information please refer to section Device Selection Strategy when Sending from a Library from page 214 onwards.

• As a preselection for the destination memory location, the library entry’s Location statement is used. If this statement is empty, SoundDiver tries to find an appropriate destination automatically.

Device Window
In the Device window the selected entries are transmitted.

If any of your equipment won’t receive individual entries, SoundDiver will ask if it should send the entire bank. If any of the entries in the bank are not recognized, you will be asked if you want the unknown settings to be initialized. If you don’t want this to happen, select “Cancel”, receive the entire bank, and then repeat the Transmit procedure.

Editor Window
In editor windows, the currently edited entry is transmitted to the device. This is necessary in particular if the device was not ready for reception at the time the editor window was opened (e.g. because it was switched off).

Find…/Find again
The Find functions allow you to search through one or more libraries for entries. SoundDiver offers many ways of entering Find criteria.
For a detailed explanation of the Find functions, please refer to the section section The Find Function from page 268 onwards.

4.8 The Options Menu

Settings
You will find a detailed explanation in chapter The Preferences from page 385 onwards.

AutoAudition
When AutoAudition is activated, the entries which you select with the mouse or cursor keys are automatically transmitted to an edit buffer of the device, so you can listen to the sounds or programs right away. This saves you the effort of selecting the Transmit function from the Edit menu every time you select an entry.

Apple: You can temporarily reverse AutoAudition if you select the entries by clicking them. Thus even if the AutoAudition function is active, you can select an entry without immediately sending it to the device.

Ctrl- or Option-clicking prevents AutoAudition (both in the Device window and in the Library). This allows you to achieve a multiple selection without having every clicked entry transmitted.

AutoPlay
Toggles the AutoPlay function between on and off. If activated, SoundDiver’s built-in sequencer plays the recorded sequence every time the Audition or AutoAudition operation is triggered, and also when a parameter in an editor is changed.

This means that you can automatically audition the new sound with the short sequence.
The recording of the test sequence is covered in section *The Mini Sequencer* on page 182.

![Note]

If you are using SoundDiver in conjunction with Logic Audio via Autolink, SoundDiver will automatically play a short segment of the open song in Logic Audio, beginning at the left locator position.

---

### MIDI Thru

Toggles SoundDiver’s MIDI Thru function between on and off. If the MIDI Thru function is active, SoundDiver diverts events received from the master keyboard to the active device. You can select the master keyboard in the MIDI Setup window; more on this in the section *Master Keyboard* on page 205.

![Note]

While requesting or transmitting entries, MIDI Thru is temporarily disabled. This prevents devices from getting confused by inserted note events.

For more information on the special features of the MIDI Thru function in connection with MIDI-Tasking please refer to the section *SoundDiver and MIDI-Tasking* on page 73 in Chapter 2 *Installation*.

---

### Hold Transmission

If this menu item is checked, all pending transmissions (i.e. dump messages) are held until the menu item is unchecked.

This feature is global for all devices. So if data is changed in several devices while Hold transmission is checked, no changed data will be sent to any device before the menu item is unchecked.

This feature is handy if you want to reorganize several entries in a bank, especially if the transmission of a single entry takes a long time (e.g. because there is only a bank dump message available).

**Example:** You want to build a bank from several library entries.

- check the menu item Hold transmission
The Options Menu

- drag and drop all entries into the bank (this is quick, because nothing is transmitted)
- uncheck the menu entry **Hold transmission**. All changed entries are then transmitted.

**Send MIDI**

**All Notes Off**
Use this function to correct MIDI problems such as hanging notes. When you select **All Notes Off**, all notes which are still playing are switched off by means of a MIDI All Notes Off command sent to all connected devices. If the built-in sequencer is playing, this is also stopped; the same applies to an external sequencer if you are using MIDI-Tasking (AutoLink).

**Reset Controllers**
This function transmits the MIDI command “Reset Controllers” which resets all MIDI controllers (e.g. pitch, modulation, aftertouch) to their “neutral” positions. Use this function if a synthesizer reacts weirdly because of a MIDI processing error, such as where the vibrato stays stuck on, or the pitch is wrong. This command affects all connected devices.

**Maximum Volume**
Sets the volume of all the connected devices to maximum. This is done by sending a value of 127 for Controllers 7 (volume) and 11 (expression) on all channels and over all MIDI outputs.
Loopback Test

This menu item tests the functionality of a MIDI connection. For this, you temporarily connect a certain MIDI input directly with a certain MIDI output using a MIDI cable. SoundDiver sends data packages and compares them with the incoming data.

To call up this function select Options > Loopback test.... You can also start the loopback test from a button in the “SysEx communication error” message.

To choose a certain port, click on a device and select the desired In and Out port.

SoundDiver leads you through each step.

First connect the MIDI In with the MIDI Out, using a MIDI cable and click Start tests.

SoundDiver sends MIDI messages to the Output and checks the incoming data.

SoundDiver transmits all 7*16 channel messages (with data byte 0), then SysEx messages with manufacturer ID “Non-Commercial SysEx” (7Dh) of increasing size.

You’ll get detailed information in the last message. The tests continue until there is a problem, or until the tested SysEx message reaches 20,000 bytes.
4.9 The Windows Menu

The Windows menu is the only variable menu in SoundDiver. Its contents depend on what/how many windows are open. In the following sections you will learn about the different window classes: “Library”, “Setup” and “Device window”. Within a window class you can open several windows which will then appear in the Windows menu. If you have a large number of open, overlapping windows, you can use the Windows menu to bring any one of them to the foreground.

If you select one of the **Open** ... menu items, and a window of this class is already open, but not active (front-most), the window gets activated. If no such window is open, or it is already active, then a new window of this class is opened (as far as multiple windows of this class are possible).

**Example:** if you select the menu item **Open Library**, a new Library window is opened. But if you select one of the menu sub-items beneath Library, the window you click is topped—no new window is opened.

### Screensets

Normally you will lay out your windows on the screen in a way that suits your way of working. This layout with various
windows, with all their different parameters (display, zoom, position of each window) is called a screenset, and can be stored. You can then swap between different screensets, much as you might swap between different computer monitors.

Windows version: The size and position of the frame window (this is the window which contains the menu bar) is stored in the screensets, too.

Storing Screensets

Screensets are numbered from 1 to 99 using only the numbers 1 to 9 (the 0 key is not allowed). You can see the number of the current screenset in the main menu next to the word Windows.

You don’t have to save screensets with an explicit command. It happens automatically, as soon as you switch to another screenset. Thus, without any effort, your current working view is always stored in the current screenset. Look at the section Screensets from page 122 onwards for an example.

Switching Screensets

Just input the number of the desired screenset (1 to 9). For two-digit screensets, hold down alt (Mac: cmd) while inputting the first digit.

Protecting Screensets

Use the option Windows > Screenset > Locked or the key command Lock/unlock current Screenset to protect the present screenset from being altered. A “•” (Macintosh) or “#” (Windows) then appears in front of the screenset number. Repeat the key command or menu command to unlock the screenset.

Copying Screensets

To copy the current screenset to a destination screenset, hold down ctrl (Mac: cmd) when you switch to the destination screenset. Two digit screensets are copied with ctrl alt (Mac: cmd alt).
SoundDiver offers a safety dialog box if you copy Screensets. You can also use menu functions to copy Screensets via the clipboard: Switch to the Screenset you would like to copy and select **Windows > Screenset > Copy Screenset**, then switch to the Screenset you wish to copy to, and select **Paste Screenset**.

**Reverting to a Stored Screenset**

The key command *Revert to current Screenset* resets your screen to the way it was when you called up the current screenset.

**Sequencer-controlled Switching**

Using the AutoLink mode, Screensets in Logic Audio and SoundDiver are synchronized. You can use Meta-Event #49 to switch Screensets via Logic. Look at chapter 10 in the Logic manual for details.

**Open Library**

This menu command opens a new window in the active library. You can open as many windows for one library as you want. Thus it is possible to lay out differently-sized sections of a library on the screen to save space.

If no Library has been loaded, the menu item **Open Library** remains active. You can use it to open a Library (the function is the same as **File > Open**...).

You can open several library windows at the same time. This allows you to arrange several sections and display scalings of the same library in order to save space. The library functions are covered in detail in page 245.
Open Setup
Opens the Setup window or tops it. You can only open one Setup window.

The Setup functions are described in detail in page 191.

Open Device
Opens a new Device window for the device that is selected in the Setup window. If no device is presently selected in the Setup window, the Device window opens for the device that was previously active. If the Device window of that device is already open, it is topped.

If the Device window shows nothing except the parameter box, check if all data types are shown. To show all data types on the screen, select View > Data types > Show All. You can also click on the All button at the top right of the device icon. You will find more information in the section The Device Window on page 220.
You can open several Device windows simultaneously for one device. This allows you to lay out different sections of a Device window on the screen, and simultaneously display sections that don’t fit in a single window.

The functions of the Device window are covered in detail in page 217.

Open Editor

When you select this command from the menu, a new Editor window opens for the entry selected in the Device window. If there is no entry selected in the Device window, you will not be able to select this command from the menu. If the selected entry cannot be edited the Audition function is carried out, and the Editor window opens for the relevant Edit buffer. If an Editor window is already open for that entry, it is brought to the front.

You can open several Editor windows for the same Edit buffer. This allows you to arrange different sections of an Editor on the

Two-section window of a Device window

The functions of the Device window are covered in detail in page 217.

Open Editor

When you select this command from the menu, a new Editor window opens for the entry selected in the Device window. If there is no entry selected in the Device window, you will not be able to select this command from the menu. If the selected entry cannot be edited the Audition function is carried out, and the Editor window opens for the relevant Edit buffer. If an Editor window is already open for that entry, it is brought to the front.

You can open several Editor windows for the same Edit buffer. This allows you to arrange different sections of an Editor on the
screen to simultaneously display areas which would not otherwise all fit in a single window.

The Editor functions are covered in detail in page 295.

“Link window” is disabled in all Editor windows if a new Editor window is opened while there is already an Editor window opened. In this case you usually want to edit different entries, and “Link window” would prevent this.

**Open Controller Assignments**

opens a window where you can assign any MIDI-in message to any parameter within SoundDiver.

Only one Controller Assignments window can be opened, as all Controller Assignments are administrated from one table.

Look for details in the section *Controller Assignments* on page 329.

**Open Install Window**

This item opens the Install window.

New devices can be installed or the setup can be scanned for new devices. Take a look at the section *Installing Devices* on page 65.

**Open Sequencer**

This menu command opens the window for the built-in sequencer. This window is (by default) a “floating window” which is always topped.

To open this window as a normal window, use the key command *Open Sequencer as normal*.

The detailed functions of the sequencer are covered in section *The Mini Sequencer* on page 182.
Open MIDI Monitor

This menu item opens a window which displays outgoing and incoming MIDI messages. It is very helpful for trouble shooting of communication problems.

The functions of the MIDI Monitor are covered in the section MIDI Monitor on page 185.

Open Help

Select this menu command or press  (H) to call up the on-line Help (or top it). The help function is context-sensitive, i.e. it always produces the help page that is relevant to the current situation.

Example: if you select a device in the Setup window and select “Help”, the help text for this device will be displayed on the screen.

The Help functions are described in more detail in the section On-line Help on page 171.

The following window commands help you get an overview of the screen by topping windows and placing them around the screen. They occur in a very similar form in all Emagic programs.

Larger View

shows the window contents in a larger font size.

Smaller View

shows the window contents in a smaller font size.

Next Window

This option brings the bottom-most window to the top and activates it if necessary.
Zoom Window
This option has the same function as clicking the zoom gadget at the top right corner of the active window. It toggles between maximum use of the screen and the set window size and simultaneously places the window beneath the menu bar.

For advanced users: when you switch from the set window size to the maximum window size, the horizontal and vertical position of the window is only altered if the window would otherwise no longer fit on the screen.

Close Window
This option closes the active window. You can also simply click the close gadget at the top left-hand corner of the window.

: In former versions of SoundDiver, the key command for this function used to be Cu. However, this does not comply with Macintosh conventions, therefore it has been changed to Cw.

: When you close a library window, the library itself is not closed. This is only done when selecting File > Close Library (see the section Close Library on page 144). This behavior is helpful when you want to create a screenset which does not have opened library windows, but you still wish to keep the library open. Also see the section Screensets on page 139.

Tile Windows
Attempts to lay out all the open windows on the screen so that you can see them all at once. Of course, whether this is successful depends on the number of open windows and the current size of the screen.

Tile Windows Horizontally
Attempts to lay out all open windows on the screen so that they will have maximum width. If there is no useful height left for the single window, a new row is set. SoundDiver optimizes the layout.
Stack Windows
Places the first window beneath the menu bar and overlaps the other windows beneath it, so that you can easily move or activate any window.

Window List
Below the window-specific menu items, a list showing all open windows can be found. The active window has a check mark. By selecting one of these menu items, the appropriate window is activated.

If there are more than 10 windows open, you will find an item More windows... where you can select one of the other open windows.

Library List
At the bottom of the Windows menu you will see the libraries that are currently open. The active library has a check mark by it. If you select a library here it will be activated and its window—if already open—will be topped. If there was no window already open for the active library, a new one is automatically opened.

4.10 On-line Help
A vital part of SoundDiver is the comprehensive on-line Help system, which offers you assistance with problems, questions and malfunctions. The on-line Help is context-sensitive—which means that whenever you call up the help, the relevant help text for the present situation will always appear on the screen. You can leaf through the pages or use the index function to directly call up specific topics.

The Windows version uses the Windows Help system.
A common window is used that you can leave open while you are working with SoundDiver.

We recommend that to start with you always leave the help window open—say on the right half of the screen—and read the help text very carefully.

The on-line Help supplements this instruction manual with information on specific devices. For example, in the Setup window you can get help on the selected MIDI device. Apart from general help messages about SoundDiver there are special help messages for every module, so that when you are installing a new module, you are supplied with a relevant up-to-date help message.

You may call up the on-line Help either by selecting Windows > Help or pressing Command + H.

Windows only: By selecting the menu item Options > Help always in foreground, the help window stays in the foreground, even when you click on something in SoundDiver.

The Help window is opened as a “floating window” by default. Key commands for the help window cease to be active. If you want to have key commands available for the help window, open it with Command held down.

Help Menu for Windows

To the right of the Windows menu, you can find the Help menu. Here, you can open the on-line Help by different means:

Help…

opens the on-line Help with different contents, depending on the current situation. This menu item is identical with the one in the Windows menu (see the section Open Help on page 169).
Search Help…
opens the index dialog of the help window relevant to the current situation. Here you can select a help page directly or search for a certain text passage in the help file.

How to Use Help…
shows help about how to use the Windows Help system.

Common Menus
On the Macintosh in the  menu, and on Windows in the Help menu you will find these items:

About SoundDiver…
opens the info window “About this program”. Among other information, here you can find the exact version number of SoundDiver. It is needed for phone support.

The following menu items only occur in the OEM and demo versions of SoundDiver.

License Agreement…
opens a help file with the license agreement. For the retail version of SoundDiver, you will find the license agreement printed in section Emagic Incorporated End User License Agreement on page 4.

SoundDiver Features…
opens a help file with a list of all features in SoundDiver.

Emagic Distributors…
opens a help file with a list of all distributors who distribute Emagic products.
Layout of the Help Window

The Help Window

Like the other windows, the Help window contains the standard window elements (scroll bars, close gadget, etc.). You can therefore place it where you want on the screen or move the window view.

The title bar always displays the disk path of the current help message.

The Control Bar on Windows

You can use the local control bar to get around the help messages as follows:

- **this new button scrolls to the first page of the selected Help file. This is where you normally find a description of the module or adaptation**
- **See below.**
- **takes you to the previously selected page. This allows you to trace your way back through the on-line Help messages to the place where you started.**
- **The Help window is closed as soon as you arrive back at the start.**
Index
If you click Index, the index appears on the screen. Select the term which you need more information on, and click it. If you change your mind and decide you don’t want to go to another page from the index, press [Esc].

Operating the On-line Help
The on-line Help itself contains built-in instructions for navigating the Help system. To bring this up, click the Help button in the control bar of the Help window (Windows: [F1]).

Zoom
The display within the Help window can be zoomed with the Zoom gadget on the Macintosh (Windows: sub-menu “Options” item “Font size”, three sizes).

Cross-references
The help messages always contain cross-references to associated or extended topics. The relevant key words are bold and underlined on the Macintosh (Windows: colored and underlined). Clicking one of these words will bring the relevant page up on the screen.

Icons
You will often come across icons which indicate particularly important sections, warnings or detailed information.
please pay close attention to the following text to avoid malfunctions or loss of data

explains how you operate an object with the mouse

a relevant example of the help message

Standard Pages

Most help files have a minimum set of standard help pages. All those pages can be recalled by the index (see the section Index on page 175).

“Module” Module (e.g. JV1080 Module)

This page is located at the very beginning of the help file for a SoundDiver Module. It contains introductory descriptions of the Module.

“Model” (e.g. XP-80)

For SoundDiver Modules, this page describes the peculiarities of the model, especially in comparison to the other models supported by the Module.

For Adaptations, this page is located at the very beginning of the help file and contains notes about the Adaptation as well as about the models supported by it.

This page is recalled from the Install window for the first selected device.

Installation

describes the necessary steps to install the device for SoundDiver, e.g. if any parameters have to be set to certain values so that the device processes SysEx messages.
**Scan…**

describes peculiarities of the Scan function. Some devices cannot be scanned, in which case it would be documented here.

**MIDI…**

Here you find details about what MIDI messages are processed by the Module or Adaptation. Some Modules don’t process “bulk dump” and/or Parameter Change messages.

You will also find general notes about peculiarities regarding MIDI communication with the device here.

**AutoLink**

This page contains all information which has to do with the display of names for Program Changes (Name Provider, see the section *The Sound Names in Logic Instruments* on page 362): if there are any entries which have to be requested or any parameters to be configured, as well as all recognized Bank Select messages. If you encounter problems with AutoLink Name Providing, you should refer to this page first.

**SysEx Communication Error**

This page enumerates any possible reasons for communication problems, and relevant fixes or workarounds.

If you click the *Help* button in the error message “xxx didn’t answer…”, this help page is displayed.

**Memory Manager**

Here, all banks of the device are listed, as well as possible configurations (e.g. cards, memory expansions).

This page is recalled by opening the help window from the Device window if there is no entry selected, or there is no online Help for the selected entry’s bank.
Chapter 4
SoundDiver's User Interface

“Data type” (e.g. Patch)
defines the data type.

“Bank” (e.g. Performance Mode Temporary Patches)
describes the bank’s peculiarities and contains a link to the
bank’s data type.
This page is displayed if there is an entry selected in the
Device window and the help window is opened, or if an entry is
selected in another bank while the help window is already
open.

Device Parameter box
Here the peculiarities of the device parameter box (see the
section The Device Parameter Box on page 197) as well as the
special parameters (see the section Special Device Parameters on
page 208) are described.
This page is recalled by clicking the Help button in the special
parameters box.

Conversion
If the Module or Adaptation is able to convert data types into
each other (or even between different device models), it is
documented here.

Import
If the Module supports importing alien file formats, it is docu-
mented here.

Credits
Here you can find out who created the Module or Adaptation as
well as the on-line Help file.
“Data type” Editor (e.g. Patch Editor)
Here the overall design and structure of the SoundDiver editor for a certain data type is described.
This page is recalled by opening the help window if an editor window is active, but there is no cursor flashing, or there is no specific help for the cursored parameter.

“Parameter group” (e.g. TVA Envelope)...
describes the purpose of the parameter group, as well as a listing of the secondary parameter groups which may also be copied separately.
This page is recalled if there is no specific help for the single parameters in the parameter group.

“Parameter” (e.g. Cutoff Frequency)...
describes the effect of a parameter and the individual parameter values, if appropriate. Often you will also find a link to the superordinate parameter group.
If the parameter can be edited using “Listen to MIDI” (see section Inputting Values via MIDI on page 310), you will find the appropriate icon together with a note on which MIDI messages can be used for entering a value.
This page is recalled when the help window is opened while the cursor is flashing on a parameter, or when the cursor is moved to another parameter while the help window is already opened.

4.11 The ToolTips
ToolTips are small popup windows, that opens when the mouse pointer moves over an object and stays there for at least half a second. ToolTips show information about entries or describe the function of a button.
The ToolTip will close if

- the mouse pointer moves to another object,
- a key or button is pushed
- you click an entry in the Device window or
- at the latest after 10 seconds.

**ToolTips in the Editor Window**

In an Editor window ToolTips display the complete name and value of the current parameter. A ToolTip opens if you edit a parameter in an Editor window

- with the mouse (Function “Mouse as slider”). The ToolTip is closed when the mouse button is released.
- with the keyboard. The ToolTip is closed after 2 seconds.

**ToolTips in the Device Window**

In Device window ToolTips contain its data type, memory location, and the complete name for every entry. This information is also shown in the status bar on the button of your window, but only for the selected entry.

**Adjust ToolTips**

ToolTips can be adjusted with Options > Settings > Display Preferences.
If *when pointing on objects* is unchecked, no ToolTips are shown when you move the mouse pointer over an object.

Disabling *while editing* suppresses ToolTips only while parameters are edited.

### Particularities

- No ToolTips are shown if parameter groups are copied, initialized or randomized. If parameters are changed by processing MIDI messages in the Controller Assignments list, Tooltips are also omitted (see the section *Controller Assignments* from page 329 onwards).

- If the option **Help > Show Balloons** is enabled, the ToolTip windows open immediately and are closed only if the mouse pointer is moved to a place where there is no object which can show a ToolTip.

On the Windows platform, the ToolTips background can be edited in the “Display” control panel, “Appearance” tab. The color can be edited in the “Color” pull down menu after selecting “ToolTip” in the “Item” pull down menu.

See the section *ToolTip* on page 403 for details.
4.12 The Mini Sequencer

SoundDiver provides a small sequencer for recording phrases or melodies that you can use when listening to your sounds. This sequencer is especially useful whenever you have to work without a MIDI keyboard. You can integrate test sequences into every library, and these can then be automatically played by the Options > AutoPlay function.

The internal sequencer is switched off whenever you use AutoLink. For more detailed information please refer to the section SoundDiver and MIDI-Tasking from page 73 onwards.

To open the sequencer window, select Windows > Sequencer. The sequencer window is a “floating window”: it is always active and topped, and doesn’t take up much space, so you can leave it open permanently if you like. If you want the sequencer as a common window use the key command Open Sequencer as normal.

The mini-sequencer has just one track, and contains the major functions that you will probably already be familiar with from other sequencers.

Under Autolink, the tempo slider is replaced by an “AutoPlay Duration” slider. This sets the length of time (in seconds) the external sequencer runs in the AutoPlay function.

If the external sequencer is already running in “cycle” mode, SoundDiver will not stop the sequencer. You can therefore try out different sounds while it cycles.
Record
To record a sequence, first use the MIDI In display to check that the sequencer is receiving data from the keyboard,
- click the record button; you will hear a metronome and the position displays for sixteenths and ticks will cycle in a loop,
- set the tempo by altering the bpm number with the mouse,
- play the sequence on the MIDI keyboard. As soon as you begin to play, the clock display will start to run. You can interrupt the recording with the pause button. After you have finished playing, click the stop button.

Output Parameters
As with MIDI Thru, the sequencer always plays on the MIDI output assigned to the active device, and on the MIDI channel which is set in the parameter Thru Ch (see the section Thru Channel on page 202).

Play
Click the play button to listen to the sequence. The sequencer plays the phrase once. You can automate the playing of the test sequence as follows:
If you have activated Options > AutoPlay, the test sequence is transmitted every time you select an entry.
In this case we advise you to use sequences which are only one bar or less in duration.

Drum Autoplay
Defines the duration of a note (in milliseconds). This parameter is only used if an editor changes a single note, in which case a complete sequence doesn’t make sense. When editing drums the relevant note is played using the duration set in Drum Autoplay.
Chapter 4
SoundDiver's User Interface

Free Memory
At the bottom of the Sequencer window, the free memory is shown. It serves as a global overview of SoundDiver’s memory consumption.

The shown value displays the largest free block’s size, not the cumulative size of all free blocks—because the latter is of no use when allocating one large block of memory.

By clicking the display, you can try to increase free memory:

- a single click “compacts” memory, i.e. moves moveable blocks so that fragmented free blocks can be combined. This function is comparable with defragmentation tools like Norton SpeedDisk.
- a right-click (-click) purges purgeable blocks, i.e. removes blocks which are currently not necessary
- double click frees as much memory as possible, i.e. performs both of the above procedures.

Store Sequence
The Library window has a menu item Library > Store sequence. This allows you to integrate the sequence that is presently in the mini-sequencer into all the selected entries. For example, you can select all the bass sounds and allocate them a typical slap bass lick, then allocate all the string sounds a slow chord progression, etc.

Just record the sequence you want, select the relevant entries in the library and select this menu command.

This feature is not available when AutoLink is in use, or SoundDiver is used with another MIDI-Tasking system. In these cases the internal sequencer is disabled.

The sequences are saved with the library onto disk and are available as soon as you start SoundDiver again.
4.13 MIDI Monitor

The MIDI Monitor window displays the flow of MIDI data, and is primarily intended for checking the MIDI connections. To open this window, click the In or Out display in the Sequencer window.

Another method is to select Windows > Open MIDI Monitor. If you hold down ⌘ (:O) at the same time, the window opens as a “floating window”.

The window shows all the MIDI data leaving or arriving at the computer, over all outputs and inputs.

The MIDI data is shown in hexadecimal to the left, and in ASCII to the right. Status bytes are in bold type (in the illustration, compare the SysEx Status bytes F0 and F7).

The window’s display can be zoomed (zoom gadget on the bottom right), and SoundDiver automatically selects the size of the typeface to match. The contents of the windows scroll as well.

The window can show up to 256 kBytes of data. To erase the buffer contents and therefore that of the window select Edit > Clear.
Chapter 4
SoundDiver’s User Interface

Note for advanced users: for SysEx messages, the vertical column next to the data window gives the offset of the first byte of each line in hexadecimal format. Together with the title line you can easily determine the offset of a data byte inside a SysEx message.

With all status bytes except F7 (End of Exclusive), there is a line feed, so that the beginning of a new message is always shown in a new line. At a change between incoming and outgoing data, or a changing output, there is also a horizontal line as well as the text “Input:” or “Output:” together with the appropriate output name shown. For a better identification, incoming data is shown red, outgoing data is shown green.

This window is especially useful when troubleshooting failing requests or scans. You can also find out how SoundDiver’s scan function works.

Edit Menu

Copy
You can copy the window’s entire contents as text to the clipboard and paste it into a text editor with the Edit > Copy menu item. This is useful when you want to give details on a communication problem. Also see Troubleshooting on page 421 in Appendix C.

Clear
With the menu item Edit > Clear, you can clear the window contents. This is useful if the window already is showing 256 KB, or you want to analyze a specific communication problem, and want only the relevant data shown.

Show Menu
The local View > ... menu allows you to show or hide specific information, and thus tailor the display more closely to your needs.
MIDI Monitor

MIDI In
Incoming MIDI data is only shown if this menu item is checked.

MIDI Out
Outgoing MIDI data is only shown if this menu item is checked.

View Menu
The local view menu allows you to enable and disable the display of various data, so that you can make it more detailed or easier to read, depending on your needs.

Time Stamps
When this menu item is checked, time stamps are shown.

Time stamp lines show the exact time when the MIDI bytes have been transmitted or received. The shown information consists of:

- the time when the data has been received or transmitted, in the format HH:MM:SS.mmm (hours, minutes, seconds, milliseconds). The shown time refers to the time when the computer was most recently booted.
- the time difference from the last time stamp line in milliseconds. This information is only shown if the value is larger than 0.
- “Input” or “Output” together with the input’s or output’s name. This information is only shown if it differs from the last time stamp line.

Time stamps for incoming MIDI bytes refer to the time when SoundDiver or the Module read them from the input buffer, and not when they actually arrived in the computer. This can be of difference if SoundDiver is currently occupied by other time-consuming tasks, e.g. screen redraws.
The shown time stamp information can help you to find a useful value for the time-out parameter in the Device Parameter box: simply request an entry and then check the value in brackets in the incoming data’s first time stamp line.

… of Status Bytes Only

When this menu item is checked, time stamp information is shown only for status bytes, otherwise it is also shown for all MIDI messages, i.e. for data bytes.

Below a time stamp line for data bytes, the next data byte is shown in the column following the last displayed data byte (and not in the first column), so that the 16’s counting inside SysEx messages is kept up.

Time stamp lines for data bytes are important for devices which make long pauses inside SysEx messages (e.g. Lexicon LXP-1/5 Bank Dump, Kawai K5000 ADD Sound Dump). This circumstance can possibly cause receive errors if the Adaptation or Module does not take this into account.

Note Off, …, System messages

These eight menu items allow you to filter specific message types, according to the status byte:

Table 3 Status filter

<table>
<thead>
<tr>
<th>Status Type</th>
<th>Status Byte Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note Off</td>
<td>80 ... 8F</td>
</tr>
<tr>
<td>Note On</td>
<td>90 ... 9F</td>
</tr>
<tr>
<td>Poly Pressure</td>
<td>A0 ... AF</td>
</tr>
<tr>
<td>Control Change</td>
<td>B0 ... BF</td>
</tr>
<tr>
<td>Program Change</td>
<td>C0 ... CF</td>
</tr>
<tr>
<td>Channel Pressure</td>
<td>D0 ... DF</td>
</tr>
<tr>
<td>Pitch Bend</td>
<td>E0 ... EF</td>
</tr>
<tr>
<td>System messages</td>
<td>F0 ... FF</td>
</tr>
</tbody>
</table>

If a menu item is checked, the corresponding MIDI messages are shown.
Incoming Real-time messages (F8h … FFh) are filtered out by principle and thus not shown.

Limitations

- The MIDI Monitor window is limited to 256 KByte of data. If this limit is reached, no more data will be shown. You can clear the window contents with 🗑️ or the menu item Edit > Clear (unless the window was opened as a floating window).

- An open MIDI Monitor window slows down MIDI processing, and could lead to communication problems, so shut it when you are not using it.

- The time stamp information has a resolution based on the system timer of 1 ms (1/1000 s) on both operating systems. This resolution is fully sufficient for time-out handling, which is usually in the range of 20 to 500 ms.
Chapter 5

The Setup Window

This chapter will teach you how to configure your setup in SoundDiver. Among other things, you will learn how to make SoundDiver automatically scan your system for connected devices, install devices manually, make individual settings for each device and automatically create a library for one or more devices.

5.1 Installing Your Devices

The section Installing Devices on page 65 in Chapter 2 Installation deals with the Install window and its functions in detail. This is where you can install your devices, either manually or using the automatic scan function. If you haven’t read this section yet, you should take a look at it now.

5.2 Installing New Devices Manually

Every device has to be installed before SoundDiver can start communication with it. New devices can be installed at any time using the Install window.

If you want to install devices manually—i.e. without the scan function—select New > Install.... When the Install window opens, you may select the device you want and install it. For details please refer to the section dealing with The Install Window on page 66 in Chapter 2 Installation.

If there is already a compatible device in the Setup, a dialog box informs you that the new device has automatically been assigned another device ID and a number has been added to the name. The Setup window will also be activated so that you can
immediately make any necessary corrections (in case the automatically assigned device ID is not right). We advise that you give the device a distinguishing name right away.

5.3 Interactive On-line Help

If you select a device in the list and then click the Help button or press \[\text{Help} \text{ (Apple: Command)}\], a help message is displayed for the selected device, with tips on any special features or limitations. If you select another device while the help function is open, the help message is automatically updated.

If you want information on installing the device, click Index in the Help window and then select Installation.

5.4 Graphic Display of the Setup

![Setup Window Diagram]
The Setup window consists of a graphic display of the current setup, with the device parameter box to the left.

The graphic display of the setup normally takes up the largest part of the Setup window. There is one icon for the computer and one for every device known to SoundDiver.

**Icons and Lists**

The Setup window’s display can figure with icons (already seen) and as a list.

You switch between the views with the menu items **View > As Icons and As List**

As you can see, the list display is not quite as informative as a graphical representation of the Setup, but you see far more devices within the same amount of space.
Chapter 5
The Setup Window

The devices are shown in alphabetic order. Each device in the list has a name, MIDI port and Device ID. To the very right, the memory allocation of the device (in bytes) is shown. This may be useful to determine which device uses up the most memory, based on the currently known entries.

The menu items Windows > Larger view and Windows > Smaller view are used to change the text size, and hence the number of devices you can see.

In the text display mode, there’s a little space to the left where you can click to deselect all the devices or to select several devices with the rubber band.

Activating a Device

You can activate a device within the setup in any of the following ways:

- click its icon.
- type in the first letter of the device name (don’t forget to enable Caps Lock).
- place the cursor (represented by a darker display of the selected icon) using the cursor keys (MIJK).

The contents of the device parameter box and the special parameter box (see below) automatically reflect the parameters of the active device.

To select several devices at once, either click them while holding down (⌘: ⌘) or drag the rubber band over them.

After a device has been activated, SoundDiver sometimes transmits a Program Change message or SysEx data to set up the correct patchbay connections.

Moving Icons with the Mouse

In the setup you will see one icon for the computer and one for each installed device; there are also connecting lines which represent the MIDI wiring but do not correspond to MIDI...
cabling in terms of MIDI In and Out. SoundDiver lays out the icons one below the other in the order in which they were installed. If a device was located via a patchbay the device’s icon is shown indented.

You can change the layout in the setup at any time, e.g. if you

• want to make space on the screen or
• want to match the position of the icons with the arrangement of your real devices.

Moving icons with the mouse in SoundDiver is done in exactly the same way as on the desktop of your computer. You can select and move several icons at once.

Just grab the icon with the mouse and drag it to the desired spot. It will be automatically placed on the next position by a “magnetic grid” and the connecting cables will also be adjusted accordingly. The size of the icons is taken into consideration to prevent overlapping. Cables are set accordingly.

To move several icons at once, first hold down the mouse button and drag a rubber band over the icons to select them.

Import New Icons

From time to time, modules are delivered with new icons.

SoundDiver can update the present icons while loading the preferences. Press `⌘` (: C) while loading the preferences.

Opening a Device Window

You can open the Device window of a device from the Setup window by first selecting the desired icon (see above) and then

• double-clicking the icon,
• selecting Windows > Open Device or
• pressing `⌦`. 
You can open the Device windows for several devices at once by selecting the desired icons and pressing \[ R \]. In this situation the Window link option of all Device windows will be disabled, because otherwise all the open windows would end up with the contents of the most recently opened Device window.

**Deinstalling a Device**

To remove one or more devices from the setup, click it/them with the mouse and

- press \[ B \] or
- select \textit{Edit} \textgreater{} \textit{Clear}.

**Buttons for Requesting/Transmitting**

You can use these two buttons to request or transmit the memory contents of the selected device(s). These functions can also be found in the \textit{Edit} menu. Just click the relevant button to execute the corresponding function.

\textit{Request} is represented by a question mark and an arrow pointing away from the device, \textit{Transmit} by an exclamation mark and an arrow pointing to the device.

The functions \textit{Request} and \textit{Transmit} in the Setup window act on all the memory locations of the selected device(s), with the exception of the Edit buffer and ROM data.

**5.5 Contextual Menu on Windows**

When you click a device icon with the right mouse button, the device will be selected, if it wasn’t previously, and a contextual menu will appear. The following menu items can be selected:

- \textbf{Open Device}: see the section \textit{Opening a Device Window} on page 195.
- \textbf{Request}: see the section \textit{Request} on page 155 and the section \textit{Buttons for Requesting/Transmitting} on page 196.
5.6 The Device Parameter Box

The parameter box in the Setup window contains the individual device parameters which control the routing and transfer of SysEx information. You can alter most of these parameters if necessary.

Some parameters are automatically entered by SoundDiver if they have been predefined in the modules or adaptations, e.g. the device name or the send pause time. Other parameters (e.g. Out Port) are automatically entered only if SoundDiver installed the device using the Scan function.
Chapter 5
The Setup Window

Hiding and Displaying the Parameter Box

You can hide the parameter box to create free space on the screen. You may have to do this on computers with small monitors in order to make the special parameter box visible, or to make more space available for the Setup window;

- if you click the small triangle in the upper left-hand corner of the parameter box (left of the device’s name), it will be vertically shortened which then allows you to see the special parameters beneath it,

- if you want to hide or display the entire parameter box, select View > Parameters in the local menu of the Setup window. In this case the width of the setup will be adjusted accordingly.

Name

The name of the device is displayed in the top line of the parameter box. SoundDiver automatically enters the name given in the module or adaptation but you can change it, say if you want to distinguish between two identical devices. To do this, just click the name and a text field will appear in which you enter the new name. Confirm your selection with [return].

Out Port and Input

This shows the MIDI output and input ports via which the computer is connected with the device. When you click these lines, a flip menu appears in which you select the output or input from the available options. These options vary according to what MIDI interface you are using.

- The out port and input are set by the Scan function.

With the release of SoundDiver 3.0 the input ports can be assigned separately. This allows SoundDiver to correctly assign incoming messages from identical devices, even if they use the same device ID.
The Device Parameter Box

If you don’t want an input assigned (i.e. messages are always processed, no matter on which input they are received), select the *any* item from the flip menu. This is also the default setting for preferences files from older SoundDiver versions.

The selection list is different, if patchbays are used. See the section *Inputs and Outputs Using Patchbays* from page 199 onwards.

**Issues Particular to Windows**
- The output “MIDI Mapper” is not available—it is usually just a duplicate of an explicit output and is thus superfluous.
- Although output names shown in gray can be selected, they cannot be used, as they are already in use by another application, and can not be opened by SoundDiver. If you want to use such an output with SoundDiver, you need to make the output multi-client capable. For details, refer to the section *Multi-client MIDI drivers* on page 79.

**Issues Particular to the Macintosh**
- In OMS mode, the OMS instrument is displayed and can be edited here.

**Inputs and Outputs Using Patchbays**

If at least one patchbay supported by SoundDiver is installed (see the section *MIDI Patchbays* on page 54), two additional parameters *Connected to* and *Return to* appear.

**Connected to**

This parameter allows you to determine how the device is connected to SoundDiver—whether via a patchbay or directly with the computer.

Click-hold the *Connected to* line in the parameter box to make a flip-menu appear for selecting the desired device.
Chapter 5
The Setup Window

---

**Out Port (of the Patchbay)**

If *Connected to* is set to a patchbay, this parameter lets you select the output at the patchbay, not at the computer or MIDI interface.

---

**Return to**

This parameter tells you whether the device’s MIDI Out is connected directly to the computer or to a patchbay.

---

**Input (of the Patchbay)**

If “Return to” is set to a patchbay, this parameter shows the MIDI input of the patchbay. If you click the line a drop menu appears where you can select one of the inputs. The number of available inputs depends on the type of patchbay.

---

*Bear this in mind:* SoundDiver allows you to have several patchbays connected in series. It is however not possible to have the output of a patchbay directly or indirectly connected to the input of the first patchbay. A warning message will appear if this is detected.

Here are two examples of cabling: in the first example, the EX5 is directly connected with the computer in both directions by Emagic’s Unitor8 interface:
The MIDI In of the EX5 in the second example is connected to output 2 of an J.L.Cooper Synapse, and the EX5 MIDI Out directly goes back to the computer’s interface input (Unitor 8, port 01).

The Scan function can recognize a device if its input is connected to a patchbay and its output is connected directly to the computer, but not vice versa. In this case you have to install the device manually.

**Device ID**

Here is where you select the device’s SysEx identification number within the MIDI system. This is used to address each individual device, and also to distinguish between devices of the same model. We recommend that you always use different device IDs for similar devices. Refer to the on-line help for information on where to find the relevant parameters within the particular device.
Chapter 5
The Setup Window

The value range of the available device IDs depends on the model. Some devices cannot have a device ID which is separate from the MIDI channel. In this case the Thru channel will not be available in the parameter box but will always be identical to the device ID.

Some devices do not even use a device ID, in which case this parameter will not be available. If you want to address two such identical devices you have to connect them to different outputs (either of the computer or patchbay).

This parameter is automatically set by the Scan function.

Thru Channel

If you have activated Options > MIDI Thru, incoming MIDI events—apart from Program Changes and SysEx data—are readdressed to the device on this channel. If the Thru channel field is empty, the data passes through unaltered, i.e., it is not re-channelized.

This parameter is only ascertained automatically by the Scan function for modules. With adaptations of devices where the device ID may be different from the Thru channel (mostly those which have MIDI Multi mode), you have to set the Thru channel manually.

Preserve Thru-Port/Channel

This option leaves the MIDI port and channel untouched if the active device is changed.

Use this function when editing effects devices.

Example:

- first click a sound generator device in the Setup window whose audio out is routed to the effects device,
- then click the effects device. As Preserve Thru Port/Ch is enabled for the effects device, MIDI Thru and the sequencer output will still go to the sound generator device
do some editing in the effects device. You will hear the sound generator playing.

**Velocity**

The value is added to (or subtracted from) the velocity of notes coming from a MIDI Thru or a sequencer note. The range is from $-127$ to $+127$.

This makes it easy to adjust the general volume of a device.

*This function is not available in AutoLink mode. In this case, you have to adjust the Velocity parameter of the matching Logic Instrument.*

**Timeout**

Here is where you determine the time that SoundDiver gives a device to react. If this time (in milliseconds) is exceeded, SoundDiver repeats the request several times (the number of retries is adjustable, see the section *Request Retries* from page 396 onwards). If there is still no reaction from the device, an error message appears saying “SysEx Communication Error: XY didn’t respond”.

*SoundDiver sets this parameter to a reasonable value when you install the device. However, if you consistently receive this error message you can try increasing the time and see if it improves the communication.*

**Send Pause**

Many devices transmit their data in blocks, even when transferring the entire contents of a Device window. This parameter determines the length of time SoundDiver waits between two such dumps, so that the device has sufficient time to process the single dumps.

Some devices even need some time to process single parameter change messages. In this case, SoundDiver pauses as well for this duration so as not to confuse the device.
Chapter 5
The Setup Window

This parameter is also set to a reasonable value when you install the device. However, if you get a newer operating system for the device which allows faster MIDI transfer, you may be able to shorten the pause.

Play Delay

If AutoPlay is active, SoundDiver waits a short time after transferring an entry before sending the test note. This ensures that the device is ready to play again after receiving the dump, and will not produce crackling or cut-off notes, because, for example, it has not finished initializing the effects section. This is where you set the required time, in milliseconds as always.

Patchbay Program

If you have connected your device to a patchbay which is not supported by SoundDiver with its own module, you can still ensure that SoundDiver always addresses the correct device. You do this by predefining a program in your patchbay which SoundDiver automatically calls up whenever the device is selected. To do this:

- add the device manually, as the Scan function has probably not found it automatically
- set the Out port and Input parameters to the MIDI ports the patchbay is connected to the computer
- activate the patchbay program change by clicking the checkbox. Additional parameters will then appear,
- select a program on your patchbay and set it so that the computer and the device are correctly connected via MIDI in both directions. The output of the master keyboard should be “merged” with the input of the computer if the patchbay has a merge option. You can thereby ensure that the MIDI Thru is functioning properly. If the patchbay does not have a merge function you will have to connect the master keyboard to a separate computer input,
- set the number of the patchbay program next to the activated checkbox. Pay attention to the numbering of the patchbay. SoundDiver numbers the patchbay programs 1…128.

- under ..Out/Ch select the MIDI Out of the computer to which the patchbay is connected. To the right of this, enter the MIDI channel on which the program changes are to be sent to the patchbay.

- if your patchbay takes a certain amount of time to reprogram the inputs and outputs, you can set a pause time in milliseconds under ..Delay. After sending the program change, SoundDiver will then wait this length of time before transmitting any dumps or test notes.

### Master Keyboard

If you are using a MIDI patchbay together with the MIDI Thru function in SoundDiver, it is useful to define one of the keyboards connected to the patchbay as the master keyboard. SoundDiver will then automatically divert the MIDI notes from this keyboard to the synthesizer that you are presently editing. The patchbays will also be automatically reprogrammed if necessary. SoundDiver looks after everything!

Of course the master keyboard control only works with patchbays that are supported by SoundDiver. With any other patchbays the master keyboard button is irrelevant, and you have to program the patchbay yourself so that the output of the master keyboard is merged with the computer.

To define a device as the master keyboard, select the device in the Setup window by clicking it with the mouse and activate the *Master keyboard* button in its parameter box. The current master keyboard is indicated by “hands above the keyboard”. SoundDiver itself ensures that you don’t mistakenly define devices without a keyboard as the master keyboard. The only exceptions to this are adaptations which are intended to be for both the keyboard and expander versions (e.g. Matrix 6 and 6R).
Chapter 5
The Setup Window

If you want to control your MIDI setup from the master keyboard, activate *Options > MIDI Thru.*

The “Master keyboard” feature is only required if your master keyboard is connected to a patchbay. If it is connected directly to the computer, MIDI Thru will always forward MIDI data received from the master keyboard to the active device.

**Auto Request**

If you have activated this function SoundDiver automatically requests the data of the device every time you start the program. You can set the number of requested entries using the following options:

**None**
nothing is requested;

**I**
only the internal memory is requested (no cards, no ROM);

**I+C**
only the internal memory and any available RAM cards are requested;

**I+C+R**
everything is requested except the contents of the edit buffers;

**All**
everything is requested.

The Auto Request function is useful because it always allows you to see the device’s current memory contents in the Device window directly after the program start; however the process can take a while depending on the device.

Please also refer to the section *Save Device Entries in Preferences File* on page 397.
The Device Parameter Box

**Module**
This is where you can see the name of the module which is responsible for the selected device. To get more detailed information on the module, click the module name.

For Adaptations, this parameter displays *Uni* for “Universal module”

**Model**
Here is where the name of the model is displayed. As you know, one module can control several models (e.g. SY77 module: SY77, TG77, SY99).

For Adaptations, this parameter displays the name of the Adaptation.

**Version**
This shows the software version of the device’s firmware. This information is only available if you installed the device using the scan function (and the device provides a way to transfer its version number via MIDI).

We therefore strongly advise you to always use the scan function. Many SoundDiver modules can distinguish between the features of the different software versions and adapt the SysEx communication accordingly. If on the other hand you install a device manually, SoundDiver always uses the first software version. This can sometimes mean that functions which were added later, or improvements to the operating software will not be supported by SoundDiver. The result could be considerable reductions in the efficiency of MIDI transmission.
Chapter 5
The Setup Window

5.7 Special Device Parameters

You will find additional settings for many devices below the device parameter box. The corresponding buttons change with each active device.

Help on Special Parameters

Click the help button to get more detailed information on the special parameters for each device.

Special Parameters for Patchbays

The Setup window’s Special Parameter box shows the patchbay’s inputs and outputs that are directly or indirectly connected to the computer. These parameters are automatically set by the Scan function.

The first of the patchbay’s active inputs and outputs are used by the computer when a device wants to communicate via the patchbay. Each active input and output is of course ignored by the Scan function.

You can use these buttons to manually install a patchbay or, if you’ve changed the cabling between the patchbay and the computer.

Bear this in mind:

• Make sure that at least one input and output are active, otherwise devices attached to the patchbay won’t be addressed.
• It stands to reason that these settings must correspond with the actual cabling.
• Changes to the button settings cannot be undone using “Undo parameter change”.
• When SoundDiver establishes a connection to a device connected to a patchbay, this is always done with the patchbay’s first input and output connected to the computer. It is currently not possible to control a device via a specific patchbay input or output.

**Patchbay Program and Standard Program**

In the Setup window’s Parameter box, each device has the *Patchbay Program* parameter. This ensures that SoundDiver is always able to address the device by selecting the appropriate program in the patchbay (see the section *Patchbay Program* from page 204 onwards).

If the device is itself a patchbay, the parameter is called *Standard Prg*.

Here, you can enter a Patchbay Program, called up every time a data transfer with a device has been completed.

Normally, a patchbay has a standard program that’s used with a sequencer. Its structure is usually:

- Master keyboard → Computer
- Computer → various devices

(depending on the situation several computer outputs can be connected with the patchbay, each of which is internally patched with several outputs)

Set the MIDI Program number of this patchbay program in the *Standard Prg* parameter. SoundDiver then automatically checks that this patchbay program is the normally active one. During communication with a different device (i.e. entries are being requested or sent) the patchbay is reprogrammed or switched.
(using the device’s Patchbay Prg). The Standard Prg is then automatically recalled so that sequencer activity is again possible.

Make sure that you also set the “Out/Ch” and “Delay” parameters correctly (see section Patchbay Program on page 204).

This automatic switching is even possible while the sequencer is running. This means for instance that you can try out different sounds in a library using AutoAudition. If a note gets stuck, it unfortunately means that the patchbay sends no “All Notes Off” messages before switching, or that the device doesn’t understand “All Notes Off”. In this case, access the device only with the sequencer stopped.

When a device is being edited, the patchbay’s Default Program remains active. To ensure parameter changes get to the device, this program should be set in such a way as to provide a connection from the computer to the edited device.

5.8 Interactive On-line Help

If you have selected a device icon, you can get a help message on that model by selecting Windows > Help. Because the help function is interactive, the help display will change as soon as you select a different icon in the Setup window.

If no icon is presently selected, selecting the help function will initially produce a list of all modules and adaptations. Clicking one of the key words will take you to the relevant Help page.
5.9 Local Menus in the Setup Window

New

Install…
Use this menu function to install a device manually. For more detailed information refer to the above section Installing New Devices Manually on page 191. This menu item is identical with Windows > Open Install.

Scan All Models
This function initiates the scan operation for installing devices. For a more detailed explanation refer to the above section Scanning from page 67 onwards.

Load and Transmit File …
This option is also available in the Device window. It acts only on the entries of the current device. See the section Load and transmit File… on page 232.

Build Library
This function enables you to automatically create a library from the memory contents of all the selected devices. For more details refer to section Saving a Sound Bank as a Library on page 286.

Save as…
This menu item works the same way as Create Library, but saves the created library directly to disk once you have entered its name and path in the file selector.
Chapter 5
The Setup Window

Export …
This function is identical to Save as ..., however the file is saved either as a Standard MIDI File or as a SYX/MidiEx file. See

Save Library for Logic Song
This function is only available in AutoLink mode using Logic (Macintosh Version 2.5 onwards, Windows Version 4.0 onwards). It allows you to automatically create a library containing all the entries (including all links) called up by the current Logic song via Instrument program changes.
If AutoLink is not active, or the Logic version does not yet support this feature, you will get an error message.
For details, refer to the section Saving Song Data in a Library on page 369.

Store All Edits
This menu item performs the function “Store” for all edited, yet unsaved edit buffers in all devices. The entries will be saved in the appropriate source (memory location in the Device window or library entry). If there is nothing to store, the menu item can not be selected.
Also see the section Store on page 320.

View

Parameters
Selecting this menu item enables you to hide or show the device parameter box. Hiding the device parameter box leaves all the space in the Setup window free for displaying the icons.
5.10 Automatically Creating a Library

SoundDiver allows you to automatically request the memory contents of one or more devices and use them to create a library. You could use this function to create a library from the internal memory of an EX5, an Access Virus or even your entire setup:

- select the device(s) whose memory contents are to be stored in the library by clicking it/them in the Setup window,
- select one of the sub-menu entries of New > Build library in the local menu of the Setup window.

If you have not selected any devices when you select this menu function, a dialog box appears asking you to select whether you want the operation to be carried out on all the connected devices.

SoundDiver will now automatically create a new library and copy the desired data into it. Depending on the selected sub-menu item, certain entries are requested if they are not yet received. Any entries which are already available are not requested again. For the meaning of the sub-menu items see the section Sub Menu on page 287.

You can use this function to make a safety copy of your whole setup with a single “click”: Don’t forget to save the library!
5.11 Device Selection Strategy when Sending from a Library

By selecting devices in the MIDI Setup window, you can influence which device SoundDiver sends data to if there are several possibilities:

- SoundDiver gives priority to transferring to devices that are selected in the setup—but only if the option Prefer selected devices as target in the Options > Settings > Library Preferences window is activated (see the section Prefer Selected Devices as Target on page 408). For example, if you want to transmit a DX7 voice to an SY77, even if you also have a DX7 in the setup, select the SY77. The voice will then automatically be converted and sent to the SY77;

- if no device is selected in the MIDI Setup window, the voice is sent to the device that can process the data without converting it, in this case the DX7;

- if there are several of these devices, the voice is sent to the device whose device ID matches that of the entry;

- if a device is selected in the MIDI Setup window which does not match the entry (e.g. a DX7 for a D-50 sound), the most suitable of the remaining devices is automatically selected.

- For the last three items, the currently active device (i.e. the one which is displayed in the Setup window’s Device Parameter box) is preferred over the others.

Example: in the setup there is a DX7II, an SY77 and a D-50. The latter is selected. A TX802 voice would then be sent to the DX7II, even though the SY77 could also convert the data.

The following table illustrates this strategy:
### Table 4  Device selection strategy

<table>
<thead>
<tr>
<th>Pass</th>
<th>Device is selected</th>
<th>Module matches</th>
<th>Device ID</th>
<th>Module / Adaptation loaded</th>
<th>Device active</th>
</tr>
</thead>
<tbody>
<tr>
<td>1&lt;sup&gt;a&lt;/sup&gt;</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>3</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>6</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>7</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>8</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>9</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>10</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>11</td>
<td>✓</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>12</td>
<td>✓</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td>no conditions, only a suitable edit buffer is searched</td>
<td></td>
</tr>
</tbody>
</table>

<sup>a</sup> skipped if option “Prefer selected Devices as target” is deactivated.
Chapter 5
The Setup Window
Chapter 6

The Device Window

In this chapter you will learn about the Device window. It displays the contents of the internal memory of a MIDI device on the screen. The Device window is where you can edit the various types of entries for your device. You can sort entries, delete them, copy them from a library into the Device window, and much more.

The term “entry” is used here and elsewhere in this manual as a generic way of describing a piece of data. Depending on the device and the type of data, it may be called a “Sound”, “Program”, “Patch”, “Performance”, “Comb”, “Mult”, “Global Data”, “System Setting”, “Tuning Table”, “Wavetable” etc.
To make sure that everything works properly, SoundDiver has two important features:

### 6.1 Data Consistency between the Device and Device Window

Many other librarian programs use banks in which the sounds saved can be completely different from the memory contents of the device itself. In contrast, with SoundDiver, the contents of the Device window always matches the data in the connected device. So the Device window is not a function that is independent of the device, but rather a reflection of your device’s memory.

**Important:** this principle is only maintained if you edit the data of your devices in SoundDiver, and not in the device itself. Copy or delete functions are not transmitted from the device via MIDI, so SoundDiver cannot recognize them. Therefore, there is the danger of accidentally overwriting important sounds. If you do change something within the device itself—e.g. during a live concert or rehearsal—the next time you start SoundDiver you should immediately request the altered version, so that you always see the current state of your device on the screen. SoundDiver can do this on its own, as shown in the section *Auto Request* on page 206.

### 6.2 Entry Dependency Management

Most modern synthesizers offer “parent entries” (often called Multis, Combinations or Performances) combining several sounds. These parent entries access the actual sound memory locations of the device.
The term “parent entry” (called in other program also “parent patch”) is used here and elsewhere in this manual as a generic way of describing an entry that is made up of multiple other component entries. The actual term used by your synthesizer is very possibly something else, i.e., Multi, Combi, Performance, or Preset. An entry which is referenced to by a parent entry is called “child entry” (also called “child patch”).

For example, an EX 5 performance called “Drum&Bass” might use the programs A24 “Drum” and B36 “Bass”. As soon as you overwrite both memory locations with new sounds, the combination program usually becomes useless, because it is using the wrong sounds.

This is not the case with SoundDiver, thanks to a feature called “Entry Dependency Management”. This function automatically keeps an eye on which entries are being used by others. To illustrate, let’s use the above example. If you move the drums from A24 to B65, SoundDiver automatically alters the Parent Entry, so that in the future it uses B65. Entry Dependency Management can even cover several levels of the device—for example the Waldorf MicroWave Program Change table → Multi → Voice → Wavetable → Wave.

Of course, in practice you don’t need to worry about these connections, since SoundDiver controls everything automatically in the background.

Bear in mind that these dependencies must be defined in the adaptations. This occurs with special objects in the editors.

**Devices with Individual Edit Buffers**

Some multi-mode devices, like the Roland JV-1080/2080, as well as Waldorf microWave XT, offer separate edit buffers for all child entries currently used by a parent entry. These edit buffers are called “Parts” or “Instruments”. When you audition a parent entry within the Device window, the SoundDiver modules supporting these devices cause the contents in these Parts to be updated. The device does this for itself whenever it receives a dump or program change message which selects a Performance or Multi.
Now, if you edit such a Part or Instrument, the parent entry’s link parameter still points to the memory location where the child entry originated from (you have however changed the child entry in the meantime). In this case, SoundDiver derives the correct dependency—that is to the Part, and not to the child entry’s original memory location, so that you can easily save the parent entry in a library without the need to store the edited Parts in the device back to the original child entry memory locations beforehand.

Also see the section *The Edit Buffers* on page 291 and the section *Devices with Individual Edit Buffers* on page 219.

### 6.3 The Device Window

You open the Device window of the active device by:

- selecting **Windows > Open Device**, ...
- pressing **R** in the Setup window or double-clicking the device icon.

SoundDiver will then open a Device window for the active device. If several devices were selected, a Device window is opened for each one.

If a Device window was already open in the background, it will be topped. If the window is already topped, another will be opened.

You can open several Device windows for the same device—for more information please refer to section *Layout of the Device Window* on page 222.

### The Link Function

Above the parameter box in the Device window, there is another button containing three stylized chain links. This is where you can switch the link function on and off. When the link function is active, the contents of the Device window are
always based on the active device whose name is displayed in the title bar.

**Example:** if you open the Device window for the EX5 while the link function is active and then select the Virus in the Setup window, SoundDiver shows the Virus in the same Device window. So you only need one single Device window for all the devices.

If there are several Device windows open at the same time, the link function is automatically switched off.

**Buttons for Requesting/Transmitting**

The Device window also has the Request/Transmit buttons that were described earlier in the *Buttons for Requesting/Transmitting* on page 196 in Chapter 5 *The Setup Window*.

The Request and Transmit functions in the Device window act only on the currently selected entries of the corresponding device.

**Zoom Functions**

The Device window display can be zoomed.

On the Macintosh, click on the zoom button in the top-right corner of the Device window to get a closer view of the section, or to display the entries in a larger typeface.

Select the menu item **Windows > Larger view** or **Windows > Smaller view** to get the same effect.

With a Microsoft IntelliMouse™ on Windows, you can also zoom in and out by turning the mouse wheel while holding Ctrl.
Chapter 6
The Device Window

Note: if banks overlap or are too far apart in an adaptation, the adaptation has to be adapted to the new format. To do this, open the Adaptation Editor. For further details, refer to the Universal Module Programming Manual.

Layout of the Device Window

The Device window contains several standard elements, a parameter box and local menus.

With most devices, the contents of the Device window will be unable to fit on a normal screen. However, as usual you can move the window section using the scroll bars or the x/y element.

Another solution is to open several Device window for the same device and lay these out around the screen. You could use this method to make space if, for example, you only wanted to see the left and right parts of the Device window, but not the area in the middle. Here is an example:
Additionally, all data types can be individually shown or hidden.

There are two ways:

- The buttons on top of the window make types disappear with a click.
- You can also use the `View > Data types` menu. Check or uncheck the various types as needed. See `Data Types` on page 236 in Chapter 6 `The Device Window` for details.

You can use the screensets (see the section `Screensets` from page 139 onwards) to preprogram the right display for every situation.

**The Contents of the Device Window**

The Device window displays the entire internal memory of the device—if a device contains preset sounds (ROM), these are also displayed on the screen so that they can be copied into the internal memory. However this is not always possible—depending on the device’s SysEx capabilities.

**Banks**

The display of the internal memory varies from device to device and is based on the type and number of the memory locations. For example, the Yamaha EX5 has 128 internal performances and four banks with 128 voices. Of course Sound-Diver also manages the global or drum kit data of this device and the edit buffers. With the Access Virus you will find 128 Multis and two banks with 128 Singles. In most cases Sound-Diver can control any data from the device which is supported by its SysEx implementation.

ℹ️ Some devices do not allow certain banks to be transferred, e.g. the SY77 cannot receive or send its card voices. Unfortunately, if this is the case you cannot display the bank.
Entries with Dependencies

Entries shown in bold face are called “child entries” used (referred to) by at least one “parent entry”, i.e. there is a dependency to bold-printed entries. You should not overwrite such entries, as otherwise some parent entries might sound different.

If the dependency management is switched off, this display feature is switched off as well. See section Dependency Management on page 399.

Entries Shown in Gray

SoundDiver shows entries in gray instead of black if only their name, but not their patch data is known. These are either ROM entries or entries which have been received, but deleted again in the meantime.

When SoundDiver deletes an entry in the Device window, it still remembers its name. This allows you to save memory if you only need the names for the name providing features of AutoLink (see the section The Sound Names in Logic Instruments from page 362 onwards).

Names of ROM Entries

SoundDiver also receives the ROM entries of a device, displays them in the Device window and allows you to copy them into the library.
ROM entries may be edited (providing there is an Edit Buffer of the same data type), although they cannot be stored back in their original location, because this cannot be overwritten. The names are shown even when SoundDiver does not know their actual data. If they are requested, however, the actual name is shown. This may differ from the gray name, if the manufacturer has stored different ROM sounds in a new version of the device.

Naturally, you can use a ROM sound as the starting point for one of your own creations. To do so, simply open it and store it in a free RAM space. For more details, see the section *Store* on page 320.

In case you need only the names of a ROM bank (e.g. to use them in a Logic multi instrument), you don’t need to request them. The function “Copy” in the Edit menu copies the names into the clipboard, even if they are only shown in gray. But try the AutoLink function first, which offers much more facilities (section *The Sound Names in Logic Instruments* on page 362).

### 6.4 Functions in the Device Window

In the Device window, entries of the same data-type can be exchanged, copied, deleted etc. Please note that SoundDiver immediately transmits these alterations to the device, because the contents of the device must always correspond to the Device window display.

Before you begin moving or copying entries please make sure that the Device window reflects the actual memory contents of the device. If you want to be completely sure, select the device in the Setup window and select *Edit > Request*. SoundDiver will then receive the entire memory contents of the device and the Device window will definitely be up to date.
Selecting Entries in the Device Window

In Selecting Entries on page 141 in Chapter 4 SoundDiver’s User Interface you read about the selection functions; these also apply in the Device window. Here is a brief summary:

- To select an entry, click it. Clicking the gray area within the Device window cancels the selection.
- To select several entries inside a rectangle, use the rubber band function. Click and hold in the background or in the numbering column to the left of a bank, and open up the rectangle.
- To select several entries, click them one after the other while holding down (⌘: S). You can toggle the selection by clicking while holding down (⌘: S) or by holding down (⌘: C) and dragging a rubber band over the entries.
- To select a whole block, click the first entry and then click the last entry while holding down (⌘: S). You can select several blocks by repeating this operation while also pressing (⌘: C). It does not matter if the blocks contain different data types;

• to select a column, click the column title (in the above example labelled “1” to “4”). You can select several columns if you also hold down (⌘: C).
Functions in the Device Window

- to select a whole bank, click the black bank title (in the above example labeled “Internal Patches”). You can select several banks if you also hold down \( \text{⌘} \) (\( \text{⌘} \) + \( \text{⌥} \));
- the rubber band function from the Setup window is also available in the Device window,
- you can use the \textbf{Edit} menu to select all entries at once, or to toggle the selection;
- to deselect all the entries, click a gray area within the Device window, or in a numbered column.

\[ \text{Zoom} \] Clicking the selection bar of a bank with only one entry is handled as if clicking the entry itself. Double-clicking the selection bar opens the entry, dragging the selection bar drags the entry.

Selecting Entries Using Names

You can search for entries in the Device window using the entry names or run through the entries in alphabetical order.

First, enable Caps Lock. This is done with \( \text{⌥} \), (the key above the left \( \text{⌘} \) key).

Now just type in the first letter(s) of the entry name. The first entry whose name begins with the same character(s) will be selected.

To select the next alphabetical entry, press \( \text{⌘} \); to jump to the previous one, press \( \text{⌘} + \text{_ctr} \).

These functions help you target the entries using their names.

\( \text{SoundDiver} \) still recognizes entries that do not contain any data, but are still present as names (e.g. deleted entries, that can be seen in the Device window).
Exchanging, Moving and Copying Entries with the Mouse

**Exchanging**

To exchange the locations of two entries within the Device window, grab one entry with the mouse and drag it onto the other entry. The locations will be automatically exchanged. Of course you can also select several entries and drag them to another location. SoundDiver will then exchange the locations of the entries in accordance with their order in the Device window.

**Example:** if you drag entries 12, 15, 18 and 32 onto entry 56, they will be moved in order onto entries 56 to 59 which in turn will be exchanged with the entries that replaced them.

If you drag entries onto empty locations they will simply be moved there.

**Copying**

If you hold down `⌘` (⌘: ⌃) during this operation, the target entry is overwritten instead. This is how you duplicate entries within the Device window.

**Example:** if you hold down `⌘` (⌘: ⌃) and drag entries 12, 15, 18 and 32 onto entry 56, they will be copied onto locations 56 to 59. Thus, entry 56 contains a duplicate of entry 12, entry 57 one of 15, 58 of 18 and 59 of 32.

Whenever you drag entries from a Device window into another window, they are always copied.

Try not to select entries printed in bold face as a destination. These are child entries and already in use by another entry. See also section *Entries with Dependencies* on page 224.
Using the Edit Menu to Cut, Copy, Paste and Delete Entries

You can select entries from the Device window and use the functions of the Edit menu to copy, cut, paste or clear (delete) them. This also applies to entries from a library. The functions of the Edit menu are covered in detail in the section The Edit Menu from page 148 onwards.

SoundDiver keeps all names of deleted entries, even if the data was deleted. The appropriate entries are shown in gray instead of black (like ROM entries. This is especially helpful when using Autolink.

Editing Entries

If you double-click an entry in SoundDiver, the Editor opens instead. For details refer to the chapter Editing with SoundDiver from page 295 onwards.

6.5 Contextual Menu

When you click an entry with the right mouse button, it is selected (if not selected already), and a context menu appears. The following menu items are available:

- **Edit**: see Edit on page 234 in Chapter 6 The Device Window.
- **Audition**: see the section Audition on page 233.
- **Cut, Copy, Paste**: see the section Using the Edit Menu to Cut, Copy, Paste and Delete Entries on page 229.
- **Request**: see the section Requesting Entries on page 237
- **Transmit**: see the section Transmitting Entries on page 238.
- **Hold Transmission**: see the section Hold Transmission on page 160.
- **Rename**: see the section Rename on page 233.
Chapter 6
The Device Window

- **Export MIDI File...**: see the section *Export MIDI File...* on page 146.
- **Parameters**: see the section *Parameters* on page 235.

When you click an empty area with the mouse button a shorter contextual menu appears which contains the only the items *Parameters* and *Hold Transmission*.

### 6.6 The Device Parameter Box

The device parameter box in the Device window is identical to the parameter box in the Setup window, except for the lines *uses...* or *used by*. The individual parameters are covered in detail in the section *The Device Parameter Box* from page 197 onwards.

The function **View > Parameters** allows you to switch the parameter box’s display off and on.

### 6.7 Special Functions

Below the parameter box are some more special functions. If you can’t see them properly, click the little triangle in the upper left corner of the parameter box to collapse it.

With devices that have a card slot for RAM or ROM cards, you can use the *Card* button to determine whether the card data should also be displayed in the Device window.

Most modules can recognize an inserted card either, during the Scan function or at any time (e.g. Korg M1), depending on the MIDI capabilities of the individual device.

The universal module displays up to four card switches. However, the function depends on the particular adaptation.
6.8 **Interactive On-line Help**

You can call up the interactive help by clicking the *Help* button which produces help messages relating to the device parameter box and the special functions. You can open the complete on-line Help by selecting **Windows > Help**. The contents of this Help window will then depend on the position of the cursor bar. The help messages contain information on the different data-types or special functions.

If there is no separate help message for the area concerned, the display will contain general information.

**Example:** open the interactive help and position it on the screen so that you can see the Device window entries. Click the different areas of the Device window to familiarize yourself with the interactive help system. If you want to open it as a floating window, see the section *On-line Help* on page 171.

6.9 **Dependency List**

Below the special functions you will find the dependency list. It tells you which other entries are used by the selected entry and which entries use the selected entry itself. If no entry or more than one entry is selected, the dependency list will be empty.

**uses:** this field displays the names of the entries which are used by the selected entry. If you select a parent entry (e.g. performance, multi or combination) the names of the child entries belonging to it will be shown here.
Chapter 6
The Device Window

used by... this field displays the names of the parent entries which use the selected entry. If you select a sound (or patch, voice, program) you will be able to see here which parent entries (multis, performances, combis), if any, it is used in.

If you click a name in the dependency list this entry will then be selected.

If the data type of the clicked entry is currently hidden, SoundDiver will automatically show this data type.

The memory location number is shown in the left-hand margin of each entry. If an entry has no name, its data-type name is shown instead (e.g. “Program Change Map”). You may have to adjust the width of the Parameter list to make this number visible.

When the dependency management is switched off, the dependency list is not displayed. Also see the section Dependency Management on page 399.

6.10 Local Menus in the Device Window

Entry

Load and transmit File...
For a description of this function refer to the section Loading for a Single Device on page 290 and the section Load and Transmit File... on page 288.
Local Menus in the Device Window

**Initialize**

You can initialize sounds, performances or other memory locations in the Device window. This function is equivalent to the “Initialize”, “Default” or “Voice Init” functions offered by some devices:

- select the entries that you want to initialize by clicking them;
- select Entry > Initialize—the relevant entries will be initialized and sent to the device.

ℹ️ The initialized entry will be written directly into the relevant memory location. You can undo the initialization by selecting Edit > Undo.

**Rename**

You can rename an entry by selecting it and selecting Entry > Rename. Type the new name in the text input field and then press ⇩ or click outside the input field. The new name will now be displayed and the entry will be sent to the device.

ℹ️ If you want to rename a whole group of entries in a row, instead of pressing ⇩ after you enter a name just press one of the cursor keys ↑ or ↓ which will make you jump to the next entry while keeping the text field open.

ℹ️ Renaming can be aborted any time by pressing ESC.

ℹ️ The number of characters available for entering the name depends on the device.

**Audition**

If you want to listen to a selected entry select Entry > Audition. This causes the data of the entry to be sent to the appropriate edit buffer, and providing the AutoPlay function is active, the sound will be played by the test note.

When you use the Audition function please note that none of the memory contents are overwritten. The only exception to this is ROM entries which don’t have an edit buffer (e.g. micro-Wave Waves). In this case the Audition function overwrites a
RAM memory location of the same type, but only after asking you whether it should.

Please also refer to the section *AutoAudition* on page 159.

**Edit**

This menu item copies the entry into an Edit buffer and opens the Editor window. For details refer to the chapter *Editing with SoundDiver* from page 295 onwards.

**Build Library**

This menu item is identical to its counterpart in the Setup window, although here it applies only to the active device. It creates a new library from the entries in the Device window.

Please also refer to the section *Build Library* from page 211 onwards.

**Save as...**

This menu item works the same way as *Build Library*, but saves the created library directly to disk once you have entered its name and path in the file selector.

**Export...**

This menu item works the same way as *Save as...*, but the file is saved either as a Standard MIDI File or as a SYX/MidiEx file. For further details see the section *Exporting Files* on page 282.

**Append to Library**

This menu item appends the selected entries to the active (the most recently selected) library.

*This function is especially helpful when you are receiving various banks from a device (e.g. because you want to convert the contents of several ROM cards or disks into a SoundDiver library):*
Local Menus in the Device Window

View

Parameters
This function determines whether the parameter box in the Device window should be displayed. If it is deactivated, the entire area of the Device window will be available for displaying the entries.

Link Windows
This function activates the link mode. In this mode the contents of the Device window are determined by the active device in the Setup window.

This function is identical using the link symbol—the settings are synchronized.

You will find an example in the section *The Link Function* on page 220

Next Device/Previous Device
These functions let you quickly select devices without opening the Setup window or creating various screensets. The order of selection is the same as the one you established in the Setup window’s list.

Note that as long as you hold down \( \text{[Option]} \) (\( \text{[Alt]} \)), only the title bar of the newly selected device is updated. As soon as you release the key the complete window contents are updated. This allows quick selection in larger setups.
Chapter 6
The Device Window

Data Types
With devices with a lot of data types (multis, voices, effects, pans…) you can easily get lost with a little scrolling. To alleviate this, you can hide certain or all groups of parameters.

The content of this menu item mirrors the structure of the device. The picture shows the menu for a Yamaha SY99.

Select the types you want to see and access.

At the top of the sub-menu, all data types are listed separately. At the bottom you can Show All or Show None.

If a Device window is completely empty or something is missing, take a look at this option first, and select Show All.

Select Data Type via Buttons
Display of data types can also be controlled with the buttons on the top of the window. You will find this feature only with devices which have more than one data type.

The buttons are sorted starting on the left with All, followed by a button for every single type. To select more than one type, click the buttons with the Shift key pressed.
Special
With some devices, the menu bar of the Device window contains another special menu with functions geared to that particular device. For example, with the Korg Wavestation you get another special menu whose functions are explained in the on-line Help.

Adaptation
In adaptations’ Device windows, you’ll find another local menu from which you can edit and save adaptations. More on this can be found in the chapter *The Universal Module* from page 379 onwards.

6.11 MIDI Functions of the Device Window

Requesting Entries
You can instruct SoundDiver to update the selected entries in the Device window by requesting the relevant data from the device.

Select one or more entries and select Edit > Request. You can also click the question mark icon above the device parameter box. SoundDiver requests the data from the device and updates the corresponding entries in the window.

This function is especially useful if you have altered the memory contents of a device on the device itself and SoundDiver is therefore no longer completely up-to-date.
Chapter 6
The Device Window

If you want to receive the entire contents of the Device window at once, you should first select Edit > Select all.

Transmitting Entries

You can transmit the selected entries to the device via MIDI. Normally this happens automatically, because SoundDiver works in the background to ensure that there is a constant synchronization between the contents of the devices and the contents of the window. If a device is not aware of a change in SoundDiver (e.g. because it has not been switched on), you can transmit the entries manually: select Edit > Transmit, or click the button with the exclamation mark above the device parameter box.

If you begin by selecting Edit > Select all, this option will transmit the entire contents of the Device window at once.
Warning: unlike the Audition function, the entries are written directly into the memory locations, and not into an edit buffer.

Requesting the Device Window Contents at Power-up

You can instruct SoundDiver to automatically request the memory contents of the installed devices at the start of the program.

Click-hold to the right of Auto Request in the device parameter box. A flip menu opens where you can determine which data you want SoundDiver to request:

- none: no entries
- I: Internal
- I+C: Internal + Card
- I+C+R: Internal + Card + ROM
- all: entire memory contents (including edit buffers)

SoundDiver will then automatically request the selected memory contents of the device whenever the program is started.

Remember that this can take a few minutes, depending on the device, and can therefore significantly lengthen SoundDiver’s start time, especially with larger MIDI setups.

You can dispense with this automatic request procedure by saving the contents of the Device window to disk before you quit the program. For more details refer to the section Save Device Entries in Preferences File from page 397 onwards.
6.12 Saving the Device Window to Disk

If you want to save the contents of the Device window to hard disk, you have two options:

- You can instruct SoundDiver to create a library containing all or part of the Device window, and save this to disk, or
- You can have the contents of the Device windows of all the installed devices automatically saved when you quit the program (refer to the section section Save Device Entries in Preferences File from page 397 onwards).

Saving the Device Window as a Library

To save the contents of the Device window in a library, either

- select Entry > Build library > Memory locations in the Device window’s local menu or
Saving the Device Window to Disk

- select the device in the Setup window and select **Entry > Build library > Memory locations** in the local menu.

SoundDiver then creates a new library containing the complete memory contents of the device. Only the edit buffers and the ROM entries are excluded. You can save the new library by selecting **File > Save**. You can also immediately select **Save as...** instead of **Build library**.

If you want to save specific entries, select them in the Device window and select **Entry > Build library > Selected entries** or **Entry > Save as... > Selected Entries** in the Device window.

---

Reloading the Device Window

If you want to reload the contents of the Device window that were saved to disk,

- load the library by either selecting **New > Load and transmit File...** in the Setup window or **Entry > Load and transmit File...** in the Device window, and select the desired library in the file selection box.

- After the entries have been transferred to the Device window, you will get a safety message asking if you really want to have them transmitted to the device.

---

Reloading Part of the Device Window

If you want to reload part of a library into the Device window,

- open the library by selecting **File > Open...** and select the desired library in the file selection box,

- switch off **Options > AutoAudition**,

- select the desired entries,

- select **Edit > Transmit**.

You can amend the target memory location for each of the entries in the dialog box which appears. If you want all the
entries to go to their original memory locations just click All. The entries are then automatically sent to the device.

For more details on the library functions refer to the section The Library from page 245 onwards.

**Saving the Device Window Contents Automatically**

By activating the option *Save Device Entries in Preferences file* in the preferences (opened by Options > Settings > Global Preferences), the contents of all installed devices are saved automatically to disk. Using the flip menu, you can additionally select which entries should be saved automatically. For further details refer to the section *Save Device Entries in Preferences File* on page 397.

If only the name of an entry is known, it is saved in the preferences, independent from the above settings. This way you see the names of the recent entries in the next session.

**6.13 Remote Control Adaptations**

Some Adaptations contain only one editor which does not correspond to a specific edit buffer of any particular device, but instead allows remote control or display of certain controls. We call these Adaptations “Remote Control Adaptations”.

As there are no dumps in Remote Control Adaptations which could be requested or transmitted, the display of a Device
window is not necessary. Therefore, opening the Adaptation from the Setup window does not open the Device window, but the Editor window directly, with initialized values. Examples include the provided “Mixer”, “Monitor” and “Roland Addresses” Adaptations.

However, there are also “normal” Adaptations which contain such a remote control editor (e.g. Dynacord DRP-15) in addition to their other editors. In this case, the Device window is opened as usual. When opening the “remote control” entry from the Device window however, it is initialized and opened without request.

Remote control of SoundDiver has nothing to do with these remote control adaptations. For more on this see the chapter Controller Assignments from page 329 onwards.
The Library

In this chapter you will learn how to use the library in SoundDiver to compile sound data banks. These data banks allow you to find and sort sounds and data in your MIDI system quickly and effectively.

7.1 What Is a SoundDiver Library?

A SoundDiver library is a file in which any SysEx data (e.g. programs, sounds, combinations, multis, effects and other data) from your MIDI devices can be saved, sorted and displayed from different perspectives.

The purpose of such a library is to enable you to compile a large collection of sounds and other data, allowing you to find the right ones immediately by sorting them using the appropriate criteria. You can then bring them up on the screen and transmit them to your MIDI devices.

In this respect, a library is similar to a database which you may use for filing addresses or book-keeping. In the same way that an address file will allow you to search through thousands of addresses and find the ones whose ZIP code begins with 4, you can search a SoundDiver library, instantly select all the sounds whose names contain “piano” and send them to the relevant devices.

Apart from the usual management functions, SoundDiver libraries offer some remarkable features:

- the size of a library is limited only by the RAM capacity of your computer. You can decide whether to use a few large
libraries or several small ones. For example, a library can contain thousands of sounds from different synthesizers or just the contents of a single Device window. Because you can exchange, copy and import the contents of different libraries, your collection of data can be compiled to suit your own requirements.

- SoundDiver allows you to compile mixed libraries. You can therefore store any data from different devices in a single library. So-called “Performances” from a Yamaha EX5, “Multis” from a Yamaha SY99 and “Singles” from an Access Virus could all be managed in the same library.

7.2 The Library Window

The library window contains three important elements:

- the library
- the parameter box for entries
- the link list
- the local menu bar

In the local menu bar you will find functions to help you with functions like displaying and sorting the library.
The library list itself is divided into a title bar which can be reconfigured, and of course the table of entries. For every entry there is a list of parameters which may be displayed in the parameter box.

Opening and Closing a Library File

You open a library file by selecting File > Open… and selecting a library file in the dialog box which appears. You can open several library documents at once and copy entries back and forth between these libraries.

To close the library file, select File > Close Library. If you have changed the library at all, a dialog box appears asking you whether or not you wish to save the altered library.

Refer to the section section The File Menu from page 143 onwards for more details on the management of library files.

- Closing a Library window does not close the file itself.
- -clicking the window’s close box closes all the library’s windows without closing the library itself.

Opening a Library Window

You can open a Library window by selecting Windows > Library. You can open several windows for the same library.

The title bar of every Library window contains the library name and—from the second window upwards—a serial number.

For example; you can bring up several sections from one library on the screen, or display the library in different sizes.
Chapter 7
The Library

Selecting Entries in the Library

In the section Selecting Entries from page 141 onwards you learned about the selection functions. These also apply in the library. Here is a brief summary:

- select an entry by clicking it; if you click it again while holding down \( \text{\textbullet} \) (\( \text{\textbullet} \)) the selection will be toggled;
- to select several entries, click them one after the other while holding down \( \text{\textbullet} \) (\( \text{\textbullet} \));
- to select a block, click the first entry, then while holding down \( \text{\textbullet} \) (\( \text{\textbullet} \)) click the last one;
- you can select blocks of entries within the library by clicking in the narrow column at the left edge of the library table and dragging a “rubber band” across the entries while holding down the mouse button. The entries within or touching the “rubber band” will be selected. You can select several blocks by holding down \( \text{\textbullet} \) (\( \text{\textbullet} \)) as well as after you have selected the first block,
- By clicking a title entry (see the section Insert Title from page 265 onwards) in the library while holding down \( \text{\textbullet} \) (\( \text{\textbullet} \)), all subsequent entries up to the next title entry are selected. This allows you to select blocks in a library very easily.
- use the Edit menu to select all entries at once, or toggle the selection;
in the library you can deselect all the entries at once by clicking in the narrow strip along the left or bottom empty area of the library table (if the latter is visible).

Selecting Child Entries as Well

In practice you will often want to cut or delete parent entries from the library along with their constituent child entries. To save you the effort of having to search through the library for the child entries, there is a key command you can use so that when you select a parent entry, the child entries that it uses are selected as well.

Just click the parent entry while holding down \( \text{cmd} \) (: ). The associated child entries will also be selected and “taken along” when you cut, move or copy the parent entry.

Whenever you cut or delete a parent entry along with its child entries, SoundDiver checks whether any of the child entries are used in other parent entries as well. If this is the case, you will be asked if you really want to delete the child entries. You can therefore avoid destroying the completeness of any other parent entries.

If you want to copy a parent entry with its component child entries, you simply select the parent entry. When you copy a parent entry the component child entries are always “taken along”, regardless of whether they are selected or not. You can always switch off this feature (see the section Dependency Management on page 399).

7.3 Mouse Operations in the Library

Apart from the general mouse operations (Mouse on page 128 in Chapter 4 SoundDiver’s User Interface) the library contains the following special functions:

• to move one or more entries within the library, select the desired entries and drag them with the mouse to another position within the same window. However, if you want to move the entries into a window of another library, hold down
(: ) while dragging, otherwise the entries will be copied.

• : If you click an entry with  held down, the **AutoAudition** setting is toggled. That’s helpful if you have activated **AutoAudition** but you now want to select an entry without transmitting it via MIDI, select it with the right mouse button.

### 7.4 Contextual Menu on Windows

When you click an entry with the right mouse button, this contextual menu appears. The following menu items are available:

- **Audition**: see the section **Audition** on page 263.
- **Edit**: see section **Edit** on page 264.
- **Cut**: see the section **Cut** on page 150.
- **Copy**: see the section **Copy** on page 151.
- **Paste**: see the section **Paste** on page 151.
- **Request**: see the section **Requesting Library Entries** on page 267.
- **Transmit**: see the section **Sending Library Entries** on page 267.
- **Hold Transmission**: see the section **Hold Transmission** on page 160.
- **Store sequence**: see the section **Store Sequence** on page 265.
- **Insert title**: see the section **Insert Title** on page 265.
- **Insert file…**: see the section **Insert File** on page 266.
- **Parameters**: see the section **Sizing and Hiding the Parameter Box** on page 260.
When you click on an empty area with the right mouse button, a shorter contextual menu appears, which consists only of the items **Paste, Hold Transmission** and the last three items.

### 7.5 Managing Libraries on Disk

You manage libraries on hard disk using the functions of the **File** menu, which are covered in detail in section *The File Menu* from page 143 onwards.

### 7.6 Creating a Library

There are several ways to create a library in SoundDiver:

- select **File > New** to open a new empty Library window in which to copy entries,
- select one or more devices in the Setup window and then select **New > Build library** in the local menu to automatically generate a library, using the memory contents of the selected devices,
- Create a new library and import libraries or banks from other programs. (see the section *Insert File* on page 266).

C-LAB Polyframe libraries can be loaded into a SoundDiver library using **File > Open**... This allows you to continue using your Polyframe libraries in SoundDiver. The conversion is automatic and SoundDiver retains the name of the old library. Polyframe Setup files (with the extension .PS) cannot be directly loaded into SoundDiver. Instead, load the Polyframe Setup into the respective Device window and save the whole Device window as a Polyframe library. SoundDiver can then read this library.

To import a Polyframe library, first rename it so that its extension is changed from .PL to .LIB. The file type has to be set to **EM9F** and its creator to **EM86**. See the section *Compatibility of the Windows, Macintosh, and Atari Versions* on page 83 for details.
All management functions for libraries are described in section *The File Menu* from page 143 onwards. Please refer to this section for more details.

### 7.7 Automatically Loading a Library on Start-up

If you are working in SoundDiver with one or more standard libraries, there’s no need to define special Autoload libraries. When you quit the program, SoundDiver remembers which libraries were open, and opens them again the next time the program is started. SoundDiver will be in exactly the same mode as it was when you were last working within it.

If your starting point is always the same library, you can rename it *Autoload* (Macintosh) or *AUTOLOAD.LIB* (Windows) and, if necessary, move it to the *Libraries* folder. It will then be automatically loaded on start-up.

### 7.8 The Layout of the Library Table

You are free to determine the look of the Library window. Using the mouse, you can determine the width of the parameter box, the relative widths of the library columns and the size of the display.

Taking advantage of the screensets, you can pre-define the various layouts of a Library window and switch between them as required. For more on the definition of screensets, please see section *Screensets* from page 139 onwards.

The library is displayed in the form of a table. The entries are arranged vertically, and can be sorted as you wish (See the section *Sort Functions* on page 255 for details).
The title bar contains all sorts of functions for determining the layout of the Library window. You can alter the order of the columns, switch out individual columns or alter their widths.

**Number**

Each entry has a numbered position in the library. This number has nothing to do with the memory position of the entry in a Device window, but simply defines where the entry is in the library. This is the reason why you cannot sort by number in the library.

**Altering the Order of the Columns**

To change a column’s position in the list, click-hold the desired column heading in the title bar: the mouse arrow becomes a hand. Drag the title field to the column’s desired position and release the mouse button. The column will be inserted there and all other columns will be moved correspondingly to the right.

**Altering the Widths of the Columns**

To alter the width of a column, move the mouse cursor to the right end of the column’s title: the mouse cursor becomes a double-arrow. Drag the column’s border to the desired position and release the mouse button.

If you hold the **S** during this operation, the next column’s width will alter correspondingly so that what you are changing is the border between the two. This function does not effect any of the other columns.

To make a column disappear, drag its right border as far as possible to the left.
Chapter 7
The Library

The View Menu

The local View menu is where you can hide/show the columns. Disabling a column in this menu is equivalent to setting its width to its minimum value. Enabling a column sets it to a width of 100 pixels; you are free to change this width using the dragging method described above.

To enable and disable columns, simply select them in the menu: the check mark shows their status.

It’s also possible to use the menu items Show All and Show None to determine the display of the entire table.

Example: there’s a whole range of columns visible, but you want to see the names and dates only. The simplest way is to use Show None followed by Show Name and Show Date, rather than disabling each column individually.

Size of Text

The zoom gadget can enlarge (lower half) or reduce (upper half) the font size.

With Windows > Larger view and Smaller view you can select the font size for a library window.

On Windows with the Microsoft IntelliMouse™ this can also be done by turning the wheel while holding down ⌃.

Zoom box: You use the little telescope symbol in the Library window’s upper right-hand corner to select the size of the text in the window. Click the left half of the zoom box to select a smaller size, and the right half to select a bigger one.

Select a small text size if you want to view as many entries at a time as possible. Bear in mind this makes them harder to read.

You can also make use of the screensets (see the section Screensets on page 139) to store your favorite displays and switch between them.
7.9 Sort Functions

A library’s entries can be sorted at any time by using SoundDiver’s range of simple and handy sort functions. It’s possible to sort according to most of the entry parameters, whether or not those parameters are currently being displayed.

A sort routine can be undone by selecting Edit > Undo as long as this is done directly after the sort.

SoundDiver can manage up to three sort levels, which are also stored in the library file. If you sort a library, the previous three sorting orders are memorized. A description with examples is shown in the section Sort Levels on page 258.

The sort functions are only available for the entire library, although a library can be divided into zones. This means that if you do a sort in one Library window, this will affect all other windows opened for the same library.

Sorting within the Title Bar

There’s a quick way of resorting the library: double-click the parameter in the title bar corresponding to the way you want the display to be sorted. This immediately sorts the display, and if AutoSort (section The Sort Menu on page 255) is enabled, the appropriate parameters will also appear underlined in the title bar.

The Sort Menu

The Library window’s local sort menu lets you select a sort criteria: the library is sorted as you select the menu contents. The Sort menu has one advantage over and above the title bar method of sorting, in that you can sort according to parameters that are not currently visible in the title bar.
Sort by Name
The entries are sorted alphabetically according to their names. This allows you to quickly find, say, all sounds beginning with “Strings”, no matter what their device.

Sort by Module
The entries are sorted alphabetically according to their module. This allows you to have a library display in which the entries are divided up into blocks determined by their respective devices.

Sort by Model
The entries are sorted alphabetically according to their model. The result of this sort is independent of the “module” criteria (e.g. “SD-1”, “SY77”, “VFX”).

Sort by Device ID
The entries are sorted by their device ID. If you are not familiar with this, take a look at the section Device ID on page 201.

If you have more than one device of the same kind in your setup, it’s easy to find entries in a certain device. Sort first by ID, then by entry name.

Sort by Data Type
The entries are sorted alphabetically according to their data type.

Example: in the table, EX5 Performances appear first, then EX5 Preset Voices, finally SY99 Voices.

Sort by Location
The entries are sorted by ascending order according to their storage location in your device.
Sort Functions

Sort by Size
The entries are sorted in ascending order according to their size in bytes.

Sort by Date
The entries are sorted in ascending order according to their date of creation. The earliest entries appear at the start, and the latest at the end of the table.

The library dates and times are shown in the local language’s format. It can be adjusted with the “Date & Time” control panel (Macintosh) or “International” control panel (Windows).

Sort by Comment
The entries are sorted alphabetically according to their comments. Giving a range of entries comments such as “Piano”, “Strings” or even “Studio” or “Live Set 07.07.2001” means they can immediately be found on demand.

Auto (AutoSort)
The entries are sorted according to last-selected sort criteria if anything was changed. Automatic sorting makes it easy to keep repeating the same sort after insert or cut operations.

To activate AutoSort, select Sort > Auto.

When AutoSort is active, the positions of the insert cursor or the target position for mouse operations are irrelevant. The only exception is if the library is divided into zones by title entries.

Undoing Sorts
Edit > Undo reverses the effects of the last sort, and allows you to toggle between the original and the last sort.
Sorting a Zoned Library

Inserting a title entry allows libraries to be subdivided into zones; this can be used for grouping sound banks, sounds for specific live sets, etc. This makes more sense than creating a new library for each grouping as sort and searches need only to be done once.

See the section *Insert Title* on page 265 for how to insert a title entry.

SoundDiver takes zones into account when sorting, and sorts them individually. This retains the relationship of the entries to their zones.

### Sort Levels

SoundDiver remembers the three last sort operations, and retains the results. With this feature you can sort within a group of entries with an identical criteria.

**Example:** Your library is sorted by date and you’re looking for a certain performance on the EX5.

Sort first by name, then by module and at last by data type. Look at the section EX5 performances, which is now sorted in alphabetic order.

After the sort by name, SoundDiver has listed the entries by module (you find all entries within the single devices sorted in alphabetic order). Now we have sorted by data type, so that it’s...
easy to find the section of performances and our desired performance by its name.

7.10 The Parameter Box for Entries

Each entry—no matter whether sound, effects program or multi—is saved with a range of parameters which help in the sorting and organizing. Some of these can be edited, such as the name of an entry.

Whenever you select an entry, you see its parameters in the box.

The parameter box's display always relates to the selected entries. If a particular parameter has different values among the selected entries, an asterisk (*) will be displayed instead of a value.

You can edit some of the parameters in the box. Editing will always effect all of the selected entries.

Adding Text to Multiple Entries

With this function identical text can be added to the names, comments or locations of more than one entry at the same time, without deleting the current text.

- First select all entries that are to be changed.
- Click on the parameter (e.g. name).
- Enter an asterisk (*) first, followed by the common text.
- Close the text field with $\mathcal{L}$.
Chapter 7
The Library

Sizing and Hiding the Parameter Box

The parameter box can be reduced in size by clicking the triangle in the upper left of the parameter box. Selecting View > Parameters allows you to switch the parameter box on/off.

Name

This line displays “No selection” if no entry is selected. If just one entry is selected, it’s name is displayed here.

If more than one entry is selected, the total number of selections is given, e.g. “35 selected”.

Clicking on the name line makes a text field open for renaming the entry. If more than one entry is selected, any alphanumeric input will affect all of them. The name of the first entry appears in the text field as a default.

To be able to edit the names of several entries one after the other, select the first entry, open the text field, type in the name, then move around the list using the cursor keys \( \text{↓} \) and \( \text{↑} \) to get to the next entry. The text field will remain open and doesn’t need to be reopened each time.

- You can use these two features to give all selected entries an additional identity. You can finish by giving each entry its own name.

- If you want to add some letters or words to entries, take a look at the section Adding Text to Multiple Entries on page 259.

- If you want to exit the field without making any changes, press \( \text{Esc} \).

Module

This line displays the module that created this entry. Clicking on this line produces an information window giving more details on this particular module.
Model
This line displays the model that created this entry. It cannot be edited.

A module can include several different models. For this reason, the model display serves to differentiate more precisely between the various devices that are served by the one module.

Device ID
This line displays the MIDI device ID of the device that created this entry. Broadly speaking, this is an identity number for SysEx data, allowing devices of the same model-type to be separately identified within a MIDI system. So, if you are auditioning a selection of entries to several identical devices (e.g. a TX816 containing eight DX7 modules), the device ID allows you to see to which device the current entry is being sent.

Example: if there are two EX5Rs in your MIDI system, the device ID differentiates between them.

Data Type
This line displays the data type of the library entry. It tells you whether the entry is a sound or a multi of an effects program.

Example: the Yamaha EX5 contains “Voices” and “Performance” data types; the Yamaha SY99 has “Voice”, “Multi”, “Synth Setup”, “Pan”, “Microtuning” and “Seq Setup” data types.

This parameter is not editable.
Chapter 7
The Library

Location
SoundDiver immediately notes the Device window location of an entry (sound, program) when it was copied into the library. This location appears in the library and is always included in all operations within SoundDiver.

- When a library entry which is to be transmitted has no location statement, SoundDiver uses a special strategy in order to guess the desired destination. See the section Default Destination Location on page 267.

- If you want to add some letters or words to the location, take a look at the section Adding Text to Multiple Entries on page 259.

Date
This shows the date of the entry’s creation. If you double-click the line, you can enter the date with the computer keyboard.

- When entering the values, use non-numerical characters to divide the year, month and day.

Time
This shows the time of the entry’s creation. Editing is carried out in the same way as the date. Odd-numbered seconds are not supported.

Size
This line displays the entry’s size in bytes. This size is not identical to the length of the actual SysEx message, as the modules optimize the amount of data by leaving out any parameter groups not being used.
Comment
Each entry can be given its own line of comment. As you can sort according to comments, groups can be created if their respective entries are given identical comments. To give several entries the same comment, select them all and click the comment line, a text field opens in which you can enter the text.

Giving entries that belong together the same comment (e.g. Piano, Strings, Solo) allows them to be quickly found again or sorted in the library.

If you want to add some letters or word to the location, take a look at the section Adding Text to Multiple Entries on page 259.

The Dependency List
The dependency list is described in the section Entry Dependency Management on page 218. It functions the same in the Library window, except that the memory location number is not shown.

7.11 Local Library Menu
The local Library menu allows you to send selected entries to the edit buffers for checking, playing a test sequence, inserting subtitles into the library or loading libraries that are on disk into the current library.

Audition
Selecting this menu item sends the selected entries to the edit buffers of the appropriate devices for auditioning.

As the entries are sent to edit buffers only, there is no danger that the AutoAudition operation will mistakenly over-write memory contents. The one exception is the sending of data for
which a device has no edit buffer. However, this is always preceded by a warning.

If an entry is a parent entry, i.e. it has child entries which belong to it—such as several Sounds belonging to a Multi—SoundDiver asks you in a dialog box whether these should be sent as well. If you select “All”, the parent entry and the child entries are transmitted.

To permanently store the selected entries in the device, just copy them to the Device window by dragging them across to the corresponding target position of a Device window or selecting Edit > Transmit.

**Devices with Individual Edit Buffers**

Some devices, like the ones with multi mode from Roland (D-70, JV-80/90/1000, JV-1080, U-20/220, XP-50/80) as well as the Waldorf MicroWave, offer separate edit buffers for the child entries used by a parent entry. SoundDiver can take advantage of this: when you Audition a parent entry (e.g. Performance or Multi), and some of the linked child entries (e.g. Patches or Sounds) do not yet exist in the device, they are not transferred to a memory location, as is usual for Transmit, but to the edit buffer representing the appropriate “Part”. The device then uses the data it finds in the part, even if the link in the parent entry might point to a completely different child entry in the device’s memory. This way, you can easily audition a parent entry residing in a library, without the need to overwrite memory locations in the device.

Also see the section Devices with Individual Edit Buffers on page 219 and the section Multiple Edit Buffers on page 314.

**Edit**

Library > Edit opens the Editor window of the entry.

If a Device window was already open in the background, it will initially be topped. If the window was already topped another will be opened.
The Editor window can be opened by a double click on an entry or by pressing \[.\]

**Store Sequence**

The test sequence recorded in SoundDiver’s mini-sequencer is assigned to the selected entries, allowing each entry to have its own suitable auditioning sequence, such as a chord for string sounds and a melody for solo sounds. To have this sequence play, activate the options **AutoPlay** and **AutoAudition**.

Entries which contain a sequence show an asterisk (*) in the **Sequence** column.

This operation is not available if you are using SoundDiver within AutoLink, as this automatically disables the internal sequencer.

This operation over-writes an existing sequence that’s already been assigned to the entry without warning.

**Delete Sequence**

The stored sequence is deleted for all selected entries. All asterisks (*) are erased.

**Insert Title**

This function lets you insert text at any location within the library. Select the entry above which the text is to be inserted and select Library > **Insert title**. This opens a text field for you.
Chapter 7
The Library

to type into. If you need several lines of text, you may select the menu item as many times as you like in a row.

The text can be later edited by first clicking on it in the Library window, then clicking on the text line in the parameter box, or you simply double-click on the title.

**Important:** these titles subdivide a library into zones—e.g. “Stage sounds”, “Studio sounds”, “SY99 working sounds” and so on.

To get rid of a title, select it and choose **Edit > Delete**.

You can select all the title entries in a library with the aid of the find function. Activate “More Options”, and use “The data type” “is” “Title” and “Select all”. If you need to find out how to operate the find function, please refer to the section **The Find Function** on page 268.

The zones are recognized by the sort routines, in that the relationship between title and entries remains safeguarded. SoundDiver will always sort entries within each zone individually.

**Insert File**

You can insert a library or imported file from floppy or hard disk into a SoundDiver library. This would allow you to make one big library out of several small ones. **Insert file…** is similar to **Import …** in the File menu, except that it doesn’t create a new library document.

Select the entry **before** the new library is to be inserted and select **Insert file…**. Now select the desired library from the selection box that appears. If this library is “foreign” (Polyframe, X-alyzer, Synthworks, etc.) it is automatically converted. You’ll find more details in the section **Importing Polyframe Libraries** on page 275.

This operation automatically inserts a subtitle before the new library, giving the name of the file. You are free to delete this title afterwards.

It is possible to use a Find function to look for title entries, by selecting “more options” and selecting criteria “The data-type” “is” “Title”. The search functions are explained in the section **The Find Function** from page 268 onwards.
7.12 Requesting Library Entries

If you select Edit > Request, this requests the internal memories of all the devices selected in the Setup window and inserts them in the library. (see the section Request from page 155 onwards)

7.13 Sending Library Entries

If you select the desired entries first and select Edit > Transmit, this sends the data to the devices whose IDs agree with those of the entries being sent. So, if you want to send eight DX7 voices to the eight modules in a TX816, you can use the device IDs to determine which voice goes to which expander.

For details regarding the converting of data between related devices (such as the DX7 and SY77), please see the section Device Selection Strategy when Sending from a Library from page 214 onwards.

Default Destination Location

When you transmit a library entry to a device with the menu item Transmit, SoundDiver uses the Location statement as a default destination value. When the safety message “Overwriting memory entries” is activated (see the section Overwriting Memory Entries on page 405), a dialog will appear which allows you to manipulate this default destination. Generally, you just have to confirm with 🗼.

If there is no location statement in the library entry, SoundDiver suggests the most suitable memory location to you:

- If an equivalent entry already exists in the Device window (i.e. it is identical concerning the data—the names are not compared), this entry is used as a target. In this case, no safety message appears. Otherwise, the next entry is suggested which has the following properties in descending priority:
• unknown and not used by other entries (not a child entry)
• known and not used by other entries (not a child entry)
• unknown
• known

This means that you can transmit an entire library without the need to adjust the destination positions manually, even if the library contains dependencies, but no location statements.

You can also easily fill up banks with sounds without overwriting already used locations. Simply select the desired entries in the library and select Edit > Transmit. SoundDiver now automatically writes them into locations which are not yet used by other entries.

7.14 The Find Function

One of SoundDiver’s most powerful features is the Find function; it allows you to conduct a targeted search for an entry through a zone within a library, a whole library or your whole MIDI system. This function is of particular use in the studio, where you often need to find a specific sound or a range of suitable sounds from within a large collection. Here are a few practical examples:

• Looking for all the string sounds within a group of selected entries
• Looking for a sound called “SuperBass” within all the opened libraries
• Looking for all the sounds that were created before 07.07.2001
• Looking for all the EX5 sounds in a library

Searching makes sense only if a library is present—so the menu item and the key commands Edit > Find... and Edit > Find again are only available when a library is loaded.
SoundDiver can conduct simple searches according to names or syllables, but can also make use of more complex criteria.

The Find windows looks different in the Macintosh and Windows versions. You will therefore find pictures of both in the following section.

**Opening the Find Window**

Select **Edit > Find...**

Macintosh

![Macintosh Find Window]

**Important:** the Find window is a real window, not a dialog box. The advantage is that it remains open during the Find operation to allow you to improve or change the Find criteria. You can even position the library and Find windows on the screen in such a way that you can see them both at the same time. The window positions and the Find criteria you have defined are stored by SoundDiver when you quit the program.

Windows

![Windows Find Window]
A Simple Find Operation

When you first open the Find window, all it contains is a text field and the buttons More options and Find. In this mode you can find entries by name or part of a name. The case of characters is ignored.

If you are looking for a character string at the beginning of a name in a library, you don’t even need to open the Find window: the Library window offers a quick method like the one you have already come across in the Device window, as follows:

- First enable Caps Lock by pressing the Y key (the one above the left S key).
- Simply type in the first character(s) of the desired entry’s name. SoundDiver immediately finds the first entry whose name begins with the characters you have typed.
- Use of T allows you to jump to the next entry alphabetically; TS jumps to the previous one.

Starting the Find Operation

Enter the desired text and click Find.

The search for names that contain those characters now starts in the active library, beginning from the selected entry.

The first entry to be found is selected. If AutoAudition and/or AutoPlay are active, the entry is immediately sent and/or auditioned.

If no name is found, a dialog box opens.

Repeating the Find

After the first Find, the Find button becomes Find again. Clicking it continues the operation for the next name. You can also select Edit > Find again.
If you make use of the key or menu commands, you are able to close the Find window to save screen space.

More Options
If you require more sophisticated Find criteria, click the Find window’s More options button. The Find window expands to display a range of flip menus that are used to define more complex Find criteria.

What
This flip menu allows you to define the main parameter that will be used as a Find criteria. You can define the entry’s name, model, data type, date, size, comment, location and “data” (see the next section).

Windows:

Find and select objects matching following condition:

- The Document contains [great sound]
- Search in all documents
- Select all

A selection of the entries found

Mac

Found:

Find and select objects matching following condition:

- The Document contains [great sound]
- Search in all documents
- Select all

A selection of the entries found

More Options

- What
- How
- Value to be found

More Options
Special Issues with the Criterion “Data”

This option appears nowhere else but in the Find window: it tells SoundDiver to compare the entry’s SysEx data. This allows you to find similar sounding sounds if a name search produces nothing useful.

This function cannot guarantee that the sounds it finds will be similar. If you alter a synth sound's basic wave form, it will sound completely different, though the corresponding SysEx parameter may have hardly changed.

It makes sense to use the “Data” operation in situations where you have created several variations (envelopes, filter) of the same sound, and now wish to delete those variations.

**Warning:** never use “Data” with “Keep first, delete rest” as this might delete entries you wanted to keep.

How

This flip menu contains the conditions that the “What” Find criteria must match for the entry to be found. The contents of the flip menu refer to the criteria selected under “What”.

Table 5 “How”-conditions

<table>
<thead>
<tr>
<th>Condition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>contains</td>
<td>contains the text entered</td>
</tr>
<tr>
<td>does not contain</td>
<td>does not contain the text entered</td>
</tr>
<tr>
<td>begins with</td>
<td>begins with the text entered</td>
</tr>
<tr>
<td>ends with (not date, size, contents)</td>
<td>ends with the text entered</td>
</tr>
<tr>
<td>is</td>
<td>exactly matches the text entered</td>
</tr>
<tr>
<td>is not</td>
<td>does not match the text entered</td>
</tr>
<tr>
<td>is before (date only)</td>
<td>was created before the date entered</td>
</tr>
<tr>
<td>is after (date only)</td>
<td>was created after the date entered</td>
</tr>
<tr>
<td>is less than (size only)</td>
<td>size is smaller than value entered</td>
</tr>
<tr>
<td>is greater than (size only)</td>
<td>size is greater than value entered</td>
</tr>
</tbody>
</table>
The Find Function

Comparison Criteria

The next four criteria do not search for a given example, but each compares two entries taken as a pair. This allows you to find, say, all sounds that have similar names.

Table 7 Comparison criteria

<table>
<thead>
<tr>
<th>Condition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>is equal to selection</td>
<td>selects an entry that is identical with one of the selected entries</td>
</tr>
<tr>
<td>is similar to selection</td>
<td>selects an entry that is similar to one of the selected entries</td>
</tr>
<tr>
<td>is equal in pairs</td>
<td>selects two identical entries</td>
</tr>
<tr>
<td>is similar in pairs</td>
<td>selects two similar entries</td>
</tr>
</tbody>
</table>

The Find Value

Depending on the contents of the first two fields, a text field appears (e.g. for names or comments) or a numerical field (for date or size inputs).

Selection of the Entries Found

This additional flip menu allows you to define what SoundDiver does with the entries it finds:
Select One
This deselects all previous entries, selects the first entry found and moves the window section correspondingly to show it. If AutoAudition is active, the entry is also sent to its device.

If no window is open for the current library, one will open automatically. Find again only makes sense here if you don’t change the Find conditions.

Select All
This selects all the entries found and deselects all previous entries.

Add to Selection
Those entries found are selected in addition to entries already selected ("logical OR").

Select in Selection
The search is conducted within the selection only. Only those entries found remain selected; all others are deselected ("logical AND").

Keep First, Delete Rest
This option exists only in conjunction with the comparison criteria (see section Comparison Criteria on page 273). If an entry is identical with, or similar to, one or more other entries, the first one found is kept and the others are marked as being ready for deletion by being showed “dimmed” (in gray).

The actual deletion takes place after the search operation is over, and only after you have responded to a warning prompt.

This function is particularly suitable when used in combination with “Search in all documents” and “The Data” “is equal in pairs”. The result then corresponds to the deletion of duplicates that might be spread across more than one library.
Importing from Other Programs

Search in All Documents
Activating this option conducts searches through all open libraries. When used with comparison criteria (see the section Comparison Criteria on page 273) each entry in each library is compared with each entry in each of the other open libraries.

Less Options
Click this button if all you want to do is search by name and don’t need the extra options.

Find
Click this button to start the search. After the first entry has been found the button’s caption changes to Find again. Click it or press F to initiate the next Find.

The menu item Edit > Find again … allows you to Find again even if the Find window is closed.

7.15 Importing from Other Programs
SoundDiver is capable of loading other programs’ files and converting them into SoundDiver libraries. This import function offers a range of options that make it easy to import files.

Selecting File > Import… opens a file selection box. Confirm your selection and SoundDiver will attempt to load it.

Importing Polyframe Libraries
When you import Polyframe libraries all the data is converted into the SoundDiver format. The only thing lacking is the link information because this is not available in a Polyframe library. You can generate links by copying the desired entries into a
Device window and copying them from there into a new library (see the **New** menu item).

To make SoundDiver on Windows see Polyframe libraries, change their file name extension from **PL** to **LIB**.

To make SoundDiver see Polyframe libraries, make them have the same file type as SoundDiver libraries. You can achieve this by assigning the file suffix **PL** to the file type **EM9F** in the “File Exchange” control panel which is part of Mac OS—however you can also use similar third party products.

Open the “File Exchange” control panel, click the “Add…” button, select the SoundDiver application file, enter “**PL**” in the text field at the top and select the SoundDiver library icon at the bottom. You can now insert an Atari floppy disk containing a Polyframe library, and it can be immediately loaded by SoundDiver.

### Importing Standard MIDI Files

Standard MIDI Files (SMF) can be written by most MIDI programs. SoundDiver can import Standard MIDI Files, containing SysEx dumps and either send them to the relevant device or convert them into a library.

### Conditions for the File

SoundDiver is able to read all MIDI File formats (0, 1, 2) and is therefore compatible with any sequencer, editor or other MIDI software that can create MIDI Files. All the sequences within a MIDI File are evaluated.

Standard MIDI Files use the **.MID** file extension.

Usually you will find this extension on the Macintosh too, although file name extensions are not common. The file type must be either “**Midi**”, or the file type must be “**????**”, “**BINA**”, “**MDOS**”, “**mdos**”, “**pBIN**” or “**TEXT**”, and the file must have the extension **.MID**. The “Creator” is irrelevant. (“**MDOS**” and “**mdos**” are the file types which are used by PC Exchange by Emagic SoundDiver.)
Importing from Other Programs

You can import SMF files either by selecting File > Open… or File > Import… or by selecting Load and transmit file… from the Setup or Device window.

You can also drag the SMF file icon onto the SoundDiver icon.

**How the Import Function Works**

Imported SMF files simulate incoming MIDI messages, so that the loaded data ends up in the relevant Device windows. It is therefore imperative that a device is present in the SoundDiver setup for which the accompanying module or adaptation can process dumps in the Standard MIDI File format.

The device ID is irrelevant however—it is not taken into account while importing files. This is very helpful when you have a file and you don’t know which device ID was used when the file was created.

If you have several devices in the setup which can process messages in the file, you should first select the desired destination device in order to prefer it. SoundDiver always tries to assign incoming MIDI data to the active device first, then to all others. As imported SMF/SYX files are internally handled like incoming MIDI, this preference technique works here as well.

Standard MIDI files which contain data from several different devices can be imported by SoundDiver in one operation.

When data has been found for a specific device while importing, the device’s Device window is opened so that you can monitor the imported data immediately.

After an SMF has been imported, you will either get a message that no data was recognized, or you get the following message,
Chapter 7
The Library

Abort
The imported entries remain in the Device window but nothing else happens. Warning: this will probably give rise to an inconsistency with the data in your MIDI devices.

Library
The imported entries are placed in a new library. You can then save it.

Transmit
The imported entries are sent to the devices.

After moving imported entries into a library, the previous entries reappear in the Device window. You don’t need to re-request the Device window contents after such an import operation. However, if you selected “Abort” or “Transmit”, you can undo the import: the menu item Edit > Undo is then named Undo Import.

Import of Files with Several Dumps for the Same Entries
If an SMF file contains several dumps for the same banks or entries, the following dialog appears:

Abort
The already imported entries remain in the Device window, the rest of the imported file is ignored.
Importing from Other Programs

Skip
All entries recognized as doubles are skipped. The remaining file is imported, except for duplicates.

New version
All entries recognized as duplicates are loaded and will overwrite previously loaded entries.

Library
All previously imported and all yet to be imported entries are moved into a new library, or appended to it. Afterwards you can save the library. The message “Do you want to transmit the loaded entries or move them into a library?” is omitted, to be consistent.

The latter option allows you to import huge amounts of data from different programs if they can save their data as Standard MIDI Files. Opcode’s Galaxy™ for example uses the “MIDI File Capture” function for this:

- Select the menu item “Start MIDI File Capture…” from the Play menu
- Open library, bundle and bank files to your heart’s content and transmit their entire contents.
- Select the menu item “Save MIDI File…” from the Play menu.
- Quit Galaxy™
- Start SoundDiver and select the desired devices in the setup window
- Import the Standard MIDI File in SoundDiver. When the above dialog appears, select “Library”.

Import from a Song File
You are even able to extract sounds from a sequencer song saved as a Standard MIDI File. As an example: you are working on a production that was created by someone else. The creator of the file has sent you the song as a MIDI File disk. The song
also contains the sounds of the instruments used. You can use the import function to load the song file into SoundDiver and send the sounds direct to the relevant keyboards. The remaining data is ignored.

**Unrecognized Dumps**

If the file to be imported contains SysEx dumps which cannot be processed by any of the devices installed in the Setup, you get the following message:

**Abort**

Aborts the file import.

**Install**

Opens the Install window. You can now install the suitable device. Afterwards, retry the file import.

**Generic SysEx**

Installs the Adaptation “Generic SysEx” and repeats the file import. This Adaptation can process any kind of SysEx messages.

Some devices provide a so-called “Bulk Dump” (or “All Dump”) which is the contents of several banks of different data types in one single SysEx message. This type of message is often not supported by the SoundDiver modules or adaptations. If you import a file which contains such a bulk dump message, you will get the above message, although the appropriate device is already installed in the Setup window. In this case, you should first import the file with “Generic SysEx”, transmit the data from there to the device and then request the banks with the dedicated module or adaptation directly from that device. Using this detour, the bulk dump is converted to single or bank dump messages which can be handled by the module or adaptation.
Importing from Other Programs

Importing SYX Files

SYX files (also known as MidiEx or SysEx files) contain the raw dump data in unencoded form. SoundDiver can import these files and either send them to the relevant device or convert them into a library.

Conditions for the File

SYX files use the file extensions .SYX, .MQX, .DMP.

- SYX files usually have the file type “BULK”. Files of this type can be opened directly with File > Open … If a SYX file has the file type “????”, “BINA”, “MDOS”, “mdos”, “pBIN” or “TEXT”, and the file name has one of the above extensions, they are detected by SoundDiver, however you have to load them using File > Import …

How the Import Function Works

Imported SYX files simulate incoming MIDI messages (like SMF files). Please remember the special conditions which apply; see the section Importing Standard MIDI Files on page 276.

- If you want to import a file but you don’t know its format it will probably be an SYX file. Alter the file name extension to .SYX and then try to import the file.

- SYX files can also be imported by simply dragging the file’s icon onto SoundDiver’s program icon.

Import Functions for Specific Modules

Some SoundDiver modules allow you to import certain file formats. You can convert these files with the menu item File > Import... into a SoundDiver library.

Format Recognition

Because some modules contain special import functions that can identify the format of the selected file, you may find that
SoundDiver will load several modules one after the other until the format is recognized. This operation is automatic and can take a little time to complete.

As soon as SoundDiver recognizes the data format, it creates a new library whose title is taken from the file name, and loads the converted data. The number of entries it contains depends, of course, on the number of entries in the original file.

**Data Format for the Import**

To find out what data format each module is capable of recognizing, use the On-line Help.

Select the desired device in the Setup window and select **Windows > Help**. That device’s On-line Help now appears. Click **Index** and select **Import** from the list that appears.

You can find this information as well in the "**SoundDiver 3.0 Model List.pdf**" file.

**Additional Information**

- If a file cannot be imported, a dialog box will open allowing you to ignore the file or abort the whole operation.
- When importing, SoundDiver will automatically delete any duplicate entries it finds.
- SoundDiver allows you to influence the order in which the modules are selected: simply select the device in the Setup window that is the one most likely to be compatible with the file to be imported.

**7.16 Exporting Files**

SoundDiver offers various options for exporting files. This is helpful if you work with programs from other manufacturers which don’t provide flexible means of data exchange, or if you want to give sound data to friends who don’t have SoundDiver.
You should use the export functions only if there is no other way. There are some restrictions in comparison to using SoundDiver libraries (see below).

**Exporting Standard MIDI Files (SMF)**

For the operation of the various export variations see

- the section *Export MIDI File…* on page 146
- the section *Capture as MIDI-File…* on page 147
- the section *Export …* on page 212
- the section *Export…* on page 234

SoundDiver writes a Standard MIDI File in format 0 (i.e. it contains only one track). The file does not contain tempo information which leads to a default tempo of 120 bpm, and the resolution is 96 ppq. This is the most commonly used format and should be compatible with every program which can read SMF.

The transmission duration of all MIDI messages is taken into account, which results in incrementing clock positions. The clock distance between two events is always at least one tick, even if it should actually be 0 because of the low resolution. This prevents the order of MIDI events from being changed by sequencers which have some kind of “intelligent” priority optimization.

Delays which are necessary for the correct transmission of dumps are recorded as well (i.e. converted into appropriate meta events which correspond to the delay at 120 bpm).

ℹ️: The files are saved with file type “Midi” as the standard designates.

ℹ️: When you load a MIDI file created by SoundDiver and set a tempo higher than 120 bpm, this can lead to problems when sending the data, as delays necessary for a correct transfer are shortened.

ℹ️: When SoundDiver creates a MIDI file which contains dumps for several devices, which are connected to different MIDI outputs of the computer; all dumps are contained in the same track. To make a sequencer able to send the loaded file correctly, you should “demix” the loaded events to separate tracks so that they can be sent to the correct outputs.
Chapter 7
The Library

Exporting SYX Files

For details see
- the section Export … on page 212
- the section Export… on page 234

Such files contain plain MIDI data without any formatting. There is no time stamp information, thus it can lead to problems if the file is transmitted with a generic utility like “MidiEx”. If delays are necessary for correct transmission you will get a warning message when you try to export a file in SYX format.

• The file is saved with file type “BULK”. This file type is recognized by freeware tools like “Bulk SysEx Utility” or “MIDI Pack’en”.

If SoundDiver needs handshake communication in order to send certain entries, you will get an error message. The reason is that the device does not reply with the required “Acknowledge” message (as SoundDiver’s MIDI output is redirected to the export file) and the SoundDiver module consequently thinks that the data has not “arrived” at the device.

In this case you should check if you can send the data without handshake communication (either in the special parameters or in a dialog box).

Otherwise use the function Capture MIDI File… (see the section Capture as MIDI-File… on page 147).

Finally you have to state the folder and file name for the file to be exported.

• It is advisable (but not required) to append a .mid or .syx extension to be able to recognize the format from the file name.

On Windows it is necessary to use the correct file name extension, as otherwise the file cannot be read by other programs.
Limitations with File Export

The data to be exported is stored in a temporary buffer in computer memory first, not actually sent out as MIDI messages. Known limitation: there must be sufficient memory. If you get a message “Out of memory”, you must save several small files instead of one large file.

You can also assign more memory to SoundDiver.

Questions and Answers on File Export

? When I save a single Multi A-01 from the MicroWave as a Standard MIDI File and try to re-import the file, the Multi appears in the edit buffer and not in memory location A-01. Why is this?

! Because the MicroWave does not provide SysEx messages to transmit a single Multi or Voice directly to a specific memory location. As a workaround, SoundDiver first transmits the Multi or Voice to the edit buffer and then a command “store the edit buffer to memory location xxx”. When importing this sequence of SysEx commands, the MW module ignores this “store” command (as the MicroWave never does send this command).

However, if you send the MIDI file directly to the MicroWave, the desired effect is achieved.

This problem occurs with all devices which do not support direct single dump messages or if you don’t save an entire bank.

If you have to import a MIDI file in SoundDiver for any reason, it should always consist of whole banks.

? When I save a parent entry in a MIDI file or a SYX file with Export... > Selected Entries, the dependent child entries are not saved, unless I select them explicitly. Why is this?

! Because the Transmit function does not do this either. Because of SoundDiver’s “WYSIWYH” concept, the manual Transmit function is only needed in exceptional situations. Thus you have to manually add the desired data to the file.
7.17 Converting the Sounds of Related Devices

Some SoundDiver modules are capable of converting sounds that come from different synthesizers. In most cases, these are related or older devices. For example; the JV-80 module can load the sounds of a Roland D-70 and convert them into JV-80 sounds. The SY77 module will do the same with DX7 sounds.

The on-line Help will tell you what conversions are available for your devices, and will give more information on the converting process, as follows:

Select the desired device in the Setup window and select Windows > Help. That device’s on-line Help will now appear. Click Index and select Conversion from the list. This is where you can learn all about what the conversion can do for that particular device.

7.18 Saving a Sound Bank as a Library

You can manage your devices’ sounds in libraries without losing their memory allocations.

- Select the desired device in the Setup window. You can also select several devices if you want to save their contents in a single library.
- Select New > Build Library from the Setup window’s local menu, and one of the sub-options. SoundDiver now copies
them into a new library. If needed, entries are automatically requested for this purpose. See section *Automatically Creating a Library* from page 213 onwards for more information.

💡 **Build Library** can also be found in the Device window’s local Entry menu—you don’t have to change to the Setup window. The difference is that this menu acts only on the entries of the current device, not all of the selected devices.

### Sub Menu

Use the sub-menu under **Build Library** for selecting the entries SoundDiver is to use for the library.

#### Editable Entries

The library is created out of all the device’s directly editable entries. This includes the Edit Buffers, as well as the entries in the memory locations that are directly editable, such as the Yamaha SY99’s Pan settings, the Multi-Setup of the Virus or the global setup of an Alesis DM Pro. In the broadest sense, this option stores the current state of the device thus allowing you to load it again later.

💡 Bear in mind that all the entries of some adaptations fall into this category, as the Edit Buffers cannot be directly addressed via MIDI.

The Entry Dependency Management is active here as well. If you write a parent entry that addresses child entries into the library, these child entries will also be included.
Chapter 7
The Library

Memory Locations
This option acts on all the memory locations including those of cards, but not ROM entries. This option is specially useful where you address all the sounds via a Program Change in the sequencer and don’t want to transfer Edit Buffers into the library.

All Entries
This option creates the library out of all the entries (except ROM). Select All Entries when you want to create an entire backup of the device including its edit buffers.

Selected Entries
Selected entries only (except ROM) are put in the library. It allows you to manually determine what the library is to contain.

Known Entries
This creates the library out of the entries already requested in the Device window. Use this option when you want to create a safety copy from a specific number of entries (e.g. just locations 1 to 30, just the Multis, etc.).

“Save as…”
This menu item in the Setup window’s local New menu works the same way as Build Library, but saves the created library directly to disk once you have entered its name and path into the file selector.

This option is also available in the Device window; it acts only on the entries of the current device.

Load and Transmit File…
You’ll find this menu item in the Setup window’s local New menu and in the Device window’s local Entry menu.
It allows a library to be loaded from disk and directly sent to the appropriate device(s). If you have used \textit{Create Library} to make a copy of all or part of the memory contents of your Setup, \textit{Load and transmit File...} retrieves them again.

If you select a number of devices, only the entries of those devices will be accepted.

\begin{itemize}
\item Strictly speaking, \textit{Load and transmit File...} is a macro that loads a library without opening a window, selects everything, sends it all to the device(s) and then closes the library again.
\item Library entries that are blank in the location field are copied as usual to the next available location. If the Preference \textit{Safety message overwriting memory locations} is active, a dialog box appears so you can select a different target.
\item If a library contains several entries for the same memory location, only the last one is processed.
\item The selection in the Device window is extended by all the loaded entries. If you deselect everything first you will instantly be able to see any changes.
\item The process may be aborted using \textit{Edit > Undo}. \texttt{Undo} undoes the load.
\item After you have loaded a library, you are asked if you want to transmit the loaded data to the corresponding devices (except with MIDI Files; see below). This prevents you from overwriting the devices’ memory by accidentally loading the wrong file.
\item If you click “Cancel”, the data in the devices won’t match the data in the computer, so be warned!
\item With MIDI Files, SoundDiver first checks to see whether they contain data suitable for any of the installed devices. If they do not, a warning message appears.
\end{itemize}
Loading for a Single Device

Load and transmit File… is also found in the Device window’s local Entry menu. If you use this menu command, the process is limited to the current device only.

Example: after completing a production, you have made a safety copy of your entire sound palette in the form of a SoundDiver library, and now wish to load the sounds of just the Oberheim Xpander for a new production. In this situation select Load and transmit File… from the Xpander’s Device window. The other devices’ data will be ignored.

Importing Different Formats

You can also use the Load and transmit File… function to import foreign file formats and Standard MIDI Files. The contents of the loaded files are likewise sent to the appropriate devices.

For details on importing SMF files, please refer to the section Importing Standard MIDI Files on page 276.

What’s more, the Load and transmit File… function as usual limits its action to the current device when it’s loading from a different format into the Device window.

Sending Entries from the Library

If you select an entry in the library and select Edit > Transmit, the data will be sent to the memory location given under memory location.

Changing the Location

If you want to copy a library entry to a memory location that differs from the one stated in the location field, simply drag it with the mouse to that position. By using this method you can explicitly specify the new target location, so that the location field in the library is ignored. If several entries are copied this
way, the entries that come after it are copied to the subsequent locations.

**Deleting the Memory Location Assignment**

Sometimes it is specifically not desirable for SoundDiver to take into account an entry’s location field when using the Transmit function. This, for instance, is the case when you generate a universal, large library from many different sound banks. In this case you can delete the location field:

- select the library entries whose locations you wish to delete
- click the Location parameter in the Parameter Box and delete it with the delete key. This deletes the location numbers of the selected entries in the library.

If you finish by sending the entries from the library to the devices, SoundDiver distributes the entries according to their positions in the library.

**Example:** let’s assume that you want to send five sounds from the library to a synthesizer, where they are to occupy locations 24 to 28.

Here, you have to select the entries in the library and select Edit > Transmit. In the resulting dialog box select location “24” and then click the All button. SoundDiver sends the five sounds and places them one after the other in the device, starting with location 24.

**The Edit Buffers**

Entries that have no location number are assigned an “E” in the library and are transferred back to the appropriate Edit Buffer in the device. This means you can make a complete backup of the entire memory contents—including all the Edit Buffers—in SoundDiver.

You have to manually insert the “E” in older libraries. To do this it’s best to use the Find function:
Select More Options.
Enter the condition “The location”, “is” (keep empty)
Select the option Show all.
At this point all the entries without location numbers are selected. Click the location parameter in the Parameter box and enter “E”.

7.19 Practical Examples for Libraries
Here are two examples designed to show you just how useful libraries can be in your day-to-day work.

Instantly Saving Sounds for a Production
Let’s assume you are working on a production and want to save the memory contents of all your devices for later reloading, because you now have to start work on a different production:

- in the Setup window select all the devices you are using,
- select New > Save as... > Memory locations,
- save the library that appears using the name of the production,
- you can now start your next production; in other words, you are now free to alter the memory contents of your devices.

When you’re ready to continue working on the original production,

- send the library in the Setup window with New > Load and transmit file...
- After you have answered a safety question, you should be back where you left off.
Archiving Layered Sounds

Let’s assume you have created a layered sound by combining several devices and now you wish to save it:

- Create a new library with **File > New** or open an existing library,
- copy all of the entries from your various devices that make up the layered sound into this library,
- if necessary, zone-off this group of entries from the others using a title entry.
- To store these entries back in the devices, select them — this is accomplished very easily by **⌘-clicking** the title entry above — then send them using **Edit > Transmit**. To audition the sound without permanently storing the entries in the devices, select the local menu’s **Library > Audition**.
- You can also select entries from different models of the same type of device.
Chapter 7
The Library
Chapter 8

Editing with SoundDiver

In SoundDiver, you can do more than just organize your sounds—you can edit them directly on your computer’s screen.

8.1 General

Since SoundDiver contains modules and adaptations for more than 500 devices, most of which have at least one editor, not all of the special functions can be adequately described in a single manual. This manual therefore describes SoundDiver’s general editor functions, common to all of its editors.

The general form, operation and basic options are identical in all SoundDiver editors. You therefore only need to learn how to use a SoundDiver editor once, and you can then operate all of them.

If you still have questions relating to the special functions of a device or you want to get more precise details about the options available in an editor, you can make use of the information provided by the on-line Help.

The special functions, options and features of the different editors are individually described in the relevant Help window. This ensures that if there are any alterations, improvements or expansions of the modules and adaptations, the instructions remain relevant by way of updated Help text files.
For example, this is a page of the on-line Help for the Yamaha EX5. As you can see, the on-line Help contains detailed information on the specific devices.

### 8.2 Opening the Editor

To select an entry for editing either:

- double-click it in the Device or library window;
- select an entry in the Device or library window and select **Windows > Open Editor**;
- select an entry in the Device window and select **Entry > Edit** in the local menu;
- select an entry in a library and select **Library > Edit** in the local menu.
If the contents of the entry to be edited are not known yet, a dialog box appears giving you some or all of the following options, depending on the situation:

- cancel the operation;
- initialize the entry. The initialization data is then sent to the device, and the editor is opened with this data;
- request the entry from the device first.

Sometimes there will be no data available for an open Editor window. You will then get a message saying “(Data unknown)”. You can receive the editor data by selecting Edit > Request or initialize it with Edit > Initialize from the local menu.

**The Overview**

If an editor provides several views, SoundDiver opens a new editor window in overview mode. The overview allows you to see all of the function areas of your device at once. With synthesizers, this gives you a very good indication of the sound-generating structure, such as the most important parameters of the elements like volume or pan and so on. Since with many devices it’s not possible to view all the parameters at once, the overview gives you a very convenient way of selecting the area you want to edit.

Say you want to edit the AWM parameters of the EX5 sound shown in the diagram. Click the AWM box in the overview, and a detailed display of the AWM appears.
To switch back to the overview:

- select **View > Overview** from the local menu;
- ⌘: click the relevant button in the Editor window.

The overview and the detailed display act like a two-level zoom function. You can alternate between the overview and the detailed display and so quickly target the desired parameters. When you toggle between the two, your position in the overview map is retained.

If the entry you are editing only contains a few parameters, there will be no overview. This is often the case with simple effects programs or multi patches. By contrast, other editors are so complex that they are arranged in three levels (e.g. Roland D-70 drums).

### 8.3 The Easy Page

One part of the overview contains macro parameters for making coarse alterations to the sound without having to go into too much detail. These alterations, which are known as Easy Page, always affect the entire sound. Say you want to use the Easy Page to alter the filter frequency in an EMU Morpheus, all the elements are available here. If you want to alter the filter frequency of an individual sound component, you can do this in the detailed display.
When you alter a parameter in the detailed display, all the Easy Page parameters are reset to 0.

Double-clicking a parameter takes you straight to the relevant section of the detailed display.

In certain modules, more buttons are available to open additional Editor windows.

**Example:** At the detail view of the Roland VM-7100/7200, there are little buttons in the EQ-section that open another window.

### 8.4 Navigating the Editor Window

You can picture the editor as a large street map, on which all the parameters are laid out. The Editor window shows you one section of this map, which you select using the various navigational functions.

Switching between the overview and the detailed display was covered in the previous section.

You can access areas outside the editor window using the scroll bars. The parameters of a program component—what makes up a sound—are usually arranged horizontally.
Chapter 8
Editing with SoundDiver

Using the lower scroll bars of the editor to move from left to right, you can follow the signal path of the device or the structure of a combination, performance or multi-setup.

The diagrams show the parameters of an element of a Yamaha EX5, and beneath the parameters of a performance in a Yamaha SY99.

SoundDiver arranges other elements vertically. The x/y scroll gadget in the bottom left corner of the window allows you to move quickly in any direction around the map.

On Windows you can also right-click with the middle mouse button at any location of the window.
8.5 Selecting the Parameter to Edit

If a parameter has the flashing cursor on it, this means it can be edited.

You can either click the parameter directly with the mouse or move the cursor in any direction using the arrow keys, in which case the window section automatically moves as well.

Clicking an object moves the window view to allow the whole object to be seen. The window view won’t be moved if the object is already in full view or is too big for it, as happens with very big objects like the vertical keyboard table in drum editors.

The description of the parameter is seen:

- when holding the mouse pointer over an object without moving it for a moment. A little window (ToolTips) shows the parameter’s name, and the current parameter value. For parameters which have names for the various values (such as wave forms), also the value name is displayed.

   This function may be disabled. Take a look at the section ToolTips on page 403.

- On the info line of the Editor window (Macintosh) and on the status line (at the bottom of SoundDiver’s main window) on Windows.

Parameter Help

If you want to know the precise function of an individual parameter, click it and select Windows > Help, and the Help window will appear with a description of the parameter.
You can leave the Help window open and as you click the different parameters, the Help message will automatically change accordingly. It’s a good idea to open the Help window as a floating window by:

- selecting the menu item **Options > Help always in foreground** in the help window on Windows or
- ⌘: by holding down ⌘ while opening the help window.

**Cursor Position**

SoundDiver always stores the cursor position, even if you move the window into the background or recall a different screenset.

**MIDI Thru Channel**

Some modules automatically update the MIDI Thru channel in certain editors when you select a parameter. This function is available in most multi-editors to enable you to play the edited part.

This function is currently not available in Adaptations. To audition the edited parameter, change the MIDI Thru channel manually.

### 8.6 Editing Parameters with the Mouse

The editing of parameters was covered in the section *General Operation* from page 128 onwards, but the editors contain some
additional functions. For example, you can edit parameters using knobs. For the sake of the Overview, here is another description of the various methods available for editing parameters.

**Using the Mouse as a Slider**

To set parameter values directly with the mouse, click-hold the number. You can then alter the value in either direction by moving the mouse vertically.

Apple: This function is called *mouse as slider* and may be switched off in the Preferences.

**Using the Mouse to Decrement/Increment**

If you have deactivated the *Mouse-as-slider* option in the Preferences, the mouse will function as a decrement/increment key on a synthesizer.

Clicking increases the value, ⌘-clicking decreases it. If you simultaneously hold down ⌘, SoundDiver alters the value in units of ten.

Click-holding will continuously alter the value.

**Flip-menus**

You can select from a collection of presets or named values—such as wave form names or switch settings—with the help of flip-menus. Most flip-menu objects are marked by a “bevelled” surface and (if space allows) by a downward-pointing arrow on the right side.
Chapter 8
Editing with SoundDiver

Mouse Operation
By clicking a flip-menu object, the flip-menu opens. There are two options available:

• when opened with a short click, the menu is closed by another click;

• when opened by click-holding the mouse button, the flip menu closes when the mouse button is released again.

: if you hold down after opening the flip-menu with this option, the menu stays open after you release the mouse button. The menu closes when you release both and the mouse button.

Important: don’t hold down until after you have clicked ( -click selects the next level up of parameter groups, see below).

By moving the mouse pointer on the menu, you select a value. If the mouse pointer is located on a value when the menu closes, this value is chosen for the flip-menu object.

Display
If the flip-menu contains more values than will fit in one column, it is shown in multiple columns. If the screen is not wide enough to show all necessary columns, a horizontal scroll bar appears at the bottom edge. Otherwise, a number of lines is chosen so that there are as few empty lines as possible in the last column. As a side effect this often results in a number of lines which corresponds to the numbering scheme, e.g. when selecting an entry in a bank.

Windows: Keyboard Operation
On Windows, there are some additional options

• Instead of clicking in a flip-menu object, you can also move the flashing cursor on it and press .

• In opened flip menus, you can select the desired value with the cursor keys. If necessary, the menu scrolls automatically.
Editing Parameters with the Mouse

- As soon as the desired value is selected, finish the selection with `RETURN`.
- If you click a flip menu by mistake, press `ESC` in order to close it without changing a value.

**Editing a Flip-menu Object without a Flip-menu**

If you click a flip-menu object while holding down `OPTION`, it will not be opened. Instead you can set the value using "Mouse as slider". With `OPTION`-double click, you can enter value with the keyboard.

**Editing with Graphic Objects**

To alter a parameter using its graphic display, click-hold it. Depending on the type of parameter...

- …you can set the value using a knob whose position may be altered by vertically moving the mouse.

  ![Knob](image)

  Holding down `OPTION` gives you a higher resolution: moving the mouse pointer two pixels alters the value by 1. This is particularly useful for small knobs with a large value range.

- The slider works in a similar way to the knob—you alter the value by pushing the mouse up and down.

  ![Slider](image)

- Horizontal sliders work exactly the same way, but you move the mouse horizontally.

  ![Horizontal Slider](image)

  With sliders you can also make fine value adjustments by simultaneously holding down `OPTION`.

  The numerical value of a graphical object is operated just like a numerical value object. :: This applies particularly to “mouse-as-slider”.

---

**User Manual**

Version 3.0

305
Chapter 8

**Editing with SoundDiver**

**Envelopes**
Envelopes may be graphically edited by dragging the points in the desired direction. Any alterations will be reflected in the numerical display.

Depending on the structure of the envelope, the point may be moved in one or both directions. With some envelopes there are restrictions on where the point may be positioned. This is due to the structure of the envelope (e.g. with the Yamaha EX5).

Points lying outside the rectangle of the envelope’s graphic display are indicated by a small arrow. Such points may be edited by clicking the arrow.

**Keyboard Window**
For many synthesizers, note ranges on the keyboard can be defined. These are often displayed graphically next to the numerical representation.

You can change the limits of the defined ranges simply by dragging with the mouse. For some devices, only a portion of the possible 128 keys is shown, in order to save space. In this case, simply click the left or right border to define the respective limit.
If the device does not allow the “high key” to be less than the “low key”, the latter is automatically moved appropriately when the high key is edited, and vice versa.

However, there are also devices which allow this situation, e.g. Yamaha EX5. This often defines a “filter”, i.e. two ranges are defined: from key C-2 to the “high key” and from the “low key” to key G8. This is shown appropriately in SoundDiver.

**Keyboard Velocity Windows**

A variant of keyboard windows will show additional information regarding velocity range. SoundDiver shows such keyboard velocity windows as a keyboard with a rectangle above it. The range displayed by the rectangle depicts the defined keyboard range in the x axis and the defined velocity range in the y axis. Horizontal and vertical guide lines make orientation easier.

Besides the typical operation possible for keyboard windows, you can drag all four corners of the rectangle with the mouse to simultaneously change the keyboard and velocity limit.

As with keyboard ranges, some devices don’t allow the “high velocity” to be lower than the “low velocity”. Again, SoundDiver moves the affected limit automatically. The above mentioned comment regarding “keyboard range filters” also applies to keyboard velocity windows.
Chapter 8
Editing with SoundDiver

8.7 Inputting Values via the Keyboard

**Number-input Mode**

Parameter values may also be entered directly via the numerical keypad. The number keys 1 to 9 are normally used to switch between SoundDiver’s different screensets, while 0 starts the sequencer. You can bypass this by

- enabling the “Num Lock” key command; this is normally the \[~\] (\[\^\]) key—this key is also labelled with “Num.”;
- activating “Num Lock” in the preferences.

This function is also known as “NumLock”.

If number-input mode is active this is shown in SoundDiver’s info line on the Macintosh (Windows: status line):

\[\^\]: This message appears in all windows with an info line.

Please note that any pause between the individual digits should be less than one second. Negative values should be preceded by _. Here too, any pause should not exceed one second.

Pressing \[~\] (\[\^\]) again will switch number-input mode back off. The current setting of number-input mode is saved in the Preferences.

**Text Input Box**

If you don’t want to use number-input mode—if, for example, you often switch between screensets—just double-click the parameter. A small window then appears in which you type the desired value, and press \[\] to confirm.

If the cursor is already placed on the object to be changed, the input box can also be opened with \[\].
In the text input box there are many ways to enter a value.

If the parameter has only subsequent integer values or note names, the possibilities are identical to those in Emagic’s Logic Audio:

- decimal input: 0, 1, 2, 123
- hexadecimal input: $1, $2, $0A, $7F
- note values like “C3”, “C#3”, “Cb3”, “C##2” (corresponds to D3), “Dbb2” (corresponds to C2)
- add a value to the previous one: “+5”, “+$10”
- subtract a value from the previous one: “−5”

To enter an absolute negative value −x, enter “0−x”

- add two numbers: “38+17”
- subtract two numbers: “38−17”
- multiply two numbers: “7*8”
- divide two numbers: “80/5”

For all other parameters, you can enter any kind of text. SoundDiver will select the value which is most similar to the entered text.

Example: the available parameter values are

- Hall 1
- Hall 2
- Delay
- Pan-Dly

Entering “2” will select Hall 2; “del” will select Delay, and “dl” will select Pan-Dly.

Increasing or Decreasing Values

To increase or decrease a value in single steps, press □ or □. Simultaneously holding down □ makes SoundDiver alter the value in units of ten.

To input a negative value, first press □ (initially, the value decreases by 1) and then enter the amount.
Names
In many data types, an editable name belongs to the parameters. It is often shown in the upper left corner of the editor window. Click on one of the characters, and the cursor is shown as a flashing rectangle (instead of a frame). Apart from the cursor keys, the following makes input easier:

- entering a character advances the cursor to the next character
- \(\text{Alt}\) deletes the entire name
- \(\text{Ctrl}\) deletes the character to the left of the cursor and moves the rest by one position to the left
- \(\text{Alt+Del}\) (\(\text{Ctrl+Del}\)) deletes the “cursored” character and moves the rest by one position to the left
- \(\text{Ins}\) inserts a space on Windows.

\[\text{The insert and delete commands work only in editors of modules, not of adaptations.}\]

8.8 Inputting Values via MIDI
Many parameters reflect specific MIDI values like notes, velocities, controller numbers etc. In many editors you can directly input these values (not adaptations). This function is called “Listen to MIDI”.

Place the cursor on the parameter, hold down \(\text{Alt}\) and play the MIDI event on the keyboard. For example, in a multi-editor you could directly define the key range of a part by hitting the lowest and highest keys, or you could set the breath controller as the modulation source by holding down \(\text{Alt}\) and blowing.

Parameters which allow such an input are marked with this symbol:
8.9 AutoPlay

If AutoPlay is active, the built-in sequencer automatically plays the test sequence in Cycle mode with each value change, (no matter whether by mouse, keyboard or MIDI input). With AutoLink, the sequencer plays from the left locator for the period set under AutoPlay duration.

With drum editors, the edited note is played instead for the period set under Drum AutoPlay duration (this does not apply to adaptations).

8.10 Edit Button

Certain flip-menus display the names of other entries (cross-reference). For example, flip-menus in a parent entry will display the sounds of the devices.

If the name of an entry is as yet unknown, only the storage location number is displayed.

There will often be an edit switch next to it. If you click this, the corresponding editor will open. This simultaneously deactivates the Link function in the old and new windows. With some parameter values the edit switch will be deactivated (gray). In this case, first select a user RAM location.

8.11 Contextual Menu in Windows

When you click a parameter group with the right mouse button, it is selected (if not yet selected), and a contextual menu appears. The following menu items are available:

- **New window**: see the section More than One Editor Window on page 312.
Chapter 8
Editing with SoundDiver

- **Cut**: see the section *Cutting a Parameter Group* on page 317.
- **Copy**: see the section *Copying a Parameter Group* on page 317.
- **Paste**: see the section *Pasting a Parameter Group* on page 318.
- **Initialize**: see the section *Initialize* on page 326.
- **Randomize**: see the section *Randomize* on page 323.
- **Link Window**: see the section *Link Window* on page 324.
- **Overview**: see the section *The Easy Page* on page 298.
- **Request**: see the section *Request* on page 155
- **Transmit**: see the section *Transmit* on page 157.
- **Hold Transmission**: see the section *Hold Transmission* on page 160.
- **Compare**: see the section *The Compare Function* on page 319
- **Store**: see the section *Store* on page 320.
- **Store in...**: see the section *Store in...* on page 320.
- **Snapshot**: see the section *Snapshot* on page 321.
- **Parameters**: see the section *Parameter* on page 324.

When you click an empty area with the mouse button however, a shorter contextual menu appears which does not contain the menu items which only apply to parameter groups.

### 8.12 More than One Editor Window

You can open several editor windows for a single entry, one of which could show the Overview, another, the filter envelope.
If several windows are open for a single entry, all of the windows will show the parameters for that entry, but in different displays. Any alterations will always be shown in all windows where the relevant parameter is visible.

Please note that displaying the alterations in several windows always increases the time the program takes to react to any input.

8.13 The Edit Buffer

The SoundDiver editor needs to copy data into an Edit Buffer which corresponds to the one in the device itself. You can therefore see the available Edit Buffer in the Device window. The entry which you are currently listening to or editing is marked with a small “E”. The E also determines the current mode (e.g. performance, patch, multi, single mode) of the device.
This small E—which is assigned to only one entry per device—tells you whether an entry is directly editable, i.e. it is an edit buffer: only in this case will it appear when you click an entry. Certain memory locations are also directly editable.

**Multiple Edit Buffers**

When you double-click an entry, SoundDiver searches for a suitable Edit Buffer and copies the sound into it. For some devices, there is more than one edit buffer for certain data types, e.g. the Roland JV-1080’s eight “Performance Temp. Patches”. You can decide which edit buffer SoundDiver is supposed to use in such cases, either by manually copying the entry into the desired edit buffer and double-clicking this, or by clicking the desired edit buffer before opening the edit buffer by double-clicking the entry to be edited.

Also see the section *Devices with Individual Edit Buffers* on page 219 and the section *Devices with Individual Edit Buffers* on page 264.

**MIDI Thru**

Remember that the MIDI Thru function for the Edit Buffer can be intelligently dealt with by modules (not by adaptations): whenever you change Edit Buffers, it is automatically set to this value so that you can listen to this buffer. This only works if the relevant multi or global setup data of the device is available, because this is where the required channel information stems from.

**8.14 Remote-control and Monitors**

Adaptations representing remote-controls or monitors for MIDI devices or functions initialize the Editor window as soon
as you open it (MIDI monitor, MIDI mixer). This is because these editors cannot start from known settings in the device.

The same applies to devices with no Edit Buffer, or whose contents cannot be sent via a MIDI dump, here too SoundDiver has no start points for parameters and so it is best to begin with a neutral setting.

Remote control editors are very similar to Logic’s Environment or Cubase’s Mixer Map.

SoundDiver 3.0 Controller Assignments are a very complete way to remote-control all parameters. More on this can be found in the section Controller Assignments on page 329.

8.15 Undo Edit

Like anywhere else in SoundDiver, you can reverse the last edits made in the editor (Undo function).

Select the menu item Edit > Undo Parameter Change. Selecting the item a second time undoes the previous parameter change etc.

Of course, if you use the Undo function by accident you can reinstate the edit by selecting Edit > Redo Parameter Change.
Chapter 8
Editing with SoundDiver

The “Undo” and “Redo” functions are nearly unlimited. The number is only limited by the system memory (RAM). Depending on the last operation, this could take a lot of memory. Therefore the earliest step is deleted when no more memory is available. In this case—only the most recent steps in the chain can be reproduced.

If there’s not enough memory for SoundDiver to perform an operation and other measures did not work (e.g. deleting unneeded modules and adaptations), SoundDiver will erase steps until memory is available.

8.16 Clipboard Functions in the Editor

If the editor was supplied by a module (not by an adaptation of the Universal Module), you can select parameter groups within the editor and then copy or initialize them, as well as many other functions.

Selecting a Parameter Group

To select a parameter group, click the gray area within the parameter group or hold down and click a parameter from this group. Use the latter method if you can’t see the gray area within the parameter group.

The parameter groups in SoundDiver are organized into a hierarchy. For example, you can select an entire tone (element or voice) or a single envelope, an LFO or an effect or any collective sound components as a group.

To select a parameter group from further up the hierarchy, click a point that belongs to this higher parameter group but not to a lower one. For example, in an oscillator or partial hierarchy, click between the individual function groups (envelopes, filters etc.).
Clipboard Functions in the Editor

There is usually a list of the parameter groups in the Help file.

The selected group will be inverted. The above diagram shows a completely selected group of parameters for the “Pitch Envelope Generator” on the left and on the right the selected “Time” parameters for an EX5 synthesizer.

To deselect a parameter group, just click an individual parameter or the background.

Clipboard Functions for Selected Groups

The following three operations apply to the clipboard. These functions (cut, copy and paste) are also universally applicable to different windows or entries. For example, you could copy the filter envelope from the EX5 “Piano” sound onto the filter envelope of the EX5 “Strings” sound.

Cutting a Parameter Group

Select a parameter group and select Edit > Cut.

The parameter group is copied into the clipboard and initialized.

If you just want to initialize the parameters without copying them into the clipboard, select Edit > Initialize.

Copying a Parameter Group

Select a parameter group and select Edit > Copy.

The values of the parameter group are copied into the clipboard and may then be pasted somewhere else.
Pasting a Parameter Group
Select a parameter group and select Edit > Paste.

The contents of the clipboard are pasted to the selected parameter group, providing they are compatible. For example, you couldn’t copy the filter envelope from an Virus into the effects settings of the EX5.

Drag-and-Drop
Rather than copying a parameter group using copy and paste, it’s much quicker to use the Drag-and-Drop function. While holding [Shift], grab a selected parameter group with the mouse and drag it to another position which could even be in a different window. When you release the mouse button the values of the parameter group are copied to the target position. If the mouse pointer goes outside the edge of the window, the window section automatically moves with it so you can even drag the parameter group to a target position outside the visible window section.

Deleting a Parameter Group
Selecting the Edit > Clear menu initializes the parameter group, usually setting the parameters to zero or default settings.

8.17 Local Windows in the Editor Menu
The editor window contains local menus with various options for working with the editor.

The Edit Menu

Undo
see the section Undo Edit on page 315.
Local Windows in the Editor Menu

Redo
see the section *Undo Edit* on page 315.

Cut
see the section *Cutting a Parameter Group* on page 317.

Copy
see the section *Copying a Parameter Group* on page 317.

Paste
see the section *Pasting a Parameter Group* on page 318.

Clear
see the section *Deleting a Parameter Group* on page 318.

Request
see the section *Request* on page 155.

Transmit
see the section *Transmit* on page 157.

The Compare Function
Often when you are editing a sound, you can get to the stage where you can’t tell if it’s any better than the original.

SoundDiver therefore contains a function which is similar to the compare function on a synthesizer.

Select *Edit > Compare* from the local menu of the Editor window. The message “Original version” appears in the info line.

If the menu item has a check mark by it, you hear the original version. By selecting *Compare* again, you call up the edited
Chapter 8
Editing with SoundDiver

The info line on the Macintosh (Windows: status line) then reads “Edited version”.

An alert box appears if you try and edit the original version.

If you click OK, you discard the edited version and continue working on the original. If you mistakenly try to edit the original version, press Cancel to quit the function.

**Store**

Select this menu item when you want to save the result of your editing. The edited version overwrites the original one, which is thereby lost. This function corresponds to the “Write” or “Store” function of a synthesizer.

The memory location of the source entry is shown at the end of the editor window’s title bar. If the source entry comes from a Library, the title bar reads “—Library”.

This option is the quickest way of updating your work.

If you just want to keep a copy of the edited version, it is better to use the Snapshot function (see below), because you can create several versions and you don’t have to overwrite the original entry.

**Store in…**

If you want to save the edited version in a different location without closing the Editor window, select Store in.... This function is the same as Store, except that a dialog box opens where you can enter a different location.

To do this, open the flip-menu in the dialog box by click-holding it and select a different location.
If any entries are used by a parent entry (e.g. performance or multi) you will be alerted by a check mark to the right.

**Snapshot**

SoundDiver allows you to save the current stage of your edits whenever you like. When you create a snapshot, the contents of the Edit Buffer which you are working on are added to the library called **Snapshots**. If this is not available, SoundDiver will

- automatically create it;
- if available on disk, load it.

The snapshot function is extremely useful in the following situations:

- you like the result of your editing so far and you want to keep it;
- you have several variations of an edited sound and you want to find the best one;
- you are using the randomize function and want to save as many versions as possible.

When you quit SoundDiver the snapshot library is automatically saved in the **Libraries** folder. If this is not available, you will find the snapshots in the “Libraries” folder.

**Creating Snapshots Automatically**

In the Preferences (Options > Settings > Global Preferences) you will find the **Automatic Snapshots every x s** option. Here you can define a number of seconds. At these regular intervals, SoundDiver creates a snapshot and adds it to the Snapshot Library. For details refer to the section **Auto Snapshot Every x s** on page 398.
Chapter 8
Editing with SoundDiver

Autostore Dialog
SoundDiver automatically tries to prevent you from accidentally losing your edits. This is done with the aid of the Autostore dialog.

It appears whenever:

- you close an Editor after editing a sound;
- you are about to overwrite a memory location and the Overwrite memory Entries option is active (in Options > Settings > Safety Messages);
- you are about to overwrite an Edit Buffer which has not yet been saved and the Overwrite edited Entries option is active (in Options > Settings > Safety Messages);
- the target position (when moving or copying) does not match the type of the entry which you are about to add.

You have the following options:

**Don't store**
- closes the Editor window without storing the edits.

**Cancel**
- takes you back to the Editor.

**Store**
- stores the edit.

If the edited entry originally came from a Library there are more options:

**Entry in Library “library name”**
- replaces the original entry

**Add to the Library “library name”**
- adds the edited entry to the end of the Library and leaves the original intact.
If you have already closed the Library the first option is not available. SoundDiver will then give you the option of adding the edit to the active Library.

**Initialize**

This function initializes either a group of parameters or the entire entry.

First you need to select the parameter group to be initialized. For more details refer to the below section *Clipboard Functions in the Editor* on page 316. If there is nothing selected in the editor, the whole entry is initialized, which means that SoundDiver resets all the parameters to their original values.

**Randomize**

SoundDiver can create random values for selected parameter groups, and so provide inspiration for new sounds or introduce unforeseen variations.

This means that every parameter in the parameter group is assigned a random value.

If nothing is selected—some editors allow you to select the entire entry—all parameters of the entire entry are set to random values. This produces results that are always original although not always usable.

Remember the hierarchical structure of the parameter groups?

You can edit anything from the entire sound down to a single envelope with the random function.

**Find Controller Assignments**

If a parameter is marked (i.e. the cursor is flashing around it), this function opens the Controller Assignment window and selects all Controller Assignments which use this parameter as the destination. See the section *Finding Controller Assignments* on page 338.
Learn New Controller Assignment

This function defines a Controller Assignment to the active parameter.

First click the parameter, then select Edit > Learn new Controller Assignment.

If you use the key command for this function, and then keep on holding down the modifier key(s), you will get a ToolTip, which explains the subsequent steps.

See the section Learn Mode on page 345 for details.

The Local View Menu

Parameter

The parameter box is hidden when this option is active. See the section The Device Parameter Box on page 197 for details.

Link Window

When this option is active, SoundDiver automatically changes the contents of the Editor window whenever the active device or the active edit buffer changes.

This way you can quickly switch between the different Edit Buffers of a device, by simply clicking them in the Device window.

If AutoAudition is switched on, a clicked entry is immediately displayed in the Editor window and is simultaneously sent to the device. This is particularly useful when you are searching through a mixed library.

If you want to simultaneously display more than one editor, deactivate this option before opening the next window.

This option is also available as a button if the parameters are shown.
Overview
Use this to switch off the Overview display described above. Of course, you can also switch back from the Overview to the street map.

New Window
This is especially useful: select a parameter group and then select View > New Window from the local Editor menu. A new Editor window opens with the parameter group in the visible section. For example, you could “lift out” the amplitude envelope from the current editor, and continue editing it in its own window. Of course you can then alter the size and sectional position of the window.

- The “Link Window” function is automatically deactivated in the old and new editor windows.

- By holding ⌘ (⌘) while selecting New Window, the new window will be opened as a floating window.

Other Local Menus
Some editors have other local menus.

Adaptation
This menu appears with adaptations. They are used to define and alter editor objects. There is not enough space here for a detailed description of the available functions, which are covered in the SoundDiver Universal Module Programming Manual. You can download this manual free of charge from our web site http://www.emagic.de.

Of course there is nothing to stop you from experimenting to your heart’s content, but you’ll have more success with the help of this programming manual. Here’s a small tip: the “Layout mode” plays a key role…
Chapter 8
Editing with SoundDiver

Range
Some editors have a local Range menu with sub-functions for editing tuning or velocity tables. These are described below.

Full Range
In the editor there are two parameters which set an upper and lower limit for the range which is to be edited. These could be notes or velocities.

The Full range function sets this range to include all values in the table.

Initialize
initializes the values within the range.

Mirror Vertically
The values within the range are inverted: the new value = maximum – old value.

Mirror Horizontally
The values within the range are pivoted around the middle of the range: the first value is exchanged with the last, the second with the penultimate, etc.

Interpolate
There is a linear interpolation between the first and last values in the range, producing a straight line.

This is useful for creating 1⁄4 or 1⁄8 tone tunings: for example, set the range to two octaves (say C2 to C4). Set the value of C2 to C2 and the value of C4 to C3. Now select “Interpolate” and you have quarter-tone tuning.

Extrapolate
The values within the range are continued below and above the range.

Emagic
326
SoundDiver
This means if you set the tuning for just one octave you can instantly transfer it to all other octaves.

Other Menus
Other menu titles vary depending on the respective module. To find out what they mean, consult the module’s Help file.

8.18 Closing the Editor Window

If you close the editor window without saving your work first, a dialog box appears. Here you can select whether to save the edit (and where) or whether to discard it.

The options are:

Don’t Store
the Editor window is closed without the changes being saved first. The Edit Buffer remains intact, and you can copy it manually in the Device window to a desired location (remember to hold down (⌘)(⌥) , otherwise the Edit Buffer will be exchanged with the storage location: see the section Exchanging, Moving and Copying Entries with the Mouse on page 228).

Cancel
the Editor window is not closed

Store
the Edit Buffer is stored in the given location, and the window is closed.

When an editor is closed that was originally opened from a library, the options are:

- Entry in Library xxx replaces the original entry
- Append to Library xxx appends the entry to the end of the designated library, while retaining the original entry.
8.19 Recalling Editor Window
Contents in the Next Session

When you quit SoundDiver while an editor window is open, it is shown empty at the next SoundDiver session, and the message “No data” is displayed until you select an entry for editing by requesting, initializing or copying an entry into the editor.

If you want to let SoundDiver automatically re-establish the contents of the window, select all in the preferences option Save device entries in preferences file. Also see the section Save Device Entries in Preferences File on page 397.
Chapter 9

Controller Assignments

Using the Controller Assignments, SoundDiver can associate incoming messages to any parameter object inside an Editor window.

This allows you to completely remote-control parameters and to design sounds very comfortably.

The connection between incoming MIDI messages and a SoundDiver object is done in the Controller Assignments window.

9.1 What’s a Controller Assignment?

The flow of MIDI messages and internal processing is shown in the following diagram.
First Example of a Controller Assignment

Let’s say you have a Motor Mix connected to the computer, set up SoundDiver accordingly and defined some Controller Assignments, including one that controls the LFO Speed in the EX5.

If you now move a slider at the Motor Mix, it sends a controller message ①. SoundDiver then searches for the matching Controller Assignment ② and localizes the parameter controlled by it. The controller message is converted into a parameter change event ③ which changes the value of the LFO Speed ④. The corresponding parameter change message is now sent to the device (here an EX5) via MIDI parameter change message ⑤. At the same time, the Motor Mix’s LCD will show the name and current value of the controlled parameter which is done by SysEx commands ⑥. Thus, you even don’t have to watch the computer screen.
However if you change a parameter at the Editor window, SoundDiver also searches for the matching Controller Assignment and transmits display update and motor fader feedback messages to the Motor Mix as well as the parameter change message to the EX5.

As you see, there are always two parts fixed in the Controller Assignment window:

- the incoming, controlling MIDI message and
- the Controller Assignment made to a device and its parameter.

Changes made at a device or inside the Editor window are sent back to the fader box, so that the value and the fader box’s motor fader are in sync. SoundDiver takes care of this on its own.
Controller Assignment Features

A Controller Assignment is a connection between any incoming MIDI message and an Editor object. So two actions are needed to define a Controller Assignment:

- defining the incoming controller message on which SoundDiver should react and
- defining the controlled parameter.

SoundDiver gives a lot of flexibility in the assignment process, because different Controller Assignment messages can be assigned to a single parameter. As an example, a parameter with many possible values may be controlled by a fader for coarse control, by an encoder for fine control and by two buttons for single increments and decrements.

On the other hand the same MIDI message can control multiple parameters. For example, you may use a slider to control the filter cutoff of all Tones or Partial.

There is no limit to the multitude of Controller Assignments. Create them via drag and drop, manually or using the Learn function (see the section Learn Mode on page 345). Controller Assignments can be made for parameters of the Easy Page, as well as of the detailed view in an Editor window.

Controller Assignment messages are even processed if the device is not the active one or no Editor window is open which contains the controlled parameter—except you have enabled the option Requires Editor window (see the section Requires Editor Window on page 344).

Fader Box Modules

For some fader boxes, there are dedicated SoundDiver modules which offer advanced features with Controller Assignments:

- automatic labelling of the active Controller Assignments in the fader box’s LC display
What's a Controller Assignment?

- Motorized fader feedback: Changes made inside the Editor window (which may also originate from a received parameter change message) are sent back to the fader box, so that the parameter value is in sync with the position of the fader box’s motorized fader. This also works for encoders with LED ring, motorized rotary knobs, backlit buttons etc.

- While remote-controlling a parameter, the fader box’s display shows the current parameter name and/or value. Therefore, you don’t have to watch the computer screen when using the fader box.

- Easy definition of Controller Assignments with drag-and-drop (see the example below).

- Easy searching for Controller Assignments which are defined for a certain controller.

For more details, see section Fader Box Modules from page 348 onwards.

If you don’t have a fader box which is supported by a SoundDiver module, you still can use Controller Assignments. See the section Learn Mode on page 345.

Example for Creating a Controller Assignment

This example will show you how to use Controller Assignments, and especially the benefits of Drag-and-Drop creation which is only possible with fader box modules. You don’t need one of the supported fader boxes, however you need a device with a controller (modulation wheel, fader, knob etc.) that is sends MIDI messages.

- Open the Editor window of your device with detailed view (an EX5 in this example).

- Install device “Motor Mix” manually in the Install window (manufacturer “CM Automation”).
Chapter 9
Controller Assignments

☐ Open the Setup window. Now you have to set the MIDI input and output ports manually (this has to be done manually, as the Motor Mix does not support the Scan function). If you don’t have a Motor Mix, set the MIDI ports of the above mentioned device.

☐ Open the Editor window of this device by double-clicking on the “Motor Mix” icon in the Setup window.

☐ Open the Controller Assignment window using Window > Open Controller Assigns.

☐ Place all three windows on the screen as depicted.

☐ Now click and hold a fader of the Motor Mix (the mouse changes to a plug) and drag it to a parameter of your choice inside the Editor window of the device. You will see a connection cable while the mouse button is held. Objects which can be connected will be inverted when the cursor passes
over them. Release the mouse button while the mouse pointer is above an object.

- In the Controller Assignments window you will see a first entry, that shows the name of the fader to the left, with the name of the assigned parameter in the middle, and with the corresponding MIDI message displayed on the right.

If you have a Motor Mix, you get instant gratification: move the fader, and the parameter changes. Change the parameter with the mouse, and the fader moves.

Otherwise you have to change the (MIDI in) message, so that the message of our device is accepted.

- Click the button Learn Message beneath the parameter box and when its color turns blue, move the controller of your device.

- Finish by clicking the button Learn Message again. The button returns to gray.

- Now turn the knob or fader of your device and it will control the chosen parameter.

### 9.2 Terminology

To make SoundDiver’s Controller Assignments easy to understand, we use the following terms:

**Controller Assignment**
As already mentioned, this is a record which defines the remote control of a parameter.

**Fader box**
A device which transmits MIDI messages and thus initiates a Controller Assignment. A fader box may also be any type of MIDI keyboard, as also the modulation wheel or even the keyboard may be used for Controller Assignments.

**Controller**
A control on a fader box which generates a certain MIDI
message. This may be a slider, rotary knob, button, encoder, jog wheel, ribbon controller etc.

Controller message
The MIDI message generated by a controller. Often a controller message contains one or more variable bytes. SoundDiver does not only support Control Change messages (Bx xx xx), but any type of MIDI message, including SysEx. A controller message may consist of multiple MIDI message (e.g. subsequently MSB and LSB Control Change messages).

Incoming value
The value which is transmitted within an incoming controller message.

Resulting value
The value which is calculated from an incoming value using various calculation, based on properties of the Controller Assignment and the controlled parameter. The resulting value will become the new value of the controlled parameter.

Controlled parameter
A parameter in a SoundDiver editor which can be controlled by using a Controller Assignment.

9.3 The Controller Assignments Window
The Controller Assignments window looks a little bit like the Library window and consists of two parts:
• the data section with all the Controller Assignments and
• the parameter box.
The Controller Assignments Window

The Data Inside the Controller Assignments Window

The Controller Assignments window opens with `Windows > Open Controller Assigns`.

As there is only one table, there is only one Controller Assignments window, too.

Handling of Controller Assignments

Controller Assignments are treated as all objects that can be edited in SoundDiver are.

Controller Assignments are selected by the usual operations. Take a look at the section `Selecting Entries` on page 141 if help is needed.

Double-clicking a Controller Assignment opens the Editor window and marks the parameter controlled by the Controller Assignment.

All steps can be undone using the `Undo` function (see the section `Undo…` on page 148) and you can cut, copy, paste and clear all Controller Assignments at the usual way (see the section `The Edit Menu` on page 148).

The Local Assignment Menu

The local `Assignment` menu has three items.

`New`

This submenu offers several options to create new Controller Assignments.

- `Empty Assignment`
  
  This allows you to insert a new blank Controller Assignment above the first selected one.

- All other menu items are used to create Controller Assignments for remote control of the Controller Assignment Set.
Chapter 9
Controller Assignments

For details see section *Predefined Controller Assignments* from page 353 onwards.

**Show controlled parameter**

SoundDiver opens the corresponding Editor window and marks the parameter. Double-clicking will do the same.

**Learn Message**

This item is the same function as using the button inside the Controller Assignments window (section *Learn Mode in the Controller Assignments Window* from page 346 onwards).

**Finding Controller Assignments**

As you can create as many Controller Assignments as you like, there will be a lot of them, so a means of locating them is provided.

Controller Assignments can be searched from “both sides” and within the Controller Assignments window.

- Double-clicking a controller in the Editor window of a fader box opens the Controller Assignments window, and selects all Controller Assignment(s) associated with the control selected.

- In an Editor window, click a parameter which is controlled by the desired Controller Assignment, and select Edit > Find Controller Assignments. The Controller Assignments window will open, and all Controller Assignments associated with the parameter are selected.

- In the Controller Assignments window, click a Controller Assignment, and you can view all parameters which make up the Controller Assignment, including the controlled device and parameter, as well as the Controller Assignment message and the MIDI input where it must be received.
Parameters of a Controller Assignment

The Parameter box can be hidden/shown with View > Parameters.

Name

The name at the top is the name of the controlled parameter. It is for information only, and displayed in the list. When a new Controller Assignment is created, SoundDiver enters the name of the controlled parameter as a default.

The name can be edit as a text field by opening it with a double click. All text editing functions are available (take a look at the section Entering Text on page 132).

Adding text to more than one Controller Assignment can be done by first entering an asterisk (*), then the text to be added (see section Adding Text to Multiple Entries on page 259).

Input

The controller message has to arrive at this particular MIDI in port, unless it is set to “any”.

SoundDiver assigns the port automatically, when the controller message is defined by the Learn function.

To define the port manually, click the parameter and select the desired port from the flip menu (see the section Out Port and Input on page 198).

Message

This is a pattern of the MIDI controller message recognized by the Controller Assignment. All values are displayed in hexadecimal.

Two special bytes may occur in the pattern: Hi7 (for “highest significant 7 bits”) and Lo7 (for “lowest significant 7 bits”).
Chapter 9
Controller Assignments

How the incoming value and its value range is calculated depends on which of these special bytes occur in the message:

- If both \( \text{Hi7} \) and \( \text{Lo7} \) occur, the incoming value is \( \text{Hi7} \times 128 + \text{Lo7} \), and the value range is 14 bits (0 to 16383 or \(-8192\) to 8191, depending on whether the format is unsigned or signed).

- If only \( \text{Lo7} \) occurs in the controller message pattern, the incoming value equals \( \text{Lo7} \), and the value range is 7 bits (0 to 255 or \(-128\) to 127, depending on whether the format is unsigned or signed).

- If the incoming message pattern does not contain \( \text{Hi7} \) or \( \text{Lo7} \), the incoming value gets a default of 1, and the value range is 1 bit.

You can use this feature if the incoming message generated by a pressed button does not send the value 1.

Using the Learn mode (see the section Learn Mode on page 345), SoundDiver enters the incoming message pattern while it is recorded.

You can copy the MIDI message between Controller Assignments using the clipboard.

The format of the message uses the terms “\( \text{Hi7} \)” for MSB and “\( \text{Lo7} \)” for LSB parts of the message. This prevents the mix up of the Controller events MSB and LSB.

If a controller sends only the MSB portion of a control change message, you should use the Lo7 byte, so that a 7-bit scaling can be done.

**Lo7 min/Lo7 max**

These two parameters limit the accepted value range of the Lo7 byte. Only if it is inside the range, the message is recognized for this Controller Assignment. Use this feature if a fader box uses the same message for two controllers, but with different parameter ranges.
If the value of the incoming message is constant (e.g. for buttons), then you can simply enter the value in the message instead of $Lo7$. In this case you don’t have to adjust $Lo7\ min$ and $Lo7\ max$.

**Format**

This parameter defines the method how the incoming value is retrieved from the bytes of the incoming message represented by $Lo7$ and $Hi7$:

- ***Unsigned***
  - the value is always treated as positive.

- ***2’s complement***
  - If the most significant bit is set (at $Lo7$ this is Bit 6; at $Hi7$/ $Lo7$ this is Bit 13), the value is handled as a negative value with 2’s complement format.

- ***1’s complement***
  - If the most significant bit is set (at $Lo7$ this is Bit 6; at $Hi7$/ $Lo7$ this is Bit 13), the value is handled as a negative value with 1’s complement format.

- ***Sign Magnitude***
  - If the most significant bit is set (at $Lo7$ this is Bit 6; at $Hi7$/ $Lo7$ this is Bit 13), the value is handled as a negative value. The remaining bits contain the absolute value.

**Factor**

The factor defines a value that the incoming value is multiplied with before it is computed to the resulting value, depending on the mode (see below).

When *direct* mode is used, the factor may define a constant resulting value. Using *relative* mode, the factor can modify the scaling and polarity.

It is also possible to state a negative factor. Together with *relative* mode you can define Controller Assignments which decrement a parameter by one, by entering $-1.00$ here.
Chapter 9
Controller Assignments

The resolution is \( \frac{1}{100} \). This allows you to adjust the resolution of encoders. If an encoder works too fast, simply set the factor to 0.5.

**Mode**
The mode parameter defines how the incoming value is converted to the resulting value.

*Direct*  
the incoming value directly defines the resulting value.

- Use this option if the message is generated by buttons (so the message does not contain variables), and the controlled parameter has discrete, nonlinear values (e.g. LFO wave forms). Which value is actually chosen can be determined by the *Factor* parameter (see section *Factor* on page 341).

*Scaled*
the incoming value is scaled from its value range to the controlled parameter’s value range.

- By moving or turning the controller to its maximum position, the controlled parameter will also get its maximum value, and vice versa for the minimum.  
  Use this option only for controllers which have minimum and maximum value, e.g. sliders and rotary knobs.

*Relative*
The incoming value is added to the parameter’s current value (or subtracted from it, see the section *Factor* on page 341).

- You should use this setting for rotary encoders, and for buttons which are meant to increment or decrement the value by a certain amount.

**Device**
This field defines the device for which the Controller Assignment is valid.

- If the value is set to *any*, the Controller Assignment message is always sent to the cursored parameter of the current device (if an editor window is active and a cursor is flashing).
The value **Controller Assignment Set** means that the Controller Assignment does not control a parameter in a device, but the current Controller Assignment Set. For details, see section *Remote Control of Current Controller Assignment Set from page 352 onwards*.

**Data Type**

Selects the data type for which the Controller Assignment is valid.

If *Device* is set to *any*, data type is always *any*, and can’t be changed.

For *Device* set to *Controller Assignment Set*, this parameter does not have a meaning.

**Entry**

This is the entry for which the Controller Assignment is valid.

You can set it to *any* to allow the Controller Assignment to always apply to the currently edited entry. If *Device* or *Data Type* is set to *any*, Entry is also set to *any*.

The value *any* allows you to define a Controller Assignment which depends on the current edit buffer. This is useful for multi-timbral devices with separately addressable edit buffers, like the Roland JV-2080: you can create a Controller Assignment which alters the first Tone’s filter cutoff in a Patch. Which Patch of the 16 “Performance Mode Temp Patches” is meant depends on the current edit buffer.

For *Device* set to *Controller Assignment Set*, this parameter does not have a meaning.

**Memory Offset/LS Bit**

These two parameters define the controlled parameter within an edit buffer. The numbers don’t tell much, as they depend on the edit buffer’s internal data structure. As they are automatically set by drag-and-drop and the *Learn* function, this should not matter.
Chapter 9
Controller Assignments

The reason why they are shown here is that you can set the Memory Offset to any (change to the lowest possible value to do so), to allow the Controller Assignment to always apply to the current cursor parameter—as long as an editor window is active and the cursor is flashing.

For Device set to Controller Assignment Set, these parameters not have a completely different meaning. See section Remote Control of Current Controller Assignment Set from page 352 onwards.

Controller name
This is the name of the fader or control, displayed in the list, to make finding a Controller Assignment easier.

Short name
This is a short form of the parameter name, which is used by Fader Box Modules to be displayed in the fader box’s display (see the section Fader Box Modules on page 348).

When a Controller Assignment is created by using drag-and-drop or the Learn function, the short name is automatically generated from the parameter name, with a length which fits into the available space in the fader box’s LCD.

Requires Editor Window
If this option is enabled, the Controller Assignment is only active if the corresponding editor window is open and top-most. This setting is useful to prevent unwanted changes in the background.

This also allows you to assign the same controller message to parameters in different devices or edit buffers, which automatically switch when you activate the appropriate editor window.

If the option is disabled, the Controller Assignment is always active, no matter whether the editor window is active or even open. Even the device which contains the controlled parameter doesn’t have to be active. However the edit buffer data must have been received.
Learn Mode

Feedback
This determines whether changing the parameter controlled by the Controller Assignment should generate a feedback transmitted to the fader box.

- This function is currently only supported for Controller Messages which originate from a fader box which is supported by a fader box module (see section Fader Box Modules from page 348 onwards).

Local Feedback
For Controller Assignments which transmit feedback (see above) you can define by activating this option if the controller does already display the current value by simply operating it. This is usually the case for mechanical motor faders. Thus transmission of feedback is only required when the parameter is altered on the computer screen.

- This function is currently only supported for Controller Messages which originate from a fader box which is supported by a fader box module (see section Fader Box Modules from page 348 onwards).

If this option is disabled by mistake, this often manifests itself in mechanical resistance while operating the motor fader.

Controller Assignment Set
This parameter determines in which Controller Assignment Set the Controller Assignment is active. For further details, see section Controller Assignment Sets from page 351 onwards.

9.4 Learn Mode
With the learn mode, creating and modifying Controller Assignments is greatly simplified. SoundDiver can enter the controller message and some other parameters of a Controller Assignment by analyzing the MIDI input data stream.
Chapter 9
Controller Assignments

Learn Mode Features
The learn mode has following features:

- recognition of Lo7 and Hi7 bytes,
- recognition of encoders which send relative values (such controls sometimes send the same value subsequently),
- recognition of encoders which use sign-magnitude format,
- automatic removal of unwanted messages (e.g. touch / release messages for motorized faders).

*Lo7 Min* and *Lo7 Max* always get the default values 0 and 127. This might cause problems in the rare case that two controls use the same message other than the value range, but is more useful when assigning sliders or knobs, because you don’t have to move the control over the entire range.

For the automatic recognition of the above parameters to work correctly, you should operate the controller in both direction and over the full value range if possible.

If no Controller Assignment is selected when the learn mode is activated, a new one is automatically created. Otherwise the incoming message replaces the previously one(s) in all selected Controller Assignments without warning.

Learn Mode in the Controller Assignments Window
Select the Controller Assignment(s) whose MIDI message you want to alter.

Now enable the *Learn Message* button, operate a control (if possible, slowly and in both directions), and disable the switch.

* Don’t forget to disable the learn mode after you have sent the messages.

If no MIDI messages have been received by SoundDiver, the Controller Assignment is deleted, as Controller Assignments with empty messages are useless.
Learn Mode in the Editor Windows

New Controller Assignments can be created from within an Editor window, even without opening the Controller Assignments window.

Learn Mode with Launch of the Controller Assignments Window

Open an Editor window and click a parameter. Select Edit > Learn New Controller Assignment. Now the Controller Assignments window opens and the new Controller Assignment is selected.

Don’t forget: Only one side of the Controller Assignment is defined at this point. The Controller Assignment message has to be defined now.

The learn mode is now enabled. Operate the desired controller (if possible in both directions), and switch off Learn Mode.

Learn Mode without Launch of the Controller Assignments Window

To make the definition of new Controller Assignments even easier, there is a shortcut:

As above, select Edit > Learn New Controller Assignment, but hold down a modifier key. The easiest way is to use the key command and keep holding down the modifier associated to the key command.

While still holding the modifier key down, a ToolTip appears (see the section The ToolTips on page 179), which explains the next steps (generate the message by moving/turning the control, then release the modifier).

When you release the modifier key, the new Controller Assignment is created, and you can immediately operate the control to remote-control the parameter.
If you release the modifier before a message is recorded, the Controller Assignments window opens, and you get instructions in the ToolTip how to finish the learn procedure (disable the Learn Message button in the Controller Assignments window).

9.5 Fader Box Modules

SoundDiver includes advanced Controller Assignment features with the help of special modules. Currently, there are two such modules which support CM Automation Motor Mix and Radikal Technologies SAC-2k.

Fader box modules simplify the definition of Controller Assignments and their usage.

Fader Box Editor Window

Double click the icon of a fader box in the Setup window, and the Editor window opens which shows the fader box’s surface.

If you enter some text in the display, it will be sent to the device immediately.

That’s about all you can “edit” here. This window has actually a different purpose than you are used to from Editor windows:

Defining Controller Assignments with Drag-and-drop

In order to define a new Controller Assignment, click and hold on a controller object in the fader box Editor window (fader, knob, button etc.), and drag it to the parameter to be controlled (located in another editor window). The mouse pointer is shown as a plug.

As soon as the mouse pointer touches the parameter, it becomes inverted. When the mouse button is released, a new
Controller Assignment is generated in the Controller Assignments window.

**Finding Controller Assignments**
A double click on an object in the fader box Editor window opens the Controller Assignments window, and selects the associated Controller Assignment(s).

**Automatic Labelling**
If you use a controller which is directly located next to the fader box’s display in a Controller Assignment, its short name (see section *Short name* on page 344) will be automatically shown in the display.

Depending on the display’s resolution, this is done staggered in two lines: odd-numbered controllers are labelled in the first line, even-numbered in the second line.

You can change the label name by simply editing the text parameter *Short Name*.

When the assignment of a controller changes, e.g. by recalling a Controller Assignment Set (see section *Controller Assignment Sets* from page 351 onwards), the labelling is automatically updated. Labels of currently unused controllers are wiped out.

If a controller controls multiple parameters of different name, only the name of that Controller Assignment is display which is located most-bottom in the list.

**Feedback**
Fader box modules support two types of feedback to the fader box: motor fader feedback and display feedback.

**Motor Fader Feedback**
Every time a parameter changes for which an Controller Assignment which uses a motor fader (or other control which
Chapter 9
Controller Assignments

displays the parameter value) exists, SoundDiver sends a MIDI
message which updates the motor fader to the current value.

This is also the case when the entire edit buffer changes (e.g.,
by using AutoAudition) or the active Controller Assignments
are switched, e.g. by recalling a screenset.

Of course, multiple motorized faders (even of several fader
boxes) can be assigned to the same parameter. In this case, all
motorized faders are updated.

This is even the case when the parameter change is caused by
a Controller Assignment. To prevent mechanical resistance, no
feedback is sent to the operated motor fader (see also section
Local Feedback on page 345).

If a motor fader is assigned to multiple parameters, and these parameters get
different values, the motor fader always displays the most recently changed para-
meter’s value. If several of the parameters change simultaneously (e.g. by AutoAud-
tion), then the displayed value is undefined.

Display Feedback

When SoundDiver changes a parameter caused by an incoming
controller message (no matter if it originates from a motor fader
or a normal controller), the name of the parameter and its value
will be shown on the fader box’s display for two seconds.

If parameters which use text for the parameter value (e.g. waveform or sample
selection), even this text is displayed in the fader box, together with the number.

After this period, the labels are shown again (see section Automatic Labelling on page 349).

The display of the currently edited parameter name and value
can be muted in the settings of the fader box (Setup window,
special parameter section). This may be required if the trans-
mition of display feedback causes too much traffic on the
MIDI port, or if it is not desired when recording parameter
changes in AutoLink mode.

Emagic
SoundDiver
9.6 Controller Assignment Sets

Controller Assignment Sets allow you to alternatively control different parameters in an editor with the same controllers. For example, with Controller Assignment Set 1, you control the Filter parameters, and with Controller Assignment Set 2, the effect parameters are controlled.

Similar to screensets, only one Controller Assignment Set is the current one at any time. The current Controller Assignment Set can be switched by key commands or MIDI commands. Alternatively, you can even control the current Controller Assignment Set using Controller Assignments.

The Current Controller Assignment Set

At the upper left corner of the Controller Assignments window, you see a parameter—the current Controller Assignment Set. Possible values are 1 to 9999 and “All”. The current Controller Assignment Set is stored in the preferences and recalled when loading a preferences file.

Every Controller Assignment has a parameter “Controller Assignment Set” which can be either “All” or any number between 1 and 9999. If it is “All”, the Controller Assignment is always active. Otherwise, it is only active if the current Controller Assignment Set matches, except the current Controller Assignment Set is “All”.

Only the currently active Controller Assignments are displayed in the Controller Assignments window. This includes all Controller Assignments which have the value “All” in the Controller Assignment Set parameter.

Also the parameter box shows only the properties of the selected, active Controller Assignments. Edit > Cut, Edit > Copy and Edit > Clear always apply only to the selected, active Controller Assignments.
You can change the current Controller Assignment Set by following means:

- with the mouse: click-hold and move the mouse up and down
- by entering a value: double-click the parameter and enter a new value
- Key commands Next Controller Assignment Set and Previous Controller Assignment Set
- Controller Assignments (see next section).

**Display of current Controller Assignment Set on Fader Box**

If your fader box is supported by a module, the current Controller Assignment Set will be displayed on the fader box’s front panel.

At the SAC-2k, this is done in the upper right corner of the right LCD. At the Motor Mix, this is done in the 2-digit 7 segment display.

**Remote Control of Current Controller Assignment Set**

There are several ways to define Controller Assignments which control the current Controller Assignment Set.

**Defining by Drag-and-drop**

SoundDiver’s fader box modules know the special meaning of the buttons on your fader box which select a track or a group of tracks, as far as they exist.

SoundDiver allows one special destination for drag-and-drop assignment of Controller Assignments outside of Editor windows: the current Controller Assignment Set in the Controller Assignments window.
So dragging such a button (see section *Defining Controller Assignments with Drag-and-drop* on page 348) onto this parameter will automatically define a Controller Assignment which does exactly what you expect, including LED feedback on the fader box.

For the SAC-2k, the Track Select buttons 1 to 8 and the buttons 1 to 8, 9 to 16, 17 to 24 and 25 to 32 have this special meaning.

For the Motor Mix, the Track Select buttons 1 to 8 and the buttons F1, F2, F3 and F4 have this special meaning.

**Predefined Controller Assignments**

In the local Assignment > **New** sub-menu, you find several menu items which create a number of Controller Assignments which control the current Controller Assignment Set.

**Controller Assignment Set Control**

creates a single Controller Assignment which controls the current Controller Assignment Set

**4+4 button Controller Assignment Set Control**

Use this option if your fader box has four track select buttons. Four Controller Assignment Sets are created which select one of the four tracks; and four Controller Assignment Sets switch between the track groups 1—4, 5—8, 9—12 and 13—16.

**8+4 button Controller Assignment Set Control**

Use this option if your fader box has eight track select buttons. Eight Controller Assignment Sets are created which select one of the 8 tracks; and four Controller Assignment Sets switch between the track groups 1—8, 9—16, 17—24 and 25—32.

**16+4 button Controller Assignment Set Control**

Use this option if your fader box has sixteen track select buttons. Sixteen Controller Assignment Sets are created which select one of the 16 tracks; and four Controller Assignment Sets switch between the track groups 1—16, 17—32, 33—48 and 49—64.
Now simply select the created Controller Assignments one after another and use the “Learn” function to define the incoming messages.

**Defining Manually**

In the “Device” parameter of a Controller Assignment, there is a value “Controller Assignment Set”. When this value is chosen, the Controller Assignment controls the current Controller Assignment Set instead of a parameter in an Editor window.

In this mode, parameters “Data Type” and “Entry” have no meaning. Parameter “Memory Offset” and “LS Bit” define the bits of the current Controller Assignment Set which are modified. The normal settings are “Memory Offset” = 16 and “LS Bit” = 0 which means that all 16 bits, beginning with bit 0 are modified.

You can use the modes Direct and Relative to modify the current Controller Assignment Set. In direct mode, the parameter Factor determines the selected Controller Assignment Set, minus one. E.g. a factor 2.00 selects Controller Assignment Set 3. For further details, see section Mode from page 342 onwards.

If you have “Track select” and “Track Group” buttons on your fader box, and the number of tracks are a power of 2, you can use these buttons to select Controller Assignment Sets. Examples for a fader box which has 8 “Tracks”:

<table>
<thead>
<tr>
<th>Button</th>
<th>Mode</th>
<th>Mem. Offs.</th>
<th>LS Bit</th>
<th>Factor</th>
<th>results in$^a$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select 1</td>
<td>Direct</td>
<td>3</td>
<td>0</td>
<td>0.00</td>
<td>0000000000000000</td>
</tr>
<tr>
<td>Select 2</td>
<td>Direct</td>
<td>3</td>
<td>0</td>
<td>1.00</td>
<td>0000000000000001</td>
</tr>
<tr>
<td>Select 3</td>
<td>Direct</td>
<td>3</td>
<td>0</td>
<td>2.00</td>
<td>0000000000000010</td>
</tr>
<tr>
<td>1—8</td>
<td>Direct</td>
<td>13</td>
<td>3</td>
<td>0.00</td>
<td>0000000000000111</td>
</tr>
<tr>
<td>9—16</td>
<td>Direct</td>
<td>13</td>
<td>3</td>
<td>1.00</td>
<td>0000000000001111</td>
</tr>
<tr>
<td>17—24</td>
<td>Direct</td>
<td>13</td>
<td>3</td>
<td>2.00</td>
<td>0000000000010000</td>
</tr>
<tr>
<td>25—32</td>
<td>Direct</td>
<td>13</td>
<td>3</td>
<td>3.00</td>
<td>0000000000100000</td>
</tr>
</tbody>
</table>

a. Binary format. An “*” means that this bit is unaffected.
Note that Controller Assignment Set numbers are displayed with 1 added, so e.g. Controller Assignment Set 10 is stored as 9, thus it is stored as binary 00001001. To select it, you use buttons “9—16” (selecting a value 00001001) and “Select 2/10/18/26” (selecting a value 00001001).
Chapter 9
Controller Assignments
Chapter 10

AutoLink

If you use both, SoundDiver and Emagic’s “Logic” sequencer, the AutoLink feature allows you to link these two programs. If you don’t (yet) use Logic ignore this chapter (or read it to see what you’re missing!).

When Logic is mentioned in this chapter, this automatically includes Logic Audio Platinum, Gold and Silver, as those programs include the full AutoLink functionality. However, MicroLogic does not support AutoLink.

10.1 What Is Autolink?

AutoLink provides—as the name suggests—an internal link between SoundDiver and Logic. With both programs active, you can control your sound management while Logic is running.

The “Name Provider” transfers the names of the sounds being used to Logic, so that the latter’s (Multi) Instruments reflect the current sound names.

“MIDI Processing” allows Logic to record all your manipulation of SoundDiver editors via AutoLink. SoundDiver creates SysEx data when you edit parameters in the Editor window and sends it to Logic, where it is recorded directly onto the current track. This allows you to automate (i.e., record) any dynamic sound edits you make in SoundDiver.

AutoLink requires no external system expansion as SoundDiver and Logic control all the communication between them.
**System Requirements**

On Windows, AutoLink requires the following system configuration:

- Any Pentium PC,
- Windows 95/98,
- SoundDiver 2.0.6 upwards. We recommend the current version.
- Logic 4.0 upwards. We recommend the current Version.

On the Macintosh, AutoLink requires the following system configuration:

- Any Power Macintosh,
- System 7.1 upwards,
- SoundDiver 1.505 upwards. We recommend the current Version.
- Logic 2.02p upwards. We recommend the current Version.

**10.2 How Do You Start Autolink?**

**Starting AutoLink**

Starting SoundDiver in AutoLink mode is fairly easy:

- First start Logic
- Make sure that the option *Use AutoLink with SoundDiver or SoundSurfer if available* in Logic’s *Options > Settings > MIDI Interface Communication* page is enabled.

⚠️ If you are using a Logic version prior to 2.5, disable “Release Modem and Printer Port in Background if Stopped” or Logic switches off all MIDI communication when you toggle to SoundDiver, and AutoLink ceases to function.

- Now start SoundDiver. Please boot in this sequence (first Logic, then SoundDiver), because SoundDiver needs to find an active Logic program to be able to activate AutoLink.

⚠️ On Windows, this sequence can be altered only if a multi-client MIDI driver is used.
When AutoLink is activated, you will hear a “plop” sound.

**Starting AutoLink in OMS Mode**

If you want to use AutoLink and OMS simultaneously, switch on *Use OMS if available* in Logic’s preferences and set *Use OMS if available* in SoundDiver’s preferences to *always*. Also see the section **Communication with Logic in OMS Mode** on page 77.

### 10.3 MIDI Communication with AutoLink

Whenever Autolink is enabled, SoundDiver uses Logic for the MIDI input and output. You can check this in the “Preferences” window which no longer shows the two MIDI ports, but now looks like this:

![AutoLink Preferences Window](image)

Additionally the sequence window will change, so that the active AutoLink mode will also be recognized:

![Sequence Window](image)

When AutoLink is active, SoundDiver no longer uses the MIDI ports set in the Preferences, but communicates internally with Logic. All the data sent from and received by SoundDiver is first passed through Logic which is now acting as the MIDI interface. SoundDiver, then, only has access to the active ports in Logic.

All the data that arrives at any of the computer’s MIDI inputs is passed on to SoundDiver. Conversely, SoundDiver’s MIDI output is included in that of Logic.
If you quit Logic, SoundDiver automatically takes over normal control of its MIDI management.

The following scheme shows the MIDI communication between SoundDiver and Logic.

**MIDI Thru in AutoLink Mode**

SoundDiver’s MIDI Thru function also works in conjunction with AutoLink. When active, this option always sends the incoming data to the current device.

SoundDiver automatically searches the Logic song for an instrument which has the same MIDI channel and port settings as the selected device. If no matching instrument can be found, a dialog box appears asking whether you wish to create a new instrument in Logic’s Environment with the appropriate settings.

This dialog box gives you the following three options:

- **Cancel**
  - You don’t want to create an instrument.
Create
You want to create an instrument on this occasion only.

Always Create
You always want SoundDiver to automatically create an instrument.

If MIDI Thru is switched off, Logic uses the “No Output” instrument which exists in every song and cannot be deleted.

Whenever you switch back to Logic, the MIDI Thru instrument is automatically changed to the track instrument, and vice versa.

- The new instrument appears in the 7th layer “Instruments” of the Logic Environment. For details refer to Logic’s Readme file.
- The individual instruments of a multi instrument are also used as the Thru instrument if they match the desired setting.
- No instrument is required for sending data to the devices—the MIDI Thru is not used since the MIDI outputs are addressed directly, without being diverted via Logic.

A change of the MIDI channel or output in the device parameter box causes the creation of a suitable instrument only after the mouse button has been released. This prevents the needless creation of instruments.

Create Logic Instruments
This option in the Preferences (Tab “Safety Messages”) defines whether you want to be asked if SoundDiver needs to create a new instrument in the Song in order to achieve the desired MIDI Thru settings.
10.4 The Sound Names in Logic Instruments

You normally have to manually enter the names of your sounds into Logic, as Logic cannot access these patch names via Sysex data dumps as SoundDiver can.

However, since all this information is available in SoundDiver’s Device window, and SoundDiver knows which device is on which channel, this data can easily be communicated to Logic via AutoLink. Logic in turn inserts the appropriate sound names to the Instrument column and names fresh recordings accordingly. For example, instead of “Sequence recorded”, the sequence name might be “E-Piano 1 recorded”.

AutoLink allows you to select the right sound for a track at the right time without having to look in the device or rummage around in SoundDiver.

Selecting a Sound in Logic

For Logic to know which sound you have given to an Instrument, you have to enter its corresponding Program Change command in the Instrument Parameter box.

To do this, activate the Program Change in the Instrument Parameter box with a checkbox.

If you now click-hold the Program number, a flip-menu opens with the current sound names:

This is where you select a sound. The one you select automatically appears from now on in the Arrange window’s Instrument column:

You see at a glance which sound is being controlled by which track.

Please bear in mind that these names are not saved as part of the Song (on the other hand the content of multi instruments is...
stored in the song). They are displayed for only as long as SoundDiver and Logic are actively AutoLinked.

If you alter an entry in SoundDiver, delete a device or alter its MIDI configuration, this has an immediate effect on the display in Logic.

**Configuring the MIDI Channel for Program Change Detection**

SoundDiver modules automatically try to establish a device’s MIDI channel. However, adaptations cannot do this. For simpler devices with no multi mode this is not a problem, because the MIDI channel and the device ID always match.

In the case of a device where the MIDI channel does not always match the device ID the “Program Change Channel” appears amongst the device’s specialized parameters. Please set this to the device’s current MIDI channel.

In multi-mode devices, program changes often switch to the relevant sound on multiple MIDI channels. In this case a switch matrix (resembling Logic’s multi instrument) appears in the specialized parameters. Here you can whether program changes should be processed on a channel by channel basis. Depending on the device, you have to make this setting for a multi or combi program.

If you see both the “Program Change Channel” and the matrix, the “Program Change Channel” defines the channel which is used to switch Performances, Multis etc. In Roland devices, this channel is called “Control Channel”.

**Sound Names in a Multi Instrument**

You can use Logic’s Environment to create a multi instrument for a multi-timbral device. Its sound names are displayed together in the one window. Here, too, AutoLink is used to acquire the correct names.
To access Device window patch names for a multi instrument, simply select **Update using AutoLink** from the multi instrument window’s local flip-menu.

*With multi instruments, sound names are saved as part of a Logic Song, and are visible even if SoundDiver is deactivated. However, changes made in SoundDiver are not automatically reflected: you have to manually use “Update Using Autolink”.

**If AutoLink Doesn’t Work…**

If the “Name Provider” doesn’t appear to function as expected on the first try, don’t panic. There are a few important conditions that have to be fulfilled for Logic and SoundDiver to talk freely together. It may require a little patience until it’s all up and running. Please check to make sure that…

- … the MIDI Port of the device is set identically in both Logic and SoundDiver. Check the conformity at the parameter box of SoundDiver and Logic.
If you are using “MTP Cable Mode”, you should not be using the “ALL” option—either in SoundDiver or in Logic.

- the MIDI channel at Logic matches the **Thru Ch** value of the device at SoundDiver, if the device is not multitimbral (only one MIDI channel in available).

If there is no such channel, the device ID has to match the Logic instrument’s channel. With these devices, the device ID is identical with the MIDI channel. SoundDiver then only shows the device ID.

With multitimbral devices you have to distinguish modules from adaptations (you can recognize adaptations by the **adaptation** menu in the Device window)

- With adaptations, the channel must be switched on in the 4x4 matrix in the “Special Parameters” area.
  
  If the device has a control channel (e.g. for the selection of performances), and you want Logic to show this information, this channel must match the **Program Change Ch** setting in the Adaptation.

- Modules are able to request this kind of data. Detailed conditions are listed in the on-line help.

- the correct Bank Select format is set (if the device supports this MIDI command).

Although “normal” instruments send both bank select control changes, only bank select LSB (controller 32) is variable, and only in the range 0 to 62. If the sound generator needs other bank select values, use a multi instrument and select one of the bank select options in the multi instrument editor.

Or you can use the function **Define Custom Bank**
Messages ... ” in Logic 2.5 or newer (See “Defining Custom Bank Select” Chapter 5 of Logic’s manual).

In Logic 2.0x and the first version of Logic 2.5, the Bank Select information in a multi instrument was not passed on to SoundDiver. Make sure you use the latest update of Logic 2.5 (or a later version).

Particularities of devices defining the Bank Select are found at the section “Autolink” in the Help file.

• ... SoundDiver knows the device’s receive MIDI channels—if a multi-timbral device is involved. To be sure of this, SoundDiver normally needs the “Global Data” or “System Settings”, the current Multi/Combi program and any Program Change table the device may have. If Logic is showing blank or incorrect sound names, request this data again using SoundDiver. If this data is not available, the SoundDiver module assumes that the device can receive on the MIDI Thru channel set in SoundDiver’s device parameter box only. To be quite sure, request the entire Device window contents into SoundDiver again. Check the “AutoLink” section in the on-line Help of the corresponding module. You can look this page up by selecting it in the help index (see the section Index on page 175).

• ... SoundDiver knows the device’s current mode. Many devices have more than one mode (e.g. Program and Combination) in which incoming Program Changes are variously processed. To tell SoundDiver what the desired mode is (and to switch the device to that mode), you only need to click the appropriate Edit Buffer in the Device window. Some devices recognize certain Bank Select or Program Change commands and change modes accordingly. If you transmit these, SoundDiver delivers the desired names without further action on your part.

• If several devices receive on the same channel, the program names of just one of these devices will be shown, the device that was first added to the Setup window. We therefore recommend that you separate the devices by MIDI channel unless there’s a good reason for not doing so (e.g. layering
sounds—however these can still be realized with separate channels by using alias sequences).

If none of this helps, it could be because the settings needed in the SoundDiver adaptation have not yet been completed. You can check whether this is the case in the “SoundDiver Model List” file in the “AutoLink” column: a “y” means that the adaptation supports AutoLink.

If the adaptation does not yet support AutoLink, you may be able to fix this yourself.

- Open the Adaptation Editor from the Device window using Adaptation > Edit Adaptation … and open the desired bank’s “Bank Driver”.
- In the bank driver, find the parameters called Program Change detection.

**CHAN**

This item selects the MIDI channel which the corresponding Logic instrument must match in order for the Name Provider to function. You can select a fixed value, or a variable one, based on other criteria such as the Device ID or MIDI Thru Channel.

**BANK MSB** or **LSB**

- a Bank Select command, if required,

**FIXED**

- a fixed Program Change that’s sent first, if required,

**OFFSET**

- the Program Change number used to select the first entry in the bank.


If none of the mentioned steps will make it, just use Edit > Copy (in the Device window) and Paste using the “Paste all names” item (at the multi instrument pull-down menu near the “Update Using Autolink” item). Not very elegant—but this method always works.
10.5 Remote-controlling Logic by SoundDiver

AutoLink disables SoundDiver’s internal sequencer and lets Logic take over. The window is called “AutoLink/Logic”. The Transport functions in SoundDiver’s Sequencer window remote-control Logic. This allows you, for instance, to prepare a Cycle mode sequence in Logic and then seek out the appropriate sound in SoundDiver for that particular track.

The Record button can also be activated in AutoLink mode, thus allowing you to remote-control Logic from SoundDiver. This feature is very useful for recording parameter changes in a SoundDiver editor in real-time (see the section Recording Parameter Changes in Logic on page 371).

Key Commands for Logic

SoundDiver forwards all unassigned key commands to Logic. In AutoLink mode, the key commands for SoundDiver’s transport control are ignored, but forwarded to Logic. This way if you swap the assignment of Play and Stop in Logic, this assignment then also applies to SoundDiver.

10.6 Changing Logic’s Track Instruments

A handy function of AutoLink is the ability to audition a recorded track with various sounds from different tone generators—all with a single mouse click.

Set Logic Instrument

Activating this option in SoundDiver’s Options menu alters the Instrument on the selected track in Logic, if you start audition-
ing sounds at SoundDiver. So it’s easy to try out different sounds—even from different Instruments—on the same track.

For safety reasons, this option is always disabled when SoundDiver becomes active.

If you want to change the track’s instrument, select this menu item. Now the currently auditioned entry will be played by your Logic tracks.

The changed track instrument will be retained if you switch back to Logic. If you don’t want this, disable Set Logic Instrument before switching back to Logic. The original instrument is reassigned to the track, and the song remains unchanged.

10.7 Saving Song Data in a Library

Coming from Logic you can save the sounds used in a song in a SoundDiver library (if AutoLink is active). Click the New > Save Library for Logic Song > ... menu to do this.

You can select from the same list of options as in Build Library... and Save as... This allows you to build a library with entries that aren’t used in the song.
Save Entries Used by Logic Instruments

In addition there is an other option located at the bottom of the sub-menu named Entries used by Logic Instruments.

This includes all data called up by program changes selected in the Instrument Parameter Boxes in the Logic song.

If you want to use this function you have to:

- ensure that all the sounds and programs which you want to save as library entries are called up using the program change selection box in the Instrument Parameter boxes within the song (program changes which were added as events into sequences will not suffice);

- execute the key command to save the library.

You can call up this function in Logic via a key command. This can be assigned to any key combination or MIDI command in the Key Commands window:

- open the Key Commands window in Logic,

- go to the “Global Commands” section and click the line that says Save used Sound Programs using SoundSurfer/Diver;

- define a key command or MIDI command.

During the exchange Logic and SoundDiver automatically alternate as the active application.

You can also execute this function by selecting New > Save Library for Logic Song > Entries used by Logic Song Instruments in SoundDiver’s Setup window (also see section Save Library for Logic Song on page 212).

Automatically Loading and Sending the Library

The library which is created by one of the Save Library for Logic Song sub menu items has the same name as the Logic
song—except for the extension .LIB—and is stored in the same path and folder as the song.

If you then open a Logic song while SoundDiver is running in AutoLink mode, it will automatically load the library and (after your confirmation) send its contents to the devices.

**i** During the exchange Logic and SoundDiver automatically alternate as the active application.

**i** If you use Preferences files for project-oriented backups, you should think about using libraries instead of using the option “Save Library for Logic Song > Known Entries”.

Advantage: even after you have changed your MIDI setup (e.g. MIDI output assignments), such a library will still work, thanks to SoundDiver’s “intelligent” destination device finding algorithm (also see the section Device Selection Strategy when Sending from a Library on page 214). If you want to load an old Preferences file after your MIDI setup has changed, you would have to adjust MIDI output and Device ID settings manually.

**i** This function is not carried out automatically every time the song is saved in Logic. We recommend that you save the library just before you close the song or quit Logic to ensure it is up to date.

### 10.8 Recording Parameter Changes in Logic

Now that we’ve covered the transfer of sound names, let’s examine how AutoLink allows for the real-time recording of parameter changes. This means that you are able to record all the parameter editing you do in the SoundDiver editor directly in Logic, allowing, say, filter sweeps over arpeggio runs, or real-time pulse width changes during a solo. Exactly how a device reacts to being manipulated via SysEx while it’s playing depends on the device. More on this in the following two sections.

To record SoundDiver parameter changes in Logic:
First confirm that the option which allows Sysex to be recorded is enabled. This option is found in the **Options > Settings > MIDI Options** window in Logic.

You should now arrange a combination of SoundDiver and Logic windows that allows for easy access to the relevant areas in each program. For example, you may wish to position Logic’s transport panel next to a SoundDiver’s editor. (You can, alternatively, open SoundDiver’s Sequencer window and start the recording from there).

SoundDiver’s Easy Page provides a bird's-eye view of the main parameters. Here’s an example of how to lay out the Logic and SoundDiver windows:

Beneath the SoundDiver EX5 editor, you can see Logic’s transport panel in record-pause status.

Once you are ready to begin recording:

- select the desired starting point in Logic,
- click in SoundDiver’s editor,
- start recording (by pressing the key command defined for this in Logic, usually `)`,
- adjust the parameter(s) in the SoundDiver editor,
when you have finished, click the Stop button in the transport panel.

All the Logic functions such as Cycle-Record and Autodrop are freely available from within SoundDiver.

Create a screenset in both Logic and SoundDiver on the same number (e.g. 98) which calls up the assignment shown above. You can then make an instant SysEx recording since the screen configuration will be called up in both SoundDiver and Logic (if AutoLink is active).

It is not yet possible to define SysEx sliders in Logic by sending parameter changes from SoundDiver.

What to Look out for with Real-time SysEx Editing

SysEx parameter changes are extremely data-intensive. Logic has special priority routines that ensure that the timing of notes and other MIDI events is not affected by even complex SysEx editing. Despite this, problems can arise that may be unavoidable due to limitations of the device:

• The reaction time of many devices slows down when they receive notes and SysEx at the same time. If you suspect this, try allocating the offending parameter to a MIDI Controller (e.g. Modulation). MIDI Controllers are more efficiently processed by MIDI devices and don’t, as a rule, affect the timing. This is because SysEx data has a subsidiary timing priority and is treated by many devices as being of secondary importance, unlike MIDI Controllers, where the opposite is true. In any case, of course check to see whether the desired function in your device can be reached via MIDI Controller.

• Some devices deal with parameter changes only when notes are being played. In other words: filter sweeps are not possible when notes are being held, only when they are played. If this is the case, try the MIDI Controller alternative just described.
10.9 Displaying Recorded Parameter Changes in SoundDiver

Normally, Logic forwards only MIDI events received at the MIDI inputs to SoundDiver, but not the ones transmitted by Logic. Thus, parameter changes recorded in a sequence are not displayed in SoundDiver when the song is played back (see the section MIDI Communication with AutoLink on page 359).

To see these changes in the Editor window, the data has to be sent to SoundDiver.

For this purpose the “AutoLink” object in Logic’s environment exists, which is like a virtual port to SoundDiver.

The recorded SysEx data (track) is played by an instrument (1) and handed over by this instrument to a MIDI port (3). Using the “AutoLink” object Logic delivers the same data additionally to SoundDiver.
As there is only one virtual port to SoundDiver, Logic generates only one “AutoLink” object.

If display of parameter changes is desired, you can configure it as follows with Logic:

- Create a new internal instrument with the Environment window’s local menu item **New > Internal > AutoLink**. (If this menu item does not appear, instead create another internal instrument instead, i.e., QuickTime, SampleCell or WaveMaker, and adjust the instrument’s type to “AutoLink 1” afterwards.) The parameter **Which** is unused.

- Connect all instruments used by those tracks whose output you want to monitor in SoundDiver to the newly created instrument. If this instrument is “hard-wired” with a physical output, a warning message will appear asking whether this assignment should be cancelled. Select “No”; otherwise the tracks would be sent to SoundDiver only, and not to their previously assigned instrument ports.

When you start playback in Logic now, SoundDiver will display all parameter changes in the editor windows.
Chapter 10
AutoLink

This function is not available for all SoundDiver modules, particularly those whose supported devices don’t send out parameter changes themselves. Further notes can be found in the “MIDI” page of the corresponding module’s on-line Help.

10.10 Recording Dumps in Logic

If you prefer to save the actual sound data in a Song rather than rely on Program Changes, AutoLink makes it easy to record Dumps from SoundDiver to Logic.

The procedure is the same as described above in section Recording Parameter Changes in Logic on page 371.

Instead of editing in editor windows, select the entry in its desired location and transmit it. AutoAudition allows this to be done automatically, though you can also preselect the entry or entries and transmit them at the desired Song location using Edit > Transmit. Bear in mind that the sound immediately becomes active with AutoAudition; when sending memory locations, on the other hand, these have to be chosen in the Song through the use of Program Changes.

There’s more information in the section SoundDiver and MIDI-Tasking on page 73.

10.11 Synchronizing Screensets

If you recall a particular screenset in SoundDiver (see the section Storing Screensets on page 164), the corresponding one will open in Logic, and vice versa. Both programs act as one, allowing you to truly integrate your work.

Bear in mind, however, that the window hierarchy (i.e. which one is below and which above) is managed separately in both programs. By the same token, copying a screenset is possible only within its host program.

If all this automation starts to get to you, you can disable it in SoundDiver’s preferences (“Communication” page).
10.12 Open SoundDiver for Instrument

This function allows you to open the Device window of a device used by a Logic instrument very quickly.

- Select the desired track in Logic
- Select Functions > Track > Open SoundDiver for Instrument. It can also be found in the Key Commands window, in the Arrange window section. It is advisable to assign a key command to this function.

SoundDiver will now become active and open the Device window of the corresponding device. The SoundDiver device assigned to the Logic instrument is determined as follows:

- Only devices are taken into account whose MIDI output on the computer is equal to the instrument’s assigned output.
- For the following name comparisons, the case is ignored.
- If there is a device which returns a name for program change 0 on the MIDI channel used by the instrument and the device’s name is identical to the instrument’s, then the Device window of this device is opened.
- Otherwise, if there is a device which returns a name for program change 0 on the MIDI channel used by the instrument and the device’s name is contained in the instrument’s, then the Device window of this device is opened.
Otherwise, if there is a device whose name is *identical to* the instrument’s, then the Device window of this device is opened.

Otherwise, if there is a device which returns a name for program change 0 on the MIDI channel used by the instrument, then the Device window of this device is opened.

Otherwise, if there is a device whose name is *contained in* the instrument’s, then the Device window of this device is opened.

The above facts are summarized in the following table.

**Table 8 Assignment Logic instrument to SoundDiver device**

<table>
<thead>
<tr>
<th>Pass</th>
<th>Output matches</th>
<th>returns name for program change</th>
<th>Name matches</th>
<th>Name is similar</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>√</td>
<td>√</td>
<td></td>
<td>√</td>
</tr>
<tr>
<td>3</td>
<td>√</td>
<td></td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>√</td>
<td></td>
<td></td>
<td>√</td>
</tr>
</tbody>
</table>
Chapter 11

The Universal Module

SoundDiver’s support for MIDI devices comes in two forms: the module and the adaptation. Modules are created by Emagic developers and are the more advanced of the two forms. A module precisely reflects and makes full use of a device’s specific characteristics. They function as a comprehensive, independent system and have capabilities rivaling model specific editor/librarian programs.

Unfortunately, it is hardly feasible to create a module for every MIDI device in existence. The level of sales for many MIDI devices simply does not justify the amount of time and energy it takes to produce a module. Fortunately, this does not mean that other devices can’t be supported, because SoundDiver provides a quick and easy way of supporting those MIDI devices not covered by modules.

This support is made possible via a special module called the Universal Module. This module can be made to work with virtually all MIDI devices, thanks to editable driver-files called “adaptations”. These “adaptations” are user-editable, so if you know a little about SysEx data, you can create your own adaptations or edit the existing ones.

Your SoundDiver package comes with modules and adaptations that cover more than 500 MIDI devices, so it is likely that your entire MIDI system will be compatible with SoundDiver from the word “go”. The number of provided adaptations will increase every time there’s an update to the program, so the need for you to create your own adaptations will decrease correspondingly over time. However, the option is always there if you wish to take advantage of it.
11.1 The Differences between Modules and Adaptations

Here are the main differences between the modules and adaptations.

Differences in MIDI Communication

- Adaptations can be created and edited by the user; modules cannot.
- Adaptations cannot import non-SoundDiver data files, except Standard MIDI and SYX/MidiEx files.
- Adaptations’ scan functions cannot recognize cards, expansion boards or MIDI channels.
- The version number of a device’s firmware is recognized by adaptations only if the device supports the “Universal Device Reply” message. Even then, the adaptation cannot take differences between the firmware versions into account.
- Modules often support several models of one type of device, even if there are minor differences between the models. It also is ideally suited to supporting a device’s different software versions, even to the extent where new features are introduced. This is not possible with adaptations.
- Modules are able to convert files from related devices (e.g. DX7 → SY99); adaptations can do this only to a limited extent.
- Modules are able to support all kinds of SysEx communication. Adaptations have a few limitations in this respect (e.g. handshaking, Sample Dump Standard, exotic name and checksum formats).

Differences in Editors

- Overview and easy page are not possible in adaptations.
• In adaptations there are no parameter groups. Thus, you cannot select, cut, copy, paste, initialize or randomize parameter groups. The function **New Editor** is also not available.

• Adaptation editors have a fixed object layout. All objects are always visible. In modules however, objects and parameter groups can be hidden, depending on the value of a parameter. This often occurs in editors for effects devices or the effect section of synthesizers: an “algorithm” parameter often defines the meaning of all other effect parameters.

• Editors for data types which have a dynamic data structure are not, or only partially possible in adaptations.

• Custom objects like “Free Algorithm Edit” in the SY77 modules or the 3-D display of the K5000's additive synthesis are not possible in adaptations.

• Range functions (see section **Range** on page 326) are not possible in adaptations.

**Other Differences**

• Adaptations can’t automatically change the MIDI Thru channel when the active edit buffer or current parameter changes.

• The entry dependency management does not work flawlessly in all adaptations. This is because the definition of a dependency is done with a special editor object. Due to the above mentioned limitations in editors, too many dependencies are generated in some cases.

• AutoLink name providing works in adaptations for multimbral devices only with limitations, as there is no way to find out from the entry data what MIDI channels are used. Instead, the user has to define these channels manually (see the section **Configuring the MIDI Channel for Program Change Detection** on page 363).

For selecting banks, only the two bank select controller
messages and a preceding program change message are supported. Other formats are not possible.

11.2 Editing Adaptations

Most of the adaptations that come with the package have already been optimally adapted to their respective devices and do not need further editing. However, you may find that you want to alter the default parameters, in which case light editing becomes necessary.

The Adaptation Menu

In Device windows that are created by an adaptation, you will find a third local menu heading called Adaptation next to Entry and View. This new menu accesses the adaptation editor, and allows the altered adaptation to be saved to disk.

Edit…

Select this to open the adaptation editor.

You are able to alter the default parameters in the upper portion of the adaptation editor.

Save

Selecting this menu item saves the adaptation file in the Diver folder.

You can get the former version back by reloading it from the original program CD or download it from Emagic's web site (see below).
Altering Default Parameters

To find out how to create your own adaptations, please read the section Creating Your Own Adaptations on page 384.

You are, however, able to make simple changes without specialized knowledge. We are deliberately limiting ourselves to parameters which do not alter the SysEx communication between SoundDiver and the device, such as those that simply alter the appearance of objects or change the defaults to those you want.

Icon
Click-hold the icon to select a different icon for the adaptation.

As of SoundDiver 3.0 there is a new option to import icons from the flip menu.

Select Import… from the Icon flip menu, a file selection box will appear. After importing, the PNG file’s data becomes part of the Adaptation file, and is cross-platform compatible.

The file has to meet the following conditions:

- The file chosen must be a PNG file (Mac: file type “PNGf”, Windows: extension .png).
- The icon should have an alpha channel and should be 128 pixels wide plus an optional shadow of up to 5 pixels.
- The alpha channel should have reduced opacity in the shadow.

Here are two of the web sites where you can find more information about this file format and it’s particulars:

- http://www.whatis.com/png.htm
- http://www.libpng.org/pub/png/

Defaults for Timeout, Send Pause, Play Delay

If you have been having problems with these parameters—maybe due to a change in the device’s software version—and
have found better values, you can enter them here. From then on, they will become the valid default values. You will find more on these parameters in the section *The Device Parameter Box* from page 197 onwards.

### 11.3 Creating Your Own Adaptations

Creating your own adaptations in SoundDiver requires specialized SysEx knowledge, and so is not for everyone. Because of the large number of functions and information needed to create an adaptation, we have compiled a programmer’s manual, the *SoundDiver Universal Module Programming Manual* (PDF file for Acrobat Reader, english only), which can be downloaded from our web site:

[http://www.emagic.de](http://www.emagic.de)—navigate to Support > Updates > SoundDiver

e-mail: [info@emagic.de](mailto:info@emagic.de)

This manual also defines the conventions required for any adaptations to be accepted into the pool of SoundDiver adaptations distributed by Emagic.
Chapter 12

The Preferences

The Preferences are divided into five sections and can be reached from the Options > Settings menu.

12.1 Communication

This page controls the MIDI communication between SoundDiver and the interface(s), and can be opened with Options > Settings > MIDI Interface Communication…

This page looks different if AutoLink is active. See the section MIDI Communication with AutoLink on page 359 for details.
Chapter 12
The Preferences

Particular Issues on Windows
The following parameters are only available in the Windows version, as they configure the communication of SoundDiver with the MME MIDI drivers.

The parameters are hidden in AutoLink mode, as in this case Logic handles communication with the MIDI drivers.

MIDI Input Buffers per Port
This parameter determines how many input buffers are at the disposal of each MIDI input, in order to receive SysEx messages in a cyclic manner. Higher values can be necessary for slower computers, so that incoming data is not lost while SoundDiver is busy processing the data already received. A smaller value saves memory. However, it should not be set below 2.

KB per MIDI Input Buffer
Increase this value if you experience communication problems when receiving large SysEx dumps. Symptoms are that SoundDiver reports that the device did not answer (although part of the dump has already been received) or that a check sum error has occurred.

To be able to receive SysEx messages, SoundDiver passes memory blocks (so-called buffers) to the MIDI drivers, which are then written with the incoming messages and finally returned to SoundDiver when the message has been completely received. Unfortunately, Microsoft did not define precisely how a driver should behave if an incoming message is larger than the buffer. The “ideal” behavior is that the driver passes the message in several parts (each the size of one buffer). This is done by all interfaces from Emagic, Midiman and EES. You will get problems if the driver simply passes the beginning of the message (of the size of one buffer), but “swallows” the rest. In this case, the buffers should be enlarged accordingly, so that this unwanted behavior never occurs.
You should therefore set the buffer size to a value large enough to accommodate the longest dump message which can occur in your MIDI setup. The devices which we currently know use very long dump messages include: Ensoniq’s VFX/VFX-SD, SD-1 (internal Programs—about 60 KB) and Ensoniq TS-10/12 (internal Programs—about 80 KB). However, note that the overall memory requirement results in the buffer size multiplied by the number of MIDI input buffers (see above) and the number of MIDI inputs. So if you have a MotU MIDI Express XT and a sound card, this would result in a memory requirement of 3 MB if you set 10 input buffers and 30 KB per input buffer.

For this reason, SoundDiver ignores the above parameters for Emagic interfaces and instead allocates two buffers of 1 KB each per port. Another advantage of this special behavior is that the progress bar in the status line works more smoothly when SoundDiver receives large dumps.

If required, you can bypass this special behavior by holding down ⌘ while editing one of the above parameters.

Ignore MIDI In Errors

In general SoundDiver will alert you if the transmission of MIDI data breaks the rules of the MIDI protocol (e.g. data bytes are sent without accompanying status bytes).

Some drivers show this alert, even if there is no communication error. To suppress these unnecessary messages the alert “MIDI-In Errors” can be suppressed.

USB Plug-and-play

SoundDiver is plug-and-play compatible with USB MIDI interfaces, i.e. when an interface is added or removed, SoundDiver automatically updates the MIDI ports in the setup.
Particular Issues on the Macintosh

The following options are only available in the Macintosh version, as they cover the direct MIDI interface support.

If you use AppleTalk in LocalTalk mode, you should disable AppleTalk in the Chooser while using SoundDiver, or you may suffer from communications problems.

The options are hidden in AutoLink mode, as in this case Logic handles communication with the MIDI interface(s).

Modem Port/Printer Port

Enable the port(s) you want SoundDiver to use for MIDI communication.

If only a “n/a” (for “not available”) appears for a port, this means the Mac OS told SoundDiver that this port does not exist. If you have a G3 or G4 with a GeeThree “Stealth Port” or Griffin “gPort” installed, you need to install the system extension which came with this hardware. This extension tells the Mac OS that the internal modem has turned into an external Modem port.

Make sure that you use the latest version of this extension, e.g. for Mac OS 9.0.4 and Stealth, you need “Stealth Serial Port 1.0.3” or higher.

If you are not using one of the ports for SoundDiver, disable it to allow another program to use it.

If SoundDiver doesn’t find a MIDI interface at the enabled port(s), a dialog box appears drawing your attention to this, and giving you the opportunity to alter the preferences.

If this happens, check whether the MIDI interface is

- connected at all
- connected to the correct port
- switched on.

This warning message applies only to the communication between the MIDI interface and SoundDiver, not to any MIDI devices that may be connected.
To stop the message from repeatedly appearing—such as when you are experimenting with something, simply disable both ports in the preferences.

**USB**

SoundDiver supports Emagic USB MIDI interfaces directly—without the need for OMS. You only have to drop the file “USB Unitor Family Driver” (which comes with the interface) into the System folder.

Use driver version 1.1 or higher. Older versions do not support the MT4, and cause problems when an Emagic USB dongle is connected.

If your Macintosh has no USB port, or SoundDiver has detected no Emagic USB interface, the text *n/a* (for “not available”) is displayed below the label *USB*. Otherwise *ok* is displayed, and the recognized interfaces are displayed (see below).

**Using Non-Emagic USB MIDI Interfaces**

If you want to use a non-Emagic USB MIDI interface, you have to use SoundDiver in OMS mode. See the section *OMS* from page 74 onwards.

**Hot-swapping**

If an Emagic MIDI interface connected to USB is switched off or unplugged, an alert is shown, and the interface’s MIDI ports are no longer available. If the USB interface is switched on again, the MIDI ports will be available again.

**Display of Recognized Interfaces**

If an MTP, Unitor8 or AMT8 has been detected, you will find a display to the right of the Modem or Printer port icon or “USB”. The display text may be:

**MTP**

One or two MIDI Time Pieces or one MIDI Express have been detected. Below, you see two squares for the devices
which can be connected. For the ones which have been detected, the squares are filled in green.

**MTP II**
As above, however one or two MTP II or MTP AV, or one MIDI Express XT have been detected.

**Unitor8**
One or more Emagic Unitor8/AMT8 have been detected; the first unit is a Unitor8 or Unitor8 MkII whose version number is shown in brackets. Below, there are eight squares for the devices which can be connected. For the ones which have been detected, the squares are filled in green.

**AMT8**
One or more Emagic Unitor8/AMT8 have been detected; the first unit is an AMT8 whose version number is shown in brackets. Below, there are eight squares for the devices which can be connected. For the ones which have been detected, the squares are filled in green.

**MT4**
An Emagic MT4 has been detected; its version number is shown in brackets. Below, there is one green square.

**Options for Modem and Printer Port**
The following options apply only to the Modem and Printer ports and to MIDI interfaces which are compatible with the “MIDI Time Piece” (MTP) de-facto standard. If you have a different interface, these settings are irrelevant.

**Check for MTP**
If this is active, SoundDiver scans for any MTP compatible interfaces that might be connected and automatically activates *MTP Cable Mode* when it finds one. Two MTPs can be connected to one port (one set to “1—8” and the other to “9—16”), and SoundDiver will recognize this.
If there is one or several Unitor8 or AMT8 are connected, they are detected if Check for MTP is active.

**Warning:** if you are using an older Opcode Studio 4 or a Studio 5 this function is not possible. Manually disable Check for MTP and enable MTP Cable Mode. The program then assumes you have a Studio 5 and activates cables 1 to 16.

**MTP Cable Mode**

If this is enabled, SoundDiver can address all the MTP outputs separately. As before, “M0” allows all modem port outputs and “P0” all printer port outputs to be addressed simultaneously, though this does not usually make much sense.

**Fast Speed**

This switches the MTP to its Fast Speed mode, where the communication between Macintosh and MTP is about five times faster than MIDI. Bear in mind, though, that it doesn’t accelerate communication between the MTP and the MIDI devices connected to it. Fast Speed allows for faster throughput only while simultaneous output on multiple MIDI outputs occurs, which is seldom the case in SoundDiver.

**Check MTP Configuration**

Before SoundDiver can communicate with devices that are connected via an MTP, the MTP should be set up correctly.

- The MIDI channels should not be readdressed in the MTP
- Program changes and control changes should not be filtered out on any channel of the inputs and outputs
- System Exclusive should not be filtered out of the inputs or outputs
- All inputs and outputs should be connected to the Macintosh port.

When you activate Check MTP Configuration these parameters are checked every time you start the program, and whenever
you activate a MIDI port. If only one of the parameters is set incorrectly a message appears:

**No further warnings**
Deactivates *Check MTP Configuration*.

**Don't configure**
The settings for the MTP are unaltered.

**Configure**
Our recommendation. The MTP is configured so that the above-mentioned conditions are fulfilled. All other settings are unaltered.

ℹ️ **Warning:** the newer Opcode Studio 4 emulates an MTP, but not completely. The result is that SoundDiver thinks it has recognized an MTP but the “Configure” option does not work and every time you start the program SoundDiver complains that the presumed MTP is incorrectly configured. In this case you should deactivate *Check MTP Configuration*.

**Use MIDI Manager if Available**
Here you can define how SoundDiver will proceed while initializing the MIDI connections if Apple MIDI Manager is installed:

**Never**
The MIDI Manager is always ignored.

**Ask**
A dialog box will appear where you can decide each time how to proceed:

**Never**
The option “Use MIDI Manager if available” is changed to “Never”, and the MIDI Manager is ignored.

**Don't use now**
The MIDI Manager is not used this time. When the MIDI connections are initialized the next time, the di-
alog will reappear, so that you can decide differently then.

**Use now**
The MIDI Manager is used this time. When the MIDI connections are initialized the next time, the dialog will reappear, so that you can decide differently then.

**Always**
The option “Use MIDI Manager if available” is changed to “Always”, and the MIDI Manager is used.

**Always**
The MIDI Manager is always used (without asking).

**Use OMS if Available**
Here you can define how SoundDiver will proceed while initializing the MIDI connections if OMS is installed:

**Never**
OMS is always ignored.

**Ask**
A dialog box will appear where you can decide every time who to proceed:

**Never**
The option “Use OMS if available” is changed to “Never”, and OMS is ignored.

**Don’t use now**
OMS is not used this time. When the MIDI connections are initialized the next time, the dialog will reappear, so that you can decide differently then.

**Use now**
OMS is used this time. When the MIDI connections are initialized the next time, the dialog will reappear, so that you can decide differently then.
Chapter 12
The Preferences

Always
The option “Use OMS if available” is changed to “Always”, and OMS is used.

Always
OMS is always used (without asking).

OMS Settings
The following buttons appear only in OMS mode.

OMS Studio Setup …
This button only appears in OMS mode. Clicking it opens the current OMS Studio Setup using the “OMS Setup” application.

OMS MIDI Setup …
This button only appears in OMS mode. Clicking it opens the current OMS MIDI settings using the “OMS Setup” application.

Particular Issues in AutoLink Mode

Synchronize Screensets
This option only appears in AutoLink mode. For details refer to the section Synchronizing Screensets on page 376.

Process Incoming MIDI only for Active Device
Here, you can opt to process the MIDI input only for the currently active device. When disabled, SoundDiver processes and updates the data of other devices, even if they are not currently active. If data is received which matches a device whose Module is currently not yet loaded, SoundDiver auto-
matically loads this Module. If you don’t wish for this to happen, enable the option.

SoundDiver is quite smart about how it decides which inactive virtual device has to be “tried out”; only SysEx messages are processed for inactive devices, and only when the Manufacturer ID matches.

Check Device Connections at Startup

With this option active, SoundDiver scans all devices when starting and waits for a reply message.

If a device does not answer a alert pops up:

Abort

cancels the entire check. This is useful if the computer is currently not connected to a MIDI interface, but SD is started for demo purposes only.

Skip

skips the device, continues with next device in the setup. This is useful if the device is temporarily unavailable

Delete

deletes the device from the set. This is useful if the device has been removed from the setup.

Retry

retries finding the device. This is useful if you have forgotten to switch on the device or a MIDI interface

Re-scan

deletes the device from the setup and selects the model for scanning
Chapter 12
The Preferences

After all devices have been checked, all devices selected by “Re-scan” are scanned, as if selected in the Install window (see the section Scanning on page 67).

Additional Timeout
This value adds an additional global amount of waiting-time to incoming MIDI messages. It is of use when you have a MIDI device inserted between the interface and end device (Patchbay, Thru-Box, other MIDI processor) that delays the MIDI communication.

You may have to raise this value in the event that devices cannot be found via scanning.

Request Retries
This determines how often SoundDiver tries to request entries until a failure message appears. With some devices, it’s worth trying more than once, if they are slow to react. The waiting-time, however, becomes unnecessarily long if the device refuses to answer at all (e.g. if it’s switched off). You should therefore set this value to match the limit of your patience.
12.2 Global Settings

Save Device Entries in Preferences File

If this option is activated, certain entries of all the devices installed in the Setup window are saved in the Preferences file when you quit SoundDiver or save the Preferences:

- **None**
  - nothing is saved;

- **I**
  - only the internal memory is saved (no cards, no ROM);

- **I+C**
  - only the internal memory and any available RAM cards are saved;

- **I+C+R**
  - everything is saved except the contents of the edit buffers;

- **All**
  - everything is saved.

The entries you enable are available as soon as you start SoundDiver, and you don’t need to use AutoRequest or manual Request to obtain them.
Chapter 12
The Preferences

It is very important that you note the following: if you use this option, you should never alter the memory contents in the device itself or with other programs. Otherwise you run the risk of creating severe inconsistencies between SoundDiver and the memory contents of your device. This could lead to valuable, new sounds being accidentally overwritten because SoundDiver is operating in accordance with an old version of the memory contents.

If you would rather be completely safe, don't use this function (set it to "None"); activate the AutoRequest function in all devices instead. You will then arrive at the same result, but it will always be up-to-date. Of course, this means you will have to wait for each of your devices to perform a complete Sysex dump every time you load SoundDiver.

Also see the section Auto Request from page 206 onwards.

Auto Snapshot Every x s

This parameter is available for SoundDiver only. If you enter a value (x) greater than zero, Edit Buffers that are being edited are regularly saved in the Snapshots library every x seconds (see Snapshot on page 321 in Chapter 8 Editing with SoundDiver).

It's often the case that when experimenting with various parameters you are too busy to remember to invoke the manual Snapshot routine, so you may lose some of your ideas. This function ensures you lose nothing.

Because the library also stores the time of each snapshot, you can see when the snapshot was made.

This function affects all edited entries, whether or not the corresponding editor window is open. This means you're free to open and close windows, change Edit Buffers or edit different devices.

To disable this function, enter a zero (displayed as a blank field).
Dependency Management

When this option is disabled, no dependencies (links) are taken into account at all, neither in Device windows nor Libraries. For further details on dependency management, refer to the section *Entry Dependency Management* on page 218. Default: activated.

Mouse as Slider

This option determines the way numerical values are altered with the mouse:

- when activated (default setting): click-hold the value and alter it by moving the mouse forwards/backwards. If you double-click the value, a field opens where you can enter a value manually via the computer keypad.
- when deactivated: one click on the value increases it by one step and a control-click decreases it.

Fader Tracking

This parameter controls the behaviour of the mouse pointer by interpolating between short mouse movements and exact editing. If the distance between minimum and maximum is too long, or the number of steps is too small, use this feature to change the sensitivity of the mouse. If you increase the value for Fader Tracking, a longer mouse-movement will be fulfilled in order to change a parameter. This especially is useful with small objects.

The default value is 3.0, which means that the mouse pointer has to move 300 pixels at least.

If an object is larger or wider than this value—the larger value of the object is used.

The behaviour of former SoundDiver versions is simulated at a value of 1.0.
This parameter does not affect the performance of the wheel of a wheel mouse.

**Num Lock**

When this is switched on, you can enter numbers via the number keys on the computer keyboard, instead of switching screensets.

You can also switch number lock off and on with the **Num Lock** key command.

For details see the section *Inputting Values via the Keyboard* on page 308.

Don’t mix up Num Lock with Caps Lock. See the section *Selecting Entries Using Names* from page 227 onwards.

**Deauthorize**

This button allows you to remove the SoundDiver authorization from the hard disk. The SoundDiver CD is not required for this task. SoundDiver will continue to run. However, the next time you launch it you will either have to re-authorize the drive or keep the SoundDiver CD inserted. Also see the section *Removing an Authorization (Deauthorizing)* on page 62.
12.3 Display Settings

Different Appearance

This option changes the look back to the former layout (Version 2.0). Key command: *Toggle look*.

Hide Value in Linear Parameters

This option hides the numerical values in the Editor window, to make this window smoother, as many numbers and separation lines are hidden. Key command: *Toggle Parameter Value Display*.

If this option is active, sliders and knob graphics are displayed larger, as the numerical values are not shown. Numerical values are displayed as a knob instead, but only if they are not accessed as a flip menu, and if they have at least 3 possible values and are not note number values.

The picture below shows a part of the Editor window of an EX5—left with active option, right disabled.
Chapter 12
The Preferences

3D Look
SoundDiver is easier on the eye when this is activated, as described above. In this case the background, all faders and knob graphics are displayed with a 3D look, if 256 (or more) colors are possible.

SoundDiver will operate more quickly with the neutral gray background and black on white objects.

Sound Effects
SoundDiver has a range of audible signals that announce e.g. start-up, the appearance of warnings or the completion of a process. These are enabled here.

Show Progress
When active, SoundDiver shows how a calculation or an input/output operation is progressing via a progress bar. On Windows it appears in the status line. This slows the program down a little, but lets you now know how long you have to wait.

Flicker-free Display
With this option switched on, screen updates are first prepared in the background and then copied to the screen as a whole. This results in a smoother appearance, especially while scrolling and operating envelopes and 3D sliders.
Flicker free display temporarily needs some memory, depending on the size of the window and number of colors. If there is insufficient memory available, the display goes directly to the screen. At the first occurrence of this problem, you get a warning message. In this case, you should either switch off flicker-free display, or (on the Macintosh) give SoundDiver more memory.

**ToolTips**

Holding the mouse pointer over an object without moving it for 1 second shows a tool tip window next to the object (normally below it) which shows the exact name of the object. After 10 seconds (or if the mouse is moved to another object or a key is pressed), it is closed again. Also see the section *The ToolTips* on page 179.

ℹ️: If Help > Show Balloons is enabled, the tool tip windows open immediately and are closed only if the mouse pointer is moved to a place where there is no object which can show a tool tip.

**When Pointing on Objects**

If this option is enabled, SoundDiver shows ToolTips when the mouse pointer moves over an object.

**While Editing**

If this option is enabled, ToolTips are shown in Editor windows while a parameter is edited.

ℹ️: This option is especially useful when you also disable display of parameter values (see the section *Hide Value in Linear Parameters* on page 401.

**Language**

Using this flip menu, the language can be changed. The changes take place after a reboot of SoundDiver.
The setting of the language is loaded from the default “SoundDiver 3.0 Preferences” file. Staring SoundDiver from another preferences file does not overrule these settings.

More specific details can be found in the section Language on page 412.

12.4 Safety Messages

You should only disable the safety messages once you feel comfortable about operating SoundDiver and you wish to speed up your work.

Loading Device Entries from Preferences

After the preferences that contain device entries have been loaded (see the section Save Device Entries in Preferences File on page 397), the following message appears:
Click OK to overwrite the memory contents of your devices. This ensures that SoundDiver and your devices are using matching data.

If you don’t need to see it, click the button No further warnings or disable after loading Device Entries from Preferences in the preferences.

**Saving Preferences**

When activated, you will be asked if you want to save preferences files. Otherwise, preferences files are automatically saved without notice. This options defaults to being deactivated.

- As this switch is saved in the preferences file itself, you have to set it for each preferences file separately if you use several preferences files.

- You can still quit SoundDiver without saving the preferences (and without the safety message) by holding ( :O) or using the key command Quit without saving Preferences.

**Overwriting Memory Entries**

When activated (default setting), you get a safety message whenever you do a paste into the Device window or use the mouse to copy into it.

When deactivated, the safety question appears only when you use Edit > Paste, and not when you move something with the mouse.

**Deleting Doubles**

This option is only relevant if the function Check doubles (on the Library tab) is active. When active, a safety question appears whenever an identical entry is found. This allows you to select whether or not the duplicate entry should be deleted.

When deactivated, the duplicates are deleted without warning.
Chapter 12
The Preferences

Editing Unknown Entries
This option determines whether SoundDiver should ask you whether to create an initialized entry, or request it from the device when you double-click an empty (unknown) entry.

If this message is disabled, the entry is automatically requested from the device. If the device cannot be addressed, the entry is initialized.

Closing Altered Editor Windows
If you have edited an entry in the editor and wish to close the last Editor window, SoundDiver normally automatically saves the changes.

If this safety message is active, a dialog appears in which you can
• OK saving the entry
• select a different target entry for saving
• close the window without saving
• decide not to close the window after all.

When inactive, SoundDiver saves the changes in the source entry, if it's available. This can also be a library entry if you opened the editor from a library.

Overwriting Edited Entries
If you have edited an entry in the editor, but haven’t yet saved it, it might get overwritten at some stage. This can happen during an AutoAudition operation, or where you want to open the Editor window of another entry which is using the same Edit Buffer. At this point you can decide what SoundDiver should do.

If Overwriting edited entries is active, a dialog box appears. Confirm with OK if you want to overwrite the entry. You would
then lose all your edits. If you select Cancel, overwriting is aborted, and you can save your edits at a later time.

When inactive, the edited entry is overwritten without warning.

**Create Logic Instruments**

See the section *Create Logic Instruments* from page 361 onwards.

### 12.5 Library

#### Auto-save Libraries Every x min

If you enter a value (x) greater than zero, libraries that have been edited are regularly saved every x minutes. To disable this function, enter a zero (displayed as a blank field). If new libraries are involved, you will be asked for a file name. This function makes your data that much safer.

Several seconds before the auto-save takes place, you will see a countdown bar. You can continue to work while this bar is shown.
Chapter 12
The Preferences

This function works on all libraries that contain edits (even the Snapshot library), even if their windows are closed.

To be quite sure about the safety of your data, set it to 1 min.

Bear in mind though, that the File menu item “Revert” is no longer of much use, since you can only load the last saved file, whether it was saved automatically or manually.

Reopen Libraries
On quitting, SoundDiver makes a note of the open libraries in the Preferences, and automatically opens them when the program is restarted (or when the Preferences file is reloaded).
If you don’t want this to happen, disable this option.

Check Doubles
If this option is activated, every time you paste into a library, the program searches to see whether an identical entry is already present in the target window. If it is, the new duplicate will be automatically deleted.

Prefer Selected Devices as Target
When activated, devices selected in the Setup window are preferred, even if there is another device which would be more suitable for the entries to transmit. This applies to Autaudition, Audition and Transmit from within a library window.
Default: deactivated.

Also see the section Device Selection Strategy when Sending from a Library on page 214.

12.6 Preferences File
SoundDiver allows you to set up the program the way you want it, and then recall these settings the next time you start the
program. To do this, SoundDiver saves all the default settings in a file.

This option is handy in the case that you need SoundDiver to adapt to different situations. Let’s assume, for example, that you use SoundDiver equally between home and the studio with different MIDI systems in each, or you wish use SoundDiver sometimes with one module, sometimes using all your MIDI devices at the same time.

SoundDiver’s configuration is loaded from the file which you use to start SoundDiver. You can adapt the program to a different system by starting SoundDiver with a suitable Preferences file. If you start SoundDiver directly, the standard Preferences will be used (see below).

Contents of the Preferences File

Here is a list of the parameters which are saved in this file and are recalled at the start of the program:

- all the global settings of the installed devices (i.e. all parameters in the device parameter box, as well as special internal data for each device which is not displayed);
- depending the option Save device entries in Preferences, certain device entries;
- the icon positions in the Setup window;
- all settings in the sequencer window (tempo of the internal sequencer, AutoPlay duration);
- the number of the currently selected screensets;
- all settings in the Preferences window;

On Windows, the currently selected language is saved separately in the Registry. See the section Language on page 412.

- all settings in the Options menu (AutoPlay, AutoAudition, MIDI Thru);
Chapter 12
The Preferences

- all settings in the Find window;
- all settings in the Page setup dialog box;
- the model names and data-type names of all modules (except the universal module);
- the file names (including path) of all the loaded libraries;
- all screensets (without the screensets of libraries, which are stored within the library file);
- all key commands;
- all settings in the Controller Assignment window;
- all other data that enables the program to run more smoothly.

Creating the Preferences File

When you quit SoundDiver, its current state is saved to disk:

- on Windows in the file DIVER\SoundDiver 3.0 Preferences.PRF
- on the Macintosh in the “Preferences” folder of the System Folder as SoundDiver 3.0 Preferences.

To create a new preferences file, use the function File > Save Preferences as... (see the section Save Preferences as… on page 145) and enter a different file name.

If you now open this file, SoundDiver starts from here and also saves alterations to its settings in this file (except language as previously described).

On Windows, SoundDiver launches only when clicking on this file, if you first have either dragged the file onto the program icon or assigned the file type PRF to SoundDiver in Windows Explorer (see the Windows 95/98 manual).

: The selected language is always stored in the default preferences file, even if SoundDiver is launched with a different preferences file.
In previous SoundDiver versions, the default preferences file name was “SoundDiver Preferences”. As this name has changed with version 3.0, it’s possible to start SoundDiver 2.0 and 3.0 with different settings without changing the other version’s settings.

If SoundDiver does not find the file “SoundDiver 3.0 Preferences”, the file “SoundDiver Preferences” is loaded and saved as “SoundDiver 3.0 Preferences”.

**Saving Preferences Automatically**

The preferences are automatically saved to disk whenever you quit SoundDiver. You just need to select File > Quit.

**Saving Preferences Manually**

**Saving Preferences in the Current File**

You can save the preferences any time by selecting File > Save Preferences (see the section Save Preferences on page 145).

**Save Preferences under a Different File Name**

To create a new Preferences file, invoke File > Save Prefs as... Don’t forget that during an automatic or manual save (see above) this file will be overwritten.

Spending a quarter of an hour or so setting up SoundDiver to suit your taste with the help of the above list is a very good idea. Make your default settings, lay out the Setup window and the other windows, create an Autoload library and a few screensets and then save all these preferences.

**Loading Preferences**

Even in the middle of working, you can load other preferences—for example those of a colleague—by selecting File > Open, and SoundDiver is immediately reconfigured.
Chapter 12
The Preferences

: New preferences can also be loaded by a simple double-click on their icon.
A message will ask you whether you want to save the existing preferences first.

Rebuild the Content of the Install Window
SoundDiver saves the contents of the Install window in a cache file within the preferences file. If this cache is incomplete or corrupt, SoundDiver can be forced to reload the content.

When loading a preference file with held down, SoundDiver will ignore the cached model and data type names and reload all Modules when opening the Install window.

Reload Icons
When loading preferences and while holding (​), the cached icon images are ignored.
This is useful if a module holds new graphics which you want to update. Also see the section Import New Icons on page 195.

Reset Preferences
To reset all preference settings, select Options > Initialize > All Preferences except Commands. Also see the section Initializing Key or MIDI Event Assignments on page 93.

Language
SoundDiver can select the language (currently only English or German) independent of the keyboard layout.
At the first start, you are asked which language to use. Auto assigns the language to match that of the keyboard layout.
Later, the language can be changed in the Preferences menu under Global settings. This however requires a restart of SoundDiver.
Windows: The language selection is stored in the Registry under:

HKEY_LOCAL_MACHINE\Software\Emagic\SoundDiver\Locale
Appendix A

Key Commands

The following tables list SoundDiver’s Windows, Macintosh and Atari key commands. To help you find a key command speedily, the tables are arranged by window, and, within the window, alphabetically by key command.

A.1 Differences of Key Commands

If you might operate SoundDiver on a different platform, here you find a list of the differences of the key commands.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>key command</td>
<td>-character</td>
<td>-character</td>
</tr>
<tr>
<td>modified key command</td>
<td>-character</td>
<td>-character</td>
</tr>
<tr>
<td>scroll by page</td>
<td>Page↑, Page↓, Page←, Page→</td>
<td>↑, ↓, ←, →</td>
</tr>
<tr>
<td>upper left resp. lower right corner</td>
<td>←, →</td>
<td>←, →</td>
</tr>
</tbody>
</table>

These differences apply to most of the default key commands. As they are user-definable, your settings may be different.

These differences apply to most of the default key commands. As they are user-definable, your settings may be different.

- on Windows corresponds to on the Macintosh. This corresponds to the Macintosh convention where is not used to modify another key. However, Windows do not recommend the use of so as to avoid combinations such as that would reset the computer.

The “NumLock function” (on the Macintosh) switches the mode of the numeric keypad. If it’s on, you can enter values via the numeric keypad. If it’s off, you can use these keys for choosing the screen sets and for controlling the sequencer.

If you are operating SoundDiver under M•ROS, commands ... are not valid as they are reserved for M•ROS partition-switching.
## A.2 Key Commands

Here you get an overview of the fixed key commands.

You find the list of the user-definable key commands in the Key Commands window (see section Key Commands Window from page 88).

<table>
<thead>
<tr>
<th>Windows</th>
<th>Macintosh</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>All windows</td>
<td>All windows</td>
<td>All windows</td>
</tr>
<tr>
<td>Esc</td>
<td>Esc, Esc</td>
<td>Abort MIDI communication</td>
</tr>
<tr>
<td>}</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Open relevant On-line Help window for context-sensitive assistance</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>Clear</td>
</tr>
<tr>
<td></td>
<td>Return</td>
<td>NumLock on/off</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Recall screensets 1…9</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Store current screenset as screenset 1…9 (twice)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>(twice) Recall screensets 11…99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Store current screenset as screenset 1…9 (twice)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Recall screenset 1…9 (NumLock on)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Store current screenset as screenset 11…99 (twice)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Store current screenset as screenset 11…99 (twice)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Recall screenset 1…9 (NumLock on)</td>
</tr>
<tr>
<td>Library, Setup, Install, Device</td>
<td>Library, Setup, Install, Device</td>
<td>Library, Setup, Install, Device</td>
</tr>
<tr>
<td>A...Z</td>
<td>A...Z</td>
<td>Select object that begins with the typed character(s) (Caps Lock enabled)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Select next object in the alphabetical order</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Select previous object in the alphabetical order</td>
</tr>
</tbody>
</table>
### Key Commands

<table>
<thead>
<tr>
<th>Windows</th>
<th>Macintosh</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>⌘I</td>
<td>I</td>
<td>Extend selection by object above</td>
</tr>
<tr>
<td>⌘O</td>
<td>O</td>
<td>Extend selection by object below</td>
</tr>
</tbody>
</table>

**Library window**

| ⌘I      | I         | Select previous entry |
| ⌘O      | O         | Select next entry |
| ⌘I and | ⌘O and   | Extend selection by previous/next entry |
| ⌘I      | ⌘O       | Extend selection by one page |
| ⌘I and | ⌘O and   | Extend selection to beginning/end |

**Install**

| ⌘I      | I         | Cursor up/down |
| ⌘I and | ⌘O and   | Extend selection by previous/next model |
| ⌘I      | ⌘O       | Extend selection by one page |
| ⌘I and | ⌘O and   | Extend selection to beginning/end |
| ⌘O      | O         | Open Help window for installing selected device |
| Esc     | Esc       | Close window |

**Setup window**

| ⌘I      | I         | Store all edits |
| ⌘O      | O         | Open Device window for selected devices |
| ⌘I and | ⌘O and   | Select device in given direction |
| ⌘I      | ⌘O       | Extend selection by previous/next device |
| ⌘I and | ⌘O and   | Extend selection by left/right device (icon view only) |
### Key Commands

<table>
<thead>
<tr>
<th>Windows</th>
<th>Macintosh</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device window</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>↑↓</td>
<td>↑↓</td>
<td>Select next entry in given direction</td>
</tr>
<tr>
<td>⌘↑ and</td>
<td>⌘↓ and</td>
<td>Extend selection by entry above/below</td>
</tr>
<tr>
<td>⌘← and</td>
<td>⌘→ and</td>
<td>Extend selection by entry to the left</td>
</tr>
<tr>
<td><strong>Find window</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>⌘Esc</td>
<td>Esc</td>
<td>Close window</td>
</tr>
<tr>
<td>⌘F</td>
<td>F</td>
<td>Start Find</td>
</tr>
<tr>
<td><strong>Help window</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>↑↓</td>
<td>↑↓</td>
<td>One line up/down</td>
</tr>
<tr>
<td><strong>Dialog boxes</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>⌘Esc</td>
<td>Esc, ⌘Esc,</td>
<td>“Cancel” or “Abort” button</td>
</tr>
<tr>
<td>⌘F, ⌘C</td>
<td>F, C</td>
<td>button with enlarged borders</td>
</tr>
<tr>
<td>⌘H</td>
<td>Help</td>
<td>Help button</td>
</tr>
<tr>
<td>a…z</td>
<td>a…z</td>
<td>the button that begins with that letter</td>
</tr>
<tr>
<td><strong>Editor</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>↓↓</td>
<td>↓↓</td>
<td>Select next parameter</td>
</tr>
<tr>
<td>0…9</td>
<td>0…9</td>
<td>Input value (NumLock on)</td>
</tr>
</tbody>
</table>

---

**Emagic**  
**SoundDiver**
### Using the Mouse

<table>
<thead>
<tr>
<th>Windows</th>
<th>Macintosh</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on object</td>
<td>if object already selected: no change otherwise: selects object, deselects all others</td>
<td></td>
</tr>
<tr>
<td>⌘-click</td>
<td>⌘-click</td>
<td>Toggles selection of objects</td>
</tr>
<tr>
<td>⌘-click</td>
<td>⌘-click</td>
<td>selects block (block end; previous click defines block start)</td>
</tr>
<tr>
<td>⏯-click in Library/Device window: as click, but with toggled AutoAudition (e.g. without AutoAudition if it had been enabled)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>⏯-click in Library/Device window: as click, but with toggled AutoAudition (e.g. without AutoAudition if it had been enabled)</td>
<td></td>
</tr>
<tr>
<td>Double click</td>
<td>Setup: opens or activates Device window Install window: scans device Device/Library: opens editor Editor: opens &quot;enter value&quot; window</td>
<td></td>
</tr>
<tr>
<td>Click + drag</td>
<td>Moves or copies selected objects. Library: Within the library, moves objects Dragging to another library or to a device copies the entries Device window: Within the device: swaps the entries Dragging to another device or library copies the entries</td>
<td></td>
</tr>
<tr>
<td>⌘-click + drag</td>
<td>Editor: copy parameter group</td>
<td></td>
</tr>
<tr>
<td>⌘-click + drag</td>
<td>⌘-click + drag</td>
<td>Within a Device window: duplicates selected entries</td>
</tr>
<tr>
<td>Click on background + drag</td>
<td>rubber band: selects objects within or touched by it; deselects others</td>
<td></td>
</tr>
<tr>
<td>⏯-click on background + drag</td>
<td>rubber band: toggles selection of objects within or touched by it</td>
<td></td>
</tr>
</tbody>
</table>
Troubleshooting

This chapter gives the answers to the most frequent queries that arise through working with SoundDiver.

Please don’t forget the “SoundDiver Readme” file on the program CD, containing answers to the latest queries.

C.1 General

What SoundDiver version do I have?

- Start SoundDiver: at startup, the SoundDiver info window (“splash screen”) is shown. At the right bottom the exact version number and date when this version was created is shown. You can open the info window also while SoundDiver is running.

- Mac: Click the SoundDiver program icon once in the Finder and choose menu item “Get Info” in the File menu.

- Windows: Click the file “SoundDiver.EXE” in Windows Explorer with the right mouse button and choose “Properties” in the appearing context menu. Click the tab “Version”.

What version does a specific SoundDiver module have?

Activate a corresponding device in the Setup window and click the module’s name right to “Module” in the device parameter box. A dialog appears which shows the module name, version number, release number, creation date and a copyright note.
Appendix C

Troubleshooting

Please note that the release number is not incremented at every small improvement. It is advisable to simply look up the file modification date.

What version does a specific SoundDiver adaptation have?
Adaptation don’t have version numbers. Simply check the file date.

How do I get hold of the latest versions of SoundDiver?
• If you have Internet access, go fish on our WWW site: http://www.emagic.de
• Please contact Emagic or your countries Emagic distributor.

How do I get hold of new adaptations?
You can get these and new libraries in the Internet as well.

I have created an Adaptation on my own. How can I share it with other SoundDiver users?
Please send an email to info@emagic.de.

I get a message “Text not found. Check Text Resource for ID 'xx'”
This means that a text resource is missing in SoundDiver or one of its modules. Please inform us about this (send an email an support@emagic.de). This problem is not serious, only the text to be displayed is shown as “Text not found”.

Emagic
SoundDiver
I get a message “SoundDiver is about to terminate unexpectedly. Try to save your files. It’s better to not overwrite the existing files. Please report how this occurred. Email: support@emagic.de—Don’t save—Save”. What am I supposed to do?

SoundDiver has crashed due to a software bug. This ought not happen of course but—nobody’s perfect. To prevent you from data loss, you can save the opened and edited libraries, adaptations and preferences in new files after clicking “Save”. For each of these files, you get a file selection box.

You should not overwrite the existing files—it is likely that the opened files cannot be saved properly because of the crash. Thus choose a file name like “My Library—crash recovery”.

Please send a bug report to support@emagic.de. Please don’t forget to state:

- SoundDiver version (and, if AutoLink is used, Logic version)
- computer model, operating system version
- MIDI interface model, driver version (if a driver is used)
- a precise description of the operations you did immediately before the crash occurred. Try to reproduce the crash. Sometimes a crash cannot be provoked a second time—in this case it’s hard to track down the bug.

I get a message “Memory is tight for flicker-free drawing. Please increase partition size, use lower screen color resolution, or switch off “flicker-free redraws” in the Preferences.”

Flicker-free drawing temporarily needs a lot of memory. The amount depends on the window’s size and how many colors the screen is currently able to show. If you want flicker-free drawing, you should allocate more memory to SoundDiver (select its
Appendix C
Troubleshooting

icon in the Finder, open the Info window with and change “Preferred size”).

C.2 Installation

Windows: After installing a MIDI driver in Windows 95, there is a crash in MMSYSTEM.DLL.

This is a known problem in Windows 95 and occurs when you try to install more than 11 MIDI ports which may happen when you want to use two networked MIDI Time Pieces.

This is not a bug in the MIDI drivers or SoundDiver, but in Windows 95. This bug has been fixed in Windows 98. Please use Windows 98 or newer.

How do I install new versions of module or adaptation files which I have downloaded from the Internet?

1. Quit SoundDiver
2. Make sure that the file is unpacked.
   - The files are packed in StuffIt 5.0 format. Older StuffIt versions can’t handle this format. We recommend to use the free StuffIt Expander 5.5 or newer.
   - Windows: Make sure that the used unpacking tool is aware of long file names. WinZip version 6.0 or higher, VisualZIP and Aladdin Expander are suitable; unsuitable are PKZIP and StuffIt Expander 1.0.
3. Move the file into the folder “Diver” which is located in the same folder as the SoundDiver application file.
4. Run SoundDiver. The new version is automatically used.
5. If the Module offers new supported models, they might not yet be shown in the Install window. In this case, simply install another device supported by the module (causing the module to be loaded), and the list will be updated.
C.3 Startup

Windows: At startup, I get an error “MMSYSTEM020”.
A faulty MIDI driver is installed. The name of the affected MIDI port is shown in the title bar of the error message. Please contact the manufacturer of the MIDI interface.

You can configure SoundDiver to ignore the offending driver. See section How to Block MIDI Ports (Windows:) from page 82.

Windows: At startup, SoundDiver crashes or hangs.
Again, a faulty MIDI driver is probably the cause of the problem. See above.

I get an error message “File not found.”
Probably SoundDiver tried to open a library file which has moved. Don’t worry. Simply reopen the desired library, and the next startup will work flawlessly.

I get a message “Entries for device “x” have been saved using a different version of SoundDiver Module “y”. Loading them with the current Module might lead to wrong data. Load them nevertheless?—Cancel—Skip—Load
During the development and enhancement of SoundDiver modules, it is sometimes necessary to change the internal order of entries. To speed up loading, a device entry is saved in the preferences file with an internal counter, not the full memory location statement. The message gives a hint that the internal order might have changed. After clicking “Load”, you should first check if all data is loaded to the correct memory locations.
Appendix C
Troubleshooting

If not (or if the names are not shown correctly), you should re-request the data from the device, just to be sure.

C.4 Scanning

Scanning doesn’t find some devices.
- Is the device switched on and correctly connected in both directions?
- Does the device process SysEx messages?
- Some devices react incorrectly when their device ID is set to “omni” or “all”. Change the device ID to a different value.
- Check that compatible devices are set to different IDs. This also applies to devices that are quite different, but support the Universal Device Inquiry.
- Patchbays that are not supported by a special module cannot be fully scanned by SoundDiver. Only the current setting of the patchbay is scanned. Program your patchbay such that as many outputs as possible (except those to the computer) are patched to the input from the computer, and that as many inputs as possible (except those from the computer) are patched to the input to the computer. Now do a Scan and insert, for the found device, the current Program number of the patchbay in the “Patchbay Prg” parameter, together with the other relevant parameters (see section Patchbay Program on page 204).
- You may be using a patchbay or Thru box that is delaying the MIDI data. If this is the case, increase the value of the “Additional Timeout” parameter in the Preferences.
When I scan a patchbay, I get the message “No patchbay connection found”.

Follow the advice in the Help file (key words “Installation” and “Scan”) on which of the patchbay’s ports the computer should be connected, and how the patchbay should be configured.

Some patchbays (e.g. the MIDITEMP PMM-44/88) don’t react to SysEx on the “Control Input” but on every input for which a connection to an output has been defined. However, as soon as SoundDiver starts scanning and sends a SysEx message that reprograms the patchbay, the connection could be broken and the patchbay remains mute. If the “Control Inputs” have been incorrectly set, you may have a situation where the patchbay begins to react, but SoundDiver can no longer determine to which inputs and outputs the computer is connected.

C.5 MIDI Communication

Mac: I get the message “The Modem/Printer Port is used by another program, LocalTalk or ARA”

Check whether another program is using the port in question. It might be a modem terminal program, or fax software. The modem or printer ports must be free before SoundDiver is started.

Tip: if you use FaxSTF you can very quickly free-up the port using the program “Fax State” that comes with the program.

If AppleTalk is active and is running over LocalTalk (this will always be the case so long as you don’t have EtherNet), the printer port is reserved. You may find it wise to disable AppleTalk before starting SoundDiver.
Apple: I get the message “MIDI data could not be sent…”

SoundDiver could not find a MIDI interface on this port. Follow the advice in section Modem Port/Printer Port on page 388.

I sometimes get transmission or checksum errors.

- Apple: AppleTalk must be disabled. AppleTalk interferes with MIDI, and this becomes apparent with SysEx communications.
- Apple: The Printer Port of PowerBook models (especially of the 1xx series) is not reliable. Use the Modem Port instead.
- If the device sometimes fails to react to requests, increase the “Timeout” parameter.
- If the device sometimes fails to receive a Dump, increase the “Send Pause” parameter.
- Apple: It is just conceivable that unmounted SCSI drives (e.g. CD-ROM, removable hard disk or MO) might interfere with MIDI as the drive is continually looking to see whether a media is present. Insert the media. Or switch off the drive and restart the Macintosh.
- Apple: The PowerBook models of the 1xx series (except the PowerBook 190) have a common problem when receiving large amounts of data at the serial ports. This can currently only be fixed with OMS 2.2 or newer. You should use SoundDiver in OMS mode (see section OMS on page 74).

When I send dumps to a device, it does not receive them (possibly a message “memory protected” appears in the display).

Some devices (above all Yamaha devices) switch on memory protection by default at power-up. For those devices, SoundDiver has a function “Auto Bulk Protect Off” which you can
find in the “special parameters”. This function however has an effect only if SoundDiver is started after all devices have been switched on. So always first switch on the devices, then start SoundDiver.

I get the message “SysEx communication error”
This can have various causes.

Here’s how to identify the problem.

• First click “Abort” to put SoundDiver in “normal operation” again.

Note: each time you found a potential error source, and the data transfer still doesn’t work, you should restart trouble shooting at step 1 again.

1. Does the device transmit data?
Try to find out if the device transmits the desired data at all. Some devices signal this in the display. If you can’t see any activity there, watch the MIDI In LED of the MIDI interface, if any.

Very useful is a MIDI analyzer. Recommended: Studiomaster MA-36

• Yes: continue with item 8 on page 431.
• No:

2. Is the device in the correct mode?
Some devices (e.g. Roland JD-800) can transmit data of a certain type only if they are in the appropriate mode (e.g. the JD-880 can transmit Performances only in Performance mode). All Modules and Adaptations try—if possible—to change the device mode automatically. However, some devices don’t allow to change the mode via MIDI. In this case, you will find a note in the help file. Or the device did not receive the mode change message for another reason.
Appendix C
Troubleshooting

- No: put the device in the appropriate mode.
- Yes:

3. **Does the device have the requested data at all?**

Card entries of course can only requested if a card is inserted.

- No: then the data cannot be requested.
**Solution:** insert a card, or switch off the card in the “Special Parameters”.
- Yes:

4. **Does the device recognize SysEx messages?**

Some devices don’t have SysEx recognition activated by default. However, in this case the scan function should have failed before.

- No: the device must be able to recognize SysEx messages.
**Solution:** consult the SoundDiver help file, page “Installation” as well as the devices’ user manual. The desired parameter can be found in the “System” or “Global” data in most cases.

Some devices (e.g. Ensoniq ESQ-1) deactivate SysEx at each power-up. Then you must activate SysEx each time.

- Yes:

5. **Does the Device ID match?**

When the device has been scanned by SoundDiver, the Device ID should be correct. But maybe it has been changed in the device by a reset or a crash.

- No: reconcile the Device ID with the one in SoundDiver.
**Solution:** find out the device’s ID and set the same value in SoundDiver’s Device Parameter box.

Most devices count the Device ID from 1, however others from 0 or 17. This is taken into account by SoundDiver.
**Tip:** avoid settings like “all” or “omni” in the device.

- Yes:

**6. Is the Output and cable number correct?**

Probably you have changed the MIDI cabling and forgot to tell this SoundDiver. Or you have installed the device manually and not with the Scan function and forgot to adjust these settings.

- No: set the correct output and/or cable.
- Yes:

**7. Is the MIDI cabling from the computer output to the device’s input correct?**

Check the MIDI cabling. Have you really plugged the cable into the device’s In and not the Out jack? Is the connector tight? Maybe the cable is defect or has a loose connection.

- No: Correct the cabling. Try out a different, short MIDI cable.
- Yes: Either the device has an old software version which is not compatible with the SoundDiver Module resp. Adaptation (e.g. Ensoniq TS-10 V1.x), or there is a software bug in the Module or Adaptation.

**Solution:** please contact the device’s distributor and/or Emagic. It is useful if you have done a test run with the MIDI Monitor window opened, so that we can check the transmitted request message.

**8. Does the computer receive MIDI?**

You can check this in two ways:

Open the Sequencer window. If data is arriving, a bar is appearing instead of “NO IN”, with an X to the left (if SysEx data is arriving).

Open the MIDI In window. Incoming data is shown as hexadecimal numbers.
Appendix C
Troubleshooting

• Yes: continue with item 12 on page 433.
• No:

9. Is there a MIDI patchbay or an “intelligent” MIDI interface between the device and the computer?
   (the latter includes devices like Motu MIDI Time Piece or Opcode Studio 4/5)
   • Yes: then the patchbay is setup incorrectly.
   Solution: first try to find out if the dump is arriving in the patchbay. You will notice by an input LED, or you can activate a monitor or EYE mode. If data is arriving at the patchbay, it is setup incorrectly. Adjust the patchbay so that there is a connection from the device to the computer, with nothing (especially not SysEx) filtered out.
   SoundDiver does this automatically with supported patchbays (at this time Miditemp PMM-44/88, Roland A-880, Waldorf Midibay, J.L.Cooper Synapse, and Ensoniq KMX-8/16). If it still doesn’t work, a program error exists. Please contact Emagic.
• No:

10. Is the corresponding computer port setup correctly?
   Open the Preferences, page “Communication”. Is the corresponding port activated? Does “Fast Mode” match with the interface’s setting? Is “Cable Mode” activated, as far as you use an MTP compatible MIDI interface?
   • No: configure the port correctly. Possibly the interface has crashed. To make sure, switch the interface off and back on, and set Fast Mode and Cable Mode accordingly.
   To be able to transmit and receive MIDI data, the computer’s port must be activated. Normally, SoundDiver complains immediately if it is not able to send data, or at startup if no ports are activated.
• Yes:

11. **There is no MIDI connection from the device’s output to the computer.**

**Solution:** check the MIDI cabling. Have you really plugged the cable into the device’s In and not the Out jack? Is the connector tight? Maybe the cable is defect or has a loose connection.

Some devices like Lexicon LXP-1 or LXP-5 have a combined Out/Thru jack which must be switched to Out mode with a switch in the device’s inside or at the back panel. You will find an appropriate note in the help file.

12. **Does data sometimes arrive incorrectly?**

This means that names are shifted by one or two characters, or strange characters appear.

• Yes:

Windows: the MIDI driver does probably not work correctly.

**Solution:** Try to get an updated driver from the manufacturer, or use a different MIDI interface.

![AppleTalk](apple-talk.png): AppleTalk is probably enabled.

**Solution:** switch off AppleTalk in the “Chooser” window.

LocalTalk-based AppleTalk does not go with the reception of large data amounts at a serial port, as it sometimes prevents that incoming bytes are read so that it is “overrun”. If you really need network functions, you should consider to upgrade from LocalTalk to EtherTalk. Please ask your Apple dealer for details.

• No:

13. **Does an active dump work?**

Try to transmit the desired data manually from the device. Does SoundDiver show the transmitted data now?
Appendix C
Troubleshooting

• Yes: continue with item 15 on page 434.
• No:

14. Is the device’s ID set to “all” or “omni”?

• Yes: this setting cannot be used with SoundDiver. Most SoundDiver Modules give you a note in this case.

Solution: Set a different Device ID at the device. Don’t forget to provide the same setting in SoundDiver.

The setting “all” means that the device answers to all requests (no matter which Device ID they used), however sends its own dumps with device ID 1 or 128. This can lead to conflicts.

• No: then the MIDI cable from the device’s output to the computer’s input is broken.

15. Do you have several devices which are SysEx compatible?

This can even be several devices of the same model row, like TX802 and DX7 or SD-1 and VFX.

• Yes: then several devices are reacting simultaneously what SoundDiver cannot recognize, since SysEx incoming simultaneously is not merged correctly.

Solution: Make sure that all compatible devices use different device IDs (don’t forget to make the same changes in SoundDiver). If this is not possible, you must connect the devices to different computer outputs.

Some older devices (e.g. Yamaha DX7, TX816) always transmit on ID 1 although they are set to a different channel. The DX7 Module is aware of this fact. For further details, see the DX7 help file.

• No: then the Timeout is too short.

Solution: Increase the parameter “Timeout” in the Device Parameter box. It’s ok to increase it by 1000 ms; in this case you’re only “punished” by a longer pause if the device doesn’t answer.
This case can occur if patchbays or MIDI interfaces are inserted which cause a significant delay of the MIDI data, or if the software of your device reacts slower than that with which the Module or Adaptation was developed. In the first case, you should increase the parameter “Additional timeout” in the Preferences instead, since this delay applies to all devices.

Every time I activate a certain device, a program is recalled in this or another device unnecessarily.

You have defined a “Patchbay PRG” for this device, but did not adjust the MIDI channel accordingly. This MIDI channel may only be used by the patchbay to be switched. If the device is connected to the computer, using “Patchbay PRG” is not necessary and only produces unwanted delays.

C.6 Library

I have several presets from two similar devices (e.g. E-mu Proteus 1 and Proteus 2) and with different device IDs in one library. When I click them with AutoAudition activated, they are always sent to the same device.

If you don’t want that, make sure that no device is selected in the Setup window before you click an entry. Alternatively you can switch off “Prefer selected devices as target” in the preferences (see section Prefer Selected Devices as Target on page 408).
Appendix C
Troubleshooting

C.7 Device Window

I can’t find a certain Card or ROM bank.
Open the “Special parameters”. Possibly you have to activate the desired bank manually first. This is the case for all adaptations, as adaptations (in contrary to modules) cannot find out automatically which banks exist in the device.

If there is no switch for the desired bank, the bank is not supported by SoundDiver because the device does not know the necessary SysEx commands. A possible workaround is to select the bank’s sounds at the device’s front panel one by one and afterwards request the edit buffer in SoundDiver. You can easily create a library of this bank by using the function “Append to Library” (see section Appendix Library on page 234).

When “AutoAudition” is activated, the clicked entries are transmitted to the device’s edit buffer, but nothing or a different sound is heard.
In adaptations for multi-timbral devices, the MIDI thru channel is not switched to the corresponding channel automatically. You have to do that manually in the device parameter box. See section Thru Channel on page 202.

This problem can also occur when it’s possible to adjust the MIDI channels of a Multi’s (Combi’s, Performance’s) parts individually, but SoundDiver does currently not know this Multi. Then SoundDiver cannot know which Thru channel has to be set. Solution: request the Edit Multi (Edit Combi, Temporary Performance).
C.8 Editor

What does a particular parameter do, and how do I use it?
Click the parameter and choose Window > Help to make a Help window appear giving information on that parameter.

And what does “No help available” mean in the Help window?
It means that there’s no Help file yet for this adaptation. Please contact Emagic or the adaptation’s author.

I cannot grab an envelope point (it lies outside the frame).
In this situation a little arrow appears that points to it. Click the arrow.

I can’t see an envelope point, although the envelope is completely visible.
This can happen if two points coincide. Possible reasons:
• the time duration between two point is zero
• for some devices (e.g. Roland D-50), a segment of the envelope is omitted if two points have the same level value.
Simply drag away the visible point, then the other hidden one will appear.
Appendix C
Troubleshooting

When I use the knobs or sliders I can’t get a particular value because the mouse movement is too coarse.
Hold down \(\text{[Alt]}\) while moving the mouse. Or click the parameter so it flashes and enter the value via the numeric keypad and/or \(\text{[↑]}\) and \(\text{[↓]}\).

Opening a flip-menu takes too long.
Press \(\text{[Alt]}\) when clicking and move the mouse up or down.

I cannot enter any numbers.
Activate “Num Lock” (see section Inputting Values via the Keyboard from page 308), and enter the number with the numeric keypad.

With some parameters I get incorrect or too few values; some parameters aren’t even visible.
- Has the correct model been installed/scanned?
- Does the module support that particular model?
I cannot hear what I’m editing.
- Has the device been set to a different mode by mistake?
- Possibly the entry being edited must first be activated in a different editor (e.g. for Pans, Tuning Tables, Wavetables, Waves etc.). Some modules however have a specific “Monitoring” mode for this purpose.
- If the device is connected to a patchbay, and for the patchbay a “Standard PRG” is defined, this program must include a connection from the computer to the device being edited.
- Some devices crash if they receive rapid successions of parameter change messages. However, the modules and adapta-
tions have been suited to this behavior. You may find it useful to increase the “Send Pause” parameter.

- The MIDI thru channel may not be correct. Modules can adjust it automatically, however it may be necessary that the edit buffers for Multis or Combis and/or the Global Data or System Settings have been received. Further information can be found in the on-line help.

“Paste” is not possible

The types of source and destination parameter group do not agree. They sometimes look similar, but can contain small differences.

When changing Edit Buffers I get a message about pressing a key.

Either this is a particularity of the device, or SoundDiver does not know which version your device is and thus assumes it’s the oldest version.

Later versions of some devices have new SysEx features that can be used by the module only if the module knows that the device is of this later version. This device must be installed through scanning (not manually).

I cannot find a particular parameter.

Some parameters appear only if SoundDiver knows for sure that the device also knows them. SoundDiver can tell this by looking at the device’s software version number. For SoundDiver to know the version number, the device must be installed via “Scan” (not manually). Look in the Device Parameter box to see if that particular version is supported.
Appendix C
Troubleshooting

When I edit a single parameter, all the Easy Page parameters are set to 0.
This is a requirement of the program for technical reasons, and is quite normal.

C.9 AutoLink

Mac: When started, Logic announces “The Modem/Printer Port is used by another Program”.
Logic tries to access the serial ports before SoundDiver gets to know that Logic has been started and therefore releases the ports. This is why it is advisable to always start Logic first, then SoundDiver. If you happen to start the programs in the opposite order, click “Cancel” in the appearing error message, wait for the AutoLink signal tone (“plop!”) and reactivate the ports in Logic’s preferences.

A device’s sound names are shown blank or incorrect.
See the advice given in section If AutoLink Doesn’t Work… on page 364.

Logic sends everything out of the same output, regardless of what I set in SoundDiver.
You are probably using Logic in OMS mode. If you want to use AutoLink and OMS simultaneously, you must activate OMS in SoundDiver as well. See section Communication with Logic in OMS Mode on page 77 and section Use OMS if Available on page 393.
MIDI Thru cannot be switched on or off; the MIDI Thru channel and port are not set correctly.
You need SoundDiver Version 1.505 upwards and Logic Version 2.5 upwards.

When I record SysEx from SoundDiver into Logic, the device doesn’t recognize it.

SoundDiver is normally able to tell Logic exactly which port and cable are to be used to send a MIDI message. This is not possible during recording. Instead, during Record mode, all data is sent via the Instrument of the current track. It therefore has to be set correctly.
Appendix C
Troubleshooting

Emagic
SoundDiver

442
Appendix D

Glossary

This glossary explains the most common SoundDiver terms.

**3D look**  A three-dimensional-look of background patterns, sliders and knobs to SoundDiver's displays.

**Active device**  The device whose parameters are currently shown in the Setup window’s device parameter box. MIDI thru is always set to the – (except there is a Patchbay Standard Program or “Preserve Thru port/ch” is enabled). When activating a Device or editor window, the appropriate device is automatically activated.

**Adaptation**  A file within SoundDiver that allows the data of a device to be managed. Adaptations run within the Universal Module and are user-creatable and editable.

**All Notes Off**  A MIDI command that switches off droning notes on all channels.

**Audition**  To send one or more entries to a device’s edit buffer, so that it can be auditioned.

**Authorization**  The installation of SoundDiver's copy-protection onto hard disk; also, the name for the copy-protection file itself.

**AutoAudition**  Automatically sends a selected entry to the device’s appropriate edit buffer (see also →Audition).

**AutoLink**  The internal connection between →Logic and SoundDiver. AutoLink is used in the direct exchange of sound names and MIDI data between the two programs.

**Autoload library**  The library file called “Autoload.lib” and which has to be in the “Libraries” folder for it to be auto-loaded when the program is started.
AutoPlay  The function that sends a test note to the MIDI device whenever an entry is selected.

Auto Request  The function that automatically requests the memory contents from the connected devices when SoundDiver is first started.

AutoSort  The library function that auto-sorts the library after every alteration to the contents.

AutoSurf  Previously used term for →AutoAudition

Bank  A certain number of →entries of the same →data type

Card  Memory card used by synthesizers, etc. to store →entry data

Child Entry  →Entry to which other entries (→parent entries) have a dependency

Clipboard  The part of the computer memory that’s used during Cut, Copy and Paste operations.

Compare  A comparison function: by swapping between the original and edited versions you are able to check the progress of your editing.

Controlled parameter  A parameter in a SoundDiver editor which can be controlled by using a →Controller Assignment.

Controller  A control on a →fader box which generates a certain MIDI message

Controller Assignment  A record which defines the remote control of a parameter.

Controller Assignment Set  A set of →Controller Assignments which can be activated

Controller message  The MIDI message generated by a →controller

Conversion  The transformation of sounds from one device into the format of a different, yet related, device. For instance,
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SoundDiver</strong></td>
<td>Modules automatically and intelligently convert DX7 sounds into those for a SY77.</td>
</tr>
<tr>
<td><strong>Copy protection</strong></td>
<td>A necessary evil that is there to protect the authors' intellectual property by preventing the cloning and duplication of a computer program by unscrupulous thieves. SoundDiver's copy-protection is programmed into the original CD and can be transferred to a hard disk (→Authorization).</td>
</tr>
<tr>
<td><strong>Cursor</strong></td>
<td>The high-lighting that marks an on-screen object as ready for editing—takes the form of an arrow, block or color-inversion; the blinking border around a parameter.</td>
</tr>
<tr>
<td><strong>Data consistency</strong></td>
<td>In SoundDiver: the similarity between a Device window and the memory contents of its corresponding device (automatically controlled by SoundDiver).</td>
</tr>
<tr>
<td><strong>Data type</strong></td>
<td>Class or kind of an →entry. Depending on manufacturer and device, data types may be called “Multi”, “Combi”, “Performance”, “Program”, “Performance”, “Global Settings” etc.</td>
</tr>
<tr>
<td><strong>Default</strong></td>
<td>The preset or first settings that appear in the program—can normally be changed by the user.</td>
</tr>
<tr>
<td><strong>Dependency list</strong></td>
<td>A display in →Library and →Device windows showing the various dependencies of an entry to →child entries (“uses…” ) and from →parent entries (“is used by…” ).</td>
</tr>
<tr>
<td><strong>Detailed display</strong></td>
<td>A viewing mode in the →Editor in which parameters are shown in detail. →Overview.</td>
</tr>
<tr>
<td><strong>Device</strong></td>
<td>A MIDI synthesizer or sampler or other MIDI hardware (patchbay, effect unit) that is supported by a SoundDiver module or adaptation.</td>
</tr>
<tr>
<td><strong>Dialog box</strong></td>
<td>An input box that requires a decision by the user (yes, no, choice of options). The default choice (normally the safest or most logical one) has an enlarged border and can be selected using ⌘. Not a true window.</td>
</tr>
<tr>
<td><strong>Dive !</strong></td>
<td>Previously used term for →Edit.</td>
</tr>
</tbody>
</table>
Dump Request  The MIDI command sent by the receiving device, requesting a transmission of System Exclusive data. This allows a device to be “milked” of its data by an outside device or program such as SoundDiver.

Duplication  The copying of an object—such as a Device entry—within a window.

Easy Page  Forms part of the → Overview in the → Editor. The ~ contains a selection of the main sound parameters that provide “instant gratification” in sound editing.

Edit  In Library and Device window: to open an editor window of one or several editor windows. Every ~ contains an → Audition.

Edit Buffer  A temporary memory in a device, used for editable data such as sounds or multis.

Editor  A SoundDiver window showing the sound and program parameters of a device in graphic and alphanumeric detail, where entries can be edited.

Entry  The name given to a packet of data from a device (e.g. sound, multi, system-related data, drum kit).

Entry Dependency Management  Used to be called “Item Link Management”; a SoundDiver function that controls the inter-dependency or cross-referencing of entries. The ~ modifies e.g. a Multi-Program when its sounds are moved to different locations within the Devices.

Fader box  A device which transmits MIDI messages and thus initiates a → Controller Assignment.

Patchbay module  The module for a → Fader box; it contains special functions for → Controller Assignments.

Flip-menu  A list of choices that appears when the appropriate field is click-held—moving the mouse highlights the various choices, and releasing the mouse button activates the last choice to be selected and makes the list disappear.
Grab  To click-hold an object—e.g. prior to dragging it.

Help  →On-line Help

Icon  A graphical on-screen symbol that represents an object (e.g. a device).

Identity number  (also called Device ID, Device Number, Unit Number, Basic Channel): a device’s unique registration number that allows its SysEx data to be distinguished from that of the other devices in the system. Depending on the device, the ID can be set separately from the basic MIDI channel.

Import  To load the files from other programs directly into a SoundDiver library.

Incoming value  The value which is transmitted within an incoming controller message.

Initialize  To reset (to zero or other default values) an entry’s (sound, program) parameters.

Initializing  The process whereby an entry’s parameters are set to neutral or zero values. Many MIDI devices include an initialization function.

Installation  The operation whereby SoundDiver and its files (modules, adaptations) are copied to a disk other than the original CD using the Installer program. The installation should be carried out using the Installer program, as this ensures that the data is correctly placed.

Install window  The ~ is where SoundDiver manages the devices that are required for the Setup. This is where SoundDiver modules and adaptations are installed onto hard disk and models of device added or removed.

Key commands  The combination of a normal computer key and one or more modifier keys to carry out a particular function. They are used as an alternative to mouse operations.

Library  A SoundDiver file that can contain all kinds of data (sounds, setups, edit buffers) from all kinds of device. The size
of the file is limited only by the capacity of the computer’s RAM. The contents of a library can be sorted using certain criteria, and specific entries can be specified and searched for using the Find function.

**Link function**  The function that automatically keeps a window’s contents up-to-date with what has been selected in another window.

**Listen to MIDI**  A function in the Editor, while pressing incoming MIDI events directly alter the value of the current parameter.

**Local menus**  Menus that belong to a specific window and not to the program as a whole.

**Location**  A library parameter that contains an entry’s memory location address. This is one of the factors taken into account when an entry is sent. This parameter ensures that the entries’ locations within the device are safe-guarded, even when you are editing the library.

**Logic**  Emagic’s flagship sequencer and notation program, able to communicate via AutoLink with SoundDiver.

**Memory Manager**  The function within SoundDiver that represents a MIDI device’s memory contents. It allows sounds and other data to be copied, moved and deleted, etc.

**Menu**  A list of functions or options that can be selected using the mouse.

**MIDI patchbay**  A hardware device that allows MIDI signals to be routed to various destinations. Some patchbays can be remote-controlled using SoundDiver’s Patchbay modules.

**MIDI Thru**  a) The SoundDiver function that routes all incoming MIDI data directly to the active MIDI device. It also allows the MIDI channel to be changed. b) Most MIDI devices have a MIDI Thru port that allows further MIDI devices to be connected to the system.
MIDItasking system  An expansion of the computer’s operating system that manages the multitasking MIDI communication between different programs that co-habit the computer’s RAM at the same time.

Mini-sequence →Sequencer

Mixed library A library that contains the data from more than one device.

Model Manufacturers of MIDI devices usually offer various models within a family of devices, and these are all capable of being addressed by SoundDiver. Often, a module is compatible with several models (e.g. DX7II, TX802).

Modifier keys These are the keys on the computer that are used in combination with other keys to make up a variety of key commands (C, D, E, F, G).

Module These control the communication between SoundDiver and the various devices, and give SoundDiver the functions necessary to do this. A module is much more comprehensive and powerful than an →Adaptation, but it cannot be edited.

Name Provider A component of →AutoLink. The ~ provides the names of entries to an Instrument in →Logic.

On-line Help The part of the program that contains user-assistance in the form of text information displayed on-screen. SoundDiver offers interactive context-sensitive functions that produce on-screen help-text in certain situations.

Overview A viewing mode in the →Editor: it gives a bird’s-eye view of the groupings of editing parameters, facilitating your navigation around the Editor. Additionally, clicking a parameter group acts as an entry to that group’s →detailed display.

Parent Entry →Entry which contains dependencies to other entries (→child entries)

Patchbay →MIDI patchbay
Appendix D
Glossary

**Patchbay module**  The module for a →MIDI patchbay; it contains special functions for →scanning and for switching the MIDI routing.

**Path**  Gives the coordinates of a file's location on a disk, i.e. the partition (if a hard disk) and the folder(s).

**Resulting value**  The value which is calculated from an →incoming value using various calculation, based on properties of the →Controller Assignment and the →controlled parameter. The resulting value will become the new value of the controlled parameter.

**Scan**  in SoundDiver: the program automatically looks for any devices it can recognize that are hooked up to the MIDI system. If it finds any, they will be installed and displayed in the →Setup window.

**Screen set**  A storable configuration of windows, instantly recallable using a key command.

**Sequencer**  A MIDI recorder for recording and playing back notes and other MIDI data. SoundDiver has a mini-sequencer so you can create sequences for auditioning sounds.

**Setup**  The representation, in SoundDiver, of your MIDI system. Devices can be automatically scanned in or manually added to the Setup.

**Snapshot**  A temporary buffer containing the entry currently being worked on in the Editor. The ~ is copied into a library of the same name. The ~ function allows many interim stages of your editing to be stored for later retrieval.

**Surf!**  Previously used term form →Audition.

**SysEx, System Exclusive data**  MIDI messages that describe sounds and other complex data. This is the language that SoundDiver speaks, though you don’t need to know that!

**Universal Device Inquiry**  A standard →SysEx message that serves to recognize devices hooked up to the MIDI system.
Universal Module  The SoundDiver module that manages the editable adaptations for all kinds of MIDI devices.

Update  To install a new version.

User interface  All the elements and functions seen in the program’s display used to control the program, e.g. mouse, window or menu operations.

Used entries  Entries that are used by other entries within a Device or library, such as programs in a synth’s combination or voices within a multi-program.

x/y scroll gadget  The little box in the bottom left-hand corner of a SoundDiver window that can be dragged to make the contents of the window move horizontally and vertically at the same time.
Index

Numerics
3D Look ............................. 404
            (Definition) ..................... 443

A
Activating a device ............ 194
Active Device
            (Definition) ..................... 443
Adaptation ....................... 40
            (Definition) ..................... 443
            ~ menu .......................... 325, 382
            Adaption ....................... 40
            Adaptation ...................... 40
            Adaption .......................... 40
            Add to selection ................... 274
            Aliases ........................... 71
            Adapter ............................ 178
            Alien formats ..........................
            All Dump ............................ 280
            All entries ........................... 288
            All Notes Off
            (Definition) ..................... 443
            Apple Menu ........................... 173
            Apple Talk ........................... 64, 388, 427
            Archiving layered sounds ....... 293
            Assignment
            Find ................................. 323
            Assignments
            Menu item .......................... 168
            Audition ............................ 157, 233, 263
            (Definition) ..................... 443
            Auditioning the selected entries .... 106
            Authorization
            (Definition) ..................... 443
            remove ............................. 62
            Authorize ............................ 62
            Authorizing
            ~ the hard disk ..................... 61
            Auto Request ........................ 206, 239
            (Definition) ..................... 444
            AutoAudition ....................... 111, 157, 159, 324
            (Definition) ..................... 443
            AutoLink ............................ 212, 265, 357
            (Definition) ..................... 443
            ~ and OMS ............................ 359
            ~ and OMS simultaneously ......... 77
            ~ troubleshooting ................... 364, 440
            key commands ........................ 368
            online help ........................ 177
            Save Library for Logic Song ........ 212
            Autosave Libraries ................ 407
            Autoscroll .......................... 131
            AutoSurf
            (Definition) ..................... 444
            Autoload library .................... 252
            (Definition) ..................... 443
            AutoPlay ............................. 111, 159, 183, 311
            (Definition) ..................... 444
            Automatic scrolling ................. 137
            Bar display .......................... 182
            Blocks
            Selecting ~ ........................... 141
            Bulk Dump ............................ 260
            Channel Pressure .................... 188
            Capture MIDI File ........................ 163
            Card ................................. 230
            (Definition) ..................... 444
            Child Entry
            (Definition) ..................... 444
            child entry 102, 150, 153, 154, 219, 220, 224,
            .................................. 228, 231, 249, 264, 285, 287
            child patch .......................... 41, 219
            Clear ................................. 154

User Manual
Version 3.0 453
Index

Clipboard .............................................. 142, 150
Clipboard functions ................................. 316
  for selected groups .............................. 317
Close .................................................. 170
Close Library ........................................ 144
Columns ................................................ 109
  moving and altering widths ...................... 109
  altering width .................................. 253
Combination .......................................... 218
Comment .............................................. 257, 263
Communication error online help .................. 177
Compare (Definition) ............................... 444
Computer ~ keyboard ................................ 131
Configuring Library window ....................... 108
Connected to ........................................ 199
Connected to ~ a MIDI interface ................. 51
  the MIDI system ................................. 52
Control Change ....................................... 188
Controlled parameter (Definition) ............... 444
Controller ............................................ 335
  (Definition) ................................... 444
Controller Assignment (Definition) ............... 444
Controller Assignment Set (Definition) .......... 444
Controller message (Definition) .................. 444
Conversion (Definition) ............................ 444
online help ........................................ 178
Converting ~ files between Macintosh and Atari 83
  ~ sounds of related devices .................. 286
Copy ................................................... 151
  key commands to clipboard .................... 92
Copy protection (Definition) ...................... 445
Copying ~ a parameter group ...................... 317
  ~ a screenset .................................. 140
Copy-protection ..................................... 60
Creating a library .................................. 251
Credits ............................................... 178
Cross-references .................................. 175
Cubase .............................................. 315
  Simultaneous operation with ................... 74
Cursor (Definition) ................................ 445
  ~ moving ....................................... 131
Cut ................................................... 150
Cutting ~ a parameter group ....................... 317

D

Data consistency (Definition) ...................... 445
Data consistency ..................................... 218
Data format for the import ....................... 282
Data type (Definition) ............................. 445
  online help ..................................... 178
Data types .......................................... 236
Datazoom ........................................... 130
Date ................................................... 257, 262
Deauthorize .......................................... 62
Default (Definition) ............................... 445
Deinstall ............................................. 63
Deinstallation ........................................ 62
Delay .................................................. 205
Delete File ........................................... 147
Deleting ~ a parameter group ...................... 318
Deleting Doubles ..................................... 405
Deletion of duplicates .............................. 274
Dependency list ..................................... 231, 263
  (Definition) ................................... 445
Detailed display ..................................... 298
  (Definition) ................................... 445
Device (Definition) ................................ 445
~ ID ................................................. 124, 201, 261
  ~ parameter box ................................. 101, 197, 230
  ~ scanning ...................................... 98
  ~ window ....................................... 220
  ~'s software version ......................... 207
Activating ........................................... 194
active ~ (Definition) ............................... 443
Addressing from Setup window .................... 214
Deinstalling a ~ .................................... 196
Manual installation ............................... 99, 191

Emagic
SoundDiver

454
### Index

<table>
<thead>
<tr>
<th>Requesting its memory contents</th>
<th>104</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saving a ~’s memory contents</td>
<td>104</td>
</tr>
<tr>
<td>Device ID</td>
<td>256</td>
</tr>
<tr>
<td>Device Parameter box</td>
<td>178</td>
</tr>
<tr>
<td>online help</td>
<td>182, 217</td>
</tr>
<tr>
<td>Device window</td>
<td>195</td>
</tr>
<tr>
<td>Opening the ~</td>
<td>239</td>
</tr>
<tr>
<td>Requesting contents on power-up</td>
<td>239</td>
</tr>
<tr>
<td>Saving contents as library</td>
<td>240</td>
</tr>
<tr>
<td>Zooming the ~</td>
<td>221</td>
</tr>
<tr>
<td>Dialog box</td>
<td>221</td>
</tr>
<tr>
<td>(Definition)</td>
<td>445</td>
</tr>
<tr>
<td>Digital Music MX-8</td>
<td>56</td>
</tr>
<tr>
<td>Disable</td>
<td>91</td>
</tr>
<tr>
<td>MIDI Remote</td>
<td>63</td>
</tr>
<tr>
<td>DiskExpress II</td>
<td>281</td>
</tr>
<tr>
<td>Dive!</td>
<td>445</td>
</tr>
<tr>
<td>(Definition)</td>
<td>445</td>
</tr>
<tr>
<td>DMP</td>
<td>408</td>
</tr>
<tr>
<td>Duplicates</td>
<td>408, 408</td>
</tr>
<tr>
<td>deleting</td>
<td>274</td>
</tr>
<tr>
<td>Duplication</td>
<td>446</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>E</td>
<td>298</td>
</tr>
<tr>
<td>Easy Page</td>
<td>298</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>Edit</td>
<td>446</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>Edit Buffer</td>
<td>291, 313</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>individual</td>
<td>264</td>
</tr>
<tr>
<td>Multiple -s</td>
<td>314</td>
</tr>
<tr>
<td>Edit button</td>
<td>314</td>
</tr>
<tr>
<td>Edit menu</td>
<td>311</td>
</tr>
<tr>
<td>Clear</td>
<td>148</td>
</tr>
<tr>
<td>Copy</td>
<td>154</td>
</tr>
<tr>
<td>individual</td>
<td>151</td>
</tr>
<tr>
<td>Multiple -s</td>
<td>314</td>
</tr>
<tr>
<td>Edit button</td>
<td>311</td>
</tr>
<tr>
<td>Edit menu</td>
<td>148</td>
</tr>
<tr>
<td>Clear</td>
<td>154</td>
</tr>
<tr>
<td>Copy</td>
<td>151</td>
</tr>
<tr>
<td>individual</td>
<td>151</td>
</tr>
<tr>
<td>Multiple -s</td>
<td>314</td>
</tr>
<tr>
<td>Paste</td>
<td>151</td>
</tr>
<tr>
<td>Redo</td>
<td>149</td>
</tr>
<tr>
<td>Select all</td>
<td>155</td>
</tr>
<tr>
<td>Toggle Selection</td>
<td>155</td>
</tr>
<tr>
<td>Undo</td>
<td>148</td>
</tr>
<tr>
<td>Editable entries</td>
<td>287</td>
</tr>
<tr>
<td>Editing adaptations</td>
<td>382</td>
</tr>
<tr>
<td>Editor</td>
<td>446</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>~ menu</td>
<td>318</td>
</tr>
<tr>
<td>Calling up</td>
<td>296</td>
</tr>
<tr>
<td>Clipboard functions</td>
<td>316</td>
</tr>
<tr>
<td>Easy Page</td>
<td>298</td>
</tr>
<tr>
<td>Flip-menu</td>
<td>303</td>
</tr>
<tr>
<td>Help</td>
<td>295</td>
</tr>
<tr>
<td>Menu item</td>
<td>167</td>
</tr>
<tr>
<td>mouse operations</td>
<td>302</td>
</tr>
<tr>
<td>online help</td>
<td>179</td>
</tr>
<tr>
<td>Overview</td>
<td>297</td>
</tr>
<tr>
<td>Principle</td>
<td>112</td>
</tr>
<tr>
<td>Randomize</td>
<td>323</td>
</tr>
<tr>
<td>Street map</td>
<td>299</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>437</td>
</tr>
<tr>
<td>Value-inputting</td>
<td>308</td>
</tr>
<tr>
<td>Values via MIDI</td>
<td>310</td>
</tr>
<tr>
<td>Editor window</td>
<td>299</td>
</tr>
<tr>
<td>Closing the ~</td>
<td>327</td>
</tr>
<tr>
<td>more than one</td>
<td>312</td>
</tr>
<tr>
<td>Emagic distributors</td>
<td>173</td>
</tr>
<tr>
<td>ENTERING NUMERALS</td>
<td>94</td>
</tr>
<tr>
<td>Entry</td>
<td>217</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>~ auditioning</td>
<td>106</td>
</tr>
<tr>
<td>~ moving and copying</td>
<td>106</td>
</tr>
<tr>
<td>~ selecting</td>
<td>105</td>
</tr>
<tr>
<td>~ sorting</td>
<td>109</td>
</tr>
<tr>
<td>Exchanging, copying, moving an</td>
<td>228</td>
</tr>
<tr>
<td>Find an ~</td>
<td>111</td>
</tr>
<tr>
<td>Requesting an ~</td>
<td>237</td>
</tr>
<tr>
<td>save ~ in Preferences file</td>
<td>397</td>
</tr>
<tr>
<td>Selecting</td>
<td>397</td>
</tr>
<tr>
<td>~ an entry in the Device</td>
<td>226</td>
</tr>
<tr>
<td>window</td>
<td>226</td>
</tr>
<tr>
<td>~ an entry in the library</td>
<td>248</td>
</tr>
<tr>
<td>~ child entries</td>
<td>249</td>
</tr>
<tr>
<td>~ entry using names</td>
<td>227</td>
</tr>
<tr>
<td>Selection</td>
<td>141</td>
</tr>
<tr>
<td>Transmitting an ~</td>
<td>238</td>
</tr>
<tr>
<td>save ~ from a library</td>
<td>267</td>
</tr>
<tr>
<td>Transmitting an ~</td>
<td>267</td>
</tr>
</tbody>
</table>

### User Manual

**Version 3.0**

---

455
# Index

<table>
<thead>
<tr>
<th>Entry</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use of Edit menu commands</td>
<td>229</td>
</tr>
<tr>
<td>Entry Dependency Management</td>
<td>41, 154, 218</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>Entry menu</td>
<td>232</td>
</tr>
<tr>
<td>Audition</td>
<td>233</td>
</tr>
<tr>
<td>Build Library</td>
<td>234</td>
</tr>
<tr>
<td>Dive!</td>
<td>234</td>
</tr>
<tr>
<td>Initialize</td>
<td>233</td>
</tr>
<tr>
<td>Rename</td>
<td>233</td>
</tr>
<tr>
<td>Envelopes</td>
<td>306</td>
</tr>
<tr>
<td>Environment</td>
<td>315</td>
</tr>
<tr>
<td>Examples</td>
<td>326</td>
</tr>
<tr>
<td>Libraries</td>
<td>326</td>
</tr>
<tr>
<td>Extrapolate</td>
<td>326</td>
</tr>
<tr>
<td>Fader box</td>
<td>335</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>Fader box module</td>
<td>348</td>
</tr>
<tr>
<td>(Definition)</td>
<td>446</td>
</tr>
<tr>
<td>Fast Speed</td>
<td>391</td>
</tr>
<tr>
<td>File</td>
<td>391</td>
</tr>
<tr>
<td>Insert ~ in library</td>
<td>266</td>
</tr>
<tr>
<td>Load and transmit</td>
<td>211, 232, 288</td>
</tr>
<tr>
<td>File menu</td>
<td>143</td>
</tr>
<tr>
<td>Close Library</td>
<td>144</td>
</tr>
<tr>
<td>Delete file</td>
<td>147</td>
</tr>
<tr>
<td>Import</td>
<td>146</td>
</tr>
<tr>
<td>New</td>
<td>143</td>
</tr>
<tr>
<td>Open</td>
<td>143</td>
</tr>
<tr>
<td>Page setup</td>
<td>145</td>
</tr>
<tr>
<td>Preferences</td>
<td>147</td>
</tr>
<tr>
<td>Print</td>
<td>145</td>
</tr>
<tr>
<td>Quit</td>
<td>147</td>
</tr>
<tr>
<td>Revert to saved</td>
<td>144</td>
</tr>
<tr>
<td>Save</td>
<td>144</td>
</tr>
<tr>
<td>Save as</td>
<td>144</td>
</tr>
<tr>
<td>Filter sweeps</td>
<td>373</td>
</tr>
<tr>
<td>Find</td>
<td>92, 158, 275</td>
</tr>
<tr>
<td>Find again</td>
<td>158, 270</td>
</tr>
<tr>
<td>Find function</td>
<td>111, 268</td>
</tr>
<tr>
<td>Start Find</td>
<td>270</td>
</tr>
<tr>
<td>Find window</td>
<td>270</td>
</tr>
<tr>
<td>Add to selection</td>
<td>274</td>
</tr>
<tr>
<td>Comparison criteria</td>
<td>273</td>
</tr>
<tr>
<td>Data</td>
<td>272</td>
</tr>
<tr>
<td>Find value</td>
<td>273</td>
</tr>
<tr>
<td>How</td>
<td>272</td>
</tr>
<tr>
<td>Keep first, delete rest</td>
<td>274</td>
</tr>
<tr>
<td>Less options</td>
<td>275</td>
</tr>
<tr>
<td>More options</td>
<td>271</td>
</tr>
<tr>
<td>Opening the ~</td>
<td>269</td>
</tr>
<tr>
<td>Search in all documents</td>
<td>275</td>
</tr>
<tr>
<td>Select all</td>
<td>274</td>
</tr>
<tr>
<td>Select in selection</td>
<td>274</td>
</tr>
<tr>
<td>Select one</td>
<td>274</td>
</tr>
<tr>
<td>Selecting entries found</td>
<td>273</td>
</tr>
<tr>
<td>Simple search</td>
<td>270</td>
</tr>
<tr>
<td>What</td>
<td>169</td>
</tr>
<tr>
<td>Flicker-free display</td>
<td>402</td>
</tr>
<tr>
<td>Flip-menu</td>
<td>446</td>
</tr>
<tr>
<td>Flip-menus</td>
<td>446</td>
</tr>
<tr>
<td>Floating window</td>
<td>138, 168, 185, 302</td>
</tr>
<tr>
<td>Formatting</td>
<td>63</td>
</tr>
<tr>
<td>Full duplex mode</td>
<td>51</td>
</tr>
<tr>
<td>Full Range</td>
<td>326</td>
</tr>
<tr>
<td>G</td>
<td>388</td>
</tr>
<tr>
<td>GeeThree</td>
<td>388</td>
</tr>
<tr>
<td>Generic SysEx</td>
<td>280</td>
</tr>
<tr>
<td>Global settings</td>
<td>397</td>
</tr>
<tr>
<td>Glossary</td>
<td>443</td>
</tr>
<tr>
<td>gPort</td>
<td>388</td>
</tr>
<tr>
<td>Grab</td>
<td>447</td>
</tr>
<tr>
<td>(Definition)</td>
<td>447</td>
</tr>
<tr>
<td>Graphic display of setup</td>
<td>192</td>
</tr>
<tr>
<td>Griffin</td>
<td>388</td>
</tr>
<tr>
<td>H</td>
<td>63</td>
</tr>
<tr>
<td>Hard disk</td>
<td>63</td>
</tr>
<tr>
<td>formatting</td>
<td>94, 120, 231, 295</td>
</tr>
<tr>
<td>Help</td>
<td>447</td>
</tr>
<tr>
<td>(Definition)</td>
<td>447</td>
</tr>
<tr>
<td>~ control bar</td>
<td>174</td>
</tr>
<tr>
<td>~ for parameters</td>
<td>301</td>
</tr>
<tr>
<td>~ index</td>
<td>175</td>
</tr>
<tr>
<td>as a Floating window</td>
<td>172, 302</td>
</tr>
<tr>
<td>Cross-references</td>
<td>175</td>
</tr>
<tr>
<td>Interactive</td>
<td>210</td>
</tr>
<tr>
<td>Menu item</td>
<td>169</td>
</tr>
<tr>
<td>Operating the ~ system</td>
<td>175</td>
</tr>
</tbody>
</table>

---

Emagic

SoundDiver

456
Index

| Zooming the ~ window | 175 |
| Hidden Unused | 91, 92 |
| Hidden Used | 91, 92, 93 |
| High key | 307 |
| High velocity | 307 |
| Hotline | 49 |
| Internet | 49 |
| Interpolate | 326 |
| Introductory tour | 95 |
| Is equal in pairs | 273 |
| Is equal to selection | 273 |
| Is similar in pairs | 273 |
| Is similar to selection | 273 |

I

| Icon | 447 |
| ID number | 447 |
| Identity number | 447 |
| Import | 447 |
| Importing assignments | 93 |
| Installing assignments | 93 |
| Installing devices | 72 |
| Installing | 447 |
| Initial | 233, 297, 326 |
| Initialize | 233, 297, 327 |
| Initialization | 233, 297, 327 |
| Input | 198, 200 |
| Insert title | 265 |
| Install | 97 |
| Install window | 168 |
| Installation | 211 |
| Instapper program | 447 |
| Instrument | 219 |
| IntelliMouse | 130, 136, 221, 254 |
| IntelliPoint 2.0 | 130 |
| Interactive On-line Help | 210 |
| Interface | see MIDI-Interface |
| J
| J. L. Cooper Synapse | 55 |

K

| Keep first, delete rest | 274 |
| Key Commands | 85 |
| ~ in the manual | 47 |
| assigning | 89 |
| checking | 91 |
| concealing | 91 |
| deleting | 90 |
| finding | 92 |
| importing assignments | 93 |
| initializing assignments | 93 |
| overview | 415 |
| printing a list of assignments | 92 |
| special keys | 87 |
| storing | 93 |
| window | 88 |
| Key commands | 86 |
| (Definition) | 447 |
| ~ in AutoLink | 368 |
| Modifiers | 85 |
| key commands | 86 |
| Keyboard | 308 |
| Computer | 131 |
| Keyboard velocity windows | 307 |
| Keyboard window | 306 |
| KMX-8, KMX-16 | 56 |
| Knob | 305 |
| Known entries | 288 |
| L
| Language | 65 |
| Larger view | 169 |
| Layered sounds | 293 |
| archiving | 293 |
| Learn Key | 89, 90 |
Index

Learn MIDI ........................................ 90
Learn Separate Key ................................. 89
Less options ....................................... 275
Library ................................................. 107, 245
  (Definition) ....................................... 447
  ~ find functions .................................. 111
  ~ list ............................................. 171
  ~ sorting .......................................... 109
  ~ window .......................................... 246
 Altering column width ......................... 253
 Auto-loading on start-up ....................... 252
 Automatic creation .............................. 213
 Build ~ .............................................. 211, 234
 Creating ............................................. 251
 Dependency list .................................... 263
 Dividing a ~ into zones .......................... 110
 Examples of use .................................... 292
 Find functions ...................................... 268
 Import ................................................. 146
 Insert file .......................................... 266
 Insert title .......................................... 265
 Mixed .................................................. 110, 246
  (Definition) ....................................... 449
 Mouse operations ................................... 249
 Moving columns and altering widths ......... 109
 Opening, closing a ~ file ...................... 247
 Save ~ for Logic Song ............................ 212
 Selecting a ~ entries in ~ ...................... 248
 Show menu .......................................... 254
 Size of a ~ .......................................... 245
 Sort menu .......................................... 255
 Store sequence ..................................... 184
 Table .................................................. 252
 Text size ............................................. 254
 Zones ................................................. 266
 Zoom box ............................................ 254
 Library entries ......................................
  Requesting ~ ...................................... 267
  Transmitting ...................................... 267
 Library menu ....................................... 263
 Audition ............................................. 263
 Store sequence .................................... 265
 Library window ....................................
  Configuring the ~ .............................. 108
 License Agreement ............................... 173
 Link button ........................................ 196
 Link function ...................................... 220, 311, 318
  (Definition) ....................................... 448
 Listen to MIDI ....................................... 310
  (Definition) ....................................... 448

Load
  file .............................................. 211, 232, 288
 Local menu ........................................ 100, 134
  (Definition) ....................................... 448
  ~ in Library window ............................ 263
  ~ in Scrap window .............................. 211
  ~ in the Device window ...................... 232
 Location ........................................... 256, 262
  (Definition) ....................................... 448
 Locations (memory) ............................. 288
 Logic ................................................. 212, 315, 357
  (Definition) ....................................... 448
 remote controlling ~ by SoundDiver ......... 368
 Logic Audio ........................................ 357
 Logic Help .......................................... 94
 Loopback test ...................................... 162
 low key ............................................. 307
 low velocity ....................................... 307
 Memory
  free ~ ............................................. 184
 Requesting contents of device ............... 104
 Memory Manager
  (Definition) ....................................... 448
 online help ........................................ 177
 Menu
  (Definition) ....................................... 448
 File .................................................. 143
 Generally on ~ .................................... 133
 Local ~ ............................................. 100
 Local ~ bar ......................................... 134
 Main ~ bar .......................................... 134
 MIDI .................................................. 159
 Windows ............................................. 163
 Menu functions
  ~ in the manual .................................. 47
 MIDI
  communication troubleshooting .......... 427

Emagic
SoundDiver
## Index

<table>
<thead>
<tr>
<th>Note On</th>
<th>188</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>253</td>
</tr>
<tr>
<td>Number-input mode</td>
<td>308</td>
</tr>
<tr>
<td>Numerals, entering</td>
<td>94</td>
</tr>
<tr>
<td>NumLock</td>
<td>308</td>
</tr>
<tr>
<td>On-line Help</td>
<td>295</td>
</tr>
<tr>
<td>Open</td>
<td>143</td>
</tr>
<tr>
<td>Open Device</td>
<td>166</td>
</tr>
<tr>
<td>Open Library</td>
<td>165</td>
</tr>
<tr>
<td>Optimization programs</td>
<td>63</td>
</tr>
<tr>
<td>Options menu</td>
<td></td>
</tr>
<tr>
<td>Device window</td>
<td>235</td>
</tr>
<tr>
<td>Parameters</td>
<td>212</td>
</tr>
<tr>
<td>Setup window</td>
<td>212</td>
</tr>
<tr>
<td>Out</td>
<td>205</td>
</tr>
<tr>
<td>Out Port</td>
<td>198</td>
</tr>
<tr>
<td>Overview</td>
<td>297</td>
</tr>
<tr>
<td>(Definition)</td>
<td>449</td>
</tr>
<tr>
<td>Overwriting memory entries</td>
<td>405</td>
</tr>
<tr>
<td>Selecting</td>
<td>301</td>
</tr>
<tr>
<td>Parameter box</td>
<td>101</td>
</tr>
<tr>
<td>for entries</td>
<td>259</td>
</tr>
<tr>
<td>Auto Request</td>
<td>206</td>
</tr>
<tr>
<td>Comment</td>
<td>263</td>
</tr>
<tr>
<td>Connected to</td>
<td>199</td>
</tr>
<tr>
<td>Data type</td>
<td>261</td>
</tr>
<tr>
<td>Date</td>
<td>262</td>
</tr>
<tr>
<td>Device ID</td>
<td>201</td>
</tr>
<tr>
<td>Device's software version</td>
<td>207</td>
</tr>
<tr>
<td>Input</td>
<td>198</td>
</tr>
<tr>
<td>Master keyboard</td>
<td>205</td>
</tr>
<tr>
<td>Model</td>
<td>207</td>
</tr>
<tr>
<td>Module</td>
<td>207</td>
</tr>
<tr>
<td>Name</td>
<td>200</td>
</tr>
<tr>
<td>On and off</td>
<td>198</td>
</tr>
<tr>
<td>Out</td>
<td>205</td>
</tr>
<tr>
<td>Our Port</td>
<td>198</td>
</tr>
<tr>
<td>Play Delay</td>
<td>204</td>
</tr>
<tr>
<td>Preserve Thru-Port/Channel</td>
<td>202</td>
</tr>
<tr>
<td>Return to</td>
<td>200</td>
</tr>
<tr>
<td>Send Pause</td>
<td>203</td>
</tr>
<tr>
<td>Size</td>
<td>262</td>
</tr>
<tr>
<td>Thru Channel</td>
<td>202</td>
</tr>
<tr>
<td>Time</td>
<td>262</td>
</tr>
<tr>
<td>Timeout</td>
<td>203</td>
</tr>
<tr>
<td>Parameter Changes</td>
<td>125</td>
</tr>
<tr>
<td>Parameter group</td>
<td></td>
</tr>
<tr>
<td>Copying</td>
<td>317</td>
</tr>
<tr>
<td>Cutting</td>
<td>317</td>
</tr>
<tr>
<td>Deleting</td>
<td>318</td>
</tr>
<tr>
<td>online help</td>
<td>179</td>
</tr>
<tr>
<td>Pasting</td>
<td>318</td>
</tr>
<tr>
<td>Randomize</td>
<td>323</td>
</tr>
<tr>
<td>selecting</td>
<td>316</td>
</tr>
<tr>
<td>Parameterbox</td>
<td></td>
</tr>
<tr>
<td>Velocity</td>
<td>203</td>
</tr>
<tr>
<td>Parameters</td>
<td>212</td>
</tr>
<tr>
<td>Parent Entry</td>
<td></td>
</tr>
<tr>
<td>(Definition)</td>
<td>449</td>
</tr>
<tr>
<td>parent entry</td>
<td></td>
</tr>
<tr>
<td>Part</td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td></td>
</tr>
<tr>
<td>Pasting</td>
<td></td>
</tr>
<tr>
<td>Parent patch</td>
<td>41</td>
</tr>
<tr>
<td>Part</td>
<td>219</td>
</tr>
<tr>
<td>Paste</td>
<td>204</td>
</tr>
<tr>
<td>Patchbay</td>
<td>199</td>
</tr>
<tr>
<td>– Program</td>
<td>209</td>
</tr>
<tr>
<td>Special parameters</td>
<td>208</td>
</tr>
</tbody>
</table>

---

**Emagic**

**SoundDiver**

460
## Index

<table>
<thead>
<tr>
<th>Patchbay module</th>
<th>450</th>
</tr>
</thead>
<tbody>
<tr>
<td>Patchbay Program</td>
<td>204</td>
</tr>
<tr>
<td>Patchbay see MIDI ~ Path</td>
<td></td>
</tr>
<tr>
<td>(Definition)</td>
<td>450</td>
</tr>
<tr>
<td>Pause</td>
<td>182</td>
</tr>
<tr>
<td>Performance</td>
<td>218</td>
</tr>
<tr>
<td>Pitch Bend</td>
<td>188</td>
</tr>
<tr>
<td>Play</td>
<td>182</td>
</tr>
<tr>
<td>Play Delay</td>
<td>204, 383</td>
</tr>
<tr>
<td>Playback</td>
<td>183</td>
</tr>
<tr>
<td>Plop sound</td>
<td>359</td>
</tr>
<tr>
<td>Poly Pressure</td>
<td>188</td>
</tr>
<tr>
<td>Polyframe library import</td>
<td>251</td>
</tr>
<tr>
<td>PowerBook</td>
<td>75</td>
</tr>
<tr>
<td>Preferences</td>
<td>376</td>
</tr>
<tr>
<td>~ File</td>
<td>408</td>
</tr>
<tr>
<td>~ in AutoLink</td>
<td>359</td>
</tr>
<tr>
<td>Check doubles</td>
<td>408</td>
</tr>
<tr>
<td>Loading</td>
<td>411</td>
</tr>
<tr>
<td>Mouse as slider</td>
<td>399</td>
</tr>
<tr>
<td>Save ~ as</td>
<td>411</td>
</tr>
<tr>
<td>saving ~ automatically</td>
<td>411</td>
</tr>
<tr>
<td>saving ~ manually</td>
<td>411</td>
</tr>
<tr>
<td>Use GEM Clipboard</td>
<td>404</td>
</tr>
<tr>
<td>Preferences</td>
<td>147</td>
</tr>
<tr>
<td>Preserve Thru-Port/Channel</td>
<td>202</td>
</tr>
<tr>
<td>Print</td>
<td>145</td>
</tr>
<tr>
<td>Printer Port</td>
<td>388</td>
</tr>
<tr>
<td>Program Change</td>
<td>188</td>
</tr>
<tr>
<td>Program start</td>
<td></td>
</tr>
<tr>
<td>Use MIDI Manager</td>
<td>392</td>
</tr>
<tr>
<td>Use OMS</td>
<td>393</td>
</tr>
<tr>
<td>Programmierhandbuch</td>
<td>325, 384</td>
</tr>
<tr>
<td>Q</td>
<td></td>
</tr>
<tr>
<td>Quit</td>
<td>147</td>
</tr>
<tr>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Randomize</td>
<td>323</td>
</tr>
<tr>
<td>Range</td>
<td></td>
</tr>
<tr>
<td>~ menu</td>
<td>326</td>
</tr>
<tr>
<td>Record</td>
<td>182, 183</td>
</tr>
<tr>
<td>Redo</td>
<td>149</td>
</tr>
<tr>
<td>Remote Control Adaptations</td>
<td>242</td>
</tr>
<tr>
<td>Remote Control via MIDI</td>
<td>85</td>
</tr>
<tr>
<td>Remote-control adaptation</td>
<td>314</td>
</tr>
<tr>
<td>Remote-controlling Logic by SoundDiver</td>
<td>368</td>
</tr>
<tr>
<td>Rename</td>
<td>233</td>
</tr>
<tr>
<td>Request</td>
<td>159, 297</td>
</tr>
<tr>
<td>Requesting</td>
<td></td>
</tr>
<tr>
<td>~ device’s memory contents</td>
<td>104</td>
</tr>
<tr>
<td>~ entries</td>
<td>237</td>
</tr>
<tr>
<td>Reset controllers</td>
<td>161</td>
</tr>
<tr>
<td>Resulting value</td>
<td>336</td>
</tr>
<tr>
<td>(Definition)</td>
<td>450</td>
</tr>
<tr>
<td>Return to</td>
<td>200</td>
</tr>
<tr>
<td>Revert to saved</td>
<td>144</td>
</tr>
<tr>
<td>Roland A-880</td>
<td>58</td>
</tr>
<tr>
<td>Roland Diver</td>
<td></td>
</tr>
<tr>
<td>Rubber band</td>
<td>129, 142</td>
</tr>
<tr>
<td>S</td>
<td></td>
</tr>
<tr>
<td>SAC-2k</td>
<td>348</td>
</tr>
<tr>
<td>Safety messages</td>
<td>404</td>
</tr>
<tr>
<td>Save</td>
<td>144</td>
</tr>
<tr>
<td>~ device’s memory contents</td>
<td>104</td>
</tr>
<tr>
<td>preferences</td>
<td>93</td>
</tr>
<tr>
<td>Save as...</td>
<td>144, 211, 234, 288</td>
</tr>
<tr>
<td>Save device entries in Preferences file</td>
<td>397</td>
</tr>
<tr>
<td>Save Prefs as...</td>
<td>411</td>
</tr>
<tr>
<td>Saving preferences automatically</td>
<td>411</td>
</tr>
<tr>
<td>Saving preferences manually</td>
<td>411</td>
</tr>
<tr>
<td>Scan</td>
<td>98</td>
</tr>
<tr>
<td>(Definition)</td>
<td>450</td>
</tr>
<tr>
<td>~ in OMS mode</td>
<td>76</td>
</tr>
<tr>
<td>online help</td>
<td>177</td>
</tr>
<tr>
<td>Scan all models</td>
<td></td>
</tr>
<tr>
<td>Menu item</td>
<td>211</td>
</tr>
<tr>
<td>Scanning</td>
<td>67</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>426</td>
</tr>
<tr>
<td>Screen configuration</td>
<td>373</td>
</tr>
<tr>
<td>Screen set</td>
<td>122</td>
</tr>
<tr>
<td>(Definition)</td>
<td>450</td>
</tr>
<tr>
<td>Synchronizing ~s</td>
<td>376</td>
</tr>
<tr>
<td>Screenset</td>
<td>139</td>
</tr>
<tr>
<td>copying ~s</td>
<td>164</td>
</tr>
<tr>
<td>Copying a ~</td>
<td>140</td>
</tr>
<tr>
<td>Menu item</td>
<td>163</td>
</tr>
<tr>
<td>Occupying and recalling ~s</td>
<td>139</td>
</tr>
<tr>
<td>protecting ~s</td>
<td>164</td>
</tr>
<tr>
<td>reverting to saved</td>
<td>165</td>
</tr>
<tr>
<td>sequencer-controlled switching</td>
<td>165</td>
</tr>
<tr>
<td>storing ~s</td>
<td>164</td>
</tr>
<tr>
<td>switching ~s</td>
<td>164</td>
</tr>
</tbody>
</table>
## Index

| Scroll bars | 136 | Module | 256 |
| Scrolling (Definition) | 130 | Name | 256 |
| automatic | 137 | Size | 257 |
| Search in all documents | 275 | Sorting | 109 |
| Select all | 155, 274 | as a library | 258 |
| in selection | 274 | Automatic | 258 |
| in Sound bank | 265 | as a library | 286 |
| Selected entries | 288 | Sound cards | 51 |
| Selecting | 105 | Sound Diver | . |
| a parameter group | 316 | features | 173 |
| a single entry | 141 | Sound Diver EOS | 45 |
| blocks | 141 | Sound Diver K5000 | 45 |
| entries | 141 | Sound effects | 402 |
| entries found | 273 | Sound names | . |
| in the Editor | 301 | in a multi instrument | 363 |
| Toggling selection | 142, 155 | in Logic Instrument | 362 |
| Send Pause | 203, 383 | SoundDiver | . |
| Sequencer | 121, 182 | as a background program | 83 |
| (Definition) | 450 | in OMS mode | 75 |
| Menu item | 168 | `s user interface | 127 |
| Playback | 183 | Deinstalling | 62 |
| Record | 183 | Introduction in | 95 |
| Setup (Definition) | 450 | Preferences | 147 |
| `window | 97 | Quiring | 147 |
| Graphic display | 192 | Removing - from the hard disk | 64 |
| Manually adding devices | 69 | Updating - installation | 61 |
| Moving icons | 194 | Differences to SoundDiver | 45 |
| Opening Device window from the Setup w. | 195 | no hotline | 49 |
| Show menu | 254 | Sounds | . |
| Show progress | 402 | instantly saving - for a production | . |
| Size | 257, 262 | Special device parameters | 208 |
| Slider | 305 | Special functions | 230 |
| Smaller view | 169 | Special menu | 237 |
| SMF | 276 | Special parameters | . |
| Snapshot | 321 | online help | 178 |
| Softlink (Definition) | 182 | Speed Disk | 63 |
| Sort importing | 276 | Stack windows | 171 |
| Sort menu | 255 | Standard MIDI Files | . |
| Auto | 257 | Standard Program | 209 |
| Stealth Port | 388 | Stop | 182 |
| Data type | 256 | Store all edits | 212 |
| Date | 257 | Store In... | 320 |
| Device ID | 256 | Store sequence | 184, 265 |
| Location | 256 | Studio 4 | 52 |

**Emagic**

SoundDiver
## Index

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operation without OMS</td>
<td>75</td>
</tr>
<tr>
<td>Studio 4/5</td>
<td>392</td>
</tr>
<tr>
<td>Studio 5</td>
<td>52</td>
</tr>
<tr>
<td>Surf!</td>
<td>450</td>
</tr>
<tr>
<td>(Definition)</td>
<td></td>
</tr>
<tr>
<td>Switching Screensets</td>
<td>165</td>
</tr>
<tr>
<td>SysEx</td>
<td>450</td>
</tr>
<tr>
<td>(Definition)</td>
<td></td>
</tr>
<tr>
<td>~ introduction</td>
<td>122</td>
</tr>
<tr>
<td>SysEx communication error</td>
<td>177</td>
</tr>
<tr>
<td>online help</td>
<td></td>
</tr>
<tr>
<td>System Exclusive data</td>
<td></td>
</tr>
<tr>
<td>see SysEx</td>
<td></td>
</tr>
<tr>
<td>System messages</td>
<td>188</td>
</tr>
<tr>
<td>System requirements</td>
<td>50</td>
</tr>
<tr>
<td>STX</td>
<td>281</td>
</tr>
<tr>
<td><strong>T</strong></td>
<td></td>
</tr>
<tr>
<td>Tempo field</td>
<td>182</td>
</tr>
<tr>
<td>Text input box</td>
<td>308</td>
</tr>
<tr>
<td>Text size</td>
<td>254</td>
</tr>
<tr>
<td>Thru Channel</td>
<td>202</td>
</tr>
<tr>
<td>Tile windows</td>
<td>170</td>
</tr>
<tr>
<td>Time</td>
<td>262</td>
</tr>
<tr>
<td>Timeout</td>
<td>203</td>
</tr>
<tr>
<td>383</td>
<td></td>
</tr>
<tr>
<td>Timing</td>
<td>373</td>
</tr>
<tr>
<td>Toggle</td>
<td></td>
</tr>
<tr>
<td>MIDI remote</td>
<td>91</td>
</tr>
<tr>
<td>ToolTips</td>
<td>403</td>
</tr>
<tr>
<td>Transmit</td>
<td>157</td>
</tr>
<tr>
<td>file</td>
<td>211</td>
</tr>
<tr>
<td>232 288</td>
<td></td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>421</td>
</tr>
<tr>
<td><strong>U</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>148</td>
</tr>
<tr>
<td>~ edit</td>
<td>315</td>
</tr>
<tr>
<td>~ function</td>
<td>315</td>
</tr>
<tr>
<td>Universal Device Inquiry</td>
<td>52</td>
</tr>
<tr>
<td>(Definition)</td>
<td>391</td>
</tr>
<tr>
<td>Universal Module</td>
<td>379</td>
</tr>
<tr>
<td>(Definition)</td>
<td>451</td>
</tr>
<tr>
<td>Programming Manual</td>
<td>325</td>
</tr>
<tr>
<td>367 384</td>
<td></td>
</tr>
<tr>
<td>Universal-Modul</td>
<td></td>
</tr>
<tr>
<td>Programmierhandbuch</td>
<td>384</td>
</tr>
<tr>
<td>Update</td>
<td>451</td>
</tr>
<tr>
<td>(Definition)</td>
<td></td>
</tr>
<tr>
<td>SoundDiver installation</td>
<td>61</td>
</tr>
<tr>
<td>Update Service</td>
<td>49</td>
</tr>
<tr>
<td>Use GEM Clipboard</td>
<td>404</td>
</tr>
<tr>
<td>used by</td>
<td>232</td>
</tr>
<tr>
<td>Used entries</td>
<td>451</td>
</tr>
<tr>
<td>(Definition)</td>
<td></td>
</tr>
<tr>
<td>User interface</td>
<td>127</td>
</tr>
<tr>
<td>(Definition)</td>
<td>451</td>
</tr>
<tr>
<td>use</td>
<td>231</td>
</tr>
<tr>
<td><strong>V</strong></td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>336</td>
</tr>
<tr>
<td>incoming</td>
<td></td>
</tr>
<tr>
<td>resulting</td>
<td>336</td>
</tr>
<tr>
<td>Values</td>
<td>309</td>
</tr>
<tr>
<td>Increasing or decreasing -s</td>
<td></td>
</tr>
<tr>
<td>Velocity</td>
<td>203</td>
</tr>
<tr>
<td>velocity range</td>
<td>307</td>
</tr>
<tr>
<td>Version</td>
<td></td>
</tr>
<tr>
<td>new</td>
<td>422</td>
</tr>
<tr>
<td>View</td>
<td></td>
</tr>
<tr>
<td>larger</td>
<td>169</td>
</tr>
<tr>
<td>smaller</td>
<td>169</td>
</tr>
<tr>
<td>Vision</td>
<td></td>
</tr>
<tr>
<td>Simultaneous operation with</td>
<td>74</td>
</tr>
<tr>
<td><strong>W</strong></td>
<td></td>
</tr>
<tr>
<td>Waldorf Midibay</td>
<td>58</td>
</tr>
<tr>
<td>wheel button</td>
<td>130</td>
</tr>
<tr>
<td>Window</td>
<td></td>
</tr>
<tr>
<td>~ layout</td>
<td>99</td>
</tr>
<tr>
<td>~ management</td>
<td>134</td>
</tr>
<tr>
<td>~ moving contents</td>
<td>100</td>
</tr>
<tr>
<td>~ operation</td>
<td>99</td>
</tr>
<tr>
<td>~ technology</td>
<td>43</td>
</tr>
<tr>
<td>Column layout</td>
<td>137</td>
</tr>
<tr>
<td>Floating ~</td>
<td>138</td>
</tr>
<tr>
<td>larger view</td>
<td>169</td>
</tr>
<tr>
<td>Moving a ~ in background</td>
<td>137</td>
</tr>
<tr>
<td>Sequence ~</td>
<td>168</td>
</tr>
<tr>
<td>smaller view</td>
<td>169</td>
</tr>
<tr>
<td>Standard commands</td>
<td>135</td>
</tr>
<tr>
<td>Window list</td>
<td>171</td>
</tr>
<tr>
<td>Windows</td>
<td></td>
</tr>
<tr>
<td>Key Commands</td>
<td>88</td>
</tr>
<tr>
<td>Windows “number”</td>
<td>164</td>
</tr>
<tr>
<td>Windows menu</td>
<td>163</td>
</tr>
<tr>
<td>Assignments</td>
<td>168</td>
</tr>
<tr>
<td>Close window</td>
<td>170</td>
</tr>
<tr>
<td>Editor</td>
<td>167</td>
</tr>
</tbody>
</table>
Index

Help ........................................... 169
Install .......................................... 168
Library list ................................. 171
MIDI Monitor ............................... 169
Open Device ................................. 166
Open Library ............................... 165
Open Setup ................................. 166
Screenet .................................... 163
Stack windows ............................. 171
Tile windows ............................... 170
Window list .................................. 171
Zoom window ................................ 170

X

x/y scroll gadget ......................... 136, 300
(Definition) ......................... 451

Z

Zones ........................................... 266
Zoom
  ~ box .................................. 254
  ~ window ............................. 170
Zooming .................................... 180